Subject: Re: AW: AW: [Sip] SIPIT Interop problem with ;user=phone

From: Rohan Mahy <[email-masked]>
Date: Fri, 12 Sep 2003 11:10:20 -0700

On Tuesday, September 2, 2003, at 06:38 AM, Rosen, Brian wrote:

> Getting more and more confused.
>
> A "dial string" cannot go in a tel uri.
> It can go in the user part of a sip uri.

I believe that every dial string is a special case of a local number 
which can be expressed as a tel URI with the appropriate phone context.

> So, if a sip UA does not have the ability to automatically
> translate dial strings to routable telephone numbers, it has
> to be in a sip uri user part.  I don't think that is
> controversial.

No, this is still very controversial.

> The question is, does the UA need to mark the user part as
> a dial string, or is it enough for the host mentioned in the
> domain part of the sip uri to just know the difference?
> I'd prefer to mark the userpart as a dial string, but I can
> cope if we don't.

I would like to use the convention ;user=phone to indicate that the 
contents of the userpart can be interpreted (only by a host responsible 
for the domain of the SIP URI) as a valid tel URI.  if that host sees a 
phone-context parameter which it recognizes, then it can interpret that 
"local number" as appropriate, which IMO includes treating it according 
to the appropriate dial plan as a "dialed string".

I believe that standardizing this convention makes it easier to 
configure hosts which handle multiple contexts, and easier to configure 
*senders* that do not understand their own dial plan. (I have no 
problem with SIP hosts interpreting user parts as phone numbers or 
dialed strings or email addresses or whatever in a completely locally 
configured manner when user=ip).

thus, depending on the level of dial plan awareness configured into a 
phone in pittsburgh, it might send any of the following URIs

sip:0;phone-context=[email-masked];user=phone
sip:[email-masked]
sip:[email-masked]

thanks,
-rohan

> Brian
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Monday, September 01, 2003 5:21 AM
>> To: [email-masked]; [email-masked];
>> [email-masked]
>> Cc: [email-masked]; [email-masked]
>> Subject: RE: AW: AW: [Sip] SIPIT Interop problem with ;user=phone
>>
>>
>> So, the answer in any case is that it is somehow routable.
>> Therefore I conclude the allowing a sip URI to carry a dial
>> strings is not needed.
>>
>> /Hisham
>>
>>> -----Original Message-----
>>> From: ext Stastny Richard [mailto:[email-masked]]
>>> Sent: Monday, September 01, 2003 12:20 PM
>>> To: Khartabil Hisham (NMP/Helsinki); [email-masked];
>>> [email-masked]
>>> Cc: [email-masked]; [email-masked]
>>> Subject: AW: AW: AW: [Sip] SIPIT Interop problem with ;user=phone
>>>
>>>
>>> You should not need to route this call anyway, because
>>> normally you should
>>> not see such a context out of the context. The idea is: if
>>> you know the context
>>> then you also know how to route the call, if you do not know
>>> the context,
>>> you just say invalid number. In other contexts only global
>>> understandable
>>> URIs should be used
>>>
>>> Richard
>>>
>>> 	-----Ursprüngliche Nachricht-----
>>> 	Von: [email-masked]
>>> [mailto:[email-masked]]
>>> 	Gesendet: Mo 01.09.2003 10:45
>>> 	An: [email-masked]; Stastny Richard;
>>> [email-masked]
>>> 	Cc: [email-masked]; [email-masked]
>>> 	Betreff: RE: AW: AW: [Sip] SIPIT Interop problem with
>>> ;user=phone
>>> 	
>>> 	
>>>
>>> 	So, I'll ask the question again, this time for real:
>>> 	
>>> 	Under the informative text in 2806bis labeled "A Use of
>>> "tel" URIs with SIP (Informative)", it says:
>>> 	
>>> 	"
>>> 	             2.   The outbound proxy does not use the same phone
>>> 	                  context, but can route to a proxy
>>> that handles this
>>> 	                  phone context. This routing can be
>>> done via a lookup
>>> 	                  table or the domain name of the phone
>>> context might be
>>> 	                  set up to reflect the SIP domain name
>>> of a suitable
>>> 	                  proxy. For example, a proxy may
>>> always route calls
>>> 	                  with tel URIs like
>>> 	
>>> 	                  tel:1234;phone-context=munich.example.com
>>> 	
>>> 	                  to the SIP proxy located at
>>> munich.example.com."
>>> 	
>>> 	
>>> 	So, how does the proxy route this message to
>>> munich.example.com? Or how does it discover the proxy at
>>> munich.example.com?
>>> 	
>>> 	The reason I'm asking this again is due to my proposal
>>> in earlier emails to use a tel URI for dial strings and sip
>>> URI for pure sip users.
>>> 	
>>> 	Is there something wrong with mandating that if an
>>> entity placed a tel-URI in a sip request along with a
>>> phone-context carrying a domain name, then that domain name
>>> must be the address of a sip proxy?
>>> 	
>>> 	/Hisham
>>> 	
>>> 	> -----Original Message-----
>>> 	> From: ext Cullen Jennings [mailto:[email-masked]]
>>> 	> Sent: Saturday, August 30, 2003 2:48 AM
>>> 	> To: Stastny Richard; Khartabil Hisham (NMP/Helsinki);
>>> Dean Willis
>>> 	> Cc: Brian Rosen; [email-masked]
>>> 	> Subject: Re: AW: AW: [Sip] SIPIT Interop problem with
>>> ;user=phone
>>> 	>
>>> 	>
>>> 	>
>>> 	> I don't know what I was thinking - I gave the wrong answer.
>>> 	> The context in
>>> 	> the tel does not at mean you should attempt to route the call
>>> 	> to there - it
>>> 	> is just an identifier of the namespace of who
>>> understands the number.
>>> 	>
>>> 	> On 8/29/03 13:50, "Stastny Richard"
>>> <[email-masked]> wrote:
>>> 	>
>>> 	> >>> So, how does the proxy route this message to
>>> munich.example.com?
>>> 	> >>>
>>> 	> >>> /Hisham
>>> 	> >>>
>>> 	> >>
>>> 	> >> The same way it routes sip:[email-masked]
>>> 	> >
>>> 	> > Tell that to Dean :) He thinks it is not routable (that's
>>> 	> the point I was
>>> 	> > trying to make).
>>> 	> >
>>> 	> > Warning: this needs NOT to be true and IMHO this part of
>>> 	> > the informational section is misleading. In section 5.1.4
>>> 	> Local numbers
>>> 	> > it is clearly stated:
>>> 	> >
>>> 	> > "There are two ways to label the context: via a global
>>> 	> number or any    |
>>> 	> >  number of its leading digits (e.g., "+33") and via a
>>> 	> domain name,      |
>>> 	> >  e.g., "houston.example.com". The choice between the two is
>>> 	> left to     |
>>> 	> >  the "owner" of the local number and is governed by whether
>>> 	> there is a  |
>>> 	> >  global number or domain name that is a valid identifier
>>> 	> for a          |
>>> 	> >  particular local number.
>>> 	> >                                             |
>>> 	> >  The domain name does not have to resolve to any actual
>>> 	> host, but MUST  |
>>> 	> >  be under the administrative control of the entity managing
>>> 	> the local   |
>>> 	> >  phone context. "
>>> 	> >
>>> 	> > Since the domain name does not have to resolve to
>>> an actual host,
>>> 	> > one cannot rely on this, so your statement may be wrong.
>>> 	> >
>>> 	> > Richard
>>> 	> >
>>> 	> > -----Ursprüngliche Nachricht-----
>>> 	> > Von: [email-masked]
>>> [mailto:[email-masked]]
>>> 	> > Gesendet: Fr 29.08.2003 17:31
>>> 	> > An: [email-masked]; [email-masked]
>>> 	> > Cc: [email-masked]; [email-masked]
>>> 	> > Betreff: RE: AW: [Sip] SIPIT Interop problem with
>>> ;user=phone
>>> 	> >
>>> 	> >
>>> 	> >
>>> 	> >
>>> 	> >
>>> 	> >> -----Original Message-----
>>> 	> >> From: ext Cullen Jennings [mailto:[email-masked]]
>>> 	> >> Sent: Friday, August 29, 2003 5:51 PM
>>> 	> >> To: Khartabil Hisham (NMP/Helsinki); Dean Willis
>>> 	> >> Cc: Brian Rosen; [email-masked]
>>> 	> >> Subject: Re: AW: [Sip] SIPIT Interop problem with
>>> ;user=phone
>>> 	> >>
>>> 	> >>
>>> 	> >> On 8/29/03 1:03, "[email-masked]"
>>> 	> >> <[email-masked]>
>>> 	> >> wrote:
>>> 	> >>
>>> 	> >>> Under the informative text in 2806bis labeled "A Use of
>>> 	> >> "tel" URIs with SIP
>>> 	> >>> (Informative)", it says:
>>> 	> >>>
>>> 	> >>> "
>>> 	> >>>            2.   The outbound proxy does not use
>>> the same phone
>>> 	> >>>                 context, but can route to a proxy that
>>> 	> handles this
>>> 	> >>>                 phone context. This routing can be done
>>> 	> via a lookup
>>> 	> >>>                 table or the domain name of the phone
>>> 	> >> context might be
>>> 	> >>>                 set up to reflect the SIP domain name of
>>> 	> a suitable
>>> 	> >>>                 proxy. For example, a proxy may
>>> always route calls
>>> 	> >>>                 with tel URIs like
>>> 	> >>>
>>> 	> >>>                 tel:1234;phone-context=munich.example.com
>>> 	> >>>
>>> 	> >>>                 to the SIP proxy located at
>>> munich.example.com."
>>> 	> >>>
>>> 	> >>>
>>> 	> >>> So, how does the proxy route this message to
>>> munich.example.com?
>>> 	> >>>
>>> 	> >>> /Hisham
>>> 	> >>>
>>> 	> >>
>>> 	> >> The same way it routes sip:[email-masked]
>>> 	> >
>>> 	> > Tell that to Dean :) He thinks it is not routable (that's
>>> 	> the point I was
>>> 	> > trying to make).
>>> 	> >
>>> 	> > Regards,
>>> 	> > Hisham
>>> 	> >
>>> 	> >
>>> 	> >>
>>> 	> >>
>>> 	> >>
>>> 	> >
>>> 	> > _______________________________________________
>>> 	> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>>> 	> > This list is for NEW development of the core SIP Protocol
>>> 	> > Use [email-masked] for questions
>>> on current sip
>>> 	> > Use [email-masked] for new developments on the
>>> application of sip
>>> 	> >
>>> 	> >
>>> 	>
>>> 	>
>>> 	> _______________________________________________
>>> 	> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>>> 	> This list is for NEW development of the core SIP Protocol
>>> 	> Use [email-masked] for questions on
>>> current sip
>>> 	> Use [email-masked] for new developments on the
>>> application of sip
>>> 	>
>>> 	
>>>
>>>
>> J*fj)b	bm?>
> 0'~ffX)ߣ"8bX+DYׯzZ)ay+y">-%RǬWz{h,rny۟zb{(˫*T"'~~{^hg'bqbz
>>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 2 Sep 2003 09:38:24 -0400

Brian