Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone

From: William Marshall <[email-masked]>
Date: Thu, 18 Sep 2003 11:13:48 -0400 (EDT)

> On Thu, 2003-09-18 at 01:38, [email-masked] wrote:
> <snip>
> > Using your example C below, there is nothing restricting transcoder.com from forwarding the request to att.com even if the request-URI is a sip URI. Its transcoder.com local policy.
> > 
> > /Hisham
> > 
> <snip>
> > > >> B.
> > > >>
> > > >> 	INVITE tel:+14085264000 SIP/2.0
> > > >> 	Route: <sip:transcoders.com;lr>, <sip:mci.com;lr>
> > > >>
> <snip>
> > > >>
> > > >> C.
> > > >>
> > > >> 	INVITE sip:[email-masked];user=phone SIP/2.0
> > > >> 	Route: <sip:transcoders.com;lr>
> > > >>
> 
> You missed the important part of what Rohan was trying to say I think
> 
> You are right that transcoders.com could cause either request
> to go anywhere it wants. Suppose it sends the requests to att.com.
> 
> In case B, att.com could (and most likely would) legitimately 
> believe it is responsible for figuring out what to do with 
> tel: URIs - nothing malicious - its just normal processing.
> Suppose it retargets it to one of its gateways. The request would 
> then follow the route, where MCI proxy will forward the request 
> back to the ATT gateway (until MCI gets wise and starts rejecting
> such requests).
> 
> In case C, att.com has no legitimate claim on the RURI. It would be
> constrained to send the message to MCI with its RURI unchanged.
> 
> So C does have significantly better properties than B.
> 
> RjS
> 

(and in spite of the domain names being used in this example...)

This is exactly the point that I was trying to make much earlier in
this thread. 

That if ";user=phone" means that the username came from a tel: URL,
it does NOT (repeat NOT) mean that anyone else in the path can
convert it back to a tel: URL and process it.  It will only be
handled by a proxy responsible for the domain named in the sip: URL.

Past proposed wordings that the request would only be handled by 
proxies that "understand the username part" still concern me,
because ";user=phone" (if the resolution here is that it means
exactly a tel: URL) could give anyone that understanding.  Routing
still must be to the domain named in the request-URI, whether 
";user=phone" is present or not.  I'm fairly certain this point
has been agreed by all parties.

Bill Marshall
[email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Thu, 18 Sep 2003 10:25:21 -0500

> (and in spite of the domain names being used in this example...)

Point - apologies for my part in propogating that.

RjS

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 19 Sep 2003 17:14:42 -0400

Amen!!!

	Paul