Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone

From: [email-masked]
Date: Wed, 17 Sep 2003 09:27:49 +0300

I afraid C has the same problem as B.

/Hisham

> -----Original Message-----
> From: ext Rohan Mahy [mailto:[email-masked]]
> Sent: Tuesday, September 16, 2003 7:27 PM
> To: Robert Sparks
> Cc: Paul Kyzivat; Adam Roach; 'Rosen, Brian'; [email-masked]
> Subject: Re: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> On Tuesday, September 16, 2003, at 07:01 AM, Robert Sparks wrote:
> 
> > On Fri, 2003-09-12 at 13:18, Rohan Mahy wrote:
> >
> >> While I do not object to sending tel URIs to SIP proxies, 
> I believe I
> >> already articulated some reasons why you might want to use 
> sip or sips
> >> instead.
> >>
> >> 1) want to use SIPS
> >
> > Agreed!
> >
> >> 2) want to route the call to a specific domain that is not 
> the domain
> >> of your first hop proxy.
> >> 3) want to invoke a loose router for services like 
> transcoding or call
> >> history logging that have different tel URI handling rules than you
> >> want to use.
> >
> > Both 2 and 3 can be solved by pushing or preloading routes.
> 
> OK, I was being sloppy.  Looking at several options.
> 
> A.
> 	INVITE tel:+14085264000 SIP/2.0
> 	Route: <sip:transcoders.com;lr>
> 
> A is not so good, because you have no control over what 
> transcoders.com 
> does with tel URLs  (It might reject them, or send you a big bill).
> 
> B.
> 
> 	INVITE tel:+14085264000 SIP/2.0
> 	Route: <sip:transcoders.com;lr>, <sip:mci.com;lr>
> 
> B would probably work, but seems much more cumbersome than C.  In 
> addition, transcoders.com might forward all calls toward mci.com 
> through some other domain (att.com) which might just take the tel URL 
> and process it itself.
> 
> C.
> 
> 	INVITE sip:[email-masked];user=phone SIP/2.0
> 	Route: <sip:transcoders.com;lr>
> 
> C is explicit, it works, and it contains no extra info.
> 
> thanks,
> -rohan
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 17 Sep 2003 09:34:41 -0700

> I afraid C has the same problem as B.

No, it doesn't.  Nobody except a server authoritative for mci.com is 
allowed to interpret that URI. This is very clear for SIP and SIPS 
URIs. We don't have this kind of restriction on tel URIs.

thanks,
-rohan