Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: "Francois Audet" <[email-masked]>
Date: Mon, 15 Sep 2003 12:06:52 -0700

> I'm sorry, but when the draft says:
> "Dial strings are beyond the scope of this document."
> to me, means dial string is not legal in a tel uri.
> 
> The text describes a dial string the way you (and I) interpret one:  
>  Dial string: "Dial strings" are the actual numbers, symbols and
>              pauses entered by a user to place a phone call. A dial-
>              string is consumed by one or more network entities, and
>              understood in the context of the configuration of these
>              entities.
> It says that it's not in scope.  
> We can create a new RFC that extends this one, but at the moment, 
> you cannot put a dial string in a tel uri.  
> 
> Specifications are all about "terminology".  We usually
> don't create gray areas on purpose -- well, maybe sometimes we do :(
> 
> It's necessary to have a way to send a dial string
> that has pound, star and commas (or p/w, which is what
> 2543 did), which is not allowed in a tel uri.
> 
> Dial strings are interpretted into something else.
> That is a phone number, and might need some other processing. 
> You can send what a dial string translates into in a tel uri. 
> We have to have a way to denote that which is not a phone 
> number, but is a dial string.  That is what user=phone could do.

No, that's not what "user=phone" does. The spec says that if you 
map a tel URI into a sip URI, then you must put the "user=phone" 
attribute. So if the tel URI was, say sip:+1-408-555-1212, then
it is clearly not a dial string. There are numerous example of this
in RFC3261/19.1.6 (i.e., of E.164 numbers in sip URIs with user=phone).

Also, on RFC3261/page 150, it says 
	If the user string contains a telephone number formatted as a 
	telephone-subscriber, the user parameter value "phone" SHOULD
	be present.

Recall that "telephone-subscriber" is defined in 2806-bis for the Tel URI.

(Note also that it doesn't say that user=phone can't be used for other
purposes, which is what I would like to change, otherwise it is basically
useless).

Conclusion is that the "user=phone" can NOT mean "dial string". 

Paul and I are saying that we don't need to send dial digits in a SIP
or Tel URI, because of the Tel URI's ability to associate a local phone
context 
is sufficient. I don't see a need for sending "pauses", "pound" and "stars"
as part of a number, and argue they should be chewed by the phones.
The local context can handle the cases where you don't want to do 
much parsing of the numbering plan in the phone itself.

If you think that it is required to support pauses, pound & star in SIP,
then we would have to add it to the spec with a new mechanism. I'm
personally
not much in favor of that, but it would be good to see if there is much
support in the group.

---

From: "Brett Tate" <[email-masked]>
Date: Mon, 15 Sep 2003 20:49:34 -0400

> No, that's not what "user=phone" does. 
> The spec says that if you map a tel URI into 
> a sip URI, then you must put the "user=phone" 
> attribute. So if the tel URI was, say 
> sip:+1-408-555-1212, then it is clearly not 
> a dial string. There are numerous example of this 
>     If the user string contains a telephone number 
>     formatted as a telephone-subscriber, the user 
>     parameter value "phone" SHOULD be present.
> 

It was defined in rfc2543 with one definition.
And it is defined in rfc2806 with a different
definition.  And now it is defined in rfc2806bis
with another different definition.

And unfortunately "phone-context" was not part of
rfc2543.  Its usage for local numbers was listed 
only at a SHOULD strength for rfc2806.  And
rfc2806bis-02 now makes phone-context mandatory
for local numbers.

> (Note also that it doesn't say that user=phone 
> can't be used for other purposes, which is what 
> I would like to change, otherwise it is basically 
> useless).

I agree.  However rfc2806bis-02 has made the 
previously permissible usages of user=phone for 
local numbers invalid.  Thus it is not backwards
compatible with rfc2543, rfc2806, and rfc3398.

> Conclusion is that the "user=phone" can NOT 
> mean "dial string". Paul and I are saying that 
> we don't need to send dial digits in a SIP 
> or Tel URI, because of the Tel URI's ability to 
> associate a local phone context is sufficient. 
> I don't see a need for sending "pauses", "pound" 
> and "stars" as part of a number, and argue they 
> should be chewed by the phones. The local context 
> can handle the cases where you don't want to do 
> much parsing of the numbering plan in the phone 
> itself. If you think that it is required to support 
> pauses, pound & star in SIP, then we would have 
> to add it to the spec with a new mechanism.

The '*' and '#' are still part of the local number
definition within rfc2806bis-02.  

The pause and wait-for-dial-tone were part of 
rfc2543 and rfc2806; they are not part of the bis.
Because they were hard to interwork, leaving these
two out of the bis is fine with me.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip