Subject: [Sip] How to operate presence contact list?

From: "Chen Zaifeng,BISC R&D SA(BJ)" <[email-masked]>
Date: Fri, 5 Sep 2003 09:14:00 +0800

Dear All:
For SIP based presence service an end user always needs to create, modify, and delete a contact list, or make such operations on the members
of the list, would you please introduce me your ideas about how to operate and manage user contact lists stored at presence server? Through SIP or HTTP, or whatever else?
And, how to maintain the consistency of a contact list if it is stored at both a user terminal and presence server? 
Thanks!
Sincerely yours, 
Chen Zaifeng
--------------------------------------------------------------------------
Beijing International Switching System Corporation Ltd.
TD/DEW
No. 14 Jiu Xian Qiao Road
Beijing 100016, P. R. China
Tel:  +86-10-8457 1921
Fax: +86-10-6436 7732
E-mail: <mailto:[email-masked]>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: 04 Sep 2003 22:56:19 -0500

Please look at the work on data manipulation in the SIMPLE working 
group. 

(see
http://www.ietf.org/html.charters/simple-charter.html
particularly
http://www.ietf.org/internet-drafts/draft-ietf-simple-data-req-03.txt
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-00.txt
and
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-00.txt
And be sure to scan the mailing list archives available at
https://www1.ietf.org/mailman/listinfo/simple
)

RjS

---

From: "Faeez" <[email-masked]>
Date: Fri, 05 Sep 2003 10:18:50 +0530

Hi,
    I have a question.. If a SIP proxy receives multiple requests from
various UACs AT THE SAME TIME how does it go about handling those requests?
Meaning. what is the best way to implement the proxy so that it can
gracefully handle all requests without crashing and without losing any
request.
    Someone suggested THREADS.. but then how??
Thanks

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Nataraju A.B." <[email-masked]>
Date: Fri, 05 Sep 2003 11:17:03 +0530

Not exactly multi-threadng required as long as u have multi-processor system

You can have single threaded stack where in that Transport daemon serializes the received request from diff UACs

for this we need to have a diff tasks. One for stack and and other for Tpt Daemon...

as long as the number of requests/responses are within the bufering limit of Tpt daemmon no request will be dropped...

  ----- Original Message ----- 
  From: Faeez 
  To: [email-masked] 
  Sent: Friday, September 05, 2003 10:18 AM
  Subject: [Sip] SIP Proxy with muliple simultaneous requests....

  Hi,