Subject: [Sip] forking proxies

From: "Karunakara Rao" <[email-masked]>
Date: 19 Sep 2003 05:36:17 -0000

Hi All,
I am new to this group.
  a doubt regarding forking proxies,

why would a proxy do if forked an INVITE request, it got back some 
reliable provisional responses that established some early dialogs 
at the UAC, and then one of the UAS's sends a final response 200 
oK. If the other early dialogs try to send further reliable 
provisional responses this wont get through the proxy since a 
final response was already sent on the response context. Should 
the proxy behaviour not only forward immediately 200ok responses 
to INVITE, but also reliable responses ?
What happened to other early dialogs? how about sending CANCEL 
request to them which has not received final 200 OK. how to close 
those dialogs any policy can be adopted.

thanks
Karunakar.

___________________________________________________
Art meets Anesthesia; Shefali Weds Dr. Raman.
Rediff Matchmaker strikes another interesting match !!
Visit http://matchmaker.rediff.com?1

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Franz Edler" <[email-masked]>
Date: Sun, 21 Sep 2003 15:33:13 +0200

Karunkar,

let me try to answer your question, at least some aspects.

If the forking proxy has already forwarded a 200 OK response, all other 1xx
responses (regardless if reliable or not) will be blocked by the forking
proxy, because after a final response has been sent, the forking proxy only
forwards 2xx responses. All other responses are "worse" compared to the
already existing 200 OK response.

All early dialogs are terminating "silently" after 64*T1 without any message
exchange (see §13.2.2 last but one paragraph). This is also the limit for
any other 2xx response to be forwarded. After this time, the UAC considers
the INVITE transaction to be completed.

I hope this helps.

Franz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Karunakara
Rao
Sent: Freitag, 19. September 2003 07:36
To: [email-masked]
Subject: [Sip] forking proxies

Hi All,
I am new to this group.

thanks
Karunakar.