Subject: RE: Warning about dial plan assumptions (was RE: AW: [Sip] SIPIT Inte rop problem with ;user=phone)

From: "Christer Holmberg (SE/LMF)" <[email-masked]>
Date: Mon, 25 Aug 2003 16:17:42 +0200

Hi,

Assuming that user=phone means "this is a dial string", does it also means that the syntax has to be according to the telephone-subscriber ABNF? Ie, do we use "+" instead of "00", can we use visual separators without nodes treating them as actual parts of the actual user identifier, etc etc etc? OR, shall we define a separate syntax for "dial-string" in a SIP-URI? I think THAT is the question that started this discussion at the SIPit.

Regards,

Christer Holmberg
Ericsson Finland

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: 25. elokuuta 2003 17:05
> To: 'Henning Schulzrinne'; Conroy, Lawrence (SMTP)
> Cc: Adam Roach; [email-masked]; Richard
> Subject: RE: Warning about dial plan assumptions (was RE: AW: [Sip]
> SIPIT Inte rop problem with ;user=phone)
> 
> 
> This breaks nearly every existing phone.  Is that your intention?
> 
> user=phone, at the moment, means "this is a dial string".  
> It used to be that you could do the same in a tel uri, but we
> "fixed" that.  Until we have overwhelming deployment of end devices
> that translate dial strings to tel uris (PLEASE do not say
> E.164s or global identifier, they are not all global numbers after 
> translation), we need to leave user=phone as the way to send a dial 
> string.
> 
> Brian
> 
> > -----Original Message-----
> > From: Henning Schulzrinne [mailto:[email-masked]]
> > Sent: Sunday, August 24, 2003 10:52 AM
> > To: Conroy, Lawrence (SMTP)
> > Cc: Adam Roach; [email-masked]; Richard
> > Subject: Re: Warning about dial plan assumptions (was RE: AW: [Sip]
> > SIPIT Inte rop problem with ;user=phone)
> > 
> > 
> > In an earlier iteration of this discussion in the IPTEL WG, 
> there was 
> > some consensus that the appropriate way is to download a 
> > dialplan into 
> > the end system, which then does the translation from dialed 
> > digits to a 
> > global identifier. That way, it doesn't matter where the SIP 
> > or tel URI 
> > ends up and removes the where-was-this-number-dialed 
> guessing by the 
> > outbound proxy. This should be part of the general configuration 
> > mechanism. I had volunteered to write up a spec for that, but I'm 
> > waiting for the general shape of the configuration data 
> > format to settle.
> > 
> > Conroy, Lawrence (SMTP) wrote:
> > 
> > 
> > > *I* would love such a specification, because it's what my
> > > cellphone does. You wouldn't because you are in the NANP.
> > > 
> > > Thus any spec mustn't be "over the wire" - it MUST be at
> > > most an end system issue. It's dangerous for a Proxy to
> > > interpret, as the expectations of the end user may differ.
> > > 
> > > I'd be confused and miffed if I dialled 0117 and my proxy
> > > and PSTN gateway gave me a Russian number rather than the
> > > Bristol number I expected. So, no doubt, would the callee :).
> > > 
> > > all the best,
> > >   Lawrence
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 25 Aug 2003 11:10:25 -0400

Someone just pointed out to me that there could be confusion on
who translates a dial string to a routable number.
If you send sip:<dialstring>@<host>;user=phone, then <host>, 
or at least a proxy that understands the <host> dialing plan, 
does the translation.  That may or may not be the first hop proxy.

Most phones that I know have <host> configured; you don't type it.
If you did, and it wasn't your local proxy, then you better understand
how whatever you typed interprets your dial string, and your local
proxy better not muck with it.

Brian

> Sent: Monday, August 25, 2003 10:05 AM

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 25 Aug 2003 10:37:35 -0400

I think it can mean anything the proxy that knows how to translate a
dial string to a "full" routable URI allows it to mean.  
So, the answer is no. it doesn't have to parse as telephone-subscriber.  
It has to parse as userinfo.

Brian

> From: Christer Holmberg (SE/LMF) 
> [mailto:[email-masked]]
> Sent: Monday, August 25, 2003 10:18 AM
> To: 'Rosen, Brian'; 'Henning Schulzrinne'; Conroy, Lawrence (SMTP)
> Assuming that user=phone means "this is a dial string", does 
> it also means that the syntax has to be according to the 
> telephone-subscriber ABNF? Ie, do we use "+" instead of "00", 
> can we use visual separators without nodes treating them as 
> actual parts of the actual user identifier, etc etc etc? OR, 
> shall we define a separate syntax for "dial-string" in a 
> SIP-URI? I think THAT is the question that started this 
> discussion at the SIPit.
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
>