Subject: RE: AW: AW: [Sip] SIPIT Interop problem with ;user=phone

From: [email-masked]
Date: Wed, 3 Sep 2003 12:45:54 +0300

When if I hand you this on a business card:

Phone: 0401234567

and one of your colleagues hands you this:

SIP: [email-masked]

What do you dial to call me and what do you dial to call your colleague, using your phone? How does your proxy tell the difference?

/Hisham

> -----Original Message-----
> From: ext Juha Heinanen [mailto:[email-masked]]
> Sent: Tuesday, September 02, 2003 7:52 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: AW: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> [email-masked] writes:
> 
>  > I can hand a Nokia colleague a business card that has the 
> following info:
>  > 
>  > Tel: 04012345
>  > SIP: [email-masked]
>  > 
>  > He dials +3584012345. How does the UA know if it should append
>  > @nokia.com and make it a sip URI or just make it a tel URI?
> 
> if i dial +3584012345 from my sip phone, it will not append @nokia.com
> to the number.  instead it will append @tutpro.com, which is 
> the domain
> of the phone.  then the phone will forward the call to the proxy of
> tutpro.com, which will do enum lookup on the number and, if that
> succeeds, forward the call according to the reply, and if is doesn't
> succeed, forward the call to our pstn gw.
> 
> -- juha
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 3 Sep 2003 13:30:56 +0300

[email-masked] writes:

 > What do you dial to call me and what do you dial to call your
 > colleague, using your phone? How does your proxy tell the difference?

what would the phone network do if someone in india dials the number you
gave?  it would do the same as my proxy:  route the call to a
destination in a wrong local network or declare the destination
unreachable.

it is thus the responsibility of the user to figure out, how to turn
0401234567 into something that is correctly routable by the proxy of
that user the user might, for example, try to figure out from the
address on the business card in which country the person lives and then
add the corresponding cc into the number.  

that is what people do every day when they have to deal with local phone
numbers in other regions.  i don't understand why we discuss this on a
mailing list of a standards body.

-- juha