Subject: Re: [Sip] Compressing subsequent REGISTER requests

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 08 Sep 2003 13:10:56 +0300

Hisham,

since you are not creating any dialog, your next REGISTER will be sent 
to the exact same place as the first one (probably your outbound proxy). 
If you want to send compressed stuff to a proxy for the first time, you 
should first send an OPTIONS to check whether or not it supports 
compression.

Gonzalo

[email-masked] wrote:

> Hi,
> 
> RFC3486 says:
> 
> "a user agent server SHOULD add comp=sigcomp to the
>    Contact header field of the response if the URI of the next upstream
>    hop in the route set contained the parameter comp=sigcomp"
> 
> I assume this is for dialog creating responses. What about REGISTER?
> 
> If I send the very first REGISTER request uncompressed since I didn't know if it supports sigcomp. I can never learn through a similar mechanism as defined above if any subsequent REGISTER request should be compressed or not.
> 
> One solution is for the registrar to record-route (yuk). The other is to rely on the response being compressed as a hint, but I don't think this is good enough since the registrar did not get the chance to indicate its willingness to receive compressed requests.
> 
> We could also say that if an initial REGISTER is not compressed, then any subsequent REGISTER cannot be compressed.
> 
> Thanks,
> Hisham
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 29 Aug 2003 10:55:08 +0300

A resend since no one replied.

------------------------
Hi,

RFC3486 says:

Thanks,
Hisham