Subject: [Sip] RE: REFER request with method parameter != INVITE in refer-to he ader

From: Ofra Wachsman <[email-masked]>
Date: Mon, 29 Sep 2003 08:35:49 +0300

thanks for the answer.
about question 2 - you said that "if the REFER is to a
SUBSCRIBE, you will get notification about the success or 
failure of that SUBSCRIBE transaction", 
but the first NOTIFY request is part of the subscription establishment. the
subscription is not established until this request is accepted. so,
shouldn't the referee send notification about the subscription
establishment, and not about the SUBSCRIBE transaction?

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]]
Sent: Friday, September 26, 2003 5:04 PM
To: Ofra Wachsman
Cc: [email-masked]'
Subject: Re: REFER request with method parameter != INVITE in refer-to
header

On Thu, 2003-09-25 at 06:02, Ofra Wachsman wrote:
> Hi
> I have some questions about Refer-To header with method=SUBSCIRBE or
> method=REFER in it's URI. (rfc 3515)
> 1. When receiving REFER request with method=SUBSCIRBE, a new subscription
> should be created. how do I know what is the event of this subscription?
> same problem for method=REFER, how do I know the Refer-To header for the
new
> REFER?
> Is there a draft defining such behavior?
These can be defined using the URI "?" header escaping mechanism:

Some examples (which may not be completely escaped correctly, but
they show the spirit of the thing:)

Refer-To: sip:rjs-presence@example;method=SUBSCRIBE?Event=presence

Refer-To:
sip:rjs-refer@example;method=REFER?Refer-To=<sip:target's-target>

> 
> 2. If I created this subscription, what are the states of the new
> subscription, that we should notify the referrer of? only receiving
> responses? what about receiving notifications (if so, what will be the
> status code in the body status line?)?

The REFER creates an implicit subscription to the status of the 
referrenced request and that only. So, if the REFER is to a
SUBSCRIBE, you will get notification about the success or 
failure of that SUBSCRIBE transaction, but not information
about any future NOTIFYs due to that SUBSCRIBE.

RjS

> Ofra

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Mon, 29 Sep 2003 08:51:08 -0500

> establishment, and not about the SUBSCRIBE transaction?

No - the implicit subscription tells you only about how the
referenced request.

Chris noted that you can infer whether a dialog was established
by a referred SUBSCRIBE based on its final response, and that's
mostly true (there's a degenerate condition where a very delayed
200 could arrive at a proxy after the proxy has sent its final
response). But all you know from this is that _some_ dialog has
been created.

RjS