Subject: [Sip] Any one can confirm that "fork" only means parellel search and no t covers sequential search?

From: "Chen Zaifeng,BISC R&D SA(BJ)" <[email-masked]>
Date: Tue, 30 Sep 2003 11:13:24 +0800

Dear All:

In RFC3261 page 15 there is such a description "A proxy server can also send an INVITE to a number of locations at the same time.  This
type of parallel search is known as forking." I think this is enough to say that fork only means parellel search.

But some other people think that the description doesn't deny the case of sequential seach, so any one can confirm that "fork" only means
parellel search and not covers sequential search?

Thanks!

Sincerely yours, 
Chen Zaifeng
--------------------------------------------------------------------------
Beijing International Switching System Corporation Ltd.
R&D SA
No. 14 Jiu Xian Qiao Road
Beijing 100016, P. R. China
Tel:  +86-10-8457 1921
Fax: +86-10-6436 7732
E-mail: <mailto:[email-masked]>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Steve Pellegrino <[email-masked]>
Date: Tue, 30 Sep 2003 07:58:34 -0400

Refer to section 16.6 that goes on to describe that the proxy MAY choose 
to forward the request to targets in the set (i.e. fork the request) 
serially, in parallel, or using a combination of both.

Regards,
Steve