Subject: RE: [Sip] sip-publish-00.txt

From: "Samir Srivastava" <[email-masked]>
Date: Mon, 29 Sep 2003 19:26:40 -0700

-----Original Message-----
From: Samir Srivastava 
Sent: Monday, September 29, 2003 6:10 PM
To: Aki Niemi
Cc: [email-masked]
Subject: [Sip] sip-publish-00.txt

Hi,

A) In Section 5, it states

"EPAs MUST NOT send a new PUBLISH request (not a re-transmission)
 until they have received a final response from the ESC for the
 previous one or the previous PUBLISH request has timed out. "

 What's the reason for adding this exception? There may be the cases
 when PUBLISH request may be going through proxy which may retransmit.
 If it goes thru proxy callId, and Cseq comparission is needed at ESC
 as needed in the case of REGISTER. 

>> I take back the proxy retransmission. Is there any case due to reboot
   etc when out of order requests are received at the ESC ? 

B) Table 1 and 2 is incomplete.

  1. In 200 OK, Expires header is MUST. which is not shown. 
     Separte entry needed for 2xx.
 
  2. Also Min-Expires header is missing in the table. which is MUST for
423.

C) In the example Messages, mandatory "Max-Forward" Header is missing
from all 
   messages.

Thx
Samir

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aki Niemi <[email-masked]>
Date: Tue, 30 Sep 2003 11:57:08 +0300

Hi Samir,

Comments inline,

On 30.09.2003 05:26, ext Samir Srivastava:
>  What's the reason for adding this exception? 

This restriction is mainly due to congestion concerns. The same 
restriction applies to MESSAGE requests.

>  There may be the cases

PUBLISH requests are process in the order that they arrive at the ESC. 
The If-Match header field is used to identify the specific state that 
the request is targetting.

I don't quite understand the problem. Can you elaborate a bit?

>   2. Also Min-Expires header is missing in the table. which is MUST for

Good catch. I will add both to the table.

> C) In the example Messages, mandatory "Max-Forward" Header is missing

Will add that in the next revision.

Cheers,
Aki