Subject: RE: AW: AW: [Sip] SIPIT Interop problem with ;user=phone

From: [email-masked]
Date: Wed, 3 Sep 2003 13:58:08 +0300

We both live in Finland. You expect me to dial +358 every time I call you?

> -----Original Message-----
> From: ext Juha Heinanen [mailto:[email-masked]]
> Sent: Wednesday, September 03, 2003 1:31 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: AW: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> [email-masked] writes:
> 
>  > When if I hand you this on a business card:
>  > 
>  > Phone: 0401234567
>  > 
>  > and one of your colleagues hands you this:
>  > 
>  > SIP: [email-masked]
>  > 
>  > What do you dial to call me and what do you dial to call your
>  > colleague, using your phone? How does your proxy tell the 
> difference?
> 
> what would the phone network do if someone in india dials the 
> number you
> gave?  it would do the same as my proxy:  route the call to a
> destination in a wrong local network or declare the destination
> unreachable.
> 
> it is thus the responsibility of the user to figure out, how to turn
> 0401234567 into something that is correctly routable by the proxy of
> that user the user might, for example, try to figure out from the
> address on the business card in which country the person 
> lives and then
> add the corresponding cc into the number.  
> 
> that is what people do every day when they have to deal with 
> local phone
> numbers in other regions.  i don't understand why we discuss this on a
> mailing list of a standards body.
> 
> -- juha
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 3 Sep 2003 16:27:36 +0300

> We both live in Finland. You expect me to dial +358 every time I call

no, if 0401234567 is in finland, but that was now know based on the
information you gave.  as i said, the user would need more info, such as
the address, in order to figure out, how to call such a number.

-- juha