Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Oct 2003 16:39:30 -0400

Suppose we defined a new parameter value, user=phonenumber
and user=dialstring.

A phone that knew how to translate would specify user=phonenumber.
A phone that did not know how to translate would specify user=dialstring.

A proxy that translated might turn 
sip:[email-masked];user=dialstring;phone=context=pbx.example.com
into
sip:[email-masked];user=phonenumber

No configuration required.

I'd prefer that we not overload user=phone instead of phonenumber, primarily
because nearly every device that actually sets user=phone really is sending
dialstrings.

Brian

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2003 4:32 PM
> To: Rosen, Brian
> Cc: 'Paul Kyzivat'; 'Dean Willis'; 'Stastny Richard'; Francois Audet;
> Bob Penfield; [email-masked]
> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> On Wednesday, October 1, 2003, at 01:00 PM, Rosen, Brian wrote:
> 
> > I was responding to this post, which doesn't discuss that aspect.
> >
> > I think I have responded to the "differentiate by context" idea.
> > It requires that there be a way to differentiate configuration;
> > you have to know which devices translate, and which don't and get
> > them the correct context.  I think that is hard,
> 
> Brian,
> 
> Your earlier proposal is equivalently "difficult".  You have to 
> configure devices which translate to insert one string, and devices 
> which do not translate to insert another.  The only difference is the 
> strings.
> 
> thanks,
> -rohan
> 
> > and it's
> > unnecessary that it be that hard.  Usually, all the devices in
> > a domain are in the same context.
> >
> > It means that every proxy in a path that routes has to know
> > both contexts so that it can figure out what it has.
> >
> > I would much rather explicitly label the uri with what it
> > contains.
> >
> > Having said that, if we write a BCP that explains how this works,
> > I can live with it.  I'm volunteered to do some writing, so this
> > could be a part of it.
> >
> > Brian
> >
> >> -----Original Message-----
> >> From: Paul Kyzivat [mailto:[email-masked]]
> >> Sent: Wednesday, October 01, 2003 3:36 PM
> >> To: Rosen, Brian
> >> Cc: 'Dean Willis'; 'Stastny Richard'; Rohan Mahy; Francois 
> Audet; Bob
> >> Penfield; [email-masked]
> >> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> >>
> >>
> >> Rosen, Brian wrote:
> >>>
> >>> No, my point was that if I have one phone that sends a 
> dial string,
> >>> and another phone that sends a phone number, at some 
> point, someone
> >>> has to know that they are interpreted differently.
> >>
> >> Brian,
> >>
> >> You keep bringing up the same issues, but you haven't responded to
> >> earlier proposals that address your concerns. Specifically,
> >> how does the
> >> following not meet your needs?
> >>
> >> - one phone-context to represent a dial string
> >> - a different phone-context to represent a (local) phone number.
> >>
> >> As best I can tell, this should meet your needs, even if it
> >> isn't in the
> >> form you would prefer.
> >>
> >> Proxies that translate a dial string into a phone number also
> >> make the
> >> appropriate change to the the phone-context. Anybody that
> >> receives such
> >> a thing and doesn't understand the context can either pass it on to
> >> somebody else that might, or can simply fail.
> >>
> >> BTW, I agree that the presence or absence of gateways 
> doesn't change
> >> this problem at all.
> >>
> >> 	Paul
> >>
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 1 Oct 2003 14:12:32 -0700

> A phone that did not know how to translate would specify 

a phone that knew how to translate would specify 
;phone-context=phonenumber.mydomain.com, or just send a SIP URI
a phone that did not would specify ;phone-context=noclue.mydomain.com

same amount of configuration.

> No configuration required.

likewise with my proposal.  also note that if a proxy handles phones 
with different dial plans, it can disambiguate the same phone number or 
dial string with my approach, but cannot with yours.  I think this is a 
very compelling motivation for my proposal.

> because nearly every device that actually sets user=phone really is 

if user=phone means "tel URI embedded in userpart" then there is no 
semantic or syntactic ambiguity.  everything just works.

thanks,
-rohan

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Oct 2003 17:11:53 -0400

> No configuration required.

First, a small error in above:
   sip:[email-masked];user=dialstring;phone=context=pbx.example.com 
should be
   sip:1212;phone=context=[email-masked];user=dialstring

But that is irrelevant to the discussion.

The above still requires the phone to be provisioned with two strings: a 
domain ("example.com") and a context ("pbx.example.com"). The only thing 
you are saving is that you can configure phones without regard to 
whether they translate or not.

We can get the same effect by always privisioning phones with three 
strings: domain, untranslated context, translated context. Then the 
phone can decide which context to use depending on its functionality.

	Paul