Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Oct 2003 17:23:50 -0400

I can deal with having three string provisioning, although
I think my solution is a whole lot cleaner. 

I think you have to have the phone context different from the
local domain.  You can't collapse to one, although you could
default under some circumstances with some BCP work, to one.
That might be worth doing, but it doesn't change too much.
There are lots of cases of both multiple sip domains with the same
phone context and one sip domain with multiple phone contexts.

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2003 5:12 PM
> To: Rosen, Brian
> Cc: 'Rohan Mahy'; 'Dean Willis'; 'Stastny Richard'; Francois 
> Audet; Bob
> Penfield; [email-masked]
> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> 
> Rosen, Brian wrote:
> > Suppose we defined a new parameter value, user=phonenumber
> > and user=dialstring.
> > 
> > A phone that knew how to translate would specify user=phonenumber.
> > A phone that did not know how to translate would specify 
> user=dialstring.
> > 
> > A proxy that translated might turn 
> > sip:[email-masked];user=dialstring;phone=context=pbx.example.com
> > into
> > sip:[email-masked];user=phonenumber
> > 
> > No configuration required.
> 
> First, a small error in above:
>    sip:[email-masked];user=dialstring;phone=context=pbx.example.com 
> should be
>    sip:1212;phone=context=[email-masked];user=dialstring
> 
> But that is irrelevant to the discussion.
> 
> The above still requires the phone to be provisioned with two 
> strings: a 
> domain ("example.com") and a context ("pbx.example.com"). The 
> only thing 
> you are saving is that you can configure phones without regard to 
> whether they translate or not.
> 
> We can get the same effect by always privisioning phones with three 
> strings: domain, untranslated context, translated context. Then the 
> phone can decide which context to use depending on its functionality.
> 
> 	Paul
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Oct 2003 18:50:40 -0400

Rosen, Brian wrote:

> I can deal with having three string provisioning,

Progress!!! :-)

 > although I think my solution is a whole lot cleaner.

Personally I think a solution that doesn't require any changes to the 
definition of the sip: url is cleaner than one that does.

I also find it cleaner because it works in both sip and tel urls.

> default under some circumstances with some BCP work, to one.

No argument here.

	Paul