Subject: RE: [Sip] Question regarding Proxy forwarding 2XX responses

From: "Chris Boulton" <[email-masked]>
Date: Wed, 1 Oct 2003 16:09:10 +0100

All.

>-----Original Message-----
>From: Greg Scallan [mailto:[email-masked]]
>Sent: 01 October 2003 15:59
>To: [email-masked]
>Subject: [Sip] Question regarding Proxy forwarding 2XX responses
>
>Hi All,
>
>	Was hoping someone could help clarify the following question.
>Assuming RFC 3261 compliance, Does a SIP Proxy server acting in a
>transaction stateful manner *have to* forward *all* 2XX responses
received
>as a result of an INVITE that had been forwarded to multiple UAS's? Or,
can
>the Proxy decide to only forward the first one received?
>
>Thanks,
>greg
>
>
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Greg Scallan" <[email-masked]>
Date: Wed, 1 Oct 2003 08:20:14 -0700

Thank you, another question then:

If the same proxy decided instead forwarded the INVITE to UAS1, then received a 4XX response, can the SIP Proxy subsequently decide to forward the INVITE to UAS2 and upon receiving a 2XX response, only forward the 2XX response and not the 4XX response?

It was unclear to me from reading the spec if this is allowed because RFC 3261 seemed to indicate that when the Proxy server received the final response for all outstanding client transactions that it MUST forward the "best response".  In this case, we don't like the best response and want to retry additional UAS's.

thanks,
greg

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]]
Sent: Wednesday, October 01, 2003 8:09 AM
To: Greg Scallan; [email-masked]
Subject: RE: [Sip] Question regarding Proxy forwarding 2XX responses

All.

received
can