Subject: [Sip] 481 Call/Transaction Does Not Exist vs 501 Not Implemented

From: "Hechmi Khlifi" <[email-masked]>
Date: Fri, 24 Oct 2003 17:31:59 -0400

Hi,
I have a question about the 481 and 501 SIP responses. 

I want to know if i  send a SIP INFO request   to a  UA  without having a Dialog with him,  what will be its  response when he doesn't support the INFO method, 
will it be a
481 Call/Transaction Does Not Exist 

or 
501 Not Implemented 

can anyone  Help me please.

Hechmi  Khlifi 
R&D Dept.
Dialexia Communications, Inc. 
1755 St-Regis Boul. Suite 210 
Dollard-des-Ormeaux, Qc 
H9B 2M9 Canada 
Tel: 1-514-421-5918 (X 215) 
Fax: 1-514-421-1817 
Email: [email-masked] 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 24 Oct 2003 18:00:30 -0400

> I want to know if i  send a SIP INFO request
> to a  UA without having a Dialog with him,  
> what will be its  response when he doesn't 
> support the INFO method, will it be a

If your INFO has a To tag,
it should be a 481; however I have 
commonly observed 501's, 415's, 400's, 
and various other responses during
interops and sipits.  This type of
problem was one reason that the Allow 
header has become mandatory.
Thus you might not want to send
INFO to check dialog state unless you 
have received an Allow indicating that 
they support it.