Subject: [Sip] Reqesting knowelegge

From: arun kumar <[email-masked]>
Date: Fri, 10 Oct 2003 09:03:38 -0700 (PDT)

Hi,
    I am new to SIP and i wanted to know 

  1. After the server has received INVITE message from
its SIP service provider, why does it need to send the
180 Ringing and 200 OK messages through the proxy
servers as the server now know the location of the
requestor? what are the issues connected by sending
the 180 Ringing and 200 OK messages to the requestor
directly by-passing the proxies servers ? 

 2. Initially why does the requestor sends the INVITE
message to its SIP service provider or proxy servers ?
is it because it wants to make use of its DNS/lookup
services. In that case DNS work on UDP which does not
require any response ?

 I am grateful for all ur help.

 Thanks,
  Arun.

=====
Selvaraj arunkumar
909 South 70th plaza,apt #30
Omaha -68106,Nebraska.
Ph: (Res) 1-402-934-5073
      (Mob) 1-402-850-8926
      (Off) 1-402-554-2034
     
========================

__________________________________
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
http://shopping.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 13 Oct 2003 11:51:54 -0700

Hi,

Please note the following statement placed at the end of each message 
posted to this mailing list.
> This list is for NEW development of the core SIP Protocol

This mailing list is not an appropriate place to ask general questions 
of a tutorial nature. In addition to the SIP specifications, there are 
several good books on SIP which can help you understand SIP better.  
I've attached some links below.

SIP Demystified
http://www.amazon.com/exec/obidos/ASIN/0071373403/thesipcenter-20

Internet Communications with SIP
http://www.amazon.com/exec/obidos/ASIN/0471413992/thesipcenter-20

SIP: Understanding the Session Initiation Protocol
http://www.amazon.com/exec/obidos/ASIN/1580531687/thesipcenter-20

thanks,
-rohan