Subject: [Sip] what is the correct response code for CANCEL on REFER or SUBSCRIBE

From: Jay Morris <[email-masked]>
Date: Wed, 1 Oct 2003 00:01:39 -0700 (PDT)

Hi
Since CANCEL is illegal for REFER and SUBSCRIBE requests, what is the correct response code when receiving such CANCEL?
I thought about "403 Forbidden" or "405 Method Not Allowed"
what do you say?
 
Jay

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---

From: Robert Sparks <[email-masked]>
Date: Wed, 01 Oct 2003 09:49:09 -0500

It really doesn't matter much. 

You don't want to use 405, because that would claim you didn't support
CANCEL at any time for this RURI, even for INVITE.

403 or 603 are safe responses.

Using a 200 OK won't break anything. Remember, accepting a CANCEL
doesn't mean the request it's trying to cancel will _be_ cancelled.

RjS

On Wed, 2003-10-01 at 02:01, Jay Morris wrote:
> Hi
> Since CANCEL is illegal for REFER and SUBSCRIBE requests, what is the
> correct response code when receiving such CANCEL?
> ______________________________________________________________________
> Do you Yahoo!?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip