Subject: [Sip] Re: REFER request with method parameter != INVITE in refer-to he ader

From: Jay Morris <[email-masked]>
Date: Wed, 1 Oct 2003 00:40:59 -0700 (PDT)

Hello all
I did not understand the answer.
can I send a REFER request with method=OPTIONS in the Refer-To URI ???
(lets say I just want to know whether the remote target is 'alive', and I don't need any new dialog for it...)
Jay

On Mon, 2003-09-29 at 05:58, Ofra Wachsman wrote:
> another thing - is it possible to set in the method parameter of the
> Refer-To URI, a method that does not create a dialog? (method different
than
> INVITE, SUBSCRIBE or REFER)?

Yes.
You can also set it to a non sip: URI (such as http).

RjS

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---

From: Robert Sparks <[email-masked]>
Date: Wed, 01 Oct 2003 09:23:19 -0500

On Wed, 2003-10-01 at 02:40, Jay Morris wrote:
> (lets say I just want to know whether the remote target is 'alive',
> and I don't need any new dialog for it...)
> Jay
> 

Yes you can send a REFER with a Refer-To URI that looks like
<sip:remote-target@example;method=OPTIONS>.
I assume you are testing network visibility of the target from
the transferee, not just liveliness (otherwise you'ld just send
the OPTIONS directly to the target, yes?).

> ______________________________________________________________________
> Do you Yahoo!?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Greg Scallan" <[email-masked]>
Date: Wed, 1 Oct 2003 07:58:49 -0700

Hi All,

	Was hoping someone could help clarify the following question. Assuming RFC 3261 compliance, Does a SIP Proxy server acting in a transaction stateful manner *have to* forward *all* 2XX responses received as a result of an INVITE that had been forwarded to multiple UAS's? Or, can the Proxy decide to only forward the first one received?

Thanks,
greg