Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Oct 2003 16:00:29 -0400

I was responding to this post, which doesn't discuss that aspect.

I think I have responded to the "differentiate by context" idea.
It requires that there be a way to differentiate configuration;
you have to know which devices translate, and which don't and get
them the correct context.  I think that is hard, and it's
unnecessary that it be that hard.  Usually, all the devices in 
a domain are in the same context.  

It means that every proxy in a path that routes has to know
both contexts so that it can figure out what it has.

I would much rather explicitly label the uri with what it
contains.

Having said that, if we write a BCP that explains how this works,
I can live with it.  I'm volunteered to do some writing, so this
could be a part of it.

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2003 3:36 PM
> To: Rosen, Brian
> Cc: 'Dean Willis'; 'Stastny Richard'; Rohan Mahy; Francois Audet; Bob
> Penfield; [email-masked]
> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> Rosen, Brian wrote:
> > 
> > No, my point was that if I have one phone that sends a dial string,
> > and another phone that sends a phone number, at some point, someone
> > has to know that they are interpreted differently.
> 
> Brian,
> 
> You keep bringing up the same issues, but you haven't responded to 
> earlier proposals that address your concerns. Specifically, 
> how does the 
> following not meet your needs?
> 
> - one phone-context to represent a dial string
> - a different phone-context to represent a (local) phone number.
> 
> As best I can tell, this should meet your needs, even if it 
> isn't in the 
> form you would prefer.
> 
> Proxies that translate a dial string into a phone number also 
> make the 
> appropriate change to the the phone-context. Anybody that 
> receives such 
> a thing and doesn't understand the context can either pass it on to 
> somebody else that might, or can simply fail.
> 
> BTW, I agree that the presence or absence of gateways doesn't change 
> this problem at all.
> 
> 	Paul
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 1 Oct 2003 13:31:58 -0700

On Wednesday, October 1, 2003, at 01:00 PM, Rosen, Brian wrote:

> them the correct context.  I think that is hard,

Brian,

Your earlier proposal is equivalently "difficult".  You have to 
configure devices which translate to insert one string, and devices 
which do not translate to insert another.  The only difference is the 
strings.

thanks,
-rohan

> and it's