Subject: RE: [Sip] Event Based Heart Beat in SIP

From: [email-masked]
Date: Wed, 8 Oct 2003 11:41:47 +0300

Excuse my lack of knowledge about ICMP, but don't you get an ICMP error when you send a UDP packet an server that is not listening on the port you sent it to?

Also for TCP, you get an error when you try to connect the sockets.

Someone please correct me if I'm wrong.

/Hisham 

> -----Original Message-----
> From: ext Samir Srivastava [mailto:[email-masked]]
> Sent: Wednesday, October 08, 2003 3:13 AM
> To: [email-masked]
> Subject: [Sip] Event Based Heart Beat in SIP
> 
> 
> Hi,
> 
> The current standard provides OPTIONS to find the liveness of 
> remote SIP
> endpoint.
> If remote SIP server is not able to response back for the 
> OPTIONS for a
> long time,
> it results in bunch of OPTIONS requests in the network. There is no
> standard
> event defined which tells the availability of remote SIP endpoint. 
> 
> Consider SIP endpoints A (local) wants to find out the availabilty of
> B(remote).
> A subsribes event "READY_TO_PROCESS"  to B, when B is ready 
> to process 
> SIP reqs.  The subscribers of event needs to stored 
> persistenly. As soon
> as SIP 
> server is ready for signal processing, it will send the NOTIFY
> indicating its
> availability. This eliminates the OPTIONS REQs when remote endpoint is
> not
> available for checking liveness ? 
> 
> Other events can be also added, like update the availability 
> when there
> is
> no SIP traffic.
> 
> Whether checking liveness based on the events was considered earlier ?
> 
> Thx
> Samir
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Wed, 08 Oct 2003 14:12:19 -0500

> Someone please correct me if I'm wrong.

In practical terms, "maybe". If the Internet were pure and
unadulterated, you'd get an ICMP Port Unreachable response.

Unfortunately, lots of systems no longer send such ICMP responses, and
many firewalls block them. It seems that these response codes are useful
for scanning for "open" ports that might later be victimized.

In fact, some of my colleagues go so far as to automatically add packet
filter entries that block future traffic from any address they think
might be probing them. I really enjoy UDP port-scanning these guys using
a spoofed address that happens to correspond to their upstream DNS
server, NTP server, DHCP server, or the like. This holds the same sort
of fascination as popping packing bubbles or scaring oppossum,
millipedes, and other creatures that go fetal when one says "boo!" at
them. But that's another story.

Also, it is not uncommon for server applications to die in such a way
that they continue to "listen" to ports, but don't ever respond -- so
even if ICMP were "live", you'd still get no failure indication. This
seemed to happen a lot with early SIP servers running on early Java VMs,
which I believe was related to the threading model in use.

--
Dean