Subject: [Sip] A question about matching request to server transaction.

From: "Wook Park" <[email-masked]>
Date: Mon, 6 Oct 2003 10:37:07 +0900

Hi all.

I have some questions about matching transaction.
Please let me know the answer.

The following is an paragragh in rfc3261.
->
  The ACK request matches a transaction if the Request-
   URI, From tag, Call-ID, CSeq number (not the method), and top Via
   header field match those of the INVITE request which created the
   transaction, and the To tag of the ACK matches the To tag of the
   response sent by the server transaction.  Matching is done based on
   the matching rules defined for each of those header fields.

I wonder what the meaning "top Via header field match those of the
INVITE" is.
Does it mean that top Via header field should be equal those of the
INVITE?

There is the meaning "equal" in case of via header in rfc3261.
->
 Two Via header fields are equal if their sent-protocol and sent-by
   fields are equal, both have the same set of parameters, and the
   values of all parameters are equal.

However ACK could be sent without passing through proxy. In that case
UAS could receive
different Top Via Header of ACK from those of INVITE.

How does UAS match the ACK to server Transaction in this case?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christian Jansson" <[email-masked]>
Date: Mon, 6 Oct 2003 13:41:51 +0200

> I wonder what the meaning "top Via header field match those 
> of the INVITE" is. Does it mean that top Via header field 
> should be equal those of the INVITE?
> 
> However ACK could be sent without passing through proxy. In 
> that case UAS could receive different Top Via Header of ACK 
> from those of INVITE.
> 

ACK for 2xx is not part of the transaction and should therefore not
match the INVITE.
ACK for 3xx-6xx is part of the INVITE transaction and must have the same
via, and follow
the same path as the INVITE, which will lead to a match.

/ Christian Jansson, Hotsip

> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 
>