Subject: Re: [Sip] ACK retransmission for 2xx

From: "Nataraju A.B." <[email-masked]>
Date: Wed, 08 Oct 2003 11:17:43 +0530

----- Original Message ----- 
  From: Relkem Los 
  To: [email-masked] ; [email-masked] 
  Sent: Wednesday, October 08, 2003 10:59 AM
  Subject: Re: [Sip] ACK retransmission for 2xx

  I agree that for the first 2xx with different tags the UAC core should do 
  dns since these are different responses from different destinations.
  I'm still not sure about further 2xx of the same dialog.
  Should I DNS for each Ack retransmission? This can be very time consuming.
  On the other hand if all Acks are sent to the same destination (first IP and 
  Port retrieved by the
  DNS query) there is a chance that this ACK will be sent to an address that 
  no one is listening to. In this case the UAS will keep retransmitting the 
  2xx, The UAC will keep
  retransmitting the ACK (to the wrong address) and the call will never get 
  connected. The UAC has no way to learn that the remote party never got the 
  ACK and cannot recover from it.

  So my question is: Can any one point me to the place in the standard that 
  specifies whether it is needed to do DNS for ACK retransmission of 2xx.

  [ABN] even If you query DNS for each retransmitted 2xx received, the DNS results could be same, since the contact in 2xx will same in all the retransmitted 2xx responses. The above scenario will not happen since UAS might have sent the valid contact in the 2xx response. 
  ACK must reach the UAS if there is no problem with contact address in 2xd response through one of the DNS results. 
  Hence there is no need for repeated DNS query to send ACK for 2xx response 

  Thanks.

  >From: "Nataraju A.B." <[email-masked]>
  >To: Relkem Los <[email-masked]>, [email-masked]
  >Subject: Re: [Sip] ACK retransmission for 2xx
  >Date: Mon, 06 Oct 2003 18:51:51 +0530
  >
  >Regards,
  >Nataraju A.B.
  >   ----- Original Message -----
  >   From: Relkem Los
  >   To: [email-masked]
  >   Sent: Thursday, October 02, 2003 12:28 PM
  >   Subject: [Sip] ACK retransmission for 2xx
  >
  >
  >   Hi,
  >   According to RFC3261 "The UAC core MUST generate an ACK request for each 
  >2xx
  >   received from the transaction layer" and " Once the ACK has been
  >   constructed, the procedures of [4] are used to determine the destination
  >   address, port and transport."
  >   Does this mean that we need to do the DNS procedure for every 
  >retransmission
  >   of this ACK?
  >   Can't this cause the ACK to be sent to a different IP and even use a
  >   different transport for each retransmission?
  >
  >   [ABN]
  >
  >   When UAC receives a 2xx of INVITE it has to generate the ACK response 
  >and has to cache that response and retransmitt for all the responses 
  >received on that dialog. till the expiration of timer 64*T1.
  >
  >   Its better to cache the DNS results and use the same results for each 
  >ACK retransmission on that dialog. At this point of time DNS queried on 
  >contact address in 2xx. This contact URI is more specific to that UAS than 
  >one specified in Req-URI in the initial INVITE. hence it less possible that 
  >the ACK reaching different end points.
  >
  >   for each 2xx with different tags the above set operations must be 
  >repeated ( I assume ). but the what is mentioned in rfc mean that it must 
  >be repeated for all the 2xx received (whether retransmitted (same to-tag) 
  >OR with a different to-tag ).
  >
  >   but rfc does not say about DNS results must be cached or not ( It might 
  >be an implementation issue ).
  >
  >   [ABN]
  >
  >   Thanks.
  >
  >   _________________________________________________________________
  >   Add MSN 8 Internet Software to your existing Internet access and enjoy
  >   patented spam protection and more.  Sign up now!
  >   http://join.msn.com/?page=dept/byoa
  >
  >
  >   _______________________________________________
  >   Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
  >   This list is for NEW development of the core SIP Protocol
  >   Use [email-masked] for questions on current sip
  >   Use [email-masked] for new developments on the application of sip
  >

  _________________________________________________________________
  MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*. 
  http://join.msn.com/?page=features/virus

---

From: "Relkem Los" <[email-masked]>
Date: Wed, 08 Oct 2003 05:29:52 +0000

I’m still not sure about further 2xx of the same dialog.

Thanks.