Subject: [Sip] IP Address vs Domain name in the from header

From: cthakker <[email-masked]>
Date: Wed, 29 Oct 2003 10:47:50 -0600

Hi,
 We are testing out a SIP proxy which can accept requests from a SIP 
gateway or SIP endpoints.
 Should the INVITE sent by the SIP gateway be any different from the one 
sent by SIP endpoints ? (It seems that the proxy accepts requests from a 
gateway only if the from header is of the form - <sip:caller@SUT_IP> and 
it accepts requests from end points only if it is of the form 
<sip:caller@remote_id:port>) Is this behaviour valid ?
 Is there any document that explains how a gateway may modify the 
request before forwarding it to the SIP Proxy ?

 Thank you in advance,

 Chintan
 ipNetFusion Inc,
 Dallas TX

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Manoj Bhatia <[email-masked]>
Date: Fri, 31 Oct 2003 10:05:25 -0500

I don't know which gateway are you talking about, but a SIP GW has
to behave like a SIP UA.
If you send more details of the flow, it will be helpful.

thanks
-Manoj

--
Manoj Bhatia                           |        |         |
[email-masked]                       |       :|:       :|:
7025 Kit Creek Road, RTP, NC - 27709   |     :|||||:   :|||||:
Ph: 919-392-3873  Fax:919-392-6801     |  C i s c o S y s t e m s