Subject: [Sip] ACK retransmission for 2xx

From: "Relkem Los" <[email-masked]>
Date: Thu, 02 Oct 2003 06:58:26 +0000

Hi,
According to RFC3261 “The UAC core MUST generate an ACK request for each 2xx 
received from the transaction layer” and “ Once the ACK has been 
constructed, the procedures of [4] are used to determine the destination 
address, port and transport.”
Does this mean that we need to do the DNS procedure for every retransmission 
of this ACK?
Can’t this cause the ACK to be sent to a different IP and even use a 
different transport for each retransmission?

Thanks.

_________________________________________________________________
Add MSN 8 Internet Software to your existing Internet access and enjoy 
patented spam protection and more.  Sign up now!   
http://join.msn.com/?page=dept/byoa

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Mon, 06 Oct 2003 18:51:51 +0530

Regards,
Nataraju A.B.
  ----- Original Message ----- 
  From: Relkem Los 
  To: [email-masked] 
  Sent: Thursday, October 02, 2003 12:28 PM
  Subject: [Sip] ACK retransmission for 2xx

  Hi,
  According to RFC3261 "The UAC core MUST generate an ACK request for each 2xx 
  received from the transaction layer" and " Once the ACK has been 
  constructed, the procedures of [4] are used to determine the destination 
  address, port and transport."
  Does this mean that we need to do the DNS procedure for every retransmission 
  of this ACK?
  Can't this cause the ACK to be sent to a different IP and even use a 
  different transport for each retransmission?

  [ABN]

  When UAC receives a 2xx of INVITE it has to generate the ACK response and has to cache that response and retransmitt for all the responses received on that dialog. till the expiration of timer 64*T1. 

  Its better to cache the DNS results and use the same results for each ACK retransmission on that dialog. At this point of time DNS queried on contact address in 2xx. This contact URI is more specific to that UAS than one specified in Req-URI in the initial INVITE. hence it less possible that the ACK reaching different end points. 

  for each 2xx with different tags the above set operations must be repeated ( I assume ). but the what is mentioned in rfc mean that it must be repeated for all the 2xx received (whether retransmitted (same to-tag) OR with a different to-tag ).

  but rfc does not say about DNS results must be cached or not ( It might be an implementation issue ).

  [ABN]

  Thanks.