Subject: RE: [Sip] WGLC for URI and Header Parameter Registries

From: [email-masked]
Date: Mon, 20 Oct 2003 16:46:34 +0300

I thought the whole point of these drafts was to require everyone to register at IANA. What is the point if I still don't have to register? If no registering is mandated, then there will be clashes.

Regards,
Hisham

> -----Original Message-----
> From: ext Dean Willis [mailto:[email-masked]]
> Sent: Thursday, October 16, 2003 8:36 PM
> To: Gonzalo Camarillo
> Cc: Niemi Aki (NMP/Helsinki); ext Rohan Mahy; [email-masked]
> Subject: Re: [Sip] WGLC for URI and Header Parameter Registries
> 
> 
> On Thu, 2003-10-16 at 08:15, Gonzalo Camarillo wrote:
> > the policy you are talking about is exactly what the WG 
> could not agree 
> > on. The conclusion was that, for the time being, we will 
> start keeping 
> > track of RFC-defined parameters (the two drafts under 
> WGLC). Meanwhile, 
> > we will work on the proper policy to use in the future. For 
> example, if 
> > someone defines a SIP parameter in a Nokia technical 
> report, it is OK to 
> > register it or not... we will count with you for those 
> discussions ;o)
> > 
> 
> I think, though, that we have to have some statement of policy in the
> draft before sending this up to IESG. We can, of course, change the
> policy later, so I'd suggest starting with the most 
> restrictive langauge
> and loosening up later if it seems important.
> 
> I would not now object to to a policy that says roughly "IANA 
> registered
> paramters must be defined by an IETF specification" but retains the
> ability to use non-registered parameters without being "in 
> violation of
> the specification." The logic is "If a parameter is IANA 
> registered, it
> is a reserved word and has special meanings that we expect to be
> globally relevant. If a parameter is NOT registered, it's a personal
> matter."
> 
> I think we want the barrier somewhat high for the declaration of a new
> "reserved word" in our vocabulary.
> 
> --
> Dean
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 20 Oct 2003 17:31:05 +0300

Folks,

I would like to keep the WGLC about *RFC-defined* parameters and the 
discussions about *non-RFC-defined* parameters separate. That was the 
agreement we reached in Vienna.

So, I have changed the subject of this thread, since it deals with the 
latter.

Hisham, answering your question: I agree that we should register them to 
avoid colissions.

Gonzalo

---

From: Dean Willis <[email-masked]>
Date: Mon, 20 Oct 2003 11:04:05 -0500

> I thought the whole point of these drafts was to require everyone to register at IANA. What is the point if I still don't have to register? If no registering is mandated, then there will be clashes.

The point was that the REALLY important parameter names, the ones that
NEED to interoperate and not clash, get registered.  And since they're
important enough to register, we want to know what they mean and how
they work, so a specification is required.

We had consensus that these important parameters needed to be in a
registry.

We did NOT have consensus that every parameter that might ever be used
for a one-off application needed to be registered.

So, what we're doing is defining a registry with a tight admissions
policy so we can get critical stufff "on the books", and we have the
option of relaxing that policy, if needed, at some future time, should
we ever have a consensus to do so.

--
Dean