Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Oct 2003 17:18:19 -0400

We're not communicating.

If it's a defined parameter, there is no configuration other than
the single local context.  The user=phonenumber or user=dialstring
is fixed, not configured (well, it could be configured for a phone
that could translate, but could be set to not translate I suppose,
but the point is that all phones would be configured the same way).

If it's differentiated by context, then the configuration is dependent
on whether a phone translates or not.  There are two local contexts,
and the phone has to be configured differently depending on what kind
of device it is.  This is possible, but unecessarily difficult.

Are you proposing a BCP convention on the use of "phonenumber" and
"noclue"?  

Brian

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2003 5:13 PM
> To: Rosen, Brian
> Cc: 'Paul Kyzivat'; 'Dean Willis'; 'Stastny Richard'; Francois Audet;
> Bob Penfield; [email-masked]
> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> On Wednesday, October 1, 2003, at 01:39 PM, Rosen, Brian wrote:
> 
> > Suppose we defined a new parameter value, user=phonenumber
> > and user=dialstring.
> >
> > A phone that knew how to translate would specify user=phonenumber.
> > A phone that did not know how to translate would specify 
> > user=dialstring.
> 
> a phone that knew how to translate would specify 
> ;phone-context=phonenumber.mydomain.com, or just send a SIP URI
> a phone that did not would specify ;phone-context=noclue.mydomain.com
> 
> same amount of configuration.
> 
> 
> > A proxy that translated might turn
> > sip:[email-masked];user=dialstring;phone=context=pbx.example.com
> > into
> > sip:[email-masked];user=phonenumber
> >
> > No configuration required.
> 
> likewise with my proposal.  also note that if a proxy handles phones 
> with different dial plans, it can disambiguate the same phone 
> number or 
> dial string with my approach, but cannot with yours.  I think 
> this is a 
> very compelling motivation for my proposal.
> 
> > I'd prefer that we not overload user=phone instead of phonenumber, 
> > primarily
> > because nearly every device that actually sets user=phone really is 
> > sending
> > dialstrings.
> 
> if user=phone means "tel URI embedded in userpart" then there is no 
> semantic or syntactic ambiguity.  everything just works.
> 
> thanks,
> -rohan
> 
> > Brian
> >
> >> -----Original Message-----
> >> From: Rohan Mahy [mailto:[email-masked]]
> >> Sent: Wednesday, October 01, 2003 4:32 PM
> >> To: Rosen, Brian
> >> Cc: 'Paul Kyzivat'; 'Dean Willis'; 'Stastny Richard'; 
> Francois Audet;
> >> Bob Penfield; [email-masked]
> >> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> >>
> >>
> >>
> >> On Wednesday, October 1, 2003, at 01:00 PM, Rosen, Brian wrote:
> >>
> >>> I was responding to this post, which doesn't discuss that aspect.
> >>>
> >>> I think I have responded to the "differentiate by context" idea.
> >>> It requires that there be a way to differentiate configuration;
> >>> you have to know which devices translate, and which don't and get
> >>> them the correct context.  I think that is hard,
> >>
> >> Brian,
> >>
> >> Your earlier proposal is equivalently "difficult".  You have to
> >> configure devices which translate to insert one string, and devices
> >> which do not translate to insert another.  The only 
> difference is the
> >> strings.
> >>
> >> thanks,
> >> -rohan
> >>
> >>> and it's
> >>> unnecessary that it be that hard.  Usually, all the devices in
> >>> a domain are in the same context.
> >>>
> >>> It means that every proxy in a path that routes has to know
> >>> both contexts so that it can figure out what it has.
> >>>
> >>> I would much rather explicitly label the uri with what it
> >>> contains.
> >>>
> >>> Having said that, if we write a BCP that explains how this works,
> >>> I can live with it.  I'm volunteered to do some writing, so this
> >>> could be a part of it.
> >>>
> >>> Brian
> >>>
> >>>> -----Original Message-----
> >>>> From: Paul Kyzivat [mailto:[email-masked]]
> >>>> Sent: Wednesday, October 01, 2003 3:36 PM
> >>>> To: Rosen, Brian
> >>>> Cc: 'Dean Willis'; 'Stastny Richard'; Rohan Mahy; Francois
> >> Audet; Bob
> >>>> Penfield; [email-masked]
> >>>> Subject: Re: [Sip] SIPIT Interop problem with ;user=phone
> >>>>
> >>>>
> >>>> Rosen, Brian wrote:
> >>>>>
> >>>>> No, my point was that if I have one phone that sends a
> >> dial string,
> >>>>> and another phone that sends a phone number, at some
> >> point, someone
> >>>>> has to know that they are interpreted differently.
> >>>>
> >>>> Brian,
> >>>>
> >>>> You keep bringing up the same issues, but you haven't 
> responded to
> >>>> earlier proposals that address your concerns. Specifically,
> >>>> how does the
> >>>> following not meet your needs?
> >>>>
> >>>> - one phone-context to represent a dial string
> >>>> - a different phone-context to represent a (local) phone number.
> >>>>
> >>>> As best I can tell, this should meet your needs, even if it
> >>>> isn't in the
> >>>> form you would prefer.
> >>>>
> >>>> Proxies that translate a dial string into a phone number also
> >>>> make the
> >>>> appropriate change to the the phone-context. Anybody that
> >>>> receives such
> >>>> a thing and doesn't understand the context can either 
> pass it on to
> >>>> somebody else that might, or can simply fail.
> >>>>
> >>>> BTW, I agree that the presence or absence of gateways
> >> doesn't change
> >>>> this problem at all.
> >>>>
> >>>> 	Paul
> >>>>
> >>
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 1 Oct 2003 14:45:53 -0700

> but the point is that all phones would be configured the same way).

sure those are two fixed strings.  but you can accomplish the same 
thing by using a phone-context convention that reuses the domain name 
information that the phone already needs anyway and can get via DHCP.  
you don't need any new configuration for the string, but you have the 
option to add it.

> of device it is.

as Paul said, the phone can use the strings available to it (either by 
convention or configuration) and make up their own mind.

> This is possible, but unecessarily difficult.

I disagree.  Even if you have to configure the strings explicitly it is 
not a big deal and is something the phones should really know anyway.

> Are you proposing a BCP convention on the use of "phonenumber" and

no, but I would absolutely prefer it to adding a "user=dialstring" 
parameter.

thanks,
-rohan