Subject: Re: [Sip] Comments on history-info

From: Rohan Mahy <[email-masked]>
Date: Mon, 10 Nov 2003 09:31:39 -0800

On Thursday, November 6, 2003, at 01:44 AM, Eric Burger wrote:
> Big question:
> Why don't we use multiple History-Info headers, instead of a 
> (potentially VERY long) single header?

Hey Eric,

These are semantically equivalent and implementations are supposed to 
support receiving BOTH syntaxes.

Just like:

Supported: 100rel, timer, replaces

is equivalent to

Supported: 100rel
Supported: timer
Supported: replaces

AND

Via: SIP/2.0/TCP sip1.example.com, SIP/2.0/TCP sip2.example.com, 
SIP/2.0/TCP sip3.example.com

is equivalent to

Via: SIP/2.0/TCP sip1.example.com
Via: SIP/2.0/TCP sip2.example.com
Via: SIP/2.0/TCP sip3.example.com

(branches omitted for clarity)

Bottom Line: The draft is using the correct BNF.

thanks,
-rohan

> I would argue for multiple headers on two grounds.
>
> First, the idea of a proxy modifying history information doesn't sound 
> smart.  If it screws up, it is hard to figure out who screwed up.
>
> Second, the index parameter frees us from worrying about header order, 
> which is a VERY good thing.
>
>
>
> Overview:
> While the motivation for History-Info is for the initiator of a 
> request to know what happened to a request, it is also of great use to 
> the recipient (End of Section 2 overview paragraph).
>
> Section 1.2:
> How is History-Info any different than Via w.r.t. security?
>
>
>
> Nits:
> Section 2.5, first paragraph, last sentence:
> this would like be a local
> this would likely be a local
>                ^^
>
> Appendix B, message F8, extra space before last angle-bracket in the 
> History-Info line.
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Eric Burger" <[email-masked]>
Date: Mon, 10 Nov 2003 18:27:59 -0500

Whoops!  I should have looked closer at the ABNF.

Maybe we should include an example that has multiple lines.  Otherwise, we KNOW people will look at the examples, think everything has to go on a single line, and then barf when a fully conformant UA sends a response with multiple lines.

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Mon, November 10, 2003 12:32 PM
> To: Eric Burger
> Cc: SIP List (E-mail)
> Subject: Re: [Sip] Comments on history-info
> 
>

---

From: "Mary Barnes" <[email-masked]>
Date: Mon, 10 Nov 2003 22:52:43 -0600

Eric,

Thanks for your comments and reviewing the draft. I can add an example in
the next version.

Mary.

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Monday, November 10, 2003 5:28 PM
To: Rohan Mahy
Cc: SIP List (E-mail)
Subject: RE: [Sip] Comments on history-info

Maybe we should include an example that has multiple lines.  Otherwise, we
KNOW people will look at the examples, think everything has to go on a
single line, and then barf when a fully conformant UA sends a response with
multiple lines.