Subject: RE: [Sip] GRUU, Contacts, and privacy

From: [email-masked]
Date: Tue, 11 Nov 2003 05:54:04 +0200

How about reg event package? You get NOTIFY with new GRUU.

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Cullen Jennings
> Sent: Friday, November 07, 2003 9:29 PM
> To: [email-masked]; Jonathan Rosenberg
> Cc: Paul Kyzivat
> Subject: [Sip] GRUU, Contacts, and privacy
> 
> 
>     
> When making anonymous calls, the contact should change on 
> every call. For
> example of if you don't do this ...  Bill makes an anonymous call from
> Monika's phone to Hillary. Hillary, takes the call, is 
> suppositious about
> the location and makes note of the contact. Now Hillary calls 
> Monika and
> notes the contact. If the two contacts are the same, the 
> privacy of the
> original call is lost and Hillary knows the original call was 
> from Monika's
> phone. 
> 
> Unfortunately, it looks like the grid approach still reveals this
> information - the grid on the two calls might be different 
> but the core GRUU
> is still the same. 
> 
> I have a hard time imagining a simple solution that allowed the UA to
> generate the GRUUs and still have fast lookup for the proxy. 
> It seems like a
> way is needed for the UA to get many GRUU that it can use and 
> that these
> need to be anonymous and uncorelatable by third parties.
> 
> One possible solution for this is to send another Register 
> after each call
> to get a new GRUU that can be used. This would drive the text 
> to change so
> that re-registrations must result in a new GRUU - the current 
> encryption
> mechanism with salt would meet this. Presumable, the old GRUU's would
> continue to work and be good as long as the contact that 
> generated it was
> still valid. 
> 
> Cullen
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 13 Nov 2003 08:26:31 -0800

Ok, I can live with that.

Cullen

> Alan Johnston [mailto:[email-masked]] writes:
> 
>> I agree 100%.  A private Contact URI is just one small piece
>> of the privacy puzzle.  I think this privacy requirement should
>> be removed.

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 15 Nov 2003 16:28:08 -0800

I'm convinced :-) I agree we should not bother to deal with the privacy
stuff in GRUU. 

Cullen

On 11/12/03 11:39 PM, "Jonathan Rosenberg" <[email-masked]> wrote:

> I agree, and I believe this was the consensus at the meeting as well.
> Interestingly, the current requirements document:
> http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-gruu-reqs-01.txt
> 
> doesnt actually have any privacy requirements at all. So, there is
> nothing to remove :)
> 
> -Jonathan R.
> 
> Adam Roach wrote:
> 
>> I further agree.
>> /a