Subject: RE: Consensus on direction needed (was Re: [Sip] Re: draft-ietf-sip-congestsafe-02.txt)]

From: William Marshall <[email-masked]>
Date: Fri, 7 Nov 2003 16:57:42 -0500 (EST)

Dean wrote:
> Bill said:
> > In case #1: one major problem is the impact TCP has on post-dial 
> > delay.  While it certainly can be fixed by a custom TCP stack 
> > in the UA, this doesn't generally seem to be happening.  
> > Lacking this, 
> > UDP is left as the preferred solution here.  Can such 
> > modified parameters for TCP be suggested in a BCP?
> 
> Isn't this pretty much resolved by connection-reuse and a persistent TCP
> connection between UA and proxy? This seems to be even sweeter if TLS is
> also used.

Persistent connections solves one of the TCP problems, the extra round-
trips (SYN-SYNACK-ACK) needed before the INVITE request can be sent.

But the other problem is when an INVITE request is dropped by
the network due to corruption on the transmission link (far more
likely on access links than on backbone connections).  TCP will wait
for a timeout on the sender before sending a query; that timeout
standrad value is too long for telephony-type services.

As an aside, the post-dial-delay issue also seems to be forcing 
IPsec for endpoints over TLS.

Bill Marshall
[email-masked]

-----original message-----
From: "Dean Willis" <[email-masked]>
To: "'William Marshall'" <[email-masked]>, <[email-masked]>
Subject: RE: Consensus on direction needed (was Re: [Sip] Re: draft-ietf-sip-congestsafe-02.txt)]
Date: Fri, 7 Nov 2003 15:27:34 -0600

Bill said:
> I think there are really two cases here: case #1 between the 
> UA and its first proxy (where there is very little signaling 
> traffic), and case #2 between proxies (where there is lots 
> more traffic).  
> 
> In case #1: one major problem is the impact TCP has on post-dial 
> delay.  While it certainly can be fixed by a custom TCP stack 
> in the UA, this doesn't generally seem to be happening.  
> Lacking this, 
> UDP is left as the preferred solution here.  Can such 
> modified parameters for TCP be suggested in a BCP?

Isn't this pretty much resolved by connection-reuse and a persistent TCP
connection between UA and proxy? This seems to be even sweeter if TLS is
also used.

> In case #2: one problem is the impact TCP has due to head-of-line 
> blocking.  This can be fixed with SCTP.  A BCP recommending 
> this would be good.

Good point. Would it be adequate to put this discussion into the SIP-SCTP
doc,

http://www.softarmor.com/wgdb/docs/draft-ietf-sip-sctp-03.txt

Bill also said: 
> So it seems the best solution is a variation of #1, "UDP 
> Considered Harmful between SIP Proxies".
> 
> Another idea, not that I expect much traction.
> If a protocol is to "ripped out by its toenails", how about TCP? 
> It seems to be stuck in the middle, not perfect for either case.

There's also DCCP to consider.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 09 Nov 2003 22:46:15 -0800

> IPsec for endpoints over TLS.

I'm curious about this - can you provide some more information and the type
of deployments where this is an issue?