Subject: [Sip] Sip Transfer and Cisco Gateway

From: Paraskevopoulos Pavlos <[email-masked]>
Date: Fri, 21 Nov 2003 11:24:15 +0200

Hi,

I don't know if this is the appropriate list for my case.

Assume a connection between a sip endpoint and a POTS peer, AB 
connection. The access to the POTS is through a cisco gateway. 

A (pots) ----------- GW (3620)-------------- B sipEndpoint.

|
|  (Transfer the AB connection to AC)
|

C sipEndpoint

Whenever we try to transfer the AB connection to AC, the GW responses 
with just a 202 Accepted Message.

Enabling debugging in the cisco router we get the following messages.

cause i = 0x82E0981C Mandatory information Element Missing.
Call State i=0x0A

The version of the router is:

Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3620-IS-M), Version 12.2(13)T,  RELEASE 
SOFTWARE (fc1)

Compiled Sat 16-Nov-02 09:30 by ccai
Image text-base: 0x6000891C, data-base: 0x61848000

System image file is "flash:c3620-is-mz.122-13.T.bin"

The dial peers are correctly configured.
The transfer with Cisco 7960 and ATA188 has no problem.
I wonder if someone could help. What is the mandatory element missing?

Thanks in advance.

The messages flow is following:

   Request line: REFER sip:[email-masked]:5060 SIP/2.0
   Message Header
       Max-Forwards: 69
       Via: SIP/2.0/UDP 146.124.120.212;branch=z9hG4bKf08e.ecd768c1.0
       Via: SIP/2.0/UDP 146.124.120.94:5060
       From: <sip:4348@telesip1>;tag=58912
       To: <sip:002106674342@telesip1>;tag=240DD5C8-2B8
       Call-ID: [email-masked]
       CSeq: 3 REFER
       Refer-To: <sip:8001@telesip1>
       Referred-By: <sip:4348@telesip1>
       Contact: <sip:4348@telesip1:5060>
       User-Agent: netPhone-2.9
       Content-Length: 0

   Status line: SIP/2.0 202 Accepted
   Message Header
       Via: SIP/2.0/UDP 
146.124.120.212;branch=z9hG4bKf08e.ecd768c1.0,SIP/2.0/UDP 
146.124.120.94:5060
       From: <sip:4348@telesip1>;tag=58912
       To: <sip:002106674342@telesip1>;tag=240DD5C8-2B8
       Date: Mon, 08 Mar 1993 00:01:36 GMT
       Call-ID: [email-masked]
       Server: Cisco-SIPGateway/IOS-12.x
       CSeq: 3 REFER
       Content-Length: 0

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Manoj Bhatia <[email-masked]>
Date: Fri, 21 Nov 2003 16:53:31 -0500

You should be sending this to Techincal Assistance Center (TAC)
at Cisco.
You may also send at [email-masked] for help on
Cisco related SIP issues .

If you send me the 'sh run' config on the gw, I can help you further.

thanks
-Manoj

--
Manoj Bhatia                           |        |         |
[email-masked]                       |       :|:       :|:
7025 Kit Creek Road, RTP, NC - 27709   |     :|||||:   :|||||:
Ph: 919-392-3873  Fax:919-392-6801     |  C i s c o S y s t e m s