Subject: RE: [Sip] Issue with the Timestamp grammar in RFC-3261

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 22 Jan 2004 09:00:29 -0500

Generally, a number with a trailing decimal period is allowed.
However, I'll agree you need at least one digit in delay.
OTOH, it could be a fractional delay (.3).  So, delay might have
to be

delay = (1*(DIGIT) [ "." *(DIGIT) ]) \ ( *(DIGIT) "." 1*DIGIT )

Brian

> -----Original Message-----
> From: Prasanna [mailto:[email-masked]]
> Sent: Thursday, January 22, 2004 12:36 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [Sip] Issue with the Timestamp grammar in RFC-3261
> 
> 
> Hi,
> 	I feel the grammar of the Timestamp header is buggy.
> The grammar being
> Timestamp  =  "Timestamp" HCOLON 1*(DIGIT)
>                [ "." *(DIGIT) ] [ LWS delay ]
> delay      =  *(DIGIT) [ "." *(DIGIT) ]
> 
> Can allow the following two cases which makes no sense
> 
> Timestamp : 1.
> Timestamp : 1.0 .
> 
> Should'nt a bug be raised against this to update the grammar to
> 
> Timestamp  =  "Timestamp" HCOLON 1*(DIGIT)
>                [ "." 1*(DIGIT) ] [ LWS delay ]
> delay      =  1*(DIGIT) [ "." 1*(DIGIT) ]
> 
> Thanks for the patient reading.
> 
> Cheers,
> Prasanna
> 
> *****************************************************************
> This e-mail and its attachments contain confidential information from
> HUAWEI, which is intended only for the person or entity whose 
> address is
> listed above. Any use of the information contained herein in any way
> (including, but not limited to, total or partial disclosure,
> reproduction, or dissemination) by persons other than the intended
> recipient(s) is prohibited. If you receive this e-mail in 
> error, please
> notify the sender by phone or email immediately and delete it!
> *****************************************************************
>  
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Prasanna <[email-masked]>
Date: Fri, 23 Jan 2004 09:51:40 +0530

I agree to this grammar.  But I have one query?
Any reasons why a number with a trailing decimal period is allowed (it
is allowed in all the decimal numbers like "q" etc.)?
Thanks,
Prasanna

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 7:30 PM
To: 'Prasanna'; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [Sip] Issue with the Timestamp grammar in RFC-3261

Generally, a number with a trailing decimal period is allowed. However,
I'll agree you need at least one digit in delay. OTOH, it could be a
fractional delay (.3).  So, delay might have to be

Brian

> HUAWEI, which is intended only for the person or entity whose address 
> is listed above. Any use of the information contained herein in any 
> way (including, but not limited to, total or partial disclosure,
> Use [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 24 Jan 2004 11:25:42 -0500

Prasanna wrote:

> I agree to this grammar.  

I believe the grammar for delay should be identical to the timestamp 
itself, so that:

delay = 1*(DIGIT) [ "." *(DIGIT) ]

I don't see the need to support somethiing like ".3"; since you can 
represent that as "0.3".

I've logged a bug against this:
http://bugs.sipit.net/sipwg/show_bug.cgi?id=748

But I have one query?
> is allowed in all the decimal numbers like "q" etc.)?

It was inherited from HTTP which did it this way. In hindsight there 
is really no point in supporting multiple different ways of 
representing a rational number, it just makes the implementation more 
complicated. But, its what we have, so be it.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com