Subject: RE: [Sip] SIP DTMF

From: [email-masked]
Date: Wed, 14 Jan 2004 08:36:28 +0530

Wendy,

There was a discussion in the list some time back and it was decided
that SIP-INFO method should not be used to 
Send the DTMF info.

It was proposed that it is better to you kpxml for sending DTMF tones.

Please look in to the SIP-Kpxml draft for sending DTMF tomes in-midcall
processing and all.... 

Regards,
Sreeram

=====================================================
Sreeram Kanumuri                Plot No 72, Keonics Electronics City
			              Hosur Main Road
Wipro Technologies              Bangalore -29 INDIA
[email-masked]      Phone: 8520408 Ex:3208
[email-masked]             ESN  :
www.wipro.com                   Mobile:
======================================================

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of wendy
Sent: Wednesday, January 14, 2004 8:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sip] SIP DTMF

Hello all, 

Who can tell me whether there is a RFC or I-D on DTMF in SIP which is
still not expired? I remember someone proposed using SIP INFO method for
DTMF one or two years ago. Is the DTMF relay implemented only by RTP
now?

Regards,
Wendy

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Paul Long" <[email-masked]>
Date: Thu, 15 Jan 2004 13:21:56 -0600

Sreeram,

I can't find a "kpxml" draft on the IETF site or via Google--anywhere.
Can you provide a link to it?

Also, from my experience, the preferred method of DTMF carriage is RFC
2833, followed by in-band audio, and then various proprietary
INFO-method schemes. What is the standing of RFC 2833 vis-à-vis "kpxml?"

Paul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Tuesday, January 13, 2004 9:06 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Sip] SIP DTMF

Wendy,

Regards,
Sreeram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of wendy
Sent: Wednesday, January 14, 2004 8:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sip] SIP DTMF

Hello all, 

Regards,
Wendy

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 18 Jan 2004 21:14:09 -0800

The draft is
http://www.ietf.org/internet-drafts/draft-burger-sipping-kpml-02.txt

2833 is the preferred method, but if an off media axis device wished to get
notification about key presses, it could. How these all relate is covered in

http://www.softarmor.com/wgdb/docs/
         draft-ietf-sipping-app-interaction-framework-00.txt

Cullen

---

From: Bert Culpepper <[email-masked]>
Date: Mon, 19 Jan 2004 11:04:12 -0500

The SIPPING work group web page on the IETF site has 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-01.txt as 
the current draft.  This version has significant differences than the 
one quoted below, one in particular is the use of SUBSCRIBE/NOTIFY for 
requesting and reporting key presses.

Best regards,
Bert