Subject: [Sip] SIP-T and BICC

From: "Aarti Iyengar" <[email-masked]>
Date: Wed, 28 Jan 2004 07:58:13 +0000

All,
I am trying to understand SIP-T and BICC in detail.
>From my initial reading, both are essentially to seamlessly interface the 
PSTN to broadband networks. SIP-T is specifically for SIP based IP networks, 
whereas BICC is bearer independent and can interface with IP/ATM networks 
well. Apart from that, SIP-T deals with ISUP translation and encapsulation 
while BICC deals with extensions with ISUP for additional bearer support.
BICC CS3 will also enable SIP services to co-exist with BICC based networks.
My questions are -
Are these the only key differences between these protocols which essentially 
are intended perform the same function? If there are others, what are they?
Are there certain situations where one would fit in better than the other, 
and if so what are these?
How well would these interoperate with each other if they have to co-exist?

Also, any pointers to urls/whitepapers on the above (BICC versus SIP-T) 
would be appreciated.

thanks
Aarti

_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Tom Taylor <[email-masked]>
Date: Fri, 30 Jan 2004 10:27:05 -0500

The BICC work was originally started to extend ISUP capabilities to ATM networks, 
and this was what BICC CS1 achieved.  The work took on a life of its own, and BICC 
CS2 supports voice over IP networks.  I'm not sure BICC CS3 will ever happen -- it 
seems to have bogged down.  The specific advantage of BICC is that it can take 
advantage of already-installed SS7 infrastructure.

One can use SIP to make connections across ATM networks, using the attributes and 
conventions defined in RFC 3108.  Unfortunately some of the syntax in that 
document (for the m= line) does not conform to the latest SDP syntax as defined in 
draft-ietf-mmusic-sdp-new-15.txt.

The key point of SIP-T is to provide a transition mechanism from a mixed 
legacy/SIP network to a pure SIP network.  If you install a BICC network, you have 
to install a parallel SIP network to handle multimedia and new services.  You face 
a problem when you eventually want to move voice services onto the SIP network to 
achieve savings through network and service integration.

So the brief answer is that the two protocols overlap in functionality, but which 
to use is an interesting strategic decision depending on what you have in your 
network already and what services you plan to offer in the future.

Aarti Iyengar wrote:

> PSTN to broadband networks. SIP-T is specifically for SIP based IP 
> networks, whereas BICC is bearer independent and can interface with 
> IP/ATM networks well. Apart from that, SIP-T deals with ISUP translation 
> and encapsulation while BICC deals with extensions with ISUP for 
> additional bearer support.
> Are these the only key differences between these protocols which 
> essentially are intended perform the same function? If there are others, 
> what are they?
> Are there certain situations where one would fit in better than the 
> other, and if so what are these?