Subject: [Sip] Request Forwarding based on local policy.

From: [email-masked]
Date: Fri, 5 Mar 2004 00:32:45 +0530

Hi

As per point no. 6 of section 16.6 of rfc 3261 -

"A proxy MAY have a local policy that mandates that a request visit a specific set of proxies before being delivered to the destination. A proxy MUST ensure that all such proxies are loose routers...."

If a proxy has to ensure (it is a MUST) that all the proxies has to be loose routers, then how will the forwarding work when one of the proxies is 2543 compliant and does not understand loose routing ?
Does it mean that this kind of forwarding (based on local policy) cannot/should not be done if one or more of the proxies in the path are 2543 compliant ?

Would really appreciate of someone can clarify this.

thanks,

Anil Kumar Chaudhury

Hughes Software Systems

http://www.hssworld.com

_______________________________________________
Sip mailing list https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Mar 2004 00:49:26 -0500

inline.

[email-masked] wrote:

> "A proxy MAY have a local policy that mandates that a request visit a 
> specific set of proxies before being delivered to the destination. A 
> proxy MUST ensure that all such proxies are loose routers...."
>  
> If a proxy has to ensure (it is a MUST) that all the proxies has to be 
> loose routers, then how will the forwarding work when one of the proxies 
> is 2543 compliant and does not understand loose routing ?

It won't. Thats why you cant do it.

> Does it mean that this kind of forwarding (based on local policy) 
> cannot/should not be done if one or more of the proxies in the path are 
> 2543 compliant ?

Correct. You can only put a URI in there if you know it was obtained 
from a proxy that is 3261 compliant.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com