Subject: [Sip] GRUU and dial-in conference

From: Marjou Xavier <[email-masked]>
Date: Mon, 15 Mar 2004 16:53:36 +0100

Hi,

In the context of GRUU, I wonder about another use-case (requirement). The current GRUU mechanism works well for a dial-out conference, but a dial-in conference seem to be out of scope. 

For example:

Let's say that sip:[email-masked] is a URI representing a predefined conference and is available in a web page.

When UE-A wants to join this AOR, he is routed to one server (among many), which will create the conference.

When UE-B also wants to join this AOR, he does not have the GRUU: nevertheless, it would be nice that the proxy (that owns the domain foo.com) first tries to route the INVITE of UE-B to the specific server that created the conference. Otherwise another conference server could receive the INVITE of UE-B.

What do you think?

Best Regards,

Xavier Marjou

---

From: Alan Johnston <[email-masked]>
Date: Mon, 15 Mar 2004 13:27:13 -0600

Hi Xavier,

Comments below.

Thanks,
Alan Johnston
MCI
sip:[email-masked]

At 04:53 PM 3/15/2004 +0100, Marjou Xavier wrote:

>Hi,
>
>
>
>In the context of GRUU, I wonder about another use-case (requirement). The 
>current GRUU mechanism works well for a dial-out conference, but a dial-in 
>conference seem to be out of scope.
>
>
>
>For example:
>
>Let's say that sip:[email-masked] is a URI representing a 
>predefined conference and is available in a web page.

If this URI is a conference URI, then it is, by definition, a GRUU.

>which will create the conference.

Not sure what you mean here.  Sounds like you are mixing the concepts of a 
conference factory URI and a conference URI - they have different usages 
and meanings.  See 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-config-framework-02.txt 
and 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-cc-conferencing-03.txt

>When UE-B also wants to join this AOR, he does not have the GRUU:

All B needs to join is the conference URI.  In your example I think this 
would be sip:[email-masked], which is a GRUU.

>  nevertheless, it would be nice that the proxy (that owns the domain 
> foo.com) first tries to route the INVITE of UE-B to the specific server 
> that created the conference. Otherwise another conference server could 
> receive the INVITE of UE-B.

Perhaps you are wondering how the conferencing application server locates 
the correct media server (mixer)?

>Xavier Marjou

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip