Subject: Re: [Sip] changes in session timer

From: Dean Willis <[email-masked]>
Date: Mon, 01 Mar 2004 19:30:19 -0600

Drage, Keith (Keith) wrote:

> Is charging considerations within the requirements for session timer.
> 
> There was considerable discussion of this issue a couple of years back, and I thought that the charging use case was eliminated from the requirements at that time.
> 

I'd like to respond with a complete lack of political consdieration 
here, so I'm sorry if you're offended.

Is billing in scope for Session Timer? In my humble opinion: "No, Hell 
no, and what part of no did you not understand?"

I believe that billing off the SIP signaling is a profoundly bad idea. 
Accurate billing has to be closer to the bearer path.

I think perhaps that Brian is suggesting that timeouts at the SIP layer 
can be used to detect failures that affect the media path, or at least 
failures for which there is no media path. While technically true, I 
don't find the mechanism appropriate.

Suggestions:

1) The media path is assumed to have real time delivery requirements. 
Real-time is always going to be more accurate than the non-real-time 
signaling path. If you need real-time billing, derive it from the 
real-time media path.

2) If there is no real-time media path, I can't imagine what 
time-sensitive service is being consumed that requires real-time 
accuracy in  accounting for. If you THINK you need real-time tracking 
here, then perhaps a media channel that does NOTHING but report 
connectivity for billing purposes is appropriate.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sun, 29 Feb 2004 01:03:48 -0000

regards

Keith

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: 25 February 2004 13:55
> To: 'Jonathan Rosenberg'; [email-masked]
> Subject: RE: [Sip] changes in session timer
> 
> 
> > * There is now an absolute minimum session timer of 90 
> > seconds. This is 
> > basically enough time for completion of a SIP BYE transaction 
> > after half 
> > of the session has expired. The Min-SE header field now has 
> a default 
> > value of 90 seconds when not present. This will preclude usage of 
> > session timer for really fine grained refreshes, say on the 
> > order of 5 
> > to 10 seconds. I fear that some people may be trying to do 
> > some kind of 
> > nat traversal or something with session timer - this would 
> > rule that out 
> > formally (it was never the intended usage).
> I know whenever we bring up billing people turn off, but one 
> of the things
> session timer is useful for is to tear down calls that got 
> hosed somewhere.
> Making the min 90 seconds means you could not use the 
> mechanism -- you would
> have to have some other mechanism that didn't distort your 
> billing record
> so much.  90 seconds is an eternity in human time. 
> 
> Somehow, precluding use for NAT binding keepalive doesn't sound like
> a good enough reason to have such a high min.  I frankly 
> don't understand
> why there has to be a min at all; surely it depends on the 
> characteristics
> of the network the session traverses.  
> 
> Brian 
>