Subject: RE: [Sip] GRUU and dial-in conference

From: Marjou Xavier <[email-masked]>
Date: Tue, 16 Mar 2004 17:15:05 +0100

Hi,

I had missed the changes since -02 in cc-conferencing draft:
"The Conference URI MUST meet the requirements to be a GRUU (Globally Routable User Agent URI) as detailed in [9]"

This is OK and solves the point I raised. However, I am a little bit surprised, because I understand the above sentence as a somehow contradicting requirement: the "not bounded in time" conference URI must be a "temporally scoped" GRUU! (draft-ietf-sipping-conferencing-framework-01 indicates a conference URI can represent a long-lived conference).

Thanks,
Xavier Marjou

-----Original Message-----
From: Alan Johnston [mailto:[email-masked]] 
Sent: lundi 15 mars 2004 20:27
To: Marjou Xavier; [email-masked]
Subject: Re: [Sip] GRUU and dial-in conference

... 
Not sure what you mean here.
...
See http://www.ietf.org/internet-drafts/draft-ietf-sipping-cc-conferencing-03.txt
...

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 18 Mar 2004 12:07:35 -0500

I think that this points to an error in the GRUU spec more than anything 
else.

Originally, when a GRUU was bound to a contact URI, there was no 
requirement that, when the contact disappeared and got re-registered 
later, that the same GRUU was assigned. Thus, they were temporally scoped.

However, now, through its binding to the instance ID, they are no longer 
temporally scoped. They remain valid for as long as the instance ID 
exists on the network. Its possible that, in rare cases, a different 
gruu could be assigned to the same instance ID, but this is not the 
norm. This kind of validity is identical to what we see for an AOR. As 
such, I believe the GRUU spec needs to be revised to clarify this.

Thanks,
Jonathan R.

Marjou Xavier wrote:

> Hi,
> 
> I had missed the changes since -02 in cc-conferencing draft: "The
> Conference URI MUST meet the requirements to be a GRUU (Globally
> Routable User Agent URI) as detailed in [9]"
> 
> This is OK and solves the point I raised. However, I am a little bit
> surprised, because I understand the above sentence as a somehow
> contradicting requirement: the "not bounded in time" conference URI
> must be a "temporally scoped" GRUU!
> (draft-ietf-sipping-conferencing-framework-01 indicates a conference
> URI can represent a long-lived conference).
> 
> Thanks, Xavier Marjou
> 
> -----Original Message----- From: Alan Johnston
> [mailto:[email-masked]] Sent: lundi 15 mars 2004 20:27 To:
> Marjou Xavier; [email-masked] Subject: Re: [Sip] GRUU and dial-in
> conference
> 
> ... Not sure what you mean here. ... See
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-cc-conferencing-03.txt
>  ...
> 
> 
> _______________________________________________ Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
> development of the core SIP Protocol Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com