Subject: RE: [Sip] GRUU Mechanism I-D

From: Adam Roach <[email-masked]>
Date: Wed, 5 Nov 2003 14:56:00 -0600

> I do think it would be very good medicine for the protocol to
> deprecate all dialog reuse.

Hear, hear!

> My personal preference for modifying REFER is to deprecate the
> implicit subscription behavior altogether (by strengthening the
> mechanisms proposed in Sean's and Rohan's drafts perhaps).

I agree with this course of action, for the reasons you cite,
and others.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 5 Nov 2003 16:04:16 -0500

> I would be happy if dialog reuse had never been 
> there. But at this point I think it is impossible 
> to avoid supporting it. And once the effort has 
> been made to support it, deprecating it in favor 
> of a new approach is just that much more work, 
> with more backwards compatibility alternatives 
> to consider, etc. At this point I would prefer 
> to live with the mistake.

I agree.  Dialog reuse does have some under 
specification problems.  However I prefer to 
resolve the issues instead of just dropping it
until GRUU gets approved, implemented, and deployed.

Most of the current dialog reuse issues could be 
resolved by a new header which indicates a
real call-id and a parameter which indicates
that this is a request to establish a new 
call/subscription/... on this dialog.  
A new response is also needed to indicate that 
I am aware of this dialog however I am not aware
of the call/subscription/... associated with
the request (a 481 which doesn't release the 
dialog).

To avoid some complexities, potentially we could
also restrict the number of calls sharing a
dialog to be 1 at any given time.  Or potentially
we could add a statement that a call cannot be
originated on an already established dialog.

> > I do think it would be very good medicine 
> > for the protocol to deprecate all dialog reuse.

Fully deprecating it would mean that rfc3265 would 
have to be updated to remove dialog sharing among 
subscriptions so that GRUU would have to be used 
instead.