Subject: RE: [Sip] Status of SIP MIB

From: "Bob Natale" <[email-masked]>
Date: Thu, 25 Mar 2004 11:49:45 -0500

Hi Kevin,

> my sense has been all along that there isn't a ground swell of
immediate 
> need for the SIP MIBs as of yet across the sip community.

Perhaps.  But good MIBs tend to beget good (SNMP[v3]-based) management
applications, not the other way around.  And the absence of good MIBs
for otherwise good technology (e.g., SIP) virtually guarantees that
other management solutions will be deployed, increasingly lowering the
sense of (but not the reality of) need for those good MIBs.

Cheers,
BobN

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Kevin Lingle <[email-masked]>
Date: Thu, 25 Mar 2004 13:54:53 -0500

bob,

agreed.   and i think about the need to move the
draft forward almost all the time.  the issue, for
me personally, has been product development priorities.
working on this mib is by no means my main job ;)
i think i speak for my co-author as well.

i alluded to this being the _2nd wglc_ for this draft.
that was a result of us pausing, after the 1st wglc
was concluded, and taking the extra step to migrate the
mibs to be aligned with the 2nd rfc for sip (rfc3261).
the release of rfc3261 came about in the same timeframe.
so in that sense we are trying to provide the due diligence
to make the mibs better.  an rfc would probably exist
if we had not taken this step.  but it was the right
thing to do.

my comments about no ground swell relate to:
1) the fact that we, over the life of this draft
    [which is waaaayyyy too long], we've not gotten
    any sense of urgency to get the mibs done.
    i expect/hope this will change as sip becomes more and
    more mainstream.   i may have been able to
    justify more of my time for the draft work
    had there been a more vocal response from the
    sip community wrt the need for MIBs to be in
    place sooner than later.

2) our ability to solicit interest from the sip
    community to review the various drafts has also
    consistently been a problem.  to the point where
    sometimes i felt we were offering candidate mib
    objects in a vaccum.    having 2 last call reviews
    has helped this issue though.    it is also a case
    of most folks being very interested in the protocol
    but not really being "MIB folk" ;)

we will eventually get there with the draft (hopefully
sooner than later ;).

kevin