Subject: [Sip] Caller-Preferences: "no-fork" directive and addresses with equal q-value

From: [email-masked]
Date: Fri, 7 May 2004 10:27:06 +0200

Hello,

I've looked to the Draft(/RFC) but could not really figure out
how a server is supposed to work when it receives a request
with "no-fork" but it has addresses with equal q value. I mean
in what cases can it happen that the server does not accept the
"no-fork" directive and forks the request?

Generally, what is the best way for gateway type of UAs to
indicate that no forking should happen as e.g. parallel early
media may confuse the user? Does it have any effect to proxies
supporting caller preferences if Proxy-Require is set to indicate
that pref extension need to be supported?

Thanks in advance.

BR,
-Ervin

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 12 May 2004 02:10:36 -0400

inline.

[email-masked] wrote:
> with "no-fork" but it has addresses with equal q value.

In this case it would be a matter of local policy. Pick one.

> I mean

Also a matter of local policy; the directive is a suggestion from the 
user that they prefer the call not to fork.

> that pref extension need to be supported?

Proxy-Require doesn't guarantee that the directive is honored; it just 
guarantees that caller preferences is understood. There is no way using 
caller prefs to fail a request because a proxy decides it wants to fork.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com