Subject: RE: [Sip] SIP Forward, Who pays the bill ?

From: "Fred Hasle" <[email-masked]>
Date: Tue, 18 May 2004 08:29:54 -0400

Hello Diego,
My understanding is the Diversion Header will be replaced with the
Request History Information
(http://www.ietf.org/internet-drafts/draft-ietf-sip-history-info-02.txt)
Fred.

----
Fred Hasle.
Leapstone Systems www.leapstone.com

-----Original Message-----
From: Diego B [mailto:[email-masked]] 
Sent: Tuesday, May 18, 2004 7:42 AM
To: [email-masked]; sipping
Cc: Cullen Jennings
Subject: [Sip] SIP Forward, Who pays the bill ?

Hi;
My question is regarding billing a forwarded sip call.

Lets take the exmple from draft-ietf-sipping-service-examples
2.7

Alice calls Bob, and Bob has all his incomming calls forwarded to the
PSTN.

Let say that calls from ALice to Bob in the same domain are free (same 
office, or same ITSP), but calls to the PSTN are not free.

Who pays for Alice call to Bob ??
In a normal situacion, Alice knows that the call is for free becuase she

is calling Bob's sip number. But the gateweay may create CDR from the 
 From header of the SIP message and at the end of the month Alice may 
have to pay for the call.

I see this kind of examples in several other drafts/RFC related to SIP 
services and call forward.

I belive forward is a very important feature, but this issue may be 
resolved. The question is if it is a standard way to make Bob pays for 
the second leg of the call like in PSTN forward.

Maybe changing the From header where applicable and adding a new one to 
"remember" that the call is from, in my example, Alice.

The diversion header (Diversion Indication in SIP 
draft-levy-sip-diversion-07.txt)" may be a solution if the PSTN gateway 
or the SIP Billing server support it and knows that they have to bill 
the sip-uri in the diversion header ( this is right ??? ).

Regards;

-- 
Diego B
MailVision Ltd.
Tel.  : +972-4-8500505 ext 13
e-mail: [email-masked]
web   : http://www.mailvision.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 19 May 2004 11:31:09 +0100

To the best of my knowledge, IETF will not implement a charging solution. Nor will it standardise any particular user as paying for the call.

What IETF has done, and will continue to do, is standardise the information that should be placed in various headers, such that when that information is transferred into a CDR (CDR format not specified by IETF), it can be used for appropriate billing.

You can see a standardised billing model for the IMS specified for 3GPP in 3GPP TS 32.225 (for release 5) and 3GPP TS 32.260 (for release 6).

Note that it is entirely possible that your media does not pass through the entities that are generating the CDRs based on signalling, in which case unless some CDRs are collected for the media as well, and some coordination performed, then you will have a model that only charges for the signalling. In your gateway case, I assume that this is not happening.

regards

Keith

> Sent: 18 May 2004 15:14
> To: [email-masked]
> Cc: [email-masked]; 'sipping'; 'Cullen Jennings'
> Subject: Re: [Sip] SIP Forward, Who pays the bill ?
> 
> 
> Hi Baruch;
> Thanks for your answer.
> I belive that you are implementing a proprietary solution to 
> deal with it.
> I'm looking more to a standarize way to deal with the 
> second-leg issue.
> 
> I'm agree that Alice has to pay for the first leg and Bob for the 
> second, but if the Proxy that is doing the forward is not a biling 
> entity ( local calls are free, outbound call are not free and 
> billed by 
> an external real-time billing system connected to the GW 
> using RADIUS or 
> similar), the PSTN gateway will have to know that this call may be 
> billed to Bob and not to Alice ( she apears in the From header ).
> 
> Thanks
> 
> Baruch Sterman wrote:
> 
> > In the systems that we implemented, two cdrs are created: 
> the first for
> > the incoming leg (Alice to Bob's non-forwarded location) 
> and a second
> > for the forward to Bob's forwarded location.
> > 
> > Alice would pay for the first leg, and Bob pays for the second.
> > 
> > Furthermore, it may be the case that Bob pays for the first 
> leg as well.
> > If, for example, Bob has a toll free number where he pays per minute
> > charges for the inbound leg (in this case, Alice is on the PSTN). 
> > 
> > Either way, multiple CDRs is the way we came up with to handle this.
> > Care has to be taken that the key to any CDR database is NOT the
> > call-ID, because this is the same across the two CDRs.
> > 
> > Baruch
> > 
> > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Diego
> > B