Subject: [Sip] NOTIFY on call transfer procedure

From: Thomas Ackermann <[email-masked]>
Date: Mon, 10 May 2004 07:02:31 +0200

Hi all,

can anybody tell me why the transfer procedure needs NOTIFY message
with application/sipfrag message body?

Why not simply keep the REFER transaction open by sending:
 - a provisional response instead of the 202/Accepted and
 - a final 200/OK response instead of NOTIFY(200 OK) ?
Just like the INVITE transaction with all its intermediate responses.

Or even more simple:
The Transferee sends the BYE by itself instead of asking the Transferor
to terminate the call?

Do you know the reason why the NOTIFY transaction has been added to
call transfer procedure?

Thanks for your help,
Thomas

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chadha Retesh-A19894 <[email-masked]>
Date: Fri, 14 May 2004 14:24:50 +0530

NOTIFY is needed to notify the UA that the media shuffle between 2 parties is successful. 202 reponse to REFER can't be sent after success of media shuffle, since media shuffle can take more than 32 seconds(default transaction timeout value). 

BYE also doesn't make sense, as it will just signify termination of call, but not if call-transfer was success or not. There can be inconsistent state in this case, if the Transferee terminates the calls while transfer is in progress.

Regards
Retesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Ackermann
Sent: Monday, May 10, 2004 10:33 AM
To: [email-masked]
Subject: [Sip] NOTIFY on call transfer procedure

Hi all,

Or even more simple:

Thanks for your help,
Thomas