Subject: Re: [Sip] Load Balancing In SIP

From: Karthik M <[email-masked]>
Date: Tue, 18 May 2004 16:51:14 +0800

MessageDear Xavier and all,
    First of all, thanks for your info.
    I think DNS solution are good only for scalability in equal weighted servers and they cant dynamically adjust the load on the fly. Also DNS Updates are to be done by the server which most of the time is not in our control. High availability is difficult to achieve with the DNS based LB. So, this may be good for a public proxy kind of scenario but not for a app server kind of thing.
    I am looking for more generic solution for LB's, where the LB system takes care of adusting the load dynamically, do session affinity, provide high availablility for the LB system. This means that i have only one outbound proxy (LB system) and whole cluster is hidden behind that.
    Expecting your valuable comments on this and details abt any current implementations( both commerical/open source).

Thanks
Karthik M
  ----- Original Message ----- 
  From: MARJOU Xavier FTRD/DAC/LAN 
  To: [email-masked] 
  Sent: Tuesday, May 18, 2004 2:28 PM
  Subject: RE : [Sip] Load Balancing In SIP

  Hi,

  Look at RFC3263 and DNS SRV.

  Best Regards,
  Xavier
    -----Message d'origine-----
    De : [email-masked] [mailto:[email-masked]] De la part de Karthik M
    Envoyé : mardi 18 mai 2004 04:43
    À : [email-masked]
    Objet : [Sip] Load Balancing In SIP

    Hello all,
        Can anyone provide me links/ideas on general load balancing solutions implemented in sip servers. I want to whether there are any hardware based load balancer similar to HTTP and its functionality.

    Thanks in advance
    Karthik M

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 18 May 2004 10:01:12 -0400

As soon as you have a load balancer, you have introduced another single 
point of failure. Session affinity can easily be assured by SIP routing 
means. It seems dangerous to extrapolate the HTTP architecture to SIP - 
the issues, tools and problems are rather different.

Karthik M wrote:

> Dear Xavier and all,
>     I think DNS solution are good only for scalability in equal weighted 
> servers and they cant dynamically adjust the load on the fly. Also DNS 
> Updates are to be done by the server which most of the time is not in 
> our control. High availability is difficult to achieve with the DNS 
> based LB. So, this may be good for a public proxy kind of scenario but 
> not for a app server kind of thing.
>     I am looking for more generic solution for LB's, where the LB system 
> takes care of adusting the load dynamically, do session affinity, 
> provide high availablility for the LB system. This means that i have 
> only one outbound proxy (LB system) and whole cluster is hidden behind that.
>     Expecting your valuable comments on this and details abt any current 
> implementations( both commerical/open source).
>  
> Thanks
> Karthik M
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Karthik M <[email-masked]>
Date: Tue, 18 May 2004 22:24:33 +0800

Dear Henning schulzrinne,

Load balancer in vovida.org does HA thru peer LBs.
I think it provides similar feature what i require. the problem with that is
there is no dynamic load adjusting based on the server performance.Also i
dont like the idea of session data being updated in the peer for every call
data.
I thought of something like session data to be carried along with the dialog
message like JSession in HTTP request (may be its difficult) and send to the
peer LB and LB proxy will take care of the identifying the session,
dispatching it to the backend server.
    If you see weblogic application server, they identify the server cluster
details using the cookie as shown :
sessionid!primary_server_id!secondary_server_id

   In this case, i can have a standy peer LB which will take care when the
primary LB goes down. also the LB details are not in the LB proxy but in the
message. so any stateless LB can dyamically discover the servers and
dispatch.

  Let me know if i am wrong somewhere or please provide your ideas.

Thansk

Karthik

----- Original Message -----
From: "Henning Schulzrinne" <[email-masked]>
To: "Karthik M" <[email-masked]>
Cc: "MARJOU Xavier FTRD/DAC/LAN" <[email-masked]>;
<[email-masked]>
Sent: Tuesday, May 18, 2004 10:01 PM
Subject: Re: [Sip] Load Balancing In SIP