Subject: RE: [Sip] Bug in RFC3261 ?

From: [email-masked]
Date: Wed, 5 May 2004 11:11:40 +0300

Well, you were pointing at the right sections. 17.1.1.2 and 17.1.2.2 specify that when Timer B (for INVITE) and Timer F (for non-INVITE) fire, "the client transaction SHOULD inform the TU about the
   timeout, and then it SHOULD enter the "Terminated" state"
 
Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext [email-masked]
Sent: 05.May.2004 03:02
To: PROUVOST Sébastien FTRD/DAC/ISS
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] Bug in RFC3261 ?

Hi Sébastien, 

I just re-read your question and realised it's more complicated than I thought :-) 

Hmmm......I'm not sure what it should do either. 

I'm sure someone smarter than me will be along shortly though :-) 

B

Ben Gatewood
Dimension Data
SIP Wookie
Level 1 10 Dorcas Street South Melbourne
+61 3 9626 0735
+61 419 885 762
[email-masked] 

	[email-masked] 
Sent by: [email-masked] 

05/05/2004 08:33 AM 

        To:        PROUVOST Sébastien FTRD/DAC/ISS <[email-masked]> 
        cc:        [email-masked], [email-masked] 
        Subject:        Re: [Sip] Bug in RFC3261 ?

Hi Sébastien, 

There are procedures and timers for this situation in 3261. Have a look at Section 17.1.1.2 and 17.1.2.2. 

Basically the UA should wait 64*T1 (Timer 1). T1, by default, should be 500ms so your UA should wait 32 seconds for a valid response. 

HTH, 

B

Ben Gatewood
Dimension Data
SIP Wookie
Level 1 10 Dorcas Street South Melbourne
+61 3 9626 0735
+61 419 885 762
[email-masked] 

	PROUVOST Sébastien FTRD/DAC/ISS <[email-masked]> 
Sent by: [email-masked] 

04/05/2004 07:49 PM 

       To:        <[email-masked]> 
       cc:         
       Subject:        [Sip] Bug in RFC3261 ?

Hi, 
In RFC 3261, it is written (section 8.1.3.3 for UAC Core procedures) : "If more than one Via header field value is present in a response, the UAC SHOULD discard the message." 

However if the UAC Core layer discards the response and if this response was the only one sent (for example a 200 OK to an UPDATE), then this leads to a situation when the transaction is terminated (the transaction layer received the response and passed it to the UA Core) but the UA Core is still waiting for a response (it discarded the 200 OK because of the presence of two Via header field values and so is still waiting for the response). 

I believe there shall be procedures that tells the UAC Core when to stop waiting for the response. Or am I misunderstanding something ? 

Thanks for your clarifications, 

Sébastien Prouvost 
France Telecom R&D 

******************************************************************************
- NOTICE FROM DIMENSION DATA AUSTRALIA
This message is confidential, and may contain proprietary or legally privileged information. If you have received this email in error, please notify the sender and delete it immediately.

Internet communications are not secure. You should scan this message and any attachments for viruses. Under no circumstances do we accept liability for any loss or damage which may result from your receipt of this message or any attachments.
******************************************************************************

---

From: Prasanna <[email-masked]>
Date: Thu, 06 May 2004 13:48:54 +0530

There is a basic confusion...
8.1.3.3 mentions that the "UAC" should discard the message.
But is it the "transaction layer" that is discarding the message or the "TU"
(which is the UA core in this case) discarding the message.
If the transaction discards it, Hisham's flow is okay, the timers will fire.
But what if the UA core discards.  Assuming the UPDATE----200 exchange,
In this case, the transaction would have assumed the 200 response to be fine
and moved to the "completed" state.  There is no Timer F in this case
anyway.
Worse will be case if the exchange is INVITE---180----200,
And 200 has to be discarded.  The moment transaction deemed the 200 to be
okay, it will terminate.

Even if what 8.1.3.3 mentions is for the transaction, how about the
validation of the Table 2 / Table 3 requirements.
What if there is 423 without Min-Expires or a 200 for INVITE without
Contact?

Should the complete validation be done by the transaction layer?

Cheers,
Prasanna

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, May 05, 2004 1:42 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Sip] Bug in RFC3261 ?

Well, you were pointing at the right sections. 17.1.1.2 and 17.1.2.2 specify
that when Timer B (for INVITE) and Timer F (for non-INVITE) fire, "the
client transaction SHOULD inform the TU about the
   timeout, and then it SHOULD enter the "Terminated" state"

Hisham
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext

Hi Sébastien, 

I just re-read your question and realised it's more complicated than I
thought :-) 

B

Ben Gatewood
Dimension Data
SIP Wookie

        To:        PROUVOST Sébastien FTRD/DAC/ISS
<[email-masked]> 
        cc:        [email-masked], [email-masked] 
        Subject:        Re: [Sip] Bug in RFC3261 ?

Hi Sébastien, 

There are procedures and timers for this situation in 3261. Have a look at
Section 17.1.1.2 and 17.1.2.2. 

Basically the UA should wait 64*T1 (Timer 1). T1, by default, should be
500ms so your UA should wait 32 seconds for a valid response. 

HTH, 

B

Ben Gatewood
Dimension Data
SIP Wookie

Hi, 
In RFC 3261, it is written (section 8.1.3.3 for UAC Core procedures) : "If
more than one Via header field value is present in a response, the UAC
SHOULD discard the message." 
However if the UAC Core layer discards the response and if this response was
the only one sent (for example a 200 OK to an UPDATE), then this leads to a
situation when the transaction is terminated (the transaction layer received
the response and passed it to the UA Core) but the UA Core is still waiting
for a response (it discarded the 200 OK because of the presence of two Via
header field values and so is still waiting for the response). 
I believe there shall be procedures that tells the UAC Core when to stop
waiting for the response. Or am I misunderstanding something ? 
Thanks for your clarifications, 
Sébastien Prouvost 
France Telecom R&D 

****************************************************************************
**
- NOTICE FROM DIMENSION DATA AUSTRALIA
This message is confidential, and may contain proprietary or legally
privileged information. If you have received this email in error, please
notify the sender and delete it immediately.

Internet communications are not secure. You should scan this message and any
attachments for viruses. Under no circumstances do we accept liability for
any loss or damage which may result from your receipt of this message or any
attachments.
****************************************************************************
** 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip