Subject: RE: [Sip] SIP Forward, Who pays the bill ?

From: "Roy, Radhika R, ALABS" <[email-masked]>
Date: Wed, 19 May 2004 21:49:35 -0400

I agree with Baruch that AAA group is working for authentication, authorization, and accounting of applications including SIP, and there is enough room to build CDRs/Billing based on those things. So, SIP WG does not need to be worried for this.
 
Radhika R. Roy
[email-masked]
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Baruch Sterman
Sent: Wednesday, May 19, 2004 5:47 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sip] SIP Forward, Who pays the bill ?

Another avenue that can be explored is an explicit header to deal with this and other accounting issues. I think that the AAA group has suggested an ACCOUNTING header. We were thinking of a BILLING header. In that header you would have a username and type. So as the call progresses you could add to that header. This would also allow to charge for various services along the way. Imagine the following. Alice calls Bob, Bob forwards to Charlie who requires an ENUM lookup to find his IP – and you are dealing with a psychotic ITSP that *Charges* for ENUM listing.
Inbound Alice -> Bob         Billing: Alice, inbound
Forward Bob -> Charlie      Billing: Alice, inbound; Bob, outbound
ITSP looks up Charlie        Billing: Alice, inbound; Bob, outbound; Charlie, serviceX
 
So when the CDR gets written, the rating engine looks through the Billing header and applies all the relevant charges to the relevant accounts. Some may be per minute, some may be fixed charges.
 
The problems are first and foremost, security. No one can add to the billing header unless they are trusted entities within your system, because money will be charged based on the information there. Second, care has to be taken to strip off the header when it leaves the trusted domain – out to the UA’s for example. You don’t want people knowing what is going on in your billing system. 
 
But the idea here is very flexible and can take into account many things that we aren’t thinking about now. For example, we may charge differently one day calls that require NAT treatment on the RTP level (where the bandwidth cost to the hosting ITSP is not negligible). When you find that to be the case, just add it to the Billing header. What about if calls are forwarded multiple times? Keep adding each leg to the billing header.
 
What does everyone think about this?
 
Baruch
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 19, 2004 1:00 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sip] SIP Forward, Who pays the bill ?
 
Also , Alice might be sending the re-invite to on receipt of a 302 from Bob. So the set of proxies invloved in the first leg of the call may not be involved in the second ?
Solutuion to this will be on the PSTN gateway side.
The PSTN gateway should look for and bill from Diversion/Request History/remote Part Header information in preference to the from header which is unreliable any way.
However , I do not know of any standards which explicitly mentions that ..
 
Regards ,
Sayan
 
-----Original Message----- 
From: [email-masked] on behalf of Diego B 
Sent: Tue 5/18/2004 7:44 PM 
To: [email-masked] 
Cc: [email-masked]; 'sipping'; 'Cullen Jennings' 
Subject: Re: [Sip] SIP Forward, Who pays the bill ?
Hi Baruch;
Thanks for your answer.
I belive that you are implementing a proprietary solution to deal with it.
I'm looking more to a standarize way to deal with the second-leg issue.

I'm agree that Alice has to pay for the first leg and Bob for the
second, but if the Proxy that is doing the forward is not a biling
entity ( local calls are free, outbound call are not free and billed by
an external real-time billing system connected to the GW using RADIUS or
similar), the PSTN gateway will have to know that this call may be
billed to Bob and not to Alice ( she apears in the From header ).

Thanks

Baruch Sterman wrote:

> In the systems that we implemented, two cdrs are created: the first for
> the incoming leg (Alice to Bob's non-forwarded location) and a second
> for the forward to Bob's forwarded location.
>
> Alice would pay for the first leg, and Bob pays for the second.
>
> Furthermore, it may be the case that Bob pays for the first leg as well.
> If, for example, Bob has a toll free number where he pays per minute
> charges for the inbound leg (in this case, Alice is on the PSTN).
>
> Either way, multiple CDRs is the way we came up with to handle this.
> Care has to be taken that the key to any CDR database is NOT the
> call-ID, because this is the same across the two CDRs.
>
> Baruch
>
> -----Original Message-----
> From: [email-masked] [ mailto:[email-masked]] On Behalf Of Diego
> B
> Sent: Tuesday, May 18, 2004 7:42 AM
> To: [email-masked]; sipping
> Cc: Cullen Jennings
> Subject: [Sip] SIP Forward, Who pays the bill ?
>
> Hi;
> My question is regarding billing a forwarded sip call.
>
> Lets take the exmple from draft-ietf-sipping-service-examples
> 2.7
>
> Alice calls Bob, and Bob has all his incomming calls forwarded to the
> PSTN.
>
> Let say that calls from ALice to Bob in the same domain are free (same
> office, or same ITSP), but calls to the PSTN are not free.
>
> Who pays for Alice call to Bob ??
> In a normal situacion, Alice knows that the call is for free becuase she
>
> is calling Bob's sip number. But the gateweay may create CDR from the
>  From header of the SIP message and at the end of the month Alice may
> have to pay for the call.
>
> I see this kind of examples in several other drafts/RFC related to SIP
> services and call forward.
>
> I belive forward is a very important feature, but this issue may be
> resolved. The question is if it is a standard way to make Bob pays for
> the second leg of the call like in PSTN forward.
>
> Maybe changing the From header where applicable and adding a new one to
> "remember" that the call is from, in my example, Alice.
>
> The diversion header (Diversion Indication in SIP
> draft-levy-sip-diversion-07.txt)" may be a solution if the PSTN gateway
> or the SIP Billing server support it and knows that they have to bill
> the sip-uri in the diversion header ( this is right ??? ).
>
> Regards;
>
>
>
>
>

--
Diego B
MailVision Ltd.
Tel.  : 4-8500505 ext 13
e-mail: [email-masked]
web   : http://www.mailvision.com <https://gateway-india.wipro.com/,DanaInfo=www.mailvision.com> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip <https://gateway-india.wipro.com/mailman/listinfo/sip,DanaInfo=www1.ietf.org,SSL> 
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 20 May 2004 16:36:26 -0400

To be clear, Baruch is proposing a new SIP header, which the SIP WG 
would need to worry about.

I do not think such a thing is needed. As Keith pointed out, our 
philosophy to date (and this is a broader IETF thing too), is to make 
sure that you can *account* for what has happened. That is, that the 
protocols contain sufficient information to record what transpired in a 
call/transaction/dialog or whatever. Then, its someone elses problem 
(for example, 3gpp) to specify how the appropriate information is 
collected, what billing model is used, and how a CDR is generated. Not 
to say that these things arent important, they're just not the SIP 
working group's problem.

-Jonathan R.

Roy, Radhika R, ALABS wrote:

> I agree with Baruch that AAA group is working for authentication, 
> authorization, and accounting of applications including SIP, and there 
> is enough room to build CDRs/Billing based on those things. So, SIP WG 
> does not need to be worried for this.
>  
> Radhika R. Roy
> [email-masked] <mailto:[email-masked]>
> 
>     *From:* [email-masked] [mailto:[email-masked]]*On Behalf Of
>     *Baruch Sterman
>     *Sent:* Wednesday, May 19, 2004 5:47 AM
>     *To:* [email-masked]; [email-masked]
>     *Cc:* [email-masked]; [email-masked]; [email-masked]
>     *Subject:* RE: [Sip] SIP Forward, Who pays the bill ?
> 
>     Another avenue that can be explored is an explicit header to deal
>     with this and other accounting issues. I think that the AAA group
>     has suggested an ACCOUNTING header. We were thinking of a BILLING
>     header. In that header you would have a username and type. So as the
>     call progresses you could add to that header. This would also allow
>     to charge for various services along the way. Imagine the following.
>     Alice calls Bob, Bob forwards to Charlie who requires an ENUM lookup
>     to find his IP – and you are dealing with a psychotic ITSP that
>     **Charges** for ENUM listing.
> 
>     So when the CDR gets written, the rating engine looks through the
>     Billing header and applies all the relevant charges to the relevant
>     accounts. Some may be per minute, some may be fixed charges.
> 
>      
> 
>     The problems are first and foremost, security. No one can add to the
>     billing header unless they are trusted entities within your system,
>     because money will be charged based on the information there.
>     Second, care has to be taken to strip off the header when it leaves
>     the trusted domain – out to the UA’s for example. You don’t want
>     people knowing what is going on in your billing system.
> 
>      
> 
>     But the idea here is very flexible and can take into account many
>     things that we aren’t thinking about now. For example, we may charge
>     differently one day calls that require NAT treatment on the RTP
>     level (where the bandwidth cost to the hosting ITSP is not
>     negligible). When you find that to be the case, just add it to the
>     Billing header. What about if calls are forwarded multiple times?
>     Keep adding each leg to the billing header.
> 
>      
> 
>     *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
>     [email-masked]
>     *Sent:* Wednesday, May 19, 2004 1:00 AM
>     *To:* [email-masked]; [email-masked]
>     *Cc:* [email-masked]; [email-masked]; [email-masked]
>     *Subject:* RE: [Sip] SIP Forward, Who pays the bill ?
> 
>      
> 
>     Also , Alice might be sending the re-invite to on receipt of a 302
>     from Bob. So the set of proxies invloved in the first leg of the
>     call may not be involved in the second ?
> 
>     The PSTN gateway should look for and bill from Diversion/Request
>     History/remote Part Header information in preference to the from
>     header which is unreliable any way.
> 
>         *From:* [email-masked] on behalf of Diego B
>         *Sent:* Tue 5/18/2004 7:44 PM
>         *To:* [email-masked]
>         *Cc:* [email-masked]; 'sipping'; 'Cullen Jennings'
>         *Subject:* Re: [Sip] SIP Forward, Who pays the bill ?
> 
>         Hi Baruch;
>         Thanks for your answer.
>>  From: [email-masked] [mailto:[email-masked]] On Behalf
>         Of Diego
>>  B
>         web   : http://www.mailvision.com
>         <https://gateway-india.wipro.com/,DanaInfo=www.mailvision.com>
> 
> 
> 
>         Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>         <https://gateway-india.wipro.com/mailman/listinfo/sip,DanaInfo=www1.ietf.org,SSL>

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 20 May 2004 20:33:12 -0700

Agree but wanted to add one little wrinkle that has been frustrating.

In SIP, things like the call-id are often used to help figure out what has
happened to the call. However, these are often selected by the UA with very
little constraints on them. Most SIP systems allow call-id to be infinitely
long, but most radius billing systems and databases used for correlation of
billing records use fields with some fixed maximum length. Implementers
should be aware of attacks based on this. Allowing the user (instead of the
network) to pick the identifier used to correlate billing information is not
the most desirable things from a security point of view.

Cullen

On 5/20/04 1:36 PM, "Jonathan Rosenberg" <[email-masked]> wrote:

>>     to find his IP  and you are dealing with a psychotic ITSP that
>>     the trusted domain  out to the UA¹s for example. You don¹t want
>>     things that we aren¹t thinking about now. For example, we may charge
>>         Tel.  : ?4-8500505 ext 13

---

From: Diego B <[email-masked]>
Date: Fri, 21 May 2004 10:28:37 +0200

Hi;

Agreed, but my first question was exactly that, if there is a standard 
way or standard Headers, to store information about a "forward" call.

In a normal situation, no one will touch the From header and "normally"
PSTN gateway copy the user-info from the From SIP-URI to the PSTN "B 
number", and this is normally used to create the CDR.

I'm not trying to solve the CDR creation issue or how to bill a forward 
call, but I'm looking to a standard way to store forward information so 
one day this information will be used correctly to create CDRs/billing.

In a close environment, I can use whatever method to  recognize a 
forward situation. But SIP is about inter operability and integration 
and AFAIK there are some drafts but nothing specific to inform of a call 
forward situation, I don't know the status of Diversion header, but this 
can be a solution if standardized.

Thanks

Jonathan Rosenberg wrote:
>>>  In the systems that we implemented, two cdrs are created: the
>>
>>         first for
>>
>>>  the incoming leg (Alice to Bob's non-forwarded location) and a
>>
>>         second
>>
>>>  Furthermore, it may be the case that Bob pays for the first
>>
>>         leg as well.
>>
>>>  If, for example, Bob has a toll free number where he pays per
>>
>>         minute
>>
>>>  Either way, multiple CDRs is the way we came up with to handle
>>
>>         this.
>>
>>>  Alice calls Bob, and Bob has all his incomming calls forwarded
>>
>>         to the
>>
>>>  PSTN.
>>>
>>>  Let say that calls from ALice to Bob in the same domain are
>>
>>         free (same
>>
>>>  In a normal situacion, Alice knows that the call is for free
>>
>>         becuase she
>>
>>>
>>>  is calling Bob's sip number. But the gateweay may create CDR
>>
>>         from the
>>
>>>  From header of the SIP message and at the end of the month
>>
>>         Alice may
>>
>>>  I see this kind of examples in several other drafts/RFC
>>
>>         related to SIP
>>
>>>  I belive forward is a very important feature, but this issue
>>
>>         may be
>>
>>>  resolved. The question is if it is a standard way to make Bob
>>
>>         pays for
>>
>>>  Maybe changing the From header where applicable and adding a
>>
>>         new one to
>>
>>>  draft-levy-sip-diversion-07.txt)" may be a solution if the
>>
>>         PSTN gateway
>>
>>>  or the SIP Billing server support it and knows that they have
>>
>>         to bill
>>

-- 
Diego B
MailVision Ltd.
Tel.  : +972-4-8500505 ext 13
e-mail: [email-masked]
web   : http://www.mailvision.com

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 21 May 2004 11:55:22 +0300

> can be a solution if standardized.

both rpid and diversion headers have become de-facto industry ways to
achieve that you want.  may be one day some ietf standardized way to do
the same becomes widely implemented, at which point you can support this
new thing too.

-- juha