Subject: [Sip] Session Timer - Terminology is no clear

From: "Sarit Galanos" <[email-masked]>
Date: Mon, 3 May 2004 12:11:15 +0300

Hi,
The session timer draft uses the term "Initial Session Refresh Request".

The draft defines that 
              "Session Refresh Request: An INVITE or UPDATE request within a dialog."

>From that I understand that "Initial Session Refresh Request" is the first re-Invite or Update inside that dialog.

But, If the dialog was established with session timer parameters and after the first INVITE-200-ACK session time is already active,
why is there a difference between the initial refresh and further refreshes.
Or is that the  "Initial Session Refresh Request" is the first request that has session timer parameters
and it can also be the initial INVITE?

Thanks,
Sarit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 03 May 2004 10:05:52 -0400

The language in this is at times obscure. I think in part this results 
from the age of the document. (It has been in progress for years, I 
think since before 2543bis. So terminology has changed around it.)

Part of the problem is that it is written as if a reINVITE or UPDATE is 
done solely for the purpose of session timer refresh. But in reality 
things are not that simple.

A reINVITE or an UPDATE does a bunch of stuff. If session-timer is 
supported then refreshing, or cancelling, a session timer is one of the 
things it does. Any time a reINVITE or UPDATE is sent, it will affect 
the session timer one way or another, whether that was the primary 
intent in sending the message, or not.

There also isn't anything special about the "first" refresh. The request 
that first establishes a dialog also establishes some kind of session 
timer state - either leaving it disabled, or running. Every subsequent 
reINVITE, UPDATE (and reSUBSCRIBE too) does the same thing - 
restablishes a new session timer or else leaves the dialog with none. 
There is no need to consider what the previous state was - the new state 
is not affected by that.

All that the session timer mechanism does is force a reINVITE or UPDATE 
to happen by a particular time if one hasn't happened for any other reason.

	Paul