Subject: [Sip] SIP Loose routing

From: "Nuno Filipe Oliveira Novo" <[email-masked]>
Date: Wed, 02 Feb 2005 17:59:54 +0000

Dear all,
When studing loose routing in Sip i stumble in a question.
imagine that we have the situation:
Alice . . .atlanta.com . . . . . biloxi.com . . . Bob

Alice is registered in atlanta.com and Bob in biloxi.com. 
Let's assume that atlanta.com is a loose router proxy and 
biloxi.com is a strict router proxy.
When Alice try to contact Bob she send a INVITE to the 
proxy atlanta.com with the request URI filled with Bob sip 
URI.So far so good.

Now the proxy atlanta.com needs to contact with the 
biloxi.com.

The question is does the proxy atlanta.com, using a search 
mechanism based on DNS, knows that the proxy biloxi.com is 
a strict router?
Or proxy atlanta.com assume that bilibox.com is a stric 
router because atlanta.com doesn't have that kind of 
information about bilibo.com?
Is there any way of a proxy knowing if the next proxy is a 
strict or loose router in this situation?

Best Regards:
Nuno Novo.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Thu, 3 Feb 2005 10:41:45 -0600

Inline:

On Feb 2, 2005, at 11:59 AM, Nuno Filipe Oliveira Novo wrote:

> Alice is registered in atlanta.com and Bob in biloxi.com. Let's assume 
> that atlanta.com is a loose router proxy and biloxi.com is a strict 
> router proxy.
> When Alice try to contact Bob she send a INVITE to the proxy 
> atlanta.com with the request URI filled with Bob sip URI.So far so 
> good.
>
> Now the proxy atlanta.com needs to contact with the biloxi.com.
>
> The question is does the proxy atlanta.com, using a search mechanism 
> based on DNS, knows that the proxy biloxi.com is a strict router?
> Or proxy atlanta.com assume that bilibox.com is a stric router because 
> atlanta.com doesn't have that kind of information about bilibo.com?
> Is there any way of a proxy knowing if the next proxy is a strict or 
> loose router in this situation?

Inside an established dialog (with a route-set built with Record-Route, 
atlanta.com knows whether biloxi.com is a loose
or strict router by looking for ";lr" in the next Route URI.

I think you're asking about the case where Alice is sending an initial 
INVITE to sip:[email-masked] using a preloaded
route that sends her request through atlanta.com. In this case, Alice's 
initial request is going to look like:
INVITE sip:[email-masked]
Route: <sip:atlanta.com;lr>

altanta.com will consume that route header. There is no subsequent 
route header, so it makes no
difference if biloxi.com is a strict or loose router.  The request 
going from atlanta  to biloxi will be
just

INVITE sip:[email-masked]

RjS