Subject: [SIP] SDP in OPTIONS

From: "Peter Hedman (LD/EAB)" <[email-masked]>
Date: Wed, 23 Feb 2005 12:50:42 +0100

Hi,

3GPP are discussing capability exchange using SIP OPTIONS. Specifically, to be able to optimise an exchange by including UAC capabilities within the OPTIONS request, for information to those UAS that understand it. The current understanding is that a UAS following RFC 3261 would simply ignore the SDP in the OPTIONS request and normal operations take place. 

Also, even if the UAS would read the SDP in an OPTIONS request, the SDP in the response would also be a capability document that will not in any way follow the offer/answer model.

It would be great to get the groups opinion on the above assumptions.

BR,
Peter

Ericsson AB
Phone: +46 46 231760
Mobile: +46 703602149
Mail: [email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Scott Godin" <[email-masked]>
Date: Thu, 24 Feb 2005 08:20:05 -0500

My understanding is that if an SDP if provided in the OPTIONS request the
SDP in the 200 response should be the same as it would be if the UA was
responding to an INVITE request - of course the SDP exchange should not be
acted on - it is only used for capability discovery.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter
Hedman (LD/EAB)
Sent: Wednesday, February 23, 2005 6:51 AM
To: [email-masked]
Subject: [SIP] SDP in OPTIONS

Hi,

3GPP are discussing capability exchange using SIP OPTIONS. Specifically, to
be able to optimise an exchange by including UAC capabilities within the
OPTIONS request, for information to those UAS that understand it. The
current understanding is that a UAS following RFC 3261 would simply ignore
the SDP in the OPTIONS request and normal operations take place. 

Also, even if the UAS would read the SDP in an OPTIONS request, the SDP in
the response would also be a capability document that will not in any way
follow the offer/answer model.

BR,
Peter

Ericsson AB
Phone: +46 46 231760
Mobile: +46 703602149

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 24 Feb 2005 09:55:49 -0600

At 08:20 AM 2/24/2005 -0500, Scott Godin wrote:
>responding to an INVITE request

I thought the SDP in the 200 OK could/would include all the session 
parameters the UAS was willing to reveal (including all the codecs the UAS 
was willing to communicate with).

>  - of course the SDP exchange should not be

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented