Subject: [Sip] Requests within SIP Dialog and Contact Header

From: "Shekar, Nagesh Soma (Shekar)** CTR **" <[email-masked]>
Date: Tue, 1 Feb 2005 14:20:51 -0500

The Contact header is defined as a Mandatory Header in some of Request messages,
like NOTIFY as a mandatory header. 
 
I am trying to understand if this is required for SIP header like Contact to be mandatory
in SIP requests that are sent in a dialog that is already setup with a INVITE transaction.
If it is required, then what is the intent of making it Mandatory and how it should be used.
 
In my opinion, I think a distinction needs to be made between the case how a request
such as NOTIFY is used. If it is used to setup a dialog, then SIP headers like Contact 
should be mandatory, otherwise they should be not even be present.
 
Nagesh Shekar 
Email: [email-masked] 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 2 Feb 2005 13:16:39 -0500

> I am trying to understand if this is required 
> for SIP header like Contact to be mandatory
> in SIP requests that are sent in a dialog that 
> is already setup with a INVITE transaction.
> If it is required, then what is the intent of 
> making it Mandatory and how it should be used.

The Contact was made mandatory in some requests (NOTIFY, SUBSCRIBE, INVITE)
to help with dialog establishment and dialog recovery.

NOTIFY, SUBSCRIBE, INVITE, and UPDATE are target refresh requests.

Thus a Contact change in these requests indicate an attempt update the
dialog.

http://www.sipwg.org/show_bug.cgi?id=699

http://www1.ietf.org/mail-archive/web/sip/current/msg06960.html