Subject: [Sip] sip and dns

From: "Suganya" <[email-masked]>
Date: Wed, 2 Feb 2005 05:34:26 +0530

Hi,

I have the following doubts and need some help.

a) In order to contruct DNS query, I googled-up and found RFCs 1034 and
1035. But it doesn't talk of SIP. Can those guidelines be used for
constructing the DNS for SIP related queries?

b) Where to send the DNS query from UAC?

c) Unlike RFC 3261 which clearly tells how to construct invite, ack, etc...
messages, RFC 3263 specifies no syntax or query format to construct the DNS
query.

Regards,
B.Suganya

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rajeew Kumar Singh <[email-masked]>
Date: Thu, 03 Feb 2005 11:32:55 +0530

Hi,
SIP uses DND procedure to resolve SIP URI into
IP address, Port and Transport of the  next hop to contact.

In order to get this support your SIP stack should support the Client DNS
procedures
defined in RFC 3263. Also your stack should have support for sending NAPTR
and SRV query as well as maintaioning the list of all resolved addresses.

If your SIP stack is supporting then your application can use them one by
one in case of Message send failure.
Your SIP stack should be configured with a list of DNS servers and domain
suffix.

DNS query from UAC is sent to DNS server.

Rajeew Kumar Singh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Suganya
Sent: Wednesday, February 02, 2005 5:34 AM
To: [email-masked]
Subject: [Sip] sip and dns

Hi,

Regards,
B.Suganya