Subject: [Sip] SIP INFO & DTMF

From: [email-masked]
Date: Tue, 08 Feb 2005 09:15:09 +0100

Hi all,

I am currently confused how DTMF digits can be carried via the
signalling path using SIP. If I am not mistaking, then a SIP INFO
message should be used, but the confusion that I have is how should
the content look like ?

There are some drafts, namely:

 -  /draft-choudhuri-sip-info-digit-00.txt expired October 2000
/ - ///draft-mahy-sipping-signaled-digits-00.txt expired May 2002/

but as you can see, all expired.

Some think RFC2833 should be used withing a SIP message.  But
it seems rather unlogical to use a sip info message to carry digits as
explained in rfc2833 which targets rtp packets ... ?

I have checked the implementation of some MGW manufacturers:
Cisco, Snom and AudioCodes all use draft 
/mahy-sipping-signaled-digits-00.txt/,
but is this the way to go ? Or is there maybe a new draft or standard
that tell us what to use ?

Thanks in advance,

    Van Opstal Jan
    R&D Alcatel Antwerp, Belgium

Note:
1) an example of a SIP INFO message using RFC2833:

INFO sip:192.168.50.7:5060 SIP/2.0
From: <sip:[email-masked];user=phone>;tag=0082-00000002-0021
To: <sip:[email-masked];user=phone>;tag=0082-000000dd-05d1i0
Call-ID: 0082-00000002-00214204b9f1-167e-433ca000@sipua
CSeq: 4 INFO
Max-Forwards: 29
Contact: "sipua" <sip:192.168.50.6:5060>
Content-Type: audio/telephone-event
Content-Length: 4

??,2,100

(the body part is not really correct: should be extracted as
explained in RFC2833)

2) an example of a SIP INFO msg using draft 
/mahy-sipping-signaled-digits-00.txt/:

INFO sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP 172.80.2.100:5060
From: <sip:[email-masked]>;tag=43
To: <sip:[email-masked]>;tag=9753.0207
Call-ID: [email-masked]
CSeq: 25634 INFO
Content-Length: 26
Content-Type: application/dtmf-relay

Signal= 7
Duration= 300
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 9 Feb 2005 09:10:38 -0000

Take a look at the application interaction work:-

http://www.ietf.org/internet-drafts/draft-ietf-sipping-app-interaction-framework-03.txt

in association with the 'Key Pad Markup Language':-

http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-07.txt

HTH,

Chris.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 08 February 2005 08:15
To: [email-masked]
Subject: [Sip] SIP INFO & DTMF

Hi all,

 -  draft-choudhuri-sip-info-digit-00.txt expired October 2000
 - draft-mahy-sipping-signaled-digits-00.txt expired May 2002

I have checked the implementation of some MGW manufacturers:
Cisco, Snom and AudioCodes all use draft mahy-sipping-signaled-digits-00.txt,
but is this the way to go ? Or is there maybe a new draft or standard
that tell us what to use ?

Thanks in advance,

    Van Opstal Jan

Note: 

INFO sip:192.168.50.7:5060 SIP/2.0
From: <sip:[email-masked];user=phone> <mailto:sip:[email-masked];user=phone> ;tag=0082-00000002-0021
To: <sip:[email-masked];user=phone> <mailto:sip:[email-masked];user=phone> ;tag=0082-000000dd-05d1i0
Call-ID: 0082-00000002-00214204b9f1-167e-433ca000@sipua
CSeq: 4 INFO
Max-Forwards: 29
Contact: "sipua" <sip:192.168.50.6:5060>
Content-Type: audio/telephone-event
Content-Length: 4

,2,100

2) an example of a SIP INFO msg using draft mahy-sipping-signaled-digits-00.txt:

INFO sip:[email-masked] SIP/2.0 
Via: SIP/2.0/UDP 172.80.2.100:5060 
From: <sip:[email-masked]> <mailto:sip:[email-masked]> ;tag=43 
To: <sip:[email-masked]> <mailto:sip:[email-masked]> ;tag=9753.0207 
Call-ID: [email-masked] 
CSeq: 25634 INFO 
Content-Length: 26 
Content-Type: application/dtmf-relay 

Signal= 7 
Duration= 300 

This email and any attached files are confidential and copyright protected.  If you are not the addressee, any dissemination, distribution or copying of this communication is strictly prohibited.  Unless otherwise expressly agreed in writing, nothing stated in this communication shall be legally binding.