Subject: Re: [Sip] midcall signalling

From: "Ban Zie" <[email-masked]>
Date: Fri, 25 Feb 2005 09:25:26 -0500

Thank you, all.

After researching the features of various commercial & free sip phones (hard & soft), I've reached the conclusion that rfc2833 is the most common approach, and almost every phone (actually i didn't find an exception so far) seems to implement it.

cheers,
z.
----- Original Message -----
From: "Mariano Stokle" <[email-masked]>
To: "Ban Zie" <[email-masked]>
Subject: Re: [Sip] midcall signalling
Date: Fri, 25 Feb 2005 11:01:59 -0300

> 
> You should also check
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-07.txt
> 
> 
> On Fri, 25 Feb 2005 00:03:24 -0500, Ban Zie <[email-masked]> wrote:
> > Thank you for your responses Fatih & Louis, they are very helpful.
> >
> > Is there a "common minimum" set for SIP phones on which 
> > mechanism(s) to use for midcall signalling ?
> > i.e. the recipient of such signalling (which in my case would be 
> > a minimalistic IVR / B2BUA), should
> > be prepared to receive such signalling in all these forms, or is 
> > it sufficient to pick one -- say
> > the inband DTMF ? I do not have access to a SIP hard-phone (yet! 
> > but should be getting one soon), so
> > do the sip phones s.a. CISCO's, PingTel's, SNOM's have some 
> > configuration to select which kind of
> > midcall signalling they'd send ?
> >
> > cheers,
> > zie.
> >
> > ----- Original Message -----
> > From: "Louis Alexander" <[email-masked]>
> > To: "'Fatih Ey|p NAR'" <[email-masked]>, "'Ban Zie'" 
> > <[email-masked]>, [email-masked]
> > Subject: RE: [Sip] midcall signalling
> > Date: Thu, 24 Feb 2005 17:00:32 -0500
> >
> > >
> > > Of course, plain old inband dtmf (the DTMF tones encoded as audio packets,
> > > NOT 2833 tones) is still legal as well :)
> > >
> > > --Louis
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatih
> > > Ey|p NAR
> > > Sent: Thursday, February 24, 2005 4:45 PM
> > > To: Ban Zie; [email-masked]
> > > Subject: Re: [Sip] midcall signalling
> > >
> > > SIP DMTF signalling is done with INFO messages or with
> > > RTP messages, the media protocol. This is defined in
> > > http://www.ietf.org/rfc/rfc2833.txt - IETF RFC 2833
> > >
> > >
> > > --- Ban Zie <[email-masked]> wrote:
> > >
> > > > hello,
> > > > is there 100% agreement / concensus on how midcall
> > > > signalling data is to be carried in sip ?
> > > > when 2 SIP UA's are alrady in conversation, then if
> > > > one user presses some keys on his keypad, are they
> > > > transmitted as DTMF on RTP, or how exactly is it
> > > > done ?
> > > > cheers,
> > > > bzie.
> > > > --
> > > ___________________________________________________________
> > > > Sign-up for Ads Free at Mail.com
> > > > http://promo.mail.com/adsfreejump.htm
> > > >
> > > >
> > > > _______________________________________________
> > > > Sip mailing list https://www1.ietf.org/mailman/listinfo/sip
> > > > This list is for NEW development of the core SIP
> > > > Protocol
> > > > Use [email-masked] for questions
> > > > on current sip
> > > > Use [email-masked] for new developments on the
> > > > application of sip
> > > >
> > >
> > >
> > > __________________________________________________
> > > Do You Yahoo!?
> > > Tired of spam?  Yahoo! Mail has the best spam protection around
> > > http://mail.yahoo.com
> > >
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol
> > > Use [email-masked] for questions on current sip
> > > Use [email-masked] for new developments on the application of sip
> > >
> > > ______________________________________________________________________
> > > This email has been scanned by the MessageLabs Email Security System.
> > > For more information please visit http://www.messagelabs.com/email
> > > ______________________________________________________________________
> >
> > --
> > ___________________________________________________________
> > Sign-up for Ads Free at Mail.com
> > http://promo.mail.com/adsfreejump.htm
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> 
> 
> --
> Mariano Stokle
> SIP Rules

-- 
___________________________________________________________
Sign-up for Ads Free at Mail.com
http://promo.mail.com/adsfreejump.htm

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ban Zie" <[email-masked]>
Date: Fri, 25 Feb 2005 09:39:46 -0500

> http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-07.txt

I quickly skimmed thru this I-D, and it appears to me that this is more likely to be associated as a Event delivery medium between and IVR / G/w / Transcoder and a SIP AppServer. In my scenario, i.e. UA <----> UA, this doesn't seem reasonable thing to do. Here the second-UA is like a Telephonic credit-card payment gateway.

-z