Subject: RE: [Sip] Requests within SIP Dialog and Contact Header

From: "Shekar, Nagesh Soma (Shekar)** CTR **" <[email-masked]>
Date: Wed, 2 Feb 2005 15:10:19 -0500

Brett,

Thanks for the clarification, if the NOTIFY is expected 
to be  a target  refresh request, then it makes sense 
that the Contact Header be mandatory. Unfortunately, 
there are some implementations that do not include Contact 
Header in NOTIFY messages (Ex. Pingtel Instant xpressa).

I am assuming that the bug is still not fixed. How does the 
bug fixing process work with RFCs, will there be a draft that 
will have the bug fixes.

Nagesh Shekar.

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Wednesday, February 02, 2005 1:17 PM
> To: 'Shekar, Nagesh Soma (Shekar)** CTR **'; [email-masked]
> Subject: RE: [Sip] Requests within SIP Dialog and Contact Header
> 
> 
> > The Contact header is defined as a Mandatory 
> > Header in some of Request messages,
> > like NOTIFY as a mandatory header. 
> > 
> > I am trying to understand if this is required 
> > for SIP header like Contact to be mandatory
> > in SIP requests that are sent in a dialog that 
> > is already setup with a INVITE transaction.
> > If it is required, then what is the intent of 
> > making it Mandatory and how it should be used.
> 
> The Contact was made mandatory in some requests (NOTIFY, 
> SUBSCRIBE, INVITE)
> to help with dialog establishment and dialog recovery.
> 
> NOTIFY, SUBSCRIBE, INVITE, and UPDATE are target refresh requests.
> 
> Thus a Contact change in these requests indicate an attempt update the
> dialog.
> 
> http://www.sipwg.org/show_bug.cgi?id=699
> 
> http://www1.ietf.org/mail-archive/web/sip/current/msg06960.html
> 
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Thu, 3 Feb 2005 10:34:43 -0600

REFER is also a target refresh request, and a similar bug has been
posted against 3515 for clarification.

To your last question: You can't change RFCs once they are published.
You can issue new RFCs that update older ones. We queue these 
clarifications
up in our bug database until it is appropriate to issue an updating 
RFC. Whenever
possible, we mention those clarifications when they affect other new 
work.

RjS