Subject: RE: [Sip] Draft defining the Accept-Disposition header field

From: Eric Burger <[email-masked]>
Date: Mon, 28 Feb 2005 15:25:16 -0500

Could you leverage RFC3459?

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Wednesday, January 12, 2005 7:36 AM
> To: sip
> Subject: [Sip] Draft defining the Accept-Disposition header field
> 
> 
> Folks,
> 
> I have submitted a draft that defines the Accept-Disposition header 
> field. The usage of this header field would be similar to the 
> usage of 
> Accept, Accept-Encoding, or Accept-Language, but it would indicate 
> support for disposition types.
> 
>
http://www.ietf.org/internet-drafts/draft-camarillo-sip-accept-disposition-0
0.txt

Your comments are welcome.

Thanks,

Gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Eric Burger <[email-masked]>
Date: Mon, 28 Feb 2005 15:25:16 -0500

Inline.

> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Friday, January 21, 2005 4:00 PM
> To: [email-masked]
> Cc: [email-masked]; Paul H Kyzivat
> Subject: Re: [Sip] Draft defining the Accept-Disposition header field
> 
[snip]
> 
> > The same thing with uri-list bodies. A conference server may support
> > uri-list bodies for some reason, but may not support the
> > 'recipient-list' disposition type. The disposition type is 
> what tells me
> > that the conference server supports (or does not support) 
> the feature I
> > want to use. (So far there are two disposition types associated with
> > uri-list bodies and may be more in the future.)
> >
> 
> I guess I am wondering if using the MIME dispositions is 
> really the right
> way to basically tell the UA what you want it to do with a 
> given SIP command
> - what does recipient-list mean in the context of email or 
> other users of
> MIME?
[snip]
It doesn't have to make any sense whatsoever (SIP vs. E-Mail).  What is
important is the disposition is well defined for the given media type.

I would offer that it might be better to have different names than "inline"
or "render", so it is clear we mean what we mean.