Subject: [Sip] RFC3261: INVITE and non-INVITE server transactions proceeding state has no timer

From: Feng QIN <[email-masked]>
Date: Fri, 26 Aug 2005 00:45:39 -0400

Hello all,
If we look at RFC3261 on INVITE and non-INVITE server transaction, in 
proceeding state, transaction only wait for TU to give response to send, but 
there are no timers to check when TU can give the response.
Assuming in a B2BUA, if the outgoing client transaction has no response, the 
INVITE server transaction will NOT get the response from the TU ever, thus 
the transaction resource will be dead here.

Do we really miss timers there or it implies application should add timer 
for this case by itself?

Thanks in advance!

-- 
Best Regards.

QIN Feng
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "vimal srivastava" <[email-masked]>
Date: Fri, 26 Aug 2005 10:34:59 -0400

Server Transaction need not run any timer because the Client Transaction 
which has initiated the Invite/Non-Invite would take care of it. they do run 
timer.
v.

From: Feng QIN <[email-masked]>
To: [email-masked], [email-masked], [email-masked]
Subject: [Sip-implementors] RFC3261: INVITE and non-INVITE 
servertransactions proceeding state has no timer
Date: Fri, 26 Aug 2005 00:45:39 -0400

Hello all,

Thanks in advance!

--
Best Regards.

QIN Feng
_______________________________________________
Sip-implementors mailing list
[email-masked]
http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors

---

From: "vimal srivastava" <[email-masked]>
Date: Fri, 26 Aug 2005 10:40:47 -0400

This is how b2bua is working
You receive INIVTE at UAS, => a server transaction is created
you send out INVITE from UAC => a client transaction is created.
now if UAC does not receive any response from the network, then client side 
transaction will  expire Timer B, and tell the application about the TimeOut 
Condition. now B2bua should respond to UAS side (response of Invite 
received) based on policy may be 5xx etc.
so all the transactions are taken care of.
v.

Hello all,

Thanks in advance!

--
Best Regards.

QIN Feng