Subject: RE: [Sip] SDP Query

From: "Fevzi Konduk" <[email-masked]>
Date: Thu, 25 Aug 2005 11:23:35 +0200

Hello, 
As Collin Pointed out the SDP is not valid. 

        c=IN IP4 224.2.17.12/127 
        t=2873397496 2873404696 
        a=recvonly 
        m=audio 49170 RTP/AVP 0 
        c=IN IP4 224.2.17.13/127 
        m=video 51372 RTP/AVP 31

Look in rfc3264 for some examples and look also bellow. 

Quote from RFC 2327: 

Some lines in each description are required and some
   are optional but ALL MUST APPEAR IN EXACTLY THE ORDER GIVEN HERE (the
   fixed order greatly enhances error detection and allows for a simple
   parser). Optional items are marked with a `*'.

Session description
        v=  (protocol version)
        o=  (owner/creator and session identifier).
        s=  (session name)
        i=* (session information)

Handley & Jacobson          Standards Track                     [Page 7]

RFC 2327                          SDP                         April 1998

        u=* (URI of description)
        e=* (email address)
        p=* (phone number)
        c=* (connection information - not required if included in all
media)
        b=* (bandwidth information)
        One or more time descriptions (see below)
        z=* (time zone adjustments)
        k=* (encryption key)
        a=* (zero or more session attribute lines)
        Zero or more media descriptions (see below)

Time description
        t=  (time the session is active)
        r=* (zero or more repeat times)

Media description
        m=  (media name and transport address)
        i=* (media title)
        c=* (connection information - optional if included at
session-level)
        b=* (bandwidth information)
        k=* (encryption key)
        a=* (zero or more media attribute lines)

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: den 25 augusti 2005 11:11
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] SDP Query
> 
> This is not valid, since it's missing "v=", "o=", and "s=" lines, all
> of which are mandatory in SDP.
> 
> Colin
> 
> 
> On 24 Aug 2005, at 23:08, [email-masked] wrote:
> > Hi Udit,
> >
> > There Must be one "C" field at the session level (or) one "C" field
> > in each media description level.
> > "C" value at the session level is like global value.and  Media
> > level is like local.
> > so if you do not have it in Media level it will take the value at
> > Session level.
> >
> > so  to your question:
> > Yes it is valid.
> > It is indicating different Ip addresses for different Media types.
> >
> > If you want a particular media stream to be in holding give that IP
> > address for that particular Media stream  "c"  (to 0.0.0.0 or
> > a=inactive)
> >
> > HTH,
> >
> > Regards,
> > Sreeram.
> >
> > From: [email-masked] on behalf of [email-masked]
> > Sent: Wed 8/24/2005 4:11 PM
> > To: SIP Implementors
> > Cc: SIP IETF
> > Subject: [Sip] SDP Query
> >
> >
> > Hi,
> >
> > Just want to check if following SDP is valid:
> >
> >         c=IN IP4 224.2.17.12/127
> >         t=2873397496 2873404696
> >         a=recvonly
> >         m=audio 49170 RTP/AVP 0
> >         c=IN IP4 224.2.17.13/127
> >         m=video 51372 RTP/AVP 31
> >
> > It indicates different IP address used for audio and video types.
> >
> > I thought the reason we have connection parameter in both session
> > and media description is for handling hold cases, where you want to
> > hold a particular set of media instead of whole session.
> >
> > Regards,
> > Udit
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Fatih "Eyüp" NAR <[email-masked]>
Date: Thu, 25 Aug 2005 13:07:47 -0700 (PDT)

i am not on a side to break rules but...

in my opinion (as a developer) saying this sdp is not
valid in sip messaging and failing the transaction do
not make sense since the sip application who is
receving this sdp simply has ; IP# , port# , codec
info for audio receive.

besides saying this {...} is like a ITU approach :-) ,
if you have enough info to proceed go ahead if not
fail the transaction with proper response code.

--- Fevzi Konduk <[email-masked]> wrote:

> RFC 2327                          SDP               
>          April 1998
> > > Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> > Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Colin Perkins <[email-masked]>
Date: Thu, 25 Aug 2005 21:19:41 +0100

> fail the transaction with proper response code.

You're free to ignore the SDP specification if you like, there are no  
protocol police to stop you... However, interoperability is usually  
improved by trying to conform to the specifications, and the example  
in question did not conform to the SDP grammar.

Colin