Subject: [Sip] Reinvite transaction

From: [email-masked]
Date: Fri, 26 Aug 2005 09:48:54 -0400

Hi,

If during a call, UAC sends RE-invite to change the media, hence a INVITE 
client transaction will be created,
and before he gets any final response, he wants to end the call. 
 
If it sends BYE message, it will be a separate transaction, is it the 
responsibilty of UAC core to end all pending client transactions before 
sending BYE.
because BYE is a separate client transaction.

-Udit
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "vimal srivastava" <[email-masked]>
Date: Fri, 26 Aug 2005 10:51:00 -0400

I think it is taken care of.
after re-invite is sent and response is awaited, if other party sends BYE, 
then a response of 481 will be returned for re-invite (481 Call/Transaction 
Does Not Exist).
if after re-invite is sent and same party sends BYE, then
the callee, would have already replied to re-invite so situation of hanging 
re-invite transactin would never come.
v.

From: [email-masked]
To: "SIP Implementors" <[email-masked]>
CC: SIP IETF <[email-masked]>
Subject: [Sip-implementors] Reinvite transaction
Date: Fri, 26 Aug 2005 09:48:54 -0400

Hi,

-Udit
_______________________________________________
Sip-implementors mailing list
[email-masked]
http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors