Subject: [Sip] query abt 4xx response

From: Sudhir Kumar Reddy <[email-masked]>
Date: Thu, 18 Aug 2005 19:53:33 +0530

Hi All
 I had few doubts in processing 4xx responses by UAC
 
405 Method Not Allowed—what method is not allowed?

406 Not Acceptable

414 Request URI too long 

any thoughts are appericated
 thanks in advance
 regards
-- 
Sudhir Kumar Reddy 
Software Engineer,
QualPhone communications pvt. ltd.
09845052651
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 18 Aug 2005 10:26:45 -0500

>I had few doubts in processing 4xx responses by UAC

by the way - all responses are by the UAS for that transaction. The UAC 
sends the Requests for a transaction.

>405 Method Not Allowed—what method is not allowed?

One that the UAC doesn't support, likely meaning one of the extension 
Methods like UPDATE, REFER, INFO, SUBSCRIBE, NOTIFY, PUBLISH, MESSAGE or PRACK

>406 Not Acceptable

This means that something that was Requested was not acceptable, for 
example, if a call were set up with one codec, and one UA sends a reINVITE 
with a new codec (to change the RTP stream to this new codec in place of 
the first), the UAS could deny that request by sending a 406

>414 Request URI too long

I think this one is as it states, though I haven't run into this problem, I 
can imagine that since the text fields are unbounded to a great degree, a 
UAC could include one that the UAS simply could not process due to its 
length. Others may have specific experience with this one. This could also 
be rooted in the similarity of SIP to HTTP, and those URIs can get quite long.

>any thoughts are appericated

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

---

From: Peili Xu <[email-masked]>
Date: Fri, 19 Aug 2005 00:29:09 +0800

I guess you are asking for more information why the request failed by that 4xx response.

for 405, UAS can fill Allow header to indicate what it allows.
for 406, UAS can fill Accept to indicate what it accepts.
also for 414, maybe UAS can provide some information in Warning header.

regards

Peili
  ----- Original Message ----- 
  From: Sudhir Kumar Reddy 
  To: [email-masked] 
  Sent: Thursday, August 18, 2005 10:23 PM
  Subject: [Sip] query abt 4xx response

  Hi All

  406 Not Acceptable

  414 Request URI too long 

  thanks in advance

  regards

------------------------------------------------------------------------------