Subject: [Sip] Re: [Sip-implementors] Nokia Series 60 device

From: Klaus Darilion <[email-masked]>
Date: Fri, 12 Aug 2005 09:43:21 +0200

Gaurav Kheterpal wrote:
> Hi,
> 
> You can refer to
> http://sw.nokia.com/id/ad2fe51c-afa0-42f1-b319-982bd0bd9f9a/Series_60_De
> veloper_Platform_2_0_Specification_v1_0_en.pdf for Series 60 compliance
> information. The Series 60 docs are available on
> http://www.forum.nokia.com/main/0,6566,010_40,00.html#documents
> 
> Is there any particular aspect which you would like to know about the
> Series 60 compliance with RFC 3261 ? I have limited experience on using
> it but I found it *reasonably* compliant with SIP specs.

Long time ago I did some testing. The only problem with the stack I can 
remember:

I found out that in the Contact of a 200 OK response from a REGISTER, 
there must not be a q=...; parameter. If there is a q parameter, Nokia's 
SIP stack does not accept the 200 OK.

Another interesting thing is, if support for IM+presence (MESSAGE, 
SUBSCRIBE, NOTIFY, PUBLISH) is planned.

regards
Klaus

> 
> I hope this helps.
> 
> my 2 cents,
> 
> Gaurav
> 
> -----Original Message-----
> 
> 
> 
> 
> ********************** Legal Disclaimer ****************************
> "This email may contain confidential and privileged material for the sole use of the intended recipient.  Any unauthorized review, use or distribution by others is strictly prohibited.  If you have received the message in error, please advise the sender by reply email and delete the message. Thank you."
> **********************************************************************
> 
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Klaus
> Darilion
> Sent: Thursday, August 11, 2005 1:46 PM
> To: Banibrata Dutta
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip-implementors] Nokia Series 60 device
> 
> Hi!
> 
> Because it is usally much more easier to ask other developers for help.
> 
> Do you now a contact at Nokia which we may ask about their SIP stack?
> 
> Klaus
> 
> Banibrata Dutta wrote:
> 
>>Why not ask Nokia ?
>>
>>-bd
>>
>>-----Original Message-----
>>From: [email-masked]
>>[mailto:[email-masked]] On Behalf Of Rajesh 
>>Kadikar
>>Sent: Thursday, August 04, 2005 2:16 AM
>>To: [email-masked]; [email-masked]
>>Subject: [Sip-implementors] Nokia Series 60 device
>>
>>Guys,
>>
>>I am not sure if this is the right forum for this question...
>>
>>But has anybody used the SIP stack that came out with Nokia Series 60?
>>
>>Do you know if it is RFC 3261 compliant?
>>
>>Thanks in advance
>>
>>Rajesh
> 
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Gaurav Kheterpal" <[email-masked]>
Date: Thu, 11 Aug 2005 17:24:54 +0530

Hi,

You can refer to

I hope this helps.

my 2 cents,

Gaurav

-----Original Message-----

Hi!

Klaus