Subject: [Sip] Changing contact address

From: [email-masked]
Date: Mon, 10 Oct 2005 02:25:02 -0400

Hi,

If UAC wants to change its contact address i.e. target set, as per RFC 
3261, UAC ca nsedn REINVITE for that.

Is it possible to send Re-INVITE without any sdp, as it does not want to 
change any media or renegotiate any media,

because if send without SDP, then UAS can consider it as asking for offer.

Thanks,
Udit
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 10 Oct 2005 08:58:49 +0200

Hi,

>If UAC wants to change its contact address i.e. target set, as per RFC 3261, UAC ca nsedn REINVITE for that. 
>
>Is it possible to send Re-INVITE without any sdp, as it does not want to change any media or renegotiate any media, 
>

It is possible to send a re-INVITE without SDP, but in that case the UAS is mandated to send an SDP offer to you. There are different understandings on how that offer shall be contstructed, though.

But, another way is to include SDP in the re-INVITE, and to keep the version part of the SDP origin parameter unchanged, which indicates that the session description is unchanged.

Regards,

Christer
Ericsson