Subject: RE: [Sip] No dual concurrent registration

From: "Michael Tasker \(mtasker\)" <[email-masked]>
Date: Tue, 4 Oct 2005 14:44:24 -0700

Hi Richard

It really is up to the algorithm that's implemented in the phone to
control the re-home to primary behavior.

Possibly you could set the expires time on the SIP-SRST registrar to a
short value - and maybe this would trigger the phones to do a periodic
re-evaluate?
Possibly you could go kill the SIP-SRST service itself as an alternative
to power cycling the ethernet power?

Note that the effect of power cycling the phone is simply to force the
phone to re-evaluate which Proxy/Registrar it wants to register to. So
what you really need is some less brute-force way to trigger the phone
to do the re-evaluate - which has to be phone vendor specific I think.

But the intent of SIP-SRST is to be a safe haven for any phone that has
been stranded by it's primary Registrar/Proxy (for whatever reason) - so
if the phone requests service - then SIP-SRST is going to grant it if it
can. 

It's not the job of SIP-SRST to attempt to evaluate the "in-service"
state or availability of the phone's primary Registrar/Proxy - often
SIP-SRST does not even know who the primary is. Note that there is no
requirement that the SIP-SRST router is in the physical network path
between the phone and its primary Registrar/Proxy.

Mike Tasker
Cisco CallManager Express, Survivable Remote Site Telephony, SIP-SRST  

-----Original Message-----
From: Dave Oran (oran) 
Sent: Tuesday, October 04, 2005 10:02 AM
To: Michael Tasker (mtasker)
Subject: Fwd: [Sip] No dual concurrent registration

Begin forwarded message:

> From: "Richard Logan" <[email-masked]>
> Date: September 30, 2005 10:23:34 PM EDT
> To: <[email-masked]>
> Subject: [Sip] No dual concurrent registration
>
>
> Hello,
> We recently implemented a SIP phone system and are using the SIP SRST 
> fall back on our phones.  The phones do not support dual concurrent 
> registration.  We were able to get the phones to fail over to the 
> server which works great.  What were NOT able to do was to get the to 
> fail back over to the SIP server.  In other words once the phones fail

> over to the router and since the service never stops  the phones never

> fail back over to the phone system.  It doesn't sound like a big 
> problem but any time we reboot our SIP phone system the phones fail 
> over.  We have been performing a reload on the switches which kills 
> the power over Ethernet on the phones to get them operating again.
>
> Since the phones don't support dual registration Cisco won't help.   
> Anyone got any ideas?  Do I have something configured incorrectly on 
> my routers?
>
> Thanks,
> Richard Logan
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Richard Logan" <[email-masked]>
Date: Tue, 4 Oct 2005 18:28:12 -0500

Just so you know we are using Polycom IP500 phones and Cisco 2801 routers.

On the first point about the expire times I agree.  I have considered something similar to that.  The problem that I have experienced has been that any time I lower the registration time on my router in my sip.cfg file the phones won't register to it.  In fact if I modify almost any setting with regards to the router registration they won't register to it.  I think I'm going to try and re-evaluate this though it's been some time and I've learned alot since then.

I can lower the registration time on the phones with regards to the phone system.  That has actually been nice.  My phones will essentially fail over to the router after only 10 or 20 seconds.  That makes SIP SRST more functional.

With regards to disabling SRST:  Unfortunately even if you stop the SRST service and remove all the code from the Cisco routers the phones stay registered to it.  If the phone is rebooted from that point it won't register to the router.  Obviously that doesn't help with this problem though.

Anyways thanks for the email that is good information.
Thanks,
Richard Logan
IS Manager
Credit Union of America
-----Original Message-----
From: Michael Tasker (mtasker) [mailto:[email-masked]]
Sent: Tuesday, October 04, 2005 4:44 PM
To: Dave Oran (oran); Richard Logan
Cc: [email-masked]
Subject: RE: [Sip] No dual concurrent registration

Hi Richard

Mike Tasker