Subject: [Sip] Offer-answer model

From: [email-masked]
Date: Wed, 5 Oct 2005 01:16:23 -0400

Hi,

I just want to check if following offer-answer model is valid:

Offer:
v=0
o=alice 2890844526 2890844526 IN IP4 host.anywhere.com
s=
c=IN IP4 host.anywhere.com
t=0 0
m=audio 49170 RTP/AVP 0
a=rtpmap:0 PCMU/8000
m=video 51372 RTP/AVP 31
a=rtpmap:31 H261/90000
m=video 53000 RTP/AVP 32
a=rtpmap:32 MPV/90000

Answer:
v=0
o=bob 2890844730 2890844730 IN IP4 host.example.com
s=
c=IN IP4 host.example.com
t=0 0
m=audio 49920 RTP/AVP 0
a=rtpmap:0 PCMU/8000
c=IN IP4 host.example.com // can it send its own "c" value 
m=video 0 RTP/AVP 31
m=video 53000 RTP/AVP 32
a=rtpmap:32 MPV/90000

Thanks,
Udit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Wed, 5 Oct 2005 12:21:45 +0100

Hi Udit,
 
I feel your offer-answer is valid with respect to the "m="
and "c=" lines (make sure that you include all mandatory lines).
 
If the audio media has a different connection address
then it is completely valid to put the extra "c=" under
the "m=audio" line.
 
It is also valid because for every "m=" line in the offer, there
is a matching "m=" line in the offer.
 
Regards,

Attila
 
Attila Sipos
http://www.vegastream.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: 05 October 2005 06:16
To: SIP IETF
Cc: SIP Implementors
Subject: [Sip] Offer-answer model

Hi, 

Offer: 
v=0 

Answer: 
v=0 

Thanks, 
Udit

---

From: "Ettore Benedetti" <[email-masked]>
Date: Thu, 06 Oct 2005 11:13:28 +0200

Hi Udit,

the exchange is mostly correct: line order matters in SDP so
you should swap the c= and a= lines in the first media item.

Ettore Benedetti

THALES COMMUNICATIONS B.V.
Bestevaer 46, 1271 ZA  Huizen
The Netherlands

Unclassified

>>> <[email-masked]> 10/5/05 7:16:23 AM >>>
Hi,

Offer:
v=0

Answer:
v=0

Thanks,
Udit