Subject: RE: [Sip] FW: [Sip-implementors] doubt/bug with RFC-3455

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 23 Jan 2006 16:25:11 -0000

I cannot answer the question, but I can indicate that as far as I understand the issue, 3GPP never needs to send only zero URIs, as this is included in a successful registration only, and therefore at least one address must be registered. The associated list is the list of all registered URIs, both implicit and explicit:

Extract from 3GPP TS 24.229 subclause 5.4.1.2.2:

"...create a 200 (OK) response for the REGISTER request, including:

...

b)	a P-Associated-URI header containing the list of the registered public user identity and its associated set of implicitly registered public user identities. The first URI in the list of public user identities supplied by the HSS to the S-CSCF will indicate the default public user identity to be used by the S-CSCF. The public user identity indicated as the default public user identity must be a registered public user identity. The S-CSCF shall place the default public user identity as the first entry in the list of URIs present in the P-Associated-URI header. The default public user identity will be used by the P-CSCF in conjunction with the procedures for the P-Asserted-Identity header, as described in subclause 5.2.6.3. The S-CSCF shall not add a barred public user identity to the list of URIs in the P-Associated-URI header;"

I will add this to a number of issues I am in the process of addressing in RFC 3455.

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Nataraju A B
> Sent: 23 January 2006 11:47
> To: [email-masked]
> Subject: [Sip] FW: [Sip-implementors] doubt/bug with RFC-3455
> 
> 
> Hi All, 
> 
> I am posting the same query here in sipping since I did not get any
> convincing answers in sip-Implementors list...... 
> 
> Thanks & Regards,
> Nataraju A.B.
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf 
> Of Nataraju
> A B
> Sent: Friday, January 20, 2006 11:57 AM
> To: [email-masked]
> Subject: [Sip-implementors] doubt/bug with RFC-3455
> 
> Hi All, 
> 
> I have a doubt in the rfc 3455 with respect to 
> P-Associated-URI syntax, 
> 
> Excerpt from RFC-3455 
> <<<
> 4.1.2 Usage of the P-Associated-URI header
> 
>    The registrar inserts the P-Associated-URI header field 
> into the 200
>    OK response to a REGISTER request.  The header field value is
>    populated with a list containing zero or more URIs that are
>    associated to the address-of-record.
>    If the registrar supports the P-Associated-URI header 
> extension, then
>    the registrar MUST always insert the P-Associated-URI 
> header field in
>    all the 200 OK responses to a REGISTER request, regardless 
> of whether
>    the REGISTER was an initial registration, re-registration, or
>    de-registration and regardless of whether there are zero or more
>    associated URIs.
> >>>
> 
> it says if the registrar supports P-Associated-URI, then it has to
> insert the P-Asserted-URI in 200 OK response for REGISTER 
> while defining the ABNF for the same its been mentioned as 
> 
>       P-Associated-URI       = "P-Associated-URI" HCOLON
>                                (p-aso-uri-spec)
>                                *(COMMA p-aso-uri-spec)
>       p-aso-uri-spec         = name-addr *(SEMI ai-param)
>       ai-param               = generic-param
> 
> This ABNF syntax says as one or more, not zero or more number of
> p-aso-uri-spec, 
> 
> Now my question is? 
> 1) Why do we need to insert the P-Associated-URI header if 
> there are no
> entry to fill in ? 
> 2) How do we specify the zero or more P-Associated-URI header 
> values ? 
> 
> Best Regards,
> Nataraju A.B. 
> Kodiak Networks  Ind Pvt Ltd
> "Change your thoughts, and you change your world."
> 
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 23 Jan 2006 19:36:24 -0500

Keith,

It is a little unclear to me from reading 24.229 whether the 
P-Associated-URI header should contain the URI being registered or not. 
The text doesn't seem very explicit about that. While not definitive, I 
think the examples in Gonzalo's book do *not* include the URI being 
registered. OTOH, since the default URI must be first, if the URI being 
registered is to be the default then it would need to be in the list.

A case when an empty P-Associated-URI might be needed is if the URI 
being registered is barred and there is no unbarred URI. Of course in 
that case the UE isn't going to be able to do anything, but there needs 
to be some way for it to discover that.

	Paul

---

From: "Nataraju A B" <[email-masked]>
Date: Tue, 24 Jan 2006 09:57:59 +0530

Thanks & Regards,
Nataraju A.B.

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]] 
Sent: Monday, January 23, 2006 9:55 PM
To: 'Nataraju A B'; [email-masked]'
Subject: RE: [Sip] FW: [Sip-implementors] doubt/bug with RFC-3455

I cannot answer the question, but I can indicate that as far as I
understand the issue, 3GPP never needs to send only zero URIs, as this
is included in a successful registration only, and therefore at least
one address must be registered. The associated list is the list of all
registered URIs, both implicit and explicit:

...

b)	a P-Associated-URI header containing the list of the registered
public user identity and its associated set of implicitly registered
public user identities. The first URI in the list of public user
identities supplied by the HSS to the S-CSCF will indicate the default
public user identity to be used by the S-CSCF. The public user identity
indicated as the default public user identity must be a registered
public user identity. The S-CSCF shall place the default public user
identity as the first entry in the list of URIs present in the
P-Associated-URI header. The default public user identity will be used
by the P-CSCF in conjunction with the procedures for the
P-Asserted-Identity header, as described in subclause 5.2.6.3. The
S-CSCF shall not add a barred public user identity to the list of URIs
in the P-Associated-URI header;"

I will add this to a number of issues I am in the process of addressing
in RFC 3455.

[ABN] If the P-Associated-URI carries at least the registered publicURI,
then the definition of P-Associated-URI should be changed to carry
atleast one URI (registered publicURI) not zero or more URIs ??? 

Does this make sense...  ????

regards

Keith