Subject: RE: [Sip] status on the SIP MIB modules?

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 27 Feb 2006 08:10:12 +0200

Mark,

Those are complementary. The SIP MIB draft exposes a different layer of
management than the SIPPING and AVT drafts. Among other the SIP MIB
provides configuration information on UAs and servers, and SIP session
statistics. The SIPPING and AVT drafts focus on QoS reporting for media
traffic using SIP mechanisms (draft-ietf-sipping-rtcp-summary-00) or
SNMP (draft-ietf-avt-rtcp-xr-mib-03). 

Regards,

Dan

> -----Original Message-----
> From: Mark Ellison [mailto:[email-masked]] 
> Sent: Monday, February 27, 2006 12:37 AM
> To: [email-masked]
> Subject: Re: [Sip] status on the SIP MIB modules?
> 
> Hi Dean,
> 
> Thanks for your reply.
> 
> My understanding is another mechanism for exposing SIP 
> statistics is moving forward, based upon the SIPPING 
> draft-ietf-sipping-rtcp-summary-00 and AVT 
> draft-ietf-avt-rtcp-xr-mib-03 drafts.
> 
> Maybe others on the list have considerations or concerns 
> regarding any added usefulness for keeping the SIP MIB modules around?
> 
> Regards,
> 
> Mark
> 
> Dean Willis wrote:
> 
> > On Feb 24, 2006, at 11:31 AM, Mark Ellison wrote:
> >
> >> Hi,
> >>
> >> What is the current status for the SIP MIB modules?
> >>
> >> I notice that draft-ietf-sip-mib-09 is the latest revision 
> of these 
> >> module.  It is my understanding -09 was submitted for IESG 
> processing 
> >> and that the current IESG status is "revised ID  needed" ,
> >> as of 2005-12-11 (see http://tools.ietf.org/wg/sip/).   Also, I 
> >> notice that this matter is not on the agenda for IETF #65.
> >>
> >> Also I have a question about the sipMethodSupportedIndex 
> object  with 
> >> respect to IANA registrations.  In checking the IANA registry  for 
> >> sip (http://www.iana.org/assignments/sip-parameters)  I 
> see a  list 
> >> of methods (e.g. ACK, BYE, CANCEL, INFO...).  I am assuming  the 
> >> intent is that SIP method names are in the IANA registry, 
> as  are SIP 
> >> option tags.  Possibly this is an area of the SIP MIB  modules in 
> >> need of revision?
> >>
> >> Regards,
> >
> >
> > It appears to be suffering from a severe case of apathy.
> >
> > The last email I saw on the list was last summer, which may answer 
> > your question about the sipMethodSupportedIndex object.
> >
> >> -----Original Message-----
> >> From: Kevin Lingle (klingle) [mailto:[email-masked]]
> >> Sent: Friday, August 05, 2005 1:07 AM
> >> To: Romascanu, Dan (Dan)
> >> Cc: [email-masked]; [email-masked]; Wijnen, 
> Bert (Bert); 
> >> [email-masked]
> >> Subject: RE: [Sip] draft-ietf-sip-mib-09.txt - 'MIB Doctor' review
> >>
> >> dan,
> >>
> >> jean-francois and i have discussed the issue of using 
> method name as 
> >> an index and, at this point, neither of us
> >> are against making that change.   it has the benefit of
> >> removing the method to identifier table and the IANA overhead
> >> of administering the method identifiers.   i'm going to take
> >> a look at the actual changes required to the mib, but 
> don't believe 
> >> they will be significant.
> >>
> >> if you, as our mib doctor, think this is a useful change we will 
> >> persue it.  please let us know your opinion.
> >>
> >> thanks,
> >> kevin
> >
> >
> > to which Dan, as our MIB doctor, heartily agreed.
> >
> > Since then, we have awaited the revised MIB document.
> >
> > Interestingly enough, though the chairs and Allison discussed it in 
> > December, with Allison suggesting it was time to declare 
> the document 
> > dead and either 1) get new editors, or 2) abandon the effort. Note 
> > that since then nobody has asked it about until today. This 
> argues for 
> > option 2.
> >
> > Seriously, is anybody actually implementing the SIP mib?
> >
> > If it turns out that people really need this thing, perhaps 
> we can ask 
> > Kevin either cough out the document or surrender the pen (and the 
> > document source) to a pinch-hitter for carrying across the 
> finish line.
> >
> > --
> > Dean
> > cochair
> >
> >
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Mon, 27 Feb 2006 06:06:54 -0700

> It appears to be suffering from a severe case of apathy.
This is an aggravated case since MIB doctors reviewed the health of the
last draft.

Kevin and I are working on a revision to address the main mib doctor
comments on sipMethodSupportedIndex. The goal is also to go thru the mib
design guidelines and do all the final checks on the SMI.
We intend to publish draft-10 by next Monday March 6 to meet the cut-off
deadline for the next meeting. There are better topics for f2f time so I
don't think the co-authors would like to put this topic on the SIP
agenda item.

Mark Ellison wrote
> > Also I have a question about the sipMethodSupportedIndex object
> > with respect to IANA registrations.  In checking the IANA registry
> > for sip (http://www.iana.org/assignments/sip-parameters)  I see a
> > list of methods (e.g. ACK, BYE, CANCEL, INFO...).  I am assuming
> > the intent is that SIP method names are in the IANA registry, as
> > are SIP option tags.  Possibly this is an area of the SIP MIB
> > modules in need of revision?
http://www.iana.org/assignments/sip-parameters
We don't intend to change anything to add new supported methods in the
draft.

Jean-Francois

> From: Dean Willis [mailto:[email-masked]]
> Sent: Friday, February 24, 2006 3:13 PM
> To: Mark Ellison; [email-masked]; Jean-Francois Mule
> Cc: [email-masked] List
> > I notice that draft-ietf-sip-mib-09 is the latest revision of these
> > processing and that the current IESG status is "revised ID
> > needed" , as of 2005-12-11 (see http://tools.ietf.org/wg/sip/).
> > Also, I notice that this matter is not on the agenda for IETF #65.
> >
> > Also I have a question about the sipMethodSupportedIndex object
> > with respect to IANA registrations.  In checking the IANA registry
> > for sip (http://www.iana.org/assignments/sip-parameters)  I see a
> > list of methods (e.g. ACK, BYE, CANCEL, INFO...).  I am assuming
> > the intent is that SIP method names are in the IANA registry, as
> > are SIP option tags.  Possibly this is an area of the SIP MIB
> > modules in need of revision?
> >
> > Regards,
> 
> > Cc: [email-masked]; [email-masked]; Wijnen, Bert
> > (Bert); [email-masked]
> > jean-francois and i have discussed the issue of using method
> > name as an index and, at this point, neither of us
> > a look at the actual changes required to the mib, but don't
> > believe they will be significant.
> >
> > if you, as our mib doctor, think this is a useful change we
> > will persue it.  please let us know your opinion.
> >
> > thanks,
> > kevin
> 
> December, with Allison suggesting it was time to declare the document
> that since then nobody has asked it about until today. This argues
> for option 2.
> 
> If it turns out that people really need this thing, perhaps we can
> ask Kevin either cough out the document or surrender the pen (and the
> document source) to a pinch-hitter for carrying across the finish
> line.
> 
> --
> Dean
> cochair