Subject: Re: [Sip] PUBLISH and PAI/PPI

From: "Andrew Allen" <[email-masked]>
Date: Thu, 9 Feb 2006 04:46:47 -0500

Interesting dilemma.

The P-Asserted-Identity is a "P-header" that is not a standards track RFC. But RFC 3903 is standards track. 

Should the table in standards track RFC include all headers that are not standards track?

Andrew

--------------------------
Andrew Allen
Manager Standards
Research In Motion Ltd
BlackBerry Mobile  +1 847 809 8636
http://www.rim.com/

Sent from my BlackBerry Wireless Handheld

----- Original Message -----
From: [email-masked]
To: Dean Willis; Sanjay Sinha ((sanjsinh))
Cc: [email-masked]
Sent: Thu Feb 09 04:38:22 2006
Subject: RE: [Sip] PUBLISH and PAI/PPI

Yes it is used in IMS systems that run OMA PAG.
In the 3GPP spec 24.229 there is a reference to that Publish has a
P-Asserted-ID and then it refers to rfc3325 section 9.1
But in that section there is nothing about Publish but I think that it
is a matter of oversight both in IETF and 3GPP.
The 3325 can not point to PUBLISH rfc since it was released after.
The RFC 3903 should have had PAI listed in section 11.1.1.

BR Kristoffer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dean Willis
Sent: den 9 februari 2006 09:51
To: Sanjay Sinha ((sanjsinh))
Cc: [email-masked]
Subject: Re: [Sip] PUBLISH and PAI/PPI

On Feb 8, 2006, at 1:43 PM, Sanjay Sinha ((sanjsinh)) wrote:

> RFC 3325 lists out SIP methods in which P-Asserted-Identity/P- 
> Preferred-Identity header is applicable. But PUBLISH is missing from 
> the list. Neither is this header support listed in PUBLISH RFC, 3903.
> Just wanted to confirm if these headers are applicable to PUBLISH or 
> not?
>

I'm aware of no reason it would not work. I believe we discussed this on
one of the lists about two years ago and decided this was simply an
oversight in the RFC. I believe the IMS people are using p-aid with
PUBLISH.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aki Niemi <[email-masked]>
Date: Thu, 09 Feb 2006 12:03:50 +0200

I think it only makes sense to list applicability of a header field to
specific methods if they are only supposed to be used with those methods
alone.

Outside of that, the IANA registry is the place to look for header
fields and methods alike. The tables in individual RFCs only add to the
confusion.

Cheers,
Aki

ext Andrew Allen wrote:
> -------------------------- Andrew Allen Manager Standards Research In
> Motion Ltd BlackBerry Mobile  +1 847 809 8636 http://www.rim.com/
> 
> ----- Original Message ----- From: [email-masked] To: Dean
> Willis; Sanjay Sinha ((sanjsinh)) Cc: [email-masked] Sent: Thu Feb 09
> 04:38:22 2006 Subject: RE: [Sip] PUBLISH and PAI/PPI
> 
> Yes it is used in IMS systems that run OMA PAG. In the 3GPP spec
> 24.229 there is a reference to that Publish has a P-Asserted-ID and
> then it refers to rfc3325 section 9.1 But in that section there is
> nothing about Publish but I think that it is a matter of oversight
> both in IETF and 3GPP. The 3325 can not point to PUBLISH rfc since it
> was released after. The RFC 3903 should have had PAI listed in
> section 11.1.1.
> 
> BR Kristoffer
> 
> -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Dean Willis Sent: den 9
> februari 2006 09:51 To: Sanjay Sinha ((sanjsinh)) Cc: [email-masked] 
>> Preferred-Identity header is applicable. But PUBLISH is missing
>> from the list. Neither is this header support listed in PUBLISH
>> RFC, 3903. Just wanted to confirm if these headers are applicable
>> to PUBLISH or not?
>> 
> 
> 
> I'm aware of no reason it would not work. I believe we discussed this
> on one of the lists about two years ago and decided this was simply
> an oversight in the RFC. I believe the IMS people are using p-aid
> with PUBLISH.
> 
> -- Dean
> 
> 
> 
> _______________________________________________ Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
> development of the core SIP Protocol Use 
> _______________________________________________ Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
> development of the core SIP Protocol Use
>  This transmission (including any attachments) may contain
> confidential information, privileged material (including material
> protected by the solicitor-client or other applicable privileges), or
> constitute non-public information. Any use of this information by
> anyone other than the intended recipient is prohibited. If you have
> received this transmission in error, please immediately reply to the
> sender and delete this information from your system. Use,
> dissemination, distribution, or reproduction of this transmission by
> unintended recipients is not authorized and may be unlawful.
> 
> _______________________________________________ Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
> development of the core SIP Protocol Use