Subject: RE: [Sip] Outbound and STUN Keep Alive

From: "Francois Audet" <[email-masked]>
Date: Fri, 24 Feb 2006 20:01:49 -0600

Why do you need STUN for that?

Couldn't you just assign a static NAT binding for the Outbound proxy? 

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 10:55
> To: Dean Willis; Rohan Mahy
> Cc: [email-masked]
> Subject: Re: [Sip] Outbound and STUN Keep Alive
> 
> 
> On 2/23/06 1:16 PM, "Dean Willis" <[email-masked]> wrote:
> 
> > I think you guys are missing Gary's use case.
> > 
> > He's postulating an entirely different NAT problem, where 
> the NAT is 
> > between the outbound proxy and the real world, rather than 
> between the 
> > UA and its outbound proxy.
> > 
> > This just isn't a use case that's been in scope for general 
> discussion 
> > so far.
> 
> If I understand correctly ... I thin I added this use case to 
> the document awhile back because some people request it. For 
> some vague reason, I thought Dean was one of the people that 
> had requested it. People had brought up system like the 
> ingate stuff. If the use case complicated stuff, I would 
> remove it but so far the baseline the simple case has pretty 
> much solved this one too.  
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 24 Feb 2006 21:50:35 -0800

Static binding would work but requires NAT configuration. I think some
people were imaging a small office type situation where it would be
preferable not to require manual configuration of the NAT.

If this complicates the draft, based on the input to get the main use case
done, I am likely to just point it out as something not solved and keep the
draft such that future work could solve this.

---

From: Dean Willis <[email-masked]>
Date: Sat, 25 Feb 2006 01:36:04 -0600

> Couldn't you just assign a static NAT binding for the Outbound proxy?

How do you do that? It's a DHCP client behind the NAT-firewall . . .  
possibly somebody else's NAT-firewall.

--
Dean

---

From: Dean Willis <[email-masked]>
Date: Sat, 25 Feb 2006 01:37:36 -0600

> draft such that future work could solve this.

personally, I could be happy with that. We can do interproxy coaxial  
stunalive separately. Wow, I just made up a new phrase!

--
Dean

---

From: "Frank W. Miller" <[email-masked]>
Date: Sat, 25 Feb 2006 11:06:30 -0500

PING draft updated to reflect unreliable transmission (i.e. no
retransmission required at the transaction level).

http://www.cornfed.com/ping.html
http://www.cornfed.com/ping.txt

FM

---

From: "Francois Audet" <[email-masked]>
Date: Sat, 25 Feb 2006 13:25:34 -0800

I guess one could have the proxy itself send STUN packets (or other  
methods). It could try to multiplex many connections into a smaller  
number of TCP connections (like 1).

But, yeah, I'm happy with Cullen's proposal.

On Feb 24, 2006, at 23:37 , Dean Willis wrote:

> personally, I could be happy with that. We can do interproxy  
> coaxial stunalive separately. Wow, I just made up a new phrase!
>
> --
> Dean
>
>