Subject: Re: [Sip] Outbound and STUN Keep Alive

From: [email-masked]
Date: Wed, 15 Feb 2006 21:07:25 -0600

Couple questions inline...

------------------------------------------------
On Wed, 15 Feb 2006 20:19:42 -0600, Dean Willis <[email-masked]> wrote:

> These initial results show at least a 3x difference, much of which is  
> attributable to the parsing overhead. Once the MESSAGE request is  
> liberated from its framing, it still has to be parsed enough to  
> recognize it as a discardable message and figure out where to send  

Was a full parser used or on-demand parsing, i.e. did the parser breakup the entire message into all its various fields or was the message parsed piecemeal as necessary to determine what the message was?

> very mature Java stack implementation, the SIP part of which has been  
> highly optimized.

May I assume that the Java implementation was run on a Sun JVM?  I would be interested in numbers for a C and C++ implementation (I called them out separately on purpose), e.g. a reSIProcate measurement would be interesting for the C++ case.

Also, I am assuming that both the SIP and STUN implementations were done in Java and both were run on the same VM?

Thanks,
FM

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 16 Feb 2006 00:00:06 -0500

The message was parsed piecemeal, and it was on a Sun machine. Both stun 
and sip in java.

It would be good to see some results for resiprocate.

I would argue that 3x is already good enough to make this worthwhile.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Dean Willis <[email-masked]>
Date: Wed, 15 Feb 2006 22:57:33 -0600

On Feb 15, 2006, at 9:07 PM, [email-masked] wrote:

> Was a full parser used or on-demand parsing, i.e. did the parser  
> breakup the entire message into all its various fields or was the  
> message parsed piecemeal as necessary to determine what the message  
> was?
>

I believe this stuff uses a partial pre-parse followed by demand  
parsing.

Just finding the Vias is an expensive operation.

> May I assume that the Java implementation was run on a Sun JVM?  I  
> would be interested in numbers for a C and C++ implementation (I  
> called them out separately on purpose), e.g. a reSIProcate  
> measurement would be interesting for the C++ case.
>

Me too.

> Also, I am assuming that both the SIP and STUN implementations were  
> done in Java and both were run on the same VM?

I believe so.

--
Dean