Subject: [Sip] draft-fwmiller-ping-00 comments

From: Rayees Khan <[email-masked]>
Date: Tue, 21 Feb 2006 14:48:04 +0530

Hi Frank,

Section 2 of the draft mentions that signaling path of the PING method is established as a result of a call setup. Now what I understand is that main purpose the method is to keep the signaling path alive or to check the validity of the signaling path. This means that it would mostly be sent outside the context of a session. In such context I guess it has to follow path of a dialog establishing request.

Section 2.1 lists the headers that are expected in the PING method. Well, I have come across devices using Require and Proxy-Require header in PING messages.

Section 2.2 mentions the responses that are expected for a PING request. I was wondering that it is very well possible that if a server receives a PING request which is addressed to something that Server does not know about it is most likely to send a 404 response.

regards
Rayees

*****FSS-Private *****" DISCLAIMER: This message is proprietary to Flextronics Software Systems Limited (FSS) and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Frank W. Miller" <[email-masked]>
Date: Tue, 21 Feb 2006 21:02:32 -0500

On Tue, 2006-02-21 at 14:48 +0530, Rayees Khan wrote:
> Section 2 of the draft mentions that signaling path of the PING method
> is established as a result of a call setup. Now what I understand is
> that main purpose the method is to keep the signaling path alive or to
> check the validity of the signaling path. This means that it would
> mostly be sent outside the context of a session. In such context I
> guess it has to follow path of a dialog establishing request.
> 

Did some cleanup of wording here to make it more general.

> Section 2.1 lists the headers that are expected in the PING method.
> Well, I have come across devices using Require and Proxy-Require
> header in PING messages. 
> 

I saw your other email.  I'd still like to hear some other opinions
before I add this.

> Section 2.2 mentions the responses that are expected for a PING
> request. I was wondering that it is very well possible that if a
> server receives a PING request which is addressed to something that
> Server does not know about it is most likely to send a 404 response.
> 
> 

Changed the text to allow for any response other than a 1xx or 3xx to be
interpreted as a 200 OK

New version on the website: http://www.cornfed.com/ping.html and
http://www.cornfed.com/ping.txt

FM