Subject: [Sip] Record-Route

From: "Marqui Peter-E50322" <[email-masked]>
Date: Thu, 16 Feb 2006 12:20:39 -0500

Should the Record-Route fields between the calling and called party be
symmetrical ?
Or the same for each direction ?
 
    U1->P1->P2->P3->P4->U2

The INVITE arriving at U2 contains:
 
      INVITE sip:[email-masked] SIP/2.0
      Contact: sip:[email-masked]
      Record-Route: <sip:p4.domain.com;lr>
      Record-Route: <sip:p3.middle.com>
      Record-Route: <sip:p2.example.com;lr>
      Record-Route: <sip:p1.example.com;lr>
 
While subsequent messages arriving at U1 from U2 would take the
following path:     U2->P4->P3->P2->P1>U1
And the Record-Route header would be as follows
 
      SIP/2.0 200 OK
      Contact: sip:[email-masked] 
      Record-Route: <sip:p1.example.com;lr>
      Record-Route: <sip:p2.example.com;lr>
      Record-Route: <sip:p3.middle.com>
      Record-Route: <sip:p4.domain.com;lr>

Peter Marqui
Motorola MDB, Libertyville
Email:   [email-masked] <mailto:[email-masked]> 
Phone:  847-523-0584
Mobile:  847-
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Daniel-Constantin Mierla <[email-masked]>
Date: Thu, 16 Feb 2006 20:34:24 +0200

The U2 must put the Record-Route headers in 200OK reply in the same 
order as in INVITE. See section 

12.1.1 UAS behavior in RFC3261.

Cheers,
Daniel

On 02/16/06 19:20, Marqui Peter-E50322 wrote:
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
>
>