Subject: [Sip] RE: draft-fwmiller-ping-00 comments

From: [email-masked]
Date: Tue, 21 Feb 2006 07:43:36 -0600

Thanks for the comments.  Discussion inline...

------------------------------------------------
On Tue, 21 Feb 2006 14:48:04 +0530, Rayees Khan <[email-masked]> wrote:

> 
>Section 2 of the draft mentions that signaling path of the PING >method is established as a result of a call setup. Now what I >understand is that main purpose the method is to keep the >signaling path alive or to check the validity of the signaling >path. This means that it would mostly be sent outside the >context of a session. In such context I guess it has to follow >path of a dialog establishing request.

The wording here should probably be changed.  The intent is to have PINGs travel through the normal proxy sequence that any other request would take, thereby refreshing the entire path.  I know we're talking mainly about the NAT traversal problem but if we're coming up with a general method, it should address keepalive all the way along whether there a forseen problems or not.  When I changed it from in-session only to being able to send anytime, I didn't do any rewording here.  I will do that now.

>Section 2.1 lists the headers that are expected in the PING >method. Well, I have come across devices using Require and >Proxy-Require header in PING messages.

Hmm.  I'd be interested in any other discussion on this point.  It would be nice to keep these out if possible to keep the message simple.

>Section 2.2 mentions the responses that are expected for a PING >request. I was wondering that it is very well possible that if >a server receives a PING request which is addressed to >something that Server does not know about it is most likely to >send a 404 response.

I'm wondering if it shouldnt just be any response except for a 1xx and 3xx class response.

FM

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Priti <[email-masked]>
Date: Wed, 22 Feb 2006 17:39:15 +0530

Hi All,

Please let me know what are the certifications can be done on Telecom 
(i.g. Certification on SIP etc).
Ald also how to apply for the same if anybody has the idea.

Thanks,
Priti