Subject: [Sip] order of m lines in answer SDP

From: Malleswara Rao Ankem <[email-masked]>
Date: Fri, 10 Feb 2006 12:05:29 +0530

Hello,
 just wondering whether the following SDP in answer is valid or not. It can
be observed that the order of the
 m lines in the answer has been changed. Is there any section in 3264 that
disallows the behavior?
thanks
Mallesh

Offer:
v=0
o=alice 2890844526 2890844526 IN IP4 host.anywhere.com
s=
c=IN IP4 host.anywhere.com
t=0 0
m=audio 49170 RTP/AVP 0
a=rtpmap:0 PCMU/8000
m=video 51372 RTP/AVP 31
a=rtpmap:31 H261/90000
m=video 53000 RTP/AVP 32
a=rtpmap:32 MPV/90000

Answer:
v=0
o=bob 2890844730 2890844730 IN IP4 host.example.com
s=
c=IN IP4 host.example.com
t=0 0
m=audio 49920 RTP/AVP 0
a=rtpmap:0 PCMU/8000
m=video 53000 RTP/AVP 32
a=rtpmap:32 MPV/90000
m=video 51372 RTP/AVP 31
a=rtpmap:31 H261/90000
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Matthew Gardiner <[email-masked]>
Date: Fri, 10 Feb 2006 07:39:00 -0000

The exemplified behaviour is invalid. The ordering of the m= is significant,
since no unique key field is provided by SDP to differentiate individual m=
lines.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Malleswara Rao Ankem
Sent: 10 February 2006 06:35
To: [email-masked]
Subject: [Sip] order of m lines in answer SDP

Hello,
 
Offer: 
v=0 
o=alice 2890844526 2890844526 IN IP4 host.anywhere.com
<http://host.anywhere.com/>  
s= 
c=IN IP4 host.anywhere.com <http://host.anywhere.com/>  
t=0 0 
m=audio 49170 RTP/AVP 0 
a=rtpmap:0 PCMU/8000 
m=video 51372 RTP/AVP 31 
a=rtpmap:31 H261/90000 
m=video 53000 RTP/AVP 32 
a=rtpmap:32 MPV/90000 

Answer: 
v=0 
o=bob 2890844730 2890844730 IN IP4 host.example.com
<http://host.example.com/>  
s= 
c=IN IP4 host.example.com <http://host.example.com/>  
t=0 0 
m=audio 49920 RTP/AVP 0 
a=rtpmap:0 PCMU/8000 
m=video 53000 RTP/AVP 32 
a=rtpmap:32 MPV/90000
m=video 51372 RTP/AVP 31 
a=rtpmap:31 H261/90000