Subject: RE: [Sip] The Problem with PRACK

From: "Francois Audet" <[email-masked]>
Date: Thu, 9 Mar 2006 18:14:28 -0600

> I am still not following what you are suggesting. You say 
> "deprecating 
> the use PRACK altogether when TCP transport is used". Does 
> that mean the 
> UAC omits Supported:100rel if it is using TCP? Or that the 
> UAS refuses 
> 100rel when it receives a request over TCP? Or that 100rel is 
> supported 
> but still the UAS doesn't use PRACK?

First one: just omit Supported 100rel when using TCP.

> Its clearly possible that the access link for the UAC is TCP 
> while that 
> of the UAS is UDP, or visa versa.
> 
> Assuming that the e2e path is reliable without prack seems 
> like a really 
> bad idea.
> 
> And losing in band media can be a bad thing, such as when it 
> is telling 
> you why your call didn't get where it was intended to go. This can 
> easily happen without there ever being a 200.

In my mind, the really really bad idea is for proxies to downgrade 
from TCP to UDP.

It's almost as bad of an idea as recreating a transport layer in SIP
instead of using a real transport layer.

If I was a sneaky UAC, I could use TCP, not include Supported: 100rel,
and pad my messages with empty space to ensure it's big enough to to 
get downgraged to UDP... ;^)

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 09 Mar 2006 23:18:26 -0500

> In my mind, the really really bad idea is for proxies to downgrade 

The proxy doesn't necessarily have much choice in the matter. Possibly 
the UAS is only accessible via UDP.

	Paul