Subject: RE: [Sip] outbound: summary of issues

From: "Elwell, John" <[email-masked]>
Date: Wed, 29 Mar 2006 21:05:29 +0100

Jeroen,

Thanks for your explanation. However, could we not limit use of Supported
outbound to the edge proxy. Since an edge proxy would not connect to the
registrar using outbound (I assume connect-reuse would be used instead),
then there is no reason for the registrar to place Supported outbound in the
REGISTER response. This could be left for the edge proxy to insert. If it is
felt inappropriate for a proxy to insert a Supported header tag, then
perhaps there is something else it can insert. This would seem much more
reliable than depending on configuration.

John 

> -----Original Message-----
> From: Jeroen van Bemmel [mailto:[email-masked]] 
> Sent: 29 March 2006 20:36
> To: Elwell, John; [email-masked]
> Subject: Re: [Sip] outbound: summary of issues
> 
> John,
> 
> see inline
> 
> 
> ----- Original Message ----- 
> From: "Elwell, John" <[email-masked]>
> To: "Jeroen van Bemmel" <[email-masked]>; <[email-masked]>
> Sent: Wednesday, March 29, 2006 9:23 PM
> Subject: RE: [Sip] outbound: summary of issues
> 
> 
> >
> >
> >> -----Original Message-----
> >> From: Jeroen van Bemmel [mailto:[email-masked]]
> >> Sent: 29 March 2006 19:49
> >> To: [email-masked]
> >> Subject: [Sip] outbound: summary of issues
> >>
> >> An attempt to summarize issues identified so far, in the form
> >> of closed questions:
> >>
> >> 1. Configuration of outbound proxies - desire to avoid manual
> >> configuration at the UAC. Do we agree that we want this?
> >> 1a If yes, in the outbound draft or as a separate draft?
> >> 2. Detection of outbound/keepalive support - desire for
> >> dynamic discovery of support instead of (or perhaps in
> >> addition to) static configuration (the current keepalive=stun
> >> flag). Do we agree that we want this? (several options have
> >> been discussed)
> > [JRE] I can't recall what was wrong with just an option tag in the 
> > Supported
> > header of the REGISTER response.
> 
> That would indicate that the registrar supports outbound, but 
> says nothing 
> about the edge proxy. The risk is that the UAC starts poking 
> it with STUN 
> requests while it is not supported.
> 
> An outbound proxy URI with keepalive=stun would indicate 
> proxy support, but 
> that would only be an informed guess - there is the possibility for 
> misconfiguration. To avoid this, it would be good if the proxy would 
> actively indicate that it supports outbound (in particular STUN).
> 
> Jeroen
> 
> >
> > John 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 29 Mar 2006 23:13:13 +0200

John,

Yes, this is what one thread of the discussion was about, and you seem to 
agree with #2 below

Proxies inserting Supported: I think that would indeed be inappropriate as 
you indicate.
What about feature tags a la callerprefs (RFC3841) in Path and Record-Route 
headers?

Path: <sip:out.proxy.domain.com;lr>;extensions="outbound"

This would imply that proxies cannot indicate extensions without 
Record-Routing, but since the information is only relevant when the proxy 
stays in the path for next requests, this somehow feels appropriate to me

Regards,

jeroen