Subject: RE: [Sip] draft-ietf-sip-outbound

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sat, 25 Mar 2006 17:38:57 -0000

(as chair)

I was not aware that either of the chairs had declared anything out of scope, as yet.

Firstly the question asked of the list is a very standard question with the aim of getting people to identify outstanding issues. If those issues do not get posted, then we make no progress at all on any document. You have done that.

However we are working to get this document out of the door. We are past the charter milestone when we agreed it would be finished by, so we are pushing for rapid resolution of any issues.

Therefore we would ask all posters to be very clear in indicating what they see as the way forward on any issue, and how this should be documented.

This document is intended to be standards track. The postings at the moment seem to indicate that the solution to the issue you raise may well be dependent on how outbound is deployed in any architecture, which would imply a separate BCP document, or at least non-standards track document, covering those issues, rather than coverage in draft-ietf-sip-outbound itself.

I would therefore like to see posters covering issues such as:

-	Can we separate out this issue into a BCP
-	If yes, is there a member of the SIP or SIPPING WG who is prepared to put together a draft and submit.
-	If yes, what are the interdependencies between draft-ietf-sip-outbound and this proposed draft.
-	and of course as always: "send text". 

and of course, if you consider we don't need to do anything at all on this issue, then please indicate that as well.

We set a deadline of 31st March to establish what the issues are that prevent WGLC. At that time, the chairs will ascertain  whether WGLC can be started, and on what version of the document. We have already indicated that a -04 version will need to be produced for that intended WGLC.

regards

Keith

> -----Original Message-----
> From: Juha Heinanen [mailto:[email-masked]]
> Sent: 25 March 2006 04:32
> To: Drage, Keith (Keith)
> Cc: [email-masked]
> Subject: [Sip] draft-ietf-sip-outbound
> 
> 
> Drage, Keith (Keith) writes:
> 
>  > 3)	Working group: Are we ready to move to WGLC. Please indicate if
>  > 3)	you consider this document needs more work preceding WGLC.
> 
> see ongoing discussion on auto-discovery of outbound-proxy-set.  the
> document is not useful in practise without such a mechanism and you
> cannot thus declare it out of scope.
> 
> -- juha
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 25 Mar 2006 20:07:07 +0200

> -	Can we separate out this issue into a BCP

definitely not.  i have specifically asked for a mechanism to detect
outbound-proxy-set in the common default case, where outbound proxies
are freely reachable from the SIP UAs, i.e., for the case where there
are no firewall or SBCs that would block outbound SIP traffic.  i'm not
asking anything else than what SRV lookup provides for outbound proxies
according to rfc3263.  we MUST extend that mechanism in order for
the SIP UA to learn that (1) proxies implement outbound I-D and (2) that
they also learn the tags.

 > -	If yes, is there a member of the SIP or SIPPING WG who is
 > -	prepared to put together a draft and submit.

there is NO POINT to publish the outbound I-D as rfc BEFORE the above
discussed mechanism is in place, because it is FAR TOO MUCH work for
users to enter outbound-proxy-set information manually.  it is high time
to make SIP more user friendly than it currently is.  you must have
lived far too long in the abstract IETF world if you want to push this
kind manual burden to the users.  how about working for a service
provider for a few years?

 > -	If yes, what are the interdependencies between
 > -	draft-ietf-sip-outbound and this proposed draft.

the proposed draft tells what kind of DNS query SIP UA makes in order to
learn the two NEW pieces of information that outbound i-d needs on top
of regular SRV query defined in rfc 3263.  rfc 3261 refers to rfc 3263
for server discovery and this new I-D MUST refer to a successor of rfc
3263.
 
-- juha

---

From: Dean Willis <[email-masked]>
Date: Sat, 25 Mar 2006 15:27:34 -0600

> for server discovery and this new I-D MUST refer to a successor of rfc

I don't suppose you could send text? If it looks OK, Cullen would 
probably be able to paste it into the next rev for WGLC. If it doesn't 
fit into the "outbound" draft well, the text would still give us a good 
basis for a new draft that would extend RFC 3263.

--
Dean