Subject: [Sip] SIP Location Conveyance -02 is available

From: "James M. Polk" <[email-masked]>
Date: Thu, 09 Mar 2006 17:52:26 -0600

SIP WG

I have finally revised the SIP Location Conveyance ID to -02 here:

http://www.ietf.org/internet-drafts/draft-ietf-sip-location-conveyance-02.txt

Here are the highlights of this version:

    - streamlined the doc by removing text (ultimately removing 42 pages
      of text).

    - Limited the scope of this document to SIP conveyance, meaning only
      how SIP can push location information.

    - reduced emergency calling text to just a few paragraphs now that
      the ECRIT WG is taking most of that topic on.

    - greatly reduced the number of requirements in this version.

    - changed the requirements groups from "UA-to-UA", "UA-to-Proxy",
      etc to "UAC Reqs", "UAS-Reqs" and "Proxy-Reqs" to focus on what is
      being asked of each SIP element.

    - Removed the full SIP message examples.

    - completed the ABNF for the Location header, including a cid-url to
      point at a message body part to help in parsing for location.

    - Deleted the call for a new 425 (Retry Location) response code, as
      it appears this can easily be used to spoof a UA into providing
      where it is inadvertently, even if the intent is legitimate by the
      UAC.

Yesterday I received a comment on how I can change the ABNF of the Location 
header further, part of which made sense immediately, the remainder makes 
this an open issue at this moment.

More comments are welcome

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 9 Mar 2006 19:08:51 -0600

I like the reduction in size.

On a quick scan I notice a few errors:

 - PIDF-LO examples don't follow the form recommended by PIDF-LO profile
   . see the new drafts for a format for both geodetic and civic data
   . the form of provided-by here is not valid
   . namespaces and prefixes need to be checked and corrected
 - multipart MIME formation is incorrect (and check for 'broundary')
 - there is a circular reference in the BNF (this also needs a ref. to RFC4234)
 - there is no specification for the BNF 'option-tag'
 - the second Location header example on page 16 isn't a URI (a ref. to RFC 3986 might also be useful).

I pointed most of this out in the last revision.

Cheers,
Martin

> -----Original Message-----
> From: James M. Polk [mailto:[email-masked]]
> Sent: Friday, 10 March 2006 10:52 AM
> To: [email-masked]
> Subject: [Sip] SIP Location Conveyance -02 is available
> 
> SIP WG
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 09 Mar 2006 19:26:46 -0600

Martin

nothing gets by you, does it?

;-)

BTW - your last response to this ID was 20 pages, so I'm making progress!

I think each of the points you make are easily correctable now.  Thanks for 
catching these.