Subject: RE: [Sip] draft-cao-sip-response-identity-00 and draft-elwell-sip -connected-identity-01

From: "Elwell, John" <[email-masked]>
Date: Thu, 23 Mar 2006 13:29:49 +0000

Feng,

See below.

John 

> -----Original Message-----
> From: Feng Cao [mailto:[email-masked]] 
> Sent: 22 March 2006 21:01
> To: Elwell, John
> Cc: Rocky Wang; [email-masked]
> Subject: RE: [Sip] draft-cao-sip-response-identity-00 and 
> draft-elwell-sip -connected-identity-01
> 
> 
> Because connected-id is revealed in the mid-dialog, there are some 
> scenarios that are not covered by connected-identity draft.
> 
> In general, I agreed with Rocky that the mid-dialog update can be
> easily convered or embeded into the sip identity draft by Jon and
> Cullen. I don't see the need of another new draft for it.
[JRE] The identity draft has already been approved.

> 
> Some useful scenarios for response identity inside response messages
> had been listed for discussion:
> 1. disclose the response identity for non-dialog session.
> 2. reveal the proxy's identity as the responder for some response
>     codes, such as provisiional, redirect and failure responses.
>     This will help the callers to make decisions.
> 3. prevent the identity spoofing as early as possible. In some cases,
>     it is too late to be notifies of the response identity after the
>     dialogs are established.
[JRE] Yes, I understand these additional uses that are not covered by the
connected-identity draft. I look forward to reviewing further drafts that
address the problems raised during the meeting.

> 
> --Feng
> 
> 
> On Wed, 22 Mar 2006, Elwell, John wrote:
> > Rocky,
> >
> > The connected-identity draft already gives two examples why 
> a mid-dialog
> > change would be needed: PSTN gateway and B2BUA.
> >
> > We could define a new header field for response identity if 
> this can be
> > justified, but it would not be secure. I think the 
> consensus yesterday was
> > to move forward with connected-identity and consider 
> separately whether
> > response identity is achievable in a way that is secure as 
> well as adding
> > some value in certain use cases.
> >
> > John
> >
> >
> >> -----Original Message-----
> >> From: Rocky Wang [mailto:[email-masked]]
> >> Sent: 22 March 2006 14:44
> >> To: Elwell, John; [email-masked]
> >> Subject: RE: [Sip] draft-cao-sip-response-identity-00 and
> >> draft-elwell-sip-connected-identity-01
> >>
> >>  As my opinion, they two just need take the responser
> >> identifier in the
> >> response messages. We must consider and resolve all the
> >> problem include the
> >> security problems in both cases.
> >> If you want to indicate a change of party mid-dialog, you 
> can use some
> >> mid-dialog method to do it, as I considered, just like UPDATE
> >> and re-INVITE.
> >> That's not so difficult in use of exist mechanism. But can
> >> you please give
> >> me an application case of the usage of mid-dialog entity identifier
> >> indication.
> >>
> >> -----Original Message-----
> >> From: Elwell, John [mailto:[email-masked]]
> >> Sent: Tuesday, March 21, 2006 11:44 PM
> >> To: Rocky Wang; [email-masked]
> >> Subject: RE: [Sip] draft-cao-sip-response-identity-00 and
> >> draft-elwell-sip-connected-identity-01
> >>
> >> Rocky,
> >>
> >> The connected-identity draft is not a subset of the response
> >> identity draft.
> >> The response identity draft cannot be used to indicate a
> >> change of party
> >> mid-dialog.
> >>
> >> I don't think we can merge them. There was no consensus on
> >> the response
> >> identity draft. The following views have been expressed:
> >> - that it does not provide any benefit;
> >> - that the response identity problem cannot be solved, and
> >> that the approach
> >> taken in the connected-identity draft is the best that can be
> >> achieved.
> >>
> >> If and when there is consensus on a response identity
> >> solution, then we
> >> could consider whether it would be appropriate to merge the
> >> two, but that is
> >> not the case at present.
> >>
> >> John
> >>
> >>> -----Original Message-----
> >>> From: Rocky Wang [mailto:[email-masked]]
> >>> Sent: 21 March 2006 19:50
> >>> To: [email-masked]
> >>> Subject: [Sip] draft-cao-sip-response-identity-00 and
> >>> draft-elwell-sip-connected-identity-01
> >>>
> >>>
> >>> Both of draft-cao-sip-response-identity-00 and
> >>> draft-elwell-sip-connected-identity-01 have been disscussed
> >> in today's
> >>> SIP session. I found they two can be merged into one.
> >>> The first one is a common requirement to return back the identity
> >>> identifier. It can be used in both successful responses,
> >> but also in
> >>> provisiional, redirect and failure responses, but the 2nd
> >> one is just
> >>> used for 18X and 2XX response for INVITE (maybe also some
> >> other type
> >>> requests).
> >>> As I considered, the 2nd one is just a sub-set case of the
> >> first one.
> >>> Can merge the 2nd one into the 1st one? Or merge the 
> requirement of
> >>> the 1st into the last.
> >>>
> >>>
> >>>
> >>> _______________________________________________
> >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>> This list is for NEW development of the core SIP Protocol Use
> >>> [email-masked] for questions on current sip Use
> >>> [email-masked] for new developments on the application of sip
> >>>
> >>
> >>
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Shida Schubert <[email-masked]>
Date: Thu, 23 Mar 2006 08:52:33 -0800

Hi Feng;

Just out of curiosity, what is going to happen when forking
takes place and you receive multiple 1xx each with
response-identity, and first 200 OK received is from a different
UAS to the first 1xx received?

If you intend to reflect the response identity in the UI, you
might have something like..

1. "Calling User A" Request sent
2. "Trying to connect to User B" 18x received
3. "Connected to User C" 200 OK received

You might want to consider this, as this seems underspecified
in the current spec.

More comments inline..

> address the problems raised during the meeting.

Some comments on 3 of the scenarios mentioned above:

As for 1. I am curious, is it really useful to have identity on
non-dialog session?
For example if you send a MESSAGE, it's already out there and there is
no way
to cancel what you sent. Realizing that it was received by a wrong user
does not
seem too useful.

As for 3. You can try to explore the possibility of
identity-pre-condition for Connected-Identity
where UA will not start sending media until the pre-condition is met.

Thanks & Regards
Shida Schubert

---

From: Feng Cao <[email-masked]>
Date: Thu, 23 Mar 2006 11:33:55 -0800 (PST)

The next version will try to cover more cases you raised.

Thanks,

--Feng