Subject: [Sip] Comment on draft-fwmiller-sip-00

From: Cullen Jennings <[email-masked]>
Date: Sun, 05 Mar 2006 15:47:57 -0500

I don't really see what this PING method does that OPTIONS does not? If the
answer is that this can somehow be optimized in ways that OPTIONS can't,
then it is missing all the text to explain that.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 6 Mar 2006 09:24:46 -0600

I would point you at the most recent version, -01.  The new version does away with the retransmission requirements.  The UAC sends a single PING to a UAS.  If a response is not received within a timeout, the application is notified and can decide for itself whether to retransmit.  This is definitely different than OPTIONS.  This makes it look something like an ICMP ping.

Other than that tho, there is a lot of similarity.  I has also been mentioned that since there is explicitly no body allowed and the attempt to minimize the headers, the potential for optimizations in an implementation is greater.

FM

P.S. Looking at it again, I mentioned an expiration interval before reporting that the ping was not responded to but did not actually specify a duration  :(   Suggestions?  I'm thinking like 500 ms?

------------------------------------------------

---

From: [email-masked]
Date: Mon, 6 Mar 2006 09:34:13 -0600

> P.S. Looking at it again, I mentioned an expiration interval before reporting that the ping was not responded to but did not actually specify a duration  :(   Suggestions?  I'm thinking like 500 ms?

Whups, I take it back, the -01 version contains a 5 sec expiration interval.  This might be too long, thoughts on this expiration?

FM