Subject: RE: [Sip] outbound: summary of issues

From: "Elwell, John" <[email-masked]>
Date: Wed, 29 Mar 2006 20:23:22 +0100

> -----Original Message-----
> From: Jeroen van Bemmel [mailto:[email-masked]] 
> Sent: 29 March 2006 19:49
> To: [email-masked]
> Subject: [Sip] outbound: summary of issues
> 
> An attempt to summarize issues identified so far, in the form 
> of closed questions:
>  
> 1. Configuration of outbound proxies - desire to avoid manual 
> configuration at the UAC. Do we agree that we want this?
> 1a If yes, in the outbound draft or as a separate draft?
> 2. Detection of outbound/keepalive support - desire for 
> dynamic discovery of support instead of (or perhaps in 
> addition to) static configuration (the current keepalive=stun 
> flag). Do we agree that we want this? (several options have 
> been discussed)
[JRE] I can't recall what was wrong with just an option tag in the Supported
header of the REGISTER response.

John

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 29 Mar 2006 21:36:13 +0200

John,

see inline

----- Original Message ----- 
From: "Elwell, John" <[email-masked]>
To: "Jeroen van Bemmel" <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 29, 2006 9:23 PM
Subject: RE: [Sip] outbound: summary of issues

> header of the REGISTER response.

That would indicate that the registrar supports outbound, but says nothing 
about the edge proxy. The risk is that the UAC starts poking it with STUN 
requests while it is not supported.

An outbound proxy URI with keepalive=stun would indicate proxy support, but 
that would only be an informed guess - there is the possibility for 
misconfiguration. To avoid this, it would be good if the proxy would 
actively indicate that it supports outbound (in particular STUN).

Jeroen