Subject: RE: [Sip] OUTBOUND: Direction of keep-alive requests

From: "David Schwartz" <[email-masked]>
Date: Mon, 6 Mar 2006 11:19:37 +0200

Hi Juha.

I think there is a misunderstanding. 

If I understand Christer correctly, he is saying that the reason that network based keep-alive has been ignored is due to the fact that a comment was made that in some NAT's the keepalive "ping" has to emanate from "inside" the NAT (i.e. the UA needs to send the keep alive) as opposed to the network keeping the pinhole open by its constant pinging from the network side. 

Your comment that you have not seen this limitation in NAT's only strengthens Christers claim that a network based keep alive should be considered as well.

Prior to the OUTBOUND approach we had experimented in our network trying to establish which is more optimal: lowering registration expirations below binding timeouts and having UA's keep the pinhole open or alternatively "pinging" from the network. As it turned out, the pinging approach was way more scalable as sending a packet is "lighter" than receiving and parsing one. In many cases we even found that to keep pinhole open a packet from one side was enough. We tried this by setting keeapalive via to 0.0.0.0 and system scaled even further since we essentially freed up half the bandwidth associated with the keepalive ping. I know for a fact that many of the deployed commercial VoIP networks use this network based approach today.

While we could have a discussion on the merits of such an architecture, I think that if we seek broad adoption of OUTBOUND it is imperative that OUTBOUND not exclude this approach. As I have mentioned in a previous posting it is possible to add a network based "ping" without having to change OUTBOUND all that much.

Cheers,

David

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]] 
Sent: ב 06 מרץ 2006 10:25
To: Juha Heinanen
Cc: IETF SIP List
Subject: Re: [Sip] OUTBOUND: Direction of keep-alive requests

Hi Juha,

I guess it's up to the operator community to decide whether it needs to be solved. All I am saying is that it is possible, without any new terminal requirements, for the network to initiate messages to be sent from the UA towards the NAT.

Regards,

Christer

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 6 Mar 2006 23:02:24 +0200

Your comment that you have not seen this limitation in NAT's only =
  strengthens Christers claim that a network based keep alive should be =
  considered as well.

it is the only approach that is needed.  i thought christers was
proposing to do pinging from the UA.

-- juha