Subject: RE: [Sip] Updated connected-identity draft

From: "Elwell, John" <[email-masked]>
Date: Fri, 10 Mar 2006 12:03:50 +0000

Hans,

Thanks for your comments. See below.

John 

> -----Original Message-----
> From: Hans Persson [mailto:[email-masked]] 
> Sent: 10 March 2006 09:51
> To: Frank Derks
> Cc: [email-masked]; Elwell, John
> Subject: Re: [Sip] Updated connected-identity draft
> 
> tor 2006-03-09 klockan 10:23 +0100 skrev Frank Derks:
> 
> > - In 6.1/6.2/6.3 there are several occasions in which a 
> "MUST" might 
> >   be more appropriate than a "SHOULD" and a "SHOULD" than a "MAY": 
> >
> >     6.1:
> [...]
> >     "... the UA MAY ..." -> "SHOULD"?
> > 
> >     6.2:
> >     "... on that dialog, the UA MAY..." -> "SHOULD"?
> > 
> >     6.3:
> >     "... on that dialog, the UA MAY ..." -> SHOULD?
> 
> I agree. If we don't really care about alerting the end user of the
> change in identity of the party in the other end, we do we even bother
> writing this spec in the first place?
[JRE] I tend to agree too.
> 
> 
> Section 6.3 looks pretty general at first, talking about "a UA". In
> section 5 it says "A request in either direction after answer can
> indicate a change of party.", and this section (6.3) is about
> established calls. However, it only talks about discrepancies between
> the To header of the received request and the identity of the UA.
> Shouldn't it also talk about the From header of the sent 
> request and the
> identity of the UA (the *other* UA)?
[JRE] I guess you mean a discrepancy between the From header of the sent
INVITE request and the current identity of the (local) UA. In this case,
again subject to the option tag, we could send a revised URI in the From
header field - this does seem to be missing.

> Nits:
[JRE] I will attend to these when I next update the document.

> 
> Section 2, first line: The [1] reference to SIP is missing 
> whitespace on
> both sides.
> 
> Section 7.1, first paragraph: "conveys it identity" -> "conveys its
> identity". "Identity and Identity-Info header field" -> "Identity and
> Identity-Info header fields".
> 
> Both the example in 7.1 and the one in 7.2 are inconsistent about
> putting a space between the message name and the message number.
> Sometimes it is "INVITE(1)", sometimes "INVITE (1)". I would prefer
> having the space in all instances.
> 
> Example 7.1: The messages "200(3)" and "200(4)" in the 
> diagram should be
> listed as "200 (4)" and "200 (3)" since they are traveling from the
> right to the left.
> The "ACK (6)" message would be retargeted to "ACK
> sip:[email-masked]" like the INVITE, wouldn't it?
> 
> Example 7.2: The left one of the "200 (3)" labels should 
> really be "200
> (4)". The re-INVITEs are labeled 11,12 but should be labeled 
> 12,11. The
> same goes for the associated ACKs (15,16) which should be 16,15.
> 
> Hans
> 
> -- 
> Hans Persson <[email-masked]>    Ingate - Firewalls with SIP & NAT
> Ingate Systems AB  +46 13 210877   http://www.ingate.com/
> 
> Private: <[email-masked]>  http://www.lysator.liu.se/~unicorn/
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Hans Persson <[email-masked]>
Date: Fri, 10 Mar 2006 13:12:01 +0100

> header field - this does seem to be missing.

Yes, exactly.

Hans