Subject: RE: [Sip] draft-cao-sip-response-identity-00 and draft-elwell-sip -connected-identity-01

From: "Elwell, John" <[email-masked]>
Date: Wed, 22 Mar 2006 05:44:01 +0000

Rocky,

The connected-identity draft is not a subset of the response identity draft.
The response identity draft cannot be used to indicate a change of party
mid-dialog.

I don't think we can merge them. There was no consensus on the response
identity draft. The following views have been expressed:
- that it does not provide any benefit;
- that the response identity problem cannot be solved, and that the approach
taken in the connected-identity draft is the best that can be achieved.

If and when there is consensus on a response identity solution, then we
could consider whether it would be appropriate to merge the two, but that is
not the case at present.

John

> -----Original Message-----
> From: Rocky Wang [mailto:[email-masked]] 
> Sent: 21 March 2006 19:50
> To: [email-masked]
> Subject: [Sip] draft-cao-sip-response-identity-00 and 
> draft-elwell-sip-connected-identity-01
> 
> 
> Both of draft-cao-sip-response-identity-00 and
> draft-elwell-sip-connected-identity-01 have been disscussed 
> in today's SIP
> session. I found they two can be merged into one.
> The first one is a common requirement to return back the identity
> identifier. It can be used in both successful responses, but also in
> provisiional, redirect and failure responses, but the 2nd one 
> is just used
> for 18X and 2XX response for INVITE (maybe also some other 
> type requests).
> As I considered, the 2nd one is just a sub-set case of the 
> first one. Can
> merge the 2nd one into the 1st one? Or merge the requirement 
> of the 1st into
> the last.
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rocky Wang <[email-masked]>
Date: Wed, 22 Mar 2006 08:43:52 -0600

As my opinion, they two just need take the responser identifier in the
response messages. We must consider and resolve all the problem include the
security problems in both cases.
If you want to indicate a change of party mid-dialog, you can use some
mid-dialog method to do it, as I considered, just like UPDATE and re-INVITE.
That's not so difficult in use of exist mechanism. But can you please give
me an application case of the usage of mid-dialog entity identifier
indication.

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2006 11:44 PM
To: Rocky Wang; [email-masked]
Subject: RE: [Sip] draft-cao-sip-response-identity-00 and

Rocky,

John

> draft-elwell-sip-connected-identity-01 have been disscussed in today's 
> SIP session. I found they two can be merged into one.
> provisiional, redirect and failure responses, but the 2nd one is just 
> used for 18X and 2XX response for INVITE (maybe also some other type 
> requests).
> As I considered, the 2nd one is just a sub-set case of the first one. 
> Can merge the 2nd one into the 1st one? Or merge the requirement of 
> the 1st into the last.
> 
> 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
>

---

From: Shida Schubert <[email-masked]>
Date: Wed, 22 Mar 2006 07:15:17 -0800

I agree with John with the consensus of the room.

Regards
Shida Schubert

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 29 Mar 2006 18:07:12 -0800

Me too.