Subject: RE: [Sip] draft-ietf-sip-outbound

From: "Samir Srivastava" <[email-masked]>
Date: Mon, 27 Mar 2006 19:47:32 -0600

I agree. But need concrete info where PING was bad.

Thx
Samir 

-----Original Message-----
From: Audet, Francois [SC100:3055:EXCH] 
Sent: Monday, March 27, 2006 3:07 PM
To: Dean Willis; Christer Holmberg ((JO/LMF))
Cc: [email-masked]; Drage, Keith (Keith); [email-masked]
Subject: RE: [Sip] draft-ietf-sip-outbound

Agree.

The last meeting did indeed produce a strong rough consensus that the
way forward was STUN-over-SIP for both UDP and TCP.

As one of the strongest proponent of the PING method, I think it is time
to move on and and rally behind the concensus. The community will be
best served if we finalize sip-outbound rapidly.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]] 
> Sent: Monday, March 27, 2006 14:56
> To: Christer Holmberg ((JO/LMF))
> Cc: [email-masked]; Drage, Keith (Keith); [email-masked]
> Subject: Re: [Sip] draft-ietf-sip-outbound
> 
> 
> 
> On Mar 27, 2006, at 2:13 AM, Christer Holmberg ((JO/LMF)) wrote:
> 
> >
> > Hi,
> >
> > I was not at the face-to-face meeting, but from the mail 
> discussion I 
> > haven't seen a sign of consensus.
> 
> Having been the judge-of-consensus at the meeting, I noted about 185  
> hands in favor of STUN and about 5 holding out for PING.
> 
> That's a pretty strong rough consensus. Admittedly, some of the more  
> vocal PING proponents weren't present, but my sense of the matter is  
> that the wider body of opinion does favor pursuing the  
> standardization of the STUN approach.
> 
> There was also a clear sense that the community wanted to document a  
> single path rather than a set of alternatives. We've had a lot of  
> folks recently airing frustrations about our usual tendency to  
> document all proposed solutions to every problem and the rather  
> horrible interoperability problem that approach might (or may 
> already  
> have) lead to.
> 
> --
> Dean Willis
> Chair, SIP working group
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: <[email-masked]>
Date: Tue, 28 Mar 2006 10:36:24 +0300

Hi,

I am happy to see the WG to gradually gain rough consensus
also on the mailing list. Here are some comments for a couple
of issues that you raised:

> 3. The other objection was for Authrization. For the old 
> proxies, Client can resubmit the request with creditenials. 
> Do we need authrization for KEEP ALIVE traffic ? 

No we definitely do not need it, and the fact that it would
be difficult to disable authorization for PING (considering
the old proxies that do not recognize the method) would just
dilute the argument of PING being backwards compatible towards
old proxies. It might be, but there are known risks.

> STUN also has it ... compare it with MESSAGE-INTEGRITY
> option of STUN ?

Latest STUN bis introduces STUN usage for NAT keepalive
and there is still an open question if the integrity
check would be needed. My opinion is that for this
purpose the integrity check could be disabled.

   The username and password used for STUN integrity can be used for 24
   hours.

      Issue:  do we need message integrity for keepalives when doing
      STUN and SIP on the same port?

> 5. stun-keepalive flag advantage can be used for 
> PING too with similar ping-keepalive flag. 

There is currently another thread with subject
RE: [Sip] How to indicate during proxy discovery
thataproxysupports"outbound"

If the conclusion of the thread is that discovery would be
done with DNS (and if there is just STUN keepalive mechanism
specified) then Outbound could drop the keepalive flags alltogether.
At least I could not any more find use for them, to be used within
the protocol between UA and network.

Regards,

Erkki

>From: ext Samir Srivastava [mailto:[email-masked]] 
>Sent: 28.March.2006 04:48
>To: Francois Audet; Dean Willis; Christer Holmberg ((JO/LMF))

---

From: Hisham Khartabil <[email-masked]>
Date: Tue, 28 Mar 2006 16:18:35 +0200

I have asked the editors to add text advocating the choice of STUN over 
a SIP based mechanism and pointing out specific flaws in a sip based 
mechanism. They promised to do so.

Hisham