Subject: Re: [Sip] New draft about etags in subscribe/notify

From: Adam Roach <[email-masked]>
Date: Sat, 18 Mar 2006 15:40:01 -0600

Aki:

I like the overall approach you've chosen in this draft to solve the 
problem.

I have a slight issue around re-use of the "SIP-If-None-Match" header 
field for the purpose you've defined here. The semantics of that header 
field (and other header fields with similar names, both in SIP and HTTP) 
is that of an absolute predicate: "I want this operation to succeed IF 
AND ONLY IF the following condition is true, and it MUST fail otherwise."

That's not really what you mean here. What you really mean is something 
more like, "Suppress-Body-If-Match:"

Aside from that issue, which I believe is largely aesthetic, the draft 
looks good to me on first reading.

/a

Aki Niemi wrote:

> Hi All,
>
> I just submitted a new draft defining extensions to SIP events for 
> allowing conditional subscribes:
>
> http://www.ietf.org/internet-drafts/draft-niemi-sip-subnot-etags-00.txt
>
> The issue this attempts to fix were documented in a sipping draft [1], 
> and discussed in IETF 63. My impression of that discussion was 
> moderate interest, so here's the mechanism proposal.
>
> Comments are very welcome.
>
> Cheers,
> Aki
>
> [1] 
> http://www.softarmor.com/wgdb/docs/draft-niemi-sipping-subnot-issues-00.txt 
> (expired)
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aki Niemi <[email-masked]>
Date: Sun, 19 Mar 2006 18:50:10 +0200

Hi Adam,

> more like, "Suppress-Body-If-Match:"

I agree.

There is one issue that is related to this, namely whether suppressing
the notify body is sufficient, or would there be need to do something
more radical, like true If-No-Match and 412. I'll post this, and a
proposal separately.

Cheers,
Aki

---

From: Aki Niemi <[email-masked]>
Date: Sun, 19 Mar 2006 18:50:10 +0200

Hi Adam,

I agree.

Cheers,
Aki