Subject: RE: [Sip] comments on sip-connected-identity

From: "Elwell, John" <[email-masked]>
Date: Tue, 28 Mar 2006 07:46:30 +0100

Brett,

I am getting confused by this thread. In my opinion Jonathan clearly stated
that UPDATE without SDP offer is allowed.

John 

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]] 
> Sent: 28 March 2006 00:09
> To: 'Christer Holmberg'; 'Jonathan Rosenberg'; 'IETF SIP List'
> Subject: RE: [Sip] comments on sip-connected-identity
> 
> > Didn't the update-without-sdp come up a while 
> > ago, when we discussed sessions without media etc?
> 
> It has been discussed within various threads in sip and 
> sip-implementors
> over the past several years.  Because one of the purposes of 
> UPDATE is to
> alter media, some vendors interpreted rfc3311 to indicate UPDATE must
> contain an SDP.  However such a requirement is not contained 
> within rfc3311
> or rfc4028.
> 
> 
> > If one simply wants to update the remote target, using 
> > update, why would it be required to include a body?
> 
> Per rfc3311, UPDATE is not required to include a body.
> 
> However since Jonathan recently suggested otherwise (or I 
> misinterpreted his
> email), hopefully he will reply with some clarification or 
> answers for the
> following email.
> 
> http://www1.ietf.org/mail-archive/web/sip/current/msg13593.html
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 28 Mar 2006 11:11:53 -0500

> I am getting confused by this thread. In my opinion Jonathan 
> clearly stated that UPDATE without SDP offer is allowed.

Yes; he mentioned that it is allowed.  However it wasn't clear to me and
some others if Jonathan was indicating that UPDATE without SDP is valid per
rfc3311 or if the dialogURIChange tag is what allows it to be valid.  And
since this is a common UPDATE interoperability problem, I was just seeking
clarity concerning his comment.

The following is the snippet from
http://www1.ietf.org/mail-archive/web/sip/current/msg13586.html.

"Secondly, on the issue of UPDATE without offers, I believe it is fine to do
this. Though not in RFC3311, this was part of the original conceived use of
UPDATE (see http://www.jdrosen.net/papers/draft-rosenberg-sip-unify-00.txt).
We decided towards the end of the development to focus on the session update
aspects of this. However, I think its fine to use UPDATE in this fashion, as
long as the peer in the dialog indicates support for this usage of UPDATE
(through the dialogURIChange tag)."