Subject: RE: [Sip] draft-ietf-sip-outbound

From: "Francois Audet" <[email-masked]>
Date: Mon, 27 Mar 2006 17:06:41 -0600

Agree.

The last meeting did indeed produce a strong rough consensus that the
way forward was STUN-over-SIP for both UDP and TCP.

As one of the strongest proponent of the PING method, I think it is time
to move on 
and and rally behind the concensus. The community will be best served
if we finalize sip-outbound rapidly.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]] 
> Sent: Monday, March 27, 2006 14:56
> To: Christer Holmberg ((JO/LMF))
> Cc: [email-masked]; Drage, Keith (Keith); [email-masked]
> Subject: Re: [Sip] draft-ietf-sip-outbound
> 
> 
> 
> On Mar 27, 2006, at 2:13 AM, Christer Holmberg ((JO/LMF)) wrote:
> 
> >
> > Hi,
> >
> > I was not at the face-to-face meeting, but from the mail 
> discussion I 
> > haven't seen a sign of consensus.
> 
> Having been the judge-of-consensus at the meeting, I noted about 185  
> hands in favor of STUN and about 5 holding out for PING.
> 
> That's a pretty strong rough consensus. Admittedly, some of the more  
> vocal PING proponents weren't present, but my sense of the matter is  
> that the wider body of opinion does favor pursuing the  
> standardization of the STUN approach.
> 
> There was also a clear sense that the community wanted to document a  
> single path rather than a set of alternatives. We've had a lot of  
> folks recently airing frustrations about our usual tendency to  
> document all proposed solutions to every problem and the rather  
> horrible interoperability problem that approach might (or may 
> already  
> have) lead to.
> 
> --
> Dean Willis
> Chair, SIP working group
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Mon, 27 Mar 2006 18:47:18 -0500

Totally agree.  And agree with Dean that one path is the best.
So why is TCP keep-alive without STUN still an option?

And why is there a user-configured flag for keepalive=stun instead of a
sip-based (e.g. signaling) check, or dns-based (which is also the "sip" way,
methinks) determination if the first-hop is outbound compliant? 

-hadriel

> From: Francois Audet [mailto:[email-masked]]
> Sent: Monday, March 27, 2006 6:07 PM
> To: Dean Willis; Christer Holmberg ((JO/LMF))
> Subject: RE: [Sip] draft-ietf-sip-outbound
> 
> Agree.
>

---

From: "Frank W. Miller" <[email-masked]>
Date: Mon, 27 Mar 2006 19:05:41 -0500

As I noted, dissent registered.

Hi, ho, hi, ho, its off to implement I go...

FM