Subject: RE: [Sip] comments on sip-connected-identity

From: "Francois Audet" <[email-masked]>
Date: Tue, 28 Mar 2006 19:13:53 -0600

I should have said "session refresh" instead of "keep-alive".

> -----Original Message-----
> From: Audet, Francois [SC100:3055:EXCH] 
> Sent: Tuesday, March 28, 2006 17:13
> To: 'Elwell, John'; 'Brett Tate'; 'Christer Holmberg'; 
> 'Jonathan Rosenberg'; 'IETF SIP List'
> Subject: RE: [Sip] comments on sip-connected-identity
> 
> 
> RFC4028 (http://www.ietf.org/rfc/rfc4028.txt) describes the 
> use of UPDATEs without Offers (in this case it is for keep-alive).
> 
> > -----Original Message-----
> > From: Elwell, John [mailto:[email-masked]]
> > Sent: Monday, March 27, 2006 22:47
> > To: Brett Tate; 'Christer Holmberg'; 'Jonathan Rosenberg'; 
> > 'IETF SIP List'
> > Subject: RE: [Sip] comments on sip-connected-identity
> > 
> > 
> > Brett,
> > 
> > I am getting confused by this thread. In my opinion Jonathan
> > clearly stated that UPDATE without SDP offer is allowed.
> > 
> > John
> >
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 29 Mar 2006 10:58:05 -0500

> I should have said "session refresh" instead of "keep-alive".

I agree that it is valid.  I just want to ensure that the working group is
in agreement that it is valid per RFC3311 without the need of an option tag
to indicate when it is valid.

RFC4028 mentions nothing about "timer" needing to be supported at the uas
for UPDATE without offer to be valid.  The text corresponds to my
understanding of RFC3311; UPDATE without offer is valid per RFC3311 without
the need of an option tag to indicate when it is valid.  Because Jonathan
was the author and recently potentially suggested otherwise, hopefully he
will provide more clarity concerning his email since this is a common
interoperability problem.