Subject: [Sip] 3-way Handshake

From: Rehan Khan <[email-masked]>
Date: Mon, 20 Mar 2006 05:39:04 -0800

HI,

Other than Invite, is there any other method that involves a 3 way handshake

Thanks

Rehan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 20 Mar 2006 09:08:10 -0500

No. For other methods that need a similar kind of mechanism, two 
non-INVITE requests (each of which is two-way) are used. For example, 
see SUBSCRIBE/NOTIFY.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Fatih "Eyüp" NAR <[email-masked]>
Date: Mon, 20 Mar 2006 06:53:58 -0800 (PST)

or PRACK can be used for provisional response
verification which will (kind-of) give 3(~5way) way
handshake feel :-) .

sometimes I think we should have prack for final
responses too ,instead of waiting transaction-timeout
renewal of message.

regards
  fatih e.

--- Jonathan Rosenberg <[email-masked]> wrote:

> > Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com