Subject: [Sip] About add and remove steam

From: Chen Shuping <[email-masked]>
Date: Mon, 13 Mar 2006 10:24:55 +0800

Hi,All
 
     I want to know if there is a RFC or other spec to define how to add a
stream to a session or 
 
 remove existing steam from a session.such as user first establish an audio
session,then he/she wants
 
to add a video stream,or first add an audio and video session, then he/she
wants to remove the video stream.
 
My implementation is just send re-INVITE with sdp offer,if it is to add
stream, i add a m= line and related attributes
 
if it is to remove stream,I set the related port parameter of m= line to
ZERO.I am not sure it is legal.
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 13 Mar 2006 10:36:57 +0200

Hi,

It IS legal.

Regards,

Christer