Subject: Re: [Sip] The Problem with PRACK

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 8 Mar 2006 23:32:15 +0200

Hi,

When you ask whether people have implemented preconditions, you also need to ask if they have implemented it using PRACK for sending SDP offer. As you said, it COULD be done with UPDATE instead, and I don't think the precondition mechanism forbids it.

Anothet question, though: if you send an empty INVITE, and receive an offer in a reliable 18x, how would you send the answer? Using UPDATE?

Regards,

Christer

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 08 Mar 2006 18:34:32 -0500

> When you ask whether people have implemented preconditions, you also need to ask if they have implemented it using PRACK for sending SDP offer. As you said, it COULD be done with UPDATE instead, an…

I think that is fine. But it has examples showing use of PRACK

> Anothet question, though: if you send an empty INVITE, and receive an offer in a reliable 18x, how would you send the answer? Using UPDATE?

In PRACK. The current understanding is that you may not send an answer 
in UPDATE.

But that does show that we couldn't just ban PRACK for offer/answer. If 
you wanted to do that then we would have to allow an answer in an UPDATE.