Subject: AW: [Sip] draft ietf-sip-target-dialog provisionally approved by IESG

From: "Tan, Ya-Ching" <[email-masked]>
Date: Mon, 6 Mar 2006 16:42:13 +0100

Some late comments :

- The texts state that the dialog identifiers for the Target-Dialog header MUST contain the "call-id", "local-tag" and "remote-tag".  I wonder why the header is not defined to treat all these mandatory components equally (eg. Target-Dialog : call-id=[email-masked], local-tag=kkaz, remote-tag=6544).  The current BNF definition implies that the "local-tag" and "remote-tag" are optional parameters of the header, which is misleading.

- Figure 4 shows that a proxy (acting as a proxy) can add ("a") or remove ("r") a Target-Dialog header. Shouldn't it be left blank there (like for the In-Reply-To header in RFC 3261) ?

- In the example on on Page 12, the REFER is shown to contain an Event header. REFERs normally have no Event header, as this subscription is implicit.
 
Ya Ching

-----Ursprüngliche Nachricht-----
Von: Dean Willis [mailto:[email-masked]] 
Gesendet: Donnerstag, 2. März 2006 23:37
An: sip ietf
Betreff: [Sip] draft ietf-sip-target-dialog provisionally approved by IESG

Congratulations yet again.

The target-dialog draft has been approved by the IESG. Final  
announcement is pending an AD writeup to fix a couple of nits with  
Instructions to the RFC Editor.

One of these nits is that the  draft uses RFC 2119 language (MUST),  
but failed to include a reference to 2119, which it MUST do.  
Something to watch for in future drafts -- idnits currently doesn'n't  
catch this, and I've asked Henrik to look into adding this in a  
future idnist rev.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 06 Mar 2006 13:39:02 -0500

Tan, Ya-Ching wrote:

> 
> Some late comments :
> 
> - The texts state that the dialog identifiers for the Target-Dialog
> header MUST contain the "call-id", "local-tag" and "remote-tag".  I
> wonder why the header is not defined to treat all these mandatory
> components equally (eg. Target-Dialog :
> call-id=[email-masked], local-tag=kkaz,
> remote-tag=6544). 

Either way would work. Generally, header fields have values and then 
parameters separated by semicolons. If you did what you propose above, 
you'd have to make up something to put in the value, for example * or 
something. May as well put call-id in there.

In any case, as you know the draft has been approved already so this 
kind of change couldn't really be made at this point. Bugs and fixes 
like that are OK, but a design change wouldn't be appropriate.

  The current BNF definition implies that the
> "local-tag" and "remote-tag" are optional parameters of the header,
> which is misleading.

BNF cannot express all constraints. Here, we want all parameters to be 
present, but with arbitrary order. That is VERY hard to write in a bnf, 
and lends no clarity if you do it. The spec is quite explicit that all 
must be present. We have had this situation in many specifications, and 
always we use BNF to help specify the grammar of the messages, not the 
full set of constraints on the protocol.

> 
> - Figure 4 shows that a proxy (acting as a proxy) can add ("a") or
> remove ("r") a Target-Dialog header. Shouldn't it be left blank there
> (like for the In-Reply-To header in RFC 3261) ?

I think you're probably right, this is a bug. This we can correct during 
auth48. I'll make a note.

> 
> - In the example on on Page 12, the REFER is shown to contain an
> Event header. REFERs normally have no Event header, as this
> subscription is implicit.

Right, another bug. Will fix during auth48.

Thanks for the comments,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Mon, 6 Mar 2006 21:42:41 +0100

Jonathan,

A minor bug in 
http://www3.ietf.org/internet-drafts/draft-ietf-sip-target-dialog-03.txt: 
the ABNF rule for Call-ID in RFC3261 is spelled "callid" (so without the '-' 
character)

For sake of completeness, the text in section 7 should state that 'callid', 
'token' and 'generic-param' refer to the RFC3261 definitions

Regards,

Jeroen

PS It's good to treat callid separately, also because it may contain 
characters that are not allowed in parameter values. So you'd have to quote, 
escape, etc

----- Original Message ----- 
From: "Jonathan Rosenberg" <[email-masked]>
To: "Tan, Ya-Ching" <[email-masked]>
Cc: "sip ietf" <[email-masked]>
Sent: Monday, March 06, 2006 7:39 PM
Subject: Re: AW: [Sip] draft ietf-sip-target-dialog provisionally approvedby 
IESG

> In any case, as you know the draft has been approved already so this kind 
> of change couldn't really be made at this point. Bugs and fixes like that 
> are OK, but a design change wouldn't be appropriate.
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 06 Mar 2006 15:50:32 -0500

Thanks. I'll handle these too. Would've been nice to get these BEFORE 
the document was approved though....

-Jonathan R.

Jeroen van Bemmel wrote:

> the ABNF rule for Call-ID in RFC3261 is spelled "callid" (so without the 
> '-' character)
> 
> For sake of completeness, the text in section 7 should state that 
> 'callid', 'token' and 'generic-param' refer to the RFC3261 definitions
> 
> Regards,
> 
> Jeroen
> 
> characters that are not allowed in parameter values. So you'd have to 
> quote, escape, etc
> 
> ----- Original Message ----- From: "Jonathan Rosenberg" <[email-masked]>
> Subject: Re: AW: [Sip] draft ietf-sip-target-dialog provisionally 
> approvedby IESG
> 
> 
>>
>>
>> Tan, Ya-Ching wrote:
>>
>>>
>>> Some late comments :
>>>
>> present, but with arbitrary order. That is VERY hard to write in a 
>> bnf, and lends no clarity if you do it. The spec is quite explicit 
>> that all must be present. We have had this situation in many 
>> specifications, and always we use BNF to help specify the grammar of 
>> the messages, not the full set of constraints on the protocol.
>>
>>
>>>
>> I think you're probably right, this is a bug. This we can correct 
>> during auth48. I'll make a note.
>>
>>>