Subject: RE: [Sip] Outbound Issues: slides 3 and 4

From: Jeroen Van Bemmel <[email-masked]>
Date: Fri, 11 Aug 2006 09:35:03 +0200

Ok, so lets standardise a mechanism for servers to explicitly indicate 
that it supports the following, even if configured in the client:

- STUN
- loose-routing
- comp=sigcomp
- ...

[jvb] Yes, I proposed this too some time ago. "Proxy capabilities" similar to callee capabilities; I was thinking about parameters in Record-Route, Service-Route and Path headers. To start with,";extensions=..." would help

Regards,

Jeroen

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 11 Aug 2006 09:54:04 +0200

Hi,

I changed the name of the topic. It's a generic issue, and not related
to outbound and STUN keep-alive only.

>>Ok, so lets standardise a mechanism for servers to explicitly indicate
that it supports the following, even if 
>>configured in the client:
>>
>>- STUN
>>- loose-routing
>>- comp=sigcomp
>>- ...
>
>[jvb] Yes, I proposed this too some time ago. "Proxy capabilities"
similar to callee capabilities; I was thinking about 
>parameters in Record-Route, Service-Route and Path headers. To start
with,";extensions=..." would help

[CHH] I also think it is something we should look into - especially when
we are now have functions and extensions which require proxy support of
certain functions (until now most extensions have been end-to-end,
without any specific proxy support).

Regards,

Christer