Subject: RE: [Sip] GRUU and Mid-Dialog Requests

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 25 Aug 2006 11:54:20 -0400

Is it just me or does something sound fundamentally wrong to call a GRUU
an AOR?

I thought it was that Contacts are registered to AoRs, and GRUU was just
one type of Contact address, where an AoR can map to multiple Contacts,
zero or more of which may be GRUUs.

Mike

> -----Original Message-----
> From: Xavier Marjou [mailto:[email-masked]] 
> Sent: Friday, August 25, 2006 5:07 AM
> To: [email-masked]
> Subject: Re: [Sip] GRUU and Mid-Dialog Requests
> 
> I'm still not 100% convinced that extending the scope of the 
> remote target
> (ie: Contact header field) to carry a gruu URI is necessary. 
> 
> What about the following alternative mechanism: 
> 
> - UA X obtains a GRUU AOR (eg: sip:ua-x;gruu=xyz) either by a 
> response to a REGISTER request or by an external means.
> 
> - UA X must register his GRUU AOR before using it (as it 
> recognize a gruu aor, the registrar only accepts one 
> address-of-contact, so that forking towards multiple contacts 
> is not possible)
> 
> - UA X can then use its GRUU AOR in its From header when 
> sending an "initial" request, or substitute his AOR with its 
> GRUU AOR in the To header when receiving an "initial" request. 
> 
> In this case, mid-dialog requests are not impacted. Moreover 
> the anonymous property of the GRUU AOR may be left out of the 
> GRUU spec, as it comes back to the general usage in From and 
> To headers.
> 
> Xavier
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Fri, 25 Aug 2006 14:15:53 -0500

> zero or more of which may be GRUUs.

That's consistent with my view of GRUU.

I see a GRUU as an alias for a Contact URI  that can be used in place  
of a Contact URI. As such, a GRUU is a URI, but not an AOR.

It's important to understand the the GRUU, while we use the word  
"Global", isn't necessarily global. All we can be sure of is that the  
GRUU is valid in the "external" context of the node assigning the  
GRUU. This is important, because in many scenarios, that node also  
has an "internal" context, and the Contact URI used for registration  
is probably valid only in that internal context.  Of course, if the  
external context happens to be "the Internet", then we're pretty  
close to globally routable, but the GRUU mechanism is still useful  
even in cases like enterprises with internal NATs.

But GRUU sounds much cooler than ERUU to a native English speaker (or  
to a player of adventure games who has been eaten by a grue too many  
times).

--
Dean