Subject: RE: [Sip] GRUU-10: "gruu" as both a header and URI parameter

From: "B, Nataraju" <[email-masked]>
Date: Tue, 22 Aug 2006 11:24:44 +0530

Comments inline...

Thanks,
Nataraju A B
> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, August 22, 2006 3:00 AM
> To: Robert Sparks
> Cc: IETF SIP List; [email-masked]
> Subject: Re: [Sip] GRUU-10: "gruu" as both a header and URI parameter
> 
> How about "gruu" and "GRUU"? :-)
> 
> Actually, in this case it doesn't bother me enough to want to change
it.
> But I won't fight against a change.
> 
[ABN] even if think of doing this, it would add lot of deviation when
compared to other header/URI parameters. 
In most of the cases all the parameters have been considered
case-insensitive. 

> 	Paul
> 
> Robert Sparks wrote:
> > I've got several comments for the gruu spec for today's deadline,
and
> > will meet Keith's formatting requirement for them in
> > other messages. There are a couple of topics I wanted to start
> > individual threads on though. Here's the first:
> >
> > Right now, the mechanism is creating a header parameter and a URI
> > parameter with the same name : "gruu".
> >
> > Thinking about this from the perspective of debugging things in a
lab,
> > or worse, over VoIP or an IM, I envision
> > many, many conversations that will take this form:
> >
> > A: I see the problem - it's in the gruu parameter.
> > B: Ok - I'll change that
> > (retry)
> > A: It's still broken - I don't see what you... Oh wait - I didn't
mean
> > _that_ gruu parameter, go
> >      change the other one.
> > B: Oh crud - was it the header parameter or the URI parameter? (and
> > which one of those is outside
> >      the <>'s? I can never keep that straight...)
> >
> > For the sake of sanity (at least mine), could we please reconsider
> > giving these things different names?
> >
> > RjS
> >
> >
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "B, Nataraju" <[email-masked]>
Date: Tue, 22 Aug 2006 11:28:05 +0530

If we mandate for gruu as a URI parameter, I mean within ANGLE brackets
'< >' would solve all the problems, I guess so. 

Thanks,
Nataraju A B

> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Tuesday, August 22, 2006 11:16 AM
> To: Robert Sparks; IETF SIP List
> On Aug 21, 2006, at 1:26 PM, Robert Sparks wrote:
> 
> > lab, or worse, over VoIP or an IM, I envision
> > mean _that_ gruu parameter, go
> >      change the other one.
> Add my plea for consideration to Robert's - implementors are confused
> enough about the difference between header parameters and uri
> parameters without us adding to the confusion.
> 
> It's not like gruu is such an intuitively descriptive acronym that
> nothing else could make sense, we could have gruu and groovy :-)
> 
>

---

From: Jeroen Van Bemmel <[email-masked]>
Date: Tue, 22 Aug 2006 13:08:39 +0200

How about 'gr' for the URI parameter. For "globally routable"

Jeroen 

-----Oorspronkelijk bericht -----
Van: "Paul Kyzivat" <[email-masked]>
Aan: "Robert Sparks" <[email-masked]>
CC: "IETF SIP List" <[email-masked]>; [email-masked]
Verzonden: 21-8-06 23:29
Onderwerp: Re: [Sip] GRUU-10: "gruu" as both a header and URI parameter

Actually, in this case it doesn't bother me enough to want to change it. 
But I won't fight against a change.

	Paul

Robert Sparks wrote:
> I've got several comments for the gruu spec for today's deadline, and 
> Thinking about this from the perspective of debugging things in a lab, 
> A: It's still broken - I don't see what you... Oh wait - I didn't mean