Subject: RE: [Sip] updated GRUU spec

From: "Attila Sipos" <[email-masked]>
Date: Tue, 1 Aug 2006 08:38:10 +0100

For those who didn't see a link, it's at:
http://www.jdrosen.net/papers/draft-ietf-sip-gruu-10.txt

Cheers,
Attila

Attila Sipos
http://www.vegastream.com

>> -----Original Message-----
>> From: Jonathan Rosenberg [mailto:[email-masked]]
>> Sent: 31 July 2006 22:03
>> To: IETF SIP List
>> Subject: [Sip] updated GRUU spec
>> 
>> 
>> I've just submitted an update to the GRUU spec based on 
>> comments on the 
>> list. Until it appears, you can pick it up at:
>> 
>> * noted that, in the outbound direction, if the home proxy is not on
>> the original request path, another proxy in that domain 
>> needs to put in 
>> a record-route
>> that points to it. Provide links to some mechanism which 
>> allows a home
>> proxy to get on the outbound request path
>> 
>> * clarified that, if an outbound proxy is used, the request has to
>>    visit the domain from which the gruu was obtained before being
>>    forwarded to the party in the r-uri. There are two ways documented
>>    to know this:
>> 
>>     a. using a service route obtained from the same proxy 
>> that sent you
>>     a gruu
>> 
>>     b. using an outbound proxy; configuration tells you what 
>> domain its
>>     from
>> 
>> 
>> * noted that an outbound proxy is not needed; rules above only apply
>> when one is used
>> 
>> * clarified the interaction of caller prefs and callee caps with gruu
>> 
>> * clarified how a proxy determines that a request is a mid-dialog
>> request
>> 
>> * clarified that GRUU basically implies you can't have a sip dialog
>>    without registration
>> 
>> * clarified that a UA, in processing a REGISTER response, is going to
>>    have to search for and extract its own contacts in case other UA
>>    registered against the same AOR
>> 
>> * changed rules on inclusion of grid/gruu URI param in the contact. A
>>    registered contact cannot have a grid or gruu URI
>>    param if its also got an instance ID. If there is no 
>> instance ID its
>>    ok. Correspondingly, removed check on making sure a 
>> contact wasn't a
>>    gruu for the AOR in the To field. This is not necessary 
>> now, and in
>>    fact is permitted and works fine.
>> 
>> * clarified that proxy processing of 'initial' requests applies when
>>    there are no Route headers. Consequently, treatment of
>>    dialog-forming requests which happen to have route headers is not
>>    specified.
>> 
>> * removed rfc2119 strength text from requirements section
>> 
>> 
>> 
>> Thanks,
>> Jonathan R.
>> -- 
>> Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
>> Cisco Fellow                                   Parsippany, 
>> NJ 07054-2711
>> Cisco Systems
>> [email-masked]                              FAX:   (973) 952-5050
>> http://www.jdrosen.net                         PHONE: (973) 952-5000
>> http://www.cisco.com
>> 
>> _______________________________________________
>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments on the application of sip
>> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 01 Aug 2006 14:37:38 -0400

Oops, my bad. Thanks for correcting Attila.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com