Subject: Re: [Sip] Re: [Simple] UDP - what if response is bigger than 1500 bytes (ethernet MTU)?

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 10 Aug 2006 15:14:48 -0500

Aki Niemi wrote:
> On ke, 2006-07-19 at 17:46 -0500, ext Vijay K. Gurbani wrote:
> 
>>This remains a problem; I have had a quick chat with Scott
>>Lawrence on it and we'll be submitting a draft latter part
>>of next week on one way to deal with this.
> 
> 
> I'm curious, can that draft really suggest anything other than simply
> "MUST NOT use UDP"?

Aki: Alas, no.  Maybe when we get SIP/3.0, then we can get rid of
UDP, forking, retargetting, and sips ;-)

But seriously, the reasons that Willis et al. list in Section 3
of their work [1] long time ago about the applicability of
UDP are still pertinent.

About the best we may be able to do is to provide a repairable
4xx response.  That is what the draft suggests.

The edit token is with my co-author, Scott Lawrence.  As soon
as he's done, we will submit the draft.

[1] D. Willis and B. Campbell, "Session Initiation Protocol
Extension to Assure Congestion Safety," IETF Internet-Draft,
Work in Progress, October 2003.  Archived at:
http://tools.ietf.org/wg/sip/draft-ietf-sip-congestsafe/
   draft-ietf-sip-congestsafe-02.txt

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aki Niemi <[email-masked]>
Date: Fri, 11 Aug 2006 00:04:11 +0300

> of their work [1] long time ago about the applicability of

You mean 'tiny' mobile phones and extremely high-volume proxies? 

Well, I think I can speak to the former, and usually such tiny phones
have an even tinier battery. NAT/FW keepalives every 20 sec or so eat
that tiny battery up really fast. 

Modern mobile phones also start to have the horsepower that PCs in the
90s had, and their networking stack is *at least* as good. :)

In other words, I don't buy it. ;)

As to the latter, I wonder why TCP is supposed to be so much more
expensive. Is it the connection establishment overhead, or the
performance penalty of juggling with too many open TCP sockets?

In any case, security is completely broken in SIP over UDP, so that sort
of makes all of the arguments for UDP moot anyway.

> 4xx response.  That is what the draft suggests.

That could work.

> as he's done, we will submit the draft.

I will surely take a look. In the mean time, I guess I'll just have to
wait for SIP/3.0, then. ;-)

Cheers,
Aki

-- 
Aki Niemi
Nokia Research Center