Subject: RE: [Sip] proxy redirected?

From: "Elwell, John" <[email-masked]>
Date: Thu, 18 Jan 2007 08:48:39 +0000

However, RFC 3261 places restrictions depending on whether the proxy is
responsible for the domain of the existing Request-URI. It can recurse only
if it is responsible for that domain - see 16.5.

John 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 18 January 2007 03:56
> To: [email-masked]
> Subject: Re: [Sip] proxy redirected?
> 
>    From: Charles Kristofek <[email-masked]>
> 
>    Can anyone explain how an RFC3261 compliant proxy 
> determines when a 
> 
>    "302 Moved Temporarily" is received by the proxy whether to
>    a.    Redirect immediately to the new contact, or
>    b.    Pass the 302 backwards, allowing the originating UA to retry.
>    It would seem that a proxy making use of a Redirect Server
>    would always perform choice (a).
>    Subsequently, the "new contact" may also reply with a 302...
> 
> It can choose to do either, "based on local policy".
> 
> Dale
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Thu, 18 Jan 2007 09:54:58 -0500

From: "Elwell, John" <[email-masked]>

   However, RFC 3261 places restrictions depending on whether the
   proxy is responsible for the domain of the existing Request-URI. It
   can recurse only if it is responsible for that domain - see 16.5.

Interesting -- so other 302's have to be passed back upstream.  And I
suppose the UAC has blanket permission to act on any 3xx.

Dale