Subject: Re: [Sip] Question about Poll: Proposal relating to keepalive, TCP, and UDP usage in draft-ietf-sip-outbound

From: "Rohan Mahy" <[email-masked]>
Date: Thu, 4 Jan 2007 17:11:51 -0800

Hi,

I don't see value in goal #3.  I believe my proposal covers your goals
#1 and #2 (with #2 corrected to talk about receiving large packets as
corrected by Francois).

Perhaps you are having an allergic reaction to some of the specific
wording I proposed rather than the goal or effect of that text.  If
so, lets try to hammer out some mutually agreeable alternate text.

thanks,
-rohan

On 12/30/06, Cullen Jennings <[email-masked]> wrote:
>
> If the people who have been expressing strong opinions on the details
> of this proposal could comment on if they agree with these high level
> goals or not, it would be really helpful for trying to get this draft
> to move forward.
>
> On Dec 16, 2006, at 12:33 PM, Cullen Jennings wrote:
>
> > Practically speaking given where we are today, I would be a fan of
> > a solution that meant the following goals:
> >
> > 1) allowed deployments that wanted to use TCP to use TCP
> >
> > 2) allowed deployments that wanted to use UDP to use only UDP with
> > the known limitations that the UA would not be able to send large
> > requests
> >
> > 3) allowed deployments that wanted to use both UDP and TCP to do so
> > and not have the size limitations by using switchover
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 5 Jan 2007 13:08:06 +0100

Hi,

I agree with these high level goals.

Regards,

Christer

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: 31. joulukuuta 2006 3:01
> To: Cullen Jennings
> Cc: SIP
> Subject: Re: [Sip] Question about Poll: Proposal relating to 
> keepalive, TCP,and UDP usage in draft-ietf-sip-outbound
> 
> 
> If the people who have been expressing strong opinions on the 
> details of this proposal could comment on if they agree with 
> these high level goals or not, it would be really helpful for 
> trying to get this draft to move forward.
> 
> > Practically speaking given where we are today, I would be a 
> fan of a 
> > solution that meant the following goals:
> >
> > 2) allowed deployments that wanted to use UDP to use only 
> UDP with the 
> > known limitations that the UA would not be able to send 
> large requests
> >
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 5 Jan 2007 13:08:06 +0100

Hi,

Regards,

Christer

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 5 Jan 2007 15:18:12 -0800

This was why I wanted to concentrate on the high level goals. It  
seems that most people agree with 1 and 2 and I  may have stated 3  
poorly but I get the idea that if 3 is something large and complex  
with long delay people don't want to wait for it and if 3 simply  
means that you can multiregister with two protocols people have no  
objections to it and see benefits for some cases.