Subject: [Sip] Question about Content-Type.

From: XuChunrong <[email-masked]>
Date: Fri, 12 Jan 2007 21:53:29 +0800

Hi,all.
	I am a newbie here.. :-) So ask a stupid question first:
Can we defined our own Content-Type if we need a new Message Body type,
for example, can I define an "application/example" in my SIP program?

Thanks...

-- 
Best Regards

Xu Chunrong
Southeast University, Nanjing

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 12 Jan 2007 09:59:15 -0500

You can, but you will need to write an RFC to get it approved for IANA
registration.

Mike

> -----Original Message-----
> From: XuChunrong [mailto:[email-masked]] 
> Sent: Friday, January 12, 2007 8:53 AM
> To: [email-masked]
> Subject: [Sip] Question about Content-Type.
> 
> Hi,all.
> Can we defined our own Content-Type if we need a new Message 
> Body type, for example, can I define an "application/example" 
> in my SIP program?
> 
> Thanks...
> 
> --
> Best Regards
> 
> Xu Chunrong
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: [email-masked]
Date: Fri, 12 Jan 2007 10:26:19 -0500

From: XuChunrong <[email-masked]>

   I am a newbie here.. :-) So ask a stupid question first:  Can we
   defined our own Content-Type if we need a new Message Body type,
   for example, can I define an "application/example" in my SIP
   program?

If you want to define an "official" Content-Type, you have to go
through the appropriate process.  (The process varies for different
protocol identifiers.  See http://www.iana.org/numbers.html.)

If you want a private, experimental Content-Type, use a second part
that starts with "x-".  "x-" is a blanket convention for private token
values.  So you can use "application/x-example" and know that that
name will never be standardized for another purpose.

If you want an unofficial Content-Type but think its use might become
widespread, put some sort of name after the "x-", like
"application/x-aquarius-example" to reduce the risk of collision with
other uses.

Dale