Subject: RE: [Sip] RE: Stateless Proxy and SIP responses

From: "Attila Sipos" <[email-masked]>
Date: Wed, 24 Jan 2007 14:59:59 -0000

>>I think a stateless proxy can not fork a request.

This is correct.
A stateless proxy cannot fork.

Regards,
Attila

-----Original Message-----
From: Diego B [mailto:[email-masked]]
Sent: 24 January 2007 14:55
To: David Viamonte
Cc: [email-masked]
Subject: Re: [Sip] RE: Stateless Proxy and SIP responses

Hi
How a stateless proxy can fork a request and then cancel one of the legs?
A stateless Proxy has no Transaction memory, so it can not cancel a 
transaction after receiving a response.
I think a stateless proxy can not fork a request.

Regards
Diego B

David Viamonte wrote:
> A stateless proxy must receive all responses related to a request. 
> Otherwise, the proxy is not able to know whether a proxied request 
> succeeds, or a transmisssion error occurs, or the receiving entity 
> died, ...
>
> Additionally, consider a (stateless) forking proxy: it needs to 
> receive an answer in one leg in order to cancel the request in the 
> other leg, for example.
>
> In general, observe that a request is only 50% of a full transaction. 
> The minimum set of information any SIP node can proces is a full 
> transaction. Therefore, in order to correctly process a request, a 
> stateless proxy must receive and correctly process the answer(s) 
> (e.g.: 100 Trying, 18x, 200 OK) as well. Afterwars, it may safely 
> remain out of the signalling path of subsequent SIP messages.
>
> For INVITE requests, the final ACK message may not traverse the 
> stateless proxy. This is because the ACK is a "special" SIP message, 
> not exactly a real request as other SIP messages.
>
> Cheers,
>
> David
>
>
>
>
> CHADLI Youssef RD-CORE-ISS escribió:
>>
>> Hi all,
>>
>> RFC 3261 states that even a stateless SIP proxy must insert a Via 
>> entry containing its contact address in SIP request. Then, a 
>> stateless Proxy will receive all SIP responses to a proxied SIP 
>> request. However, in general, a stateless proxy would not need to 
>> receive the SIP responses to a being proxied request.
>>
>> I would like to konw what is the functional reason that leaded to 
>> mandate Proxy stateless to receive SIP responses for proxied requests.
>>
>> Thanks in advance
>>
>> Youssef 
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments on the application of sip
> ------------------------------------------------------------------------
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Wed, 24 Jan 2007 15:16:27 -0000

I can think of a few reasons...
 
1. the UA (as far as I know) cannot know if a proxy is stateless or stateful
    so it has to treat all requests in the same way.
 
(But even if you did know which proxies were stateful)....
 
2. Let's say you decide to send the response back without sending it back to
    any proxies. To make it work, you think about ripping out all the Vias except the bottom one
    and send the response to this remaining Via.
    But then even if you did try to send it to this remaining Via, there is no certainty that
    it is directly reachable - it might not have a global IP or hostname - especially if the
    request was sent via a stateless edge proxy.
 
3. for debugging purposes, say you are debugging one of the traversed proxies - it is
    easier to debug if you see the request going out and a corresponding
    response coming back.
 
Regards,
 
Attila    

-----Original Message-----
From: CHADLI Youssef RD-CORE-ISS [mailto:[email-masked]]
Sent: 24 January 2007 08:57
To: SIP LIST
Subject: [Sip] RE: Stateless Proxy and SIP responses 

Hi all, 

RFC 3261 states that even a stateless SIP proxy must insert a Via entry containing its contact address in SIP request. Then, a stateless Proxy will receive all SIP responses to a proxied SIP request. However, in general, a stateless proxy would not need to receive the SIP responses to a being proxied request.

I would like to konw what is the functional reason that leaded to mandate Proxy stateless to receive SIP responses for proxied requests.

Thanks in advance 

Youssef