Subject: [Sip] To find size of a SIP message

From: Raj <[email-masked]>
Date: Fri, 19 Jan 2007 09:36:47 -0800 (PST)

Hello,
   
            I want to find a size of a SIP message. Can anyone help me to find out the size of a SIP message?
   
  thanks in advance
   
  with regards
  Raj.

---------------------------------
Cheap Talk? Check out Yahoo! Messenger's low PC-to-Phone call rates.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 19 Jan 2007 13:03:12 -0500

From: Raj <[email-masked]>

   I want to find a size of a SIP message. Can anyone help me to find
   out the size of a SIP message?

See sections 7.4, 18.3, and 20.14 of RFC 3261.  Or just search for
"Content-Length" in the RFC.

Dale

---

From: "NC Reddy" <[email-masked]>
Date: Mon, 22 Jan 2007 11:53:27 +0530

content-length field gives only size of the SIP msg body/payload not the
complete sip msg size.

---

From: Balaji Murlitharan <[email-masked]>
Date: Mon, 22 Jan 2007 14:13:28 +0530

Hi Raj,

The size of  SIP Message is not a constant one, It varies depends upon the 
Headers included by the SIP Entity. If you want to get the Message Body 
size in a SIP Message, you can get it from the "Content-Length " header. 

Regds,
Balaji Murlitharan.C
Aricent 

Raj <[email-masked]> 
Sent by: [email-masked]
01/19/2007 11:06 PM

To
SIP forum <[email-masked]>
cc

Subject
[Sip-implementors] To find size of a SIP message

Hello,
 
            I want to find a size of a SIP message. Can anyone help me to 
find out the size of a SIP message?
 
  thanks in advance
 
  with regards
  Raj.

---------------------------------
Cheap Talk? Check out Yahoo! Messenger's low PC-to-Phone call rates.
_______________________________________________
Sip-implementors mailing list
[email-masked]
https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Mon, 22 Jan 2007 18:32:51 +0800

Hi

Content length gives only size of the SIP message body like size of SDP
body, but not size of entire SIP message. May be u could calculate the
size of SIP message from UDP/TCP packet level 

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, January 19, 2007 11:33 PM
To: [email-masked]
Subject: Re: [Sip] To find size of a SIP message

Dale

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 22 Jan 2007 10:59:10 -0500

Come on guys - this is not rocket science!

Starting with the first line of the message, you look until you find 
<cr><lf><cr><lf> to determine the end of the headers for the message, 
after which the body will begin.

Within those headers you look for the Content-Length header. It gives 
the size of the body. So that many more bytes are also part of the message.

In the case of UDP, the message always starts at the beginning of a 
packet, and any extra bytes after the message are to be ignored.

In the case of TCP, immediately after the message you should find the 
beginning of another message. There may be extra <cr><lf> pairs that you 
should ignore between messages.

Of course there are a variety of ways to optimize this processing and 
make it more robust.

	Paul