Subject: RE: [Sip] Extension mobility in SIP

From: "Anisha Kumar" <[email-masked]>
Date: Thu, 31 Jan 2008 14:33:40 +0530

Hi, 

The Extension Mobility feature dynamically configures a phone according
to the current user. Once a user logs in, the phone adopts
the user individual user default device profile information, including
line numbers, speed dials, services links, and other user-specific
properties of a phone.

For example, when user A occupies a desk and logs in to the phone, her
directory number(s), services, speed dials, and other properties appear
on that phone; but when user B uses the same desk at a different time,
his information appears.

Hope this is clear. How is this achieved in SIP ?

Thanks & Regards,
Anisha

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Thursday, January 31, 2008 11:58 AM
To: Dean Willis; Anisha Kumar
Cc: [email-masked]
Subject: Re: [Sip] Extension mobility in SIP

At 11:28 PM 1/30/2008, Dean Willis wrote:

>On Jan 30, 2008, at 10:30 PM, Anisha Kumar wrote:
>
>>Hi ,
>>
>>  Is there a separate RFC for the implementation of extension mobility

>>in SIP Uas ? If not, is it possible to achieve that ?
>What do you mean "extension mobility"? Are you thinking of the use case

>where a SIP user agent is moving around and occasionally changes its IP

>address and point of attachment to the Internet? Do you expect call 
>continuity in such a case, quick recovery of the call afterward, or 
>call drop?

A lot of times, 'extension mobility' means the number to call a phone
(UA) changes based on who logged (or registered) onto it -- which is
very different that what is above.

>--
>Dean
>
>
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol Use 
>[email-masked] for questions on current sip Use 
>[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 31 Jan 2008 07:57:37 -0500

This is largely not a sip question. The UA can register with any AOR 
(phone number) it wants after some local conversation with the user 
determine what that AOR should be.

	Paul

---

From: "Steve Langstaff" <[email-masked]>
Date: Thu, 31 Jan 2008 05:05:46 -0800

Or maybe it's a SIPPING config framework question, after some local
conversation?

http://tools.ietf.org/html/draft-ietf-sipping-config-framework-14

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 31 January 2008 12:58
> To: Anisha Kumar
> Cc: [email-masked]
> This is largely not a sip question. The UA can register with 
> any AOR (phone number) it wants after some local conversation 
> with the user determine what that AOR should be.
> 
> 	Paul
> 
> Anisha Kumar wrote:
> > Hi,
> > 
> > The Extension Mobility feature dynamically configures a phone 
> > according to the current user. Once a user logs in, the 
> phone adopts 
> > directory number(s), services, speed dials, and other properties 
> > appear on that phone; but when user B uses the same desk at a 
> > different time, his information appears.
> > 
> >> where a SIP user agent is moving around and occasionally 
> changes its 
> >> IP
> > 
> [email-masked] for questions on current sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 31 Jan 2008 10:07:31 -0500

Or,

it could be a matter of using the config framework first, discovering 
that a local conversation is needed to determine identity, then a local 
conversation, then more config framework, then registration.

But AFAIK there is no guidance on what might be in a configuration that 
would kick that off.

	Paul