Subject: [Sip] regarding session modification

From: Srinivas <[email-masked]>
Date: Wed, 16 Jan 2008 19:00:22 +0530

Hi all,

Consider the following scenarios. 

1. 

C->S: INVITE (for speechrecog)

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource is active on the established sip session

C->S: INVITE (re-INVITE for adding speechsynth resource)

S->C: 200 OK 

Offer/Answer fail for the new resource, TTS (speechsynth).

2. 

C->S: INVITE (for speechrecog)

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource is active on the established sip session.

C->S: INVITE (re-INVITE for adding speechsynth resource)

S->C: 200 OK 

Offer/Answer fail for the for the existing ASR(speechrecog) resource also.

3.

C->S: INVITE (for speechrecog)

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource is active

C->S: INVITE (re-INVITE for adding speechsynth resource)

S->C: 200 OK

C->S: ACK

Now both speechrecog and speechsynth are active on the sip session

C->S: INVITE (re-INVITE for removing speechsynth resource)

S->C: 486 BUSY HERE

What should be the behaviour of UAC in the above scenarios?

Regds,

Srinivas

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: <[email-masked]>
Date: Wed, 16 Jan 2008 19:05:18 +0530

What is the header field that is changed in all re-INVITEs.
What is the value of this header field in each scenario?

________________________________

From: Srinivas [mailto:[email-masked]]
Sent: Wed 1/16/2008 7:00 PM
To: [email-masked]
Subject: [Sip] regarding session modification

Hi all,

1. 

S->C: 200 OK

C->S: ACK

S->C: 200 OK 

 

2. 

S->C: 200 OK

C->S: ACK

S->C: 200 OK 

3.

S->C: 200 OK

C->S: ACK

S->C: 200 OK

C->S: ACK

S->C: 486 BUSY HERE

 

Regds,

Srinivas

---

From: "Zhang, Rocky Fan Wen \(Rocky\)" <[email-masked]>
Date: Thu, 17 Jan 2008 09:12:15 +0800

Hi,
 
My concerns:
 
1. SHOULD the called party reply with 200 OK if the negotiation fails?
2. Why the first two tries to add speechsynth resource failed but the
third success?
3. As my understanding, if the re-negotiation fails, it will not affect
the current media.

Best Regards,
 
===========================================
Fanwen zhang
FS5000 CPE IOT, Alcatel-Lucent Qingdao, R&D
Tel: +86-532-88615493
Email:[email-masked]
===========================================

From: Srinivas [mailto:[email-masked]] 
Sent: Wednesday, January 16, 2008 9:30 PM
To: [email-masked]
Subject: [Sip] regarding session modification

Hi all,

1. 

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource
is active on the established sip session

S->C: 200 OK 

 

2. 

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource
is active on the established sip session.

S->C: 200 OK 

Offer/Answer fail for the for the existing ASR(speechrecog) resource
also.

3.

S->C: 200 OK

C->S: ACK

Now the SIP session is established b/w UAC and UAS. speechrecog resource
is active

S->C: 200 OK

C->S: ACK

S->C: 486 BUSY HERE

 

Regds,

Srinivas

---

From: [email-masked]
Date: Wed, 16 Jan 2008 23:38:00 -0500

From: Srinivas <[email-masked]>

   1. 

   S->C: 200 OK

   C->S: ACK

   Now the SIP session is established b/w UAC and UAS. speechrecog
   resource is active on the established sip session

   S->C: 200 OK 

What?

OK, you don't specify whether the re-INVITE contains an SDP offer, but
it appears to do so as you've labeled it "for adding speechsynth
resource".  The S responds 200, but you then say "offer/answer fails
for the new resource".  If S determines that it cannot provide a
usable answer, then it must reject the re-INVITE with a failure
response.  The 200 response indicates offer/answer success.

Dale