Subject: [Sip] INVITE 200 OK - TCP retransmission

From: Thomas george <[email-masked]>
Date: Mon, 15 Sep 2008 19:17:01 -0700 (PDT)

Hi,
 
Why the 200 OK to INVITE is retransmitted even if we are using TCP?
 
rgds,
Thomas

      Unlimited freedom, unlimited storage. Get it now, on http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 16 Sep 2008 11:00:37 +0800

check RFC3261 sec 13.3.1.4
 
      Since 2xx is retransmitted end-to-end, there may be hops between
      UAS and UAC that are UDP.  To ensure reliable delivery across
      these hops, the response is retransmitted periodically even if the
      transport at the UAS is reliable.
 
-Rockson

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Thomas george
Sent: Tuesday, September 16, 2008 10:17 AM
To: [email-masked]
Subject: [Sip] INVITE 200 OK - TCP retransmission

Hi,

rgds,

Thomas

________________________________

Add more friends to your messenger and enjoy! Invite them now.
<http://in.rd.yahoo.com/tagline_messenger_6/*http://in.messenger.yahoo.c
om/invite/> 
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Thu, 18 Sep 2008 12:25:03 -0500

>       transport at the UAS is reliable.

Even more critically, there may be insane or overloaded proxies in the  
path that drop or defer the message. So even if TCP is used end-to- 
end, SIP requires retransmission-until-acknowledgement at the protocol  
level.

I have long maintained that if we'd thought this through that instead  
of the three-message INVITE transaction that we'd have been better off  
using opposing pairs of two-message transactions. Carrying payloads in  
what are essentially acknowledgement messages (200) was a bad idea.  
But it's what we do, hence the retransmission.

--
Dean