Subject: [Sip] Dubt on RFC 4484-Trait-Based Authorization Requirements for SIP

From: Francesco la Torre <[email-masked]>
Date: Sun, 07 Sep 2008 13:43:32 +0200

Hi all,
I've a doubt regarding a statement at the end of page 5 

"... Some important design decisions are associated with carrying
assertions in a SIP request.  If an assertion is carried by value, or
uses a MIME-based content indirection system, then proxy servers will be
unable to inspect the assertion themselves.  If the assertion were
referenced in a header, however, it might be possible for the proxy
to acquire and inspect the assertion itself.  There ..."

Why a proxy server will be unable to inspect the assertion themself ?

Thanks in advance,
Francesco la Torre

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 08 Sep 2008 17:59:36 +0300

This statement is indeed misleading.
SIP proxies are able to inspect the body of a message since otherwise 
the SIP Location Conveyance procedure wouldn't work either.

Ciao
Hannes

---

From: Francesco la Torre <[email-masked]>
Date: Mon, 08 Sep 2008 17:06:34 +0200

Thanks for clarification :-)

Regards
Francesco la Torre

Il giorno lun, 08/09/2008 alle 17.59 +0300, Hannes Tschofenig ha