Subject: [Sip] Should SIP LoadBalancer add VIA header?

From: "Karthikeyan Gopal " <[email-masked]>
Date: Wed, 8 Oct 2008 12:28:47 +0530

Hi All,

  My Query:

     1. SIP-Load Balancer should add VIA header?

     2. SIP Response should traverse SIP-Loadbalancer or the SIP-Server
can send it directly to respective SIP-Client.

Thanks & Regards,

Karthikeyan.G

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Iñaki Baz Castillo" <[email-masked]>
Date: Wed, 8 Oct 2008 10:05:34 +0200

>      1. SIP-Load Balancer should add VIA header?

A SIP load balander is in fact a SIP proxy (generally in stateless),
so it must add's a Via header.

>      2. SIP Response should traverse SIP-Loadbalancer or the SIP-Server can
> send it directly to respective SIP-Client.

The resopnse should traverse the load balancer. This is by SIP
definition. Imagine two cases:

1) Load balancer ---> SIP UDP ---> UAS
In this case the UAS would reply to the Via sent-by in case it's equal
to the load balancer IP address. In case the Via sent-by added by the
load balancer is a hostname then the UAS would add
"received=REAL_SOURCE_IP_OF_LOAD_BALANCER" to Via and sent replies
there,

2) Load balancer ---> SIP TCP ---> UAS
By definition a UAS msut reply using the incoming TCP connection.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "Karthikeyan Gopal " <[email-masked]>
Date: Wed, 8 Oct 2008 14:23:16 +0530

Is there any way to bypass SIP-Response?
Load on SIP-Loadbalancer gets increased when response traverse through it.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Iñaki Baz Castillo
Sent: Wednesday, October 08, 2008 1:36 PM
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] Should SIP LoadBalancer add VIA header?

DISCLAIMER:

---

From: "Iñaki Baz Castillo" <[email-masked]>
Date: Wed, 8 Oct 2008 12:14:57 +0200

> Load on SIP-Loadbalancer gets increased when response traverse through it.

Not AFAIK. This is how SIP works.

Anyway, note that only the initial transaction (request + responses)
will use the load balancer. The following in-dialog request will go
directly from acller to callee (if load balancing proxy doesn't add
Record-Route).