Subject: [Sip] INFO Events Replacing or Updating INFO?

From: Eric Burger <[email-masked]>
Date: Fri, 24 Oct 2008 08:44:58 -0500

You may or may not recall there was discussion in Dublin (but not on  
the list or in the minutes) about whether the new INFO Events document  
should Update or Obsolete the old INFO specification, RFC 2976.  Upon  
reflection, and what you see in the current draft, the editors went  
with Obsolete. The reasons are:

o  This mechanism substantially replaces the old mechanism; it is not  
an incremental change or correction.

o  There are already way too many documents in SIP; it would be easy  
for an implementor to not bother checking what the Update is when they  
look at RFC 2976.

o   We want the RFC 2976 mechanism to go away. Keeping RFC 2976 active  
is begging for implementors to build the wrong thing. An Update sort  
of implies "new and improved, but old is still good."  Old, in this  
case, is NOT good.

The editors made this decision and it is what the current document  
reflects.  However, we would like to make sure this represents the  
work group consensus.  Therefore, it would be helpful if you could  
chime in with your thoughts:

[ ] INFO Events should Obsolete RFC 2976
[ ] INFO Events should Update RFC 2796, because ____________
[ ] I do not care what you do

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 24 Oct 2008 09:58:15 -0400

Eric Burger wrote:

> [X] INFO Events should Obsolete RFC 2976

But of course the new document must carefully define backward compatible 
behavior. Its made a stab at that, and I expect it to be complete before 
approval.

	Thanks,
	Paul

---

From: Salvatore Loreto <[email-masked]>
Date: Sat, 25 Oct 2008 19:25:15 +0300

I agree with Paul

Sal

Paul Kyzivat wrote:
> But of course the new document must carefully define backward 
> compatible behavior. Its made a stab at that, and I expect it to be 
> complete before approval.
>
>     Thanks,
>     Paul

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Sun, 26 Oct 2008 13:41:12 +0100

I believe we can take that as a given condition.

Please validate the results of your comments so far in any new version,
and of course, it is open for all to make comments on this issue.

Note that there are some things that are not well defined in RFC 2796,
so primarily the WG will be looking for compatibility with what RFC 2976
actually says, rather than what one implementation may have interpreted.
So please back up any comments on compatibility issues with existing RFC
2976 text.

Regards

Keith 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Paul Kyzivat
> Sent: Friday, October 24, 2008 2:58 PM
> To: Eric Burger
> Cc: SIP IETF
> Subject: Re: [Sip] INFO Events Replacing or Updating INFO?
> 
> 
> 
> Eric Burger wrote:
> 
> > [X] INFO Events should Obsolete RFC 2976 [ ] INFO Events 
> should Update 
> > RFC 2796, because ____________ [ ] I do not care what you do
> 
> compatible behavior. Its made a stab at that, and I expect it 
> to be complete before approval.
> 
> 	Thanks,
> 	Paul
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 28 Oct 2008 15:58:22 +0000

+1, provided existing use for ISUP and QSIG (Ecma-355) continues to be
valid.

John 

> Sent: 24 October 2008 14:58
> To: Eric Burger
> Cc: SIP IETF
> compatible

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Tue, 28 Oct 2008 18:55:45 +0100

Depends what you mean by that statement.

A legacy usage of INFO should interwork with a new usage. 

However, the question of what criteria exist for package definition in
conformance with the new document is still open.

Note also that obsolete RFCs do not disappear, they are just tagged
"obsolete".

Regards

Keith

> Behalf Of Elwell, John
> Sent: Tuesday, October 28, 2008 3:58 PM
> To: Paul Kyzivat; Eric Burger
> Cc: SIP IETF
> Behalf Of 
> > Paul Kyzivat
> > > [X] INFO Events should Obsolete RFC 2976 [ ] INFO Events should 
> > > Update RFC 2796, because ____________ [ ] I do not care 
> what you do
> > 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> >