Subject: Re: [Sip] I-D Action:draft-rosenberg-sip-target-uri-delivery-00.txt

From: Shida Schubert <[email-masked]>
Date: Fri, 31 Oct 2008 18:19:57 +0900

Jonathan;

  Thanks for writing up the draft.

  There was a use-case for freephone number mentioned in section 2.7 of
loose-route draft which no longer exists in this draft.

  I do recall that in section 2.7 of loose-route you expressed that  
freephone
number is just another form of alias, so I am assuming that is the  
reason
you removed the text OR was there any technical reason why you removed
the use-case?

  If there is no technical reason behind removing the text, could you
add its use for freephone number as a use-case either as a separate
sub-section or as part of alias use-case..

  Thanks & Regards
   Shida

On 27-Oct-08, at 1:30 PM, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
> 	Title           : Delivery of Request-URI Targets to User Agents
> 	Author(s)       : J. Rosenberg
> 	Filename        : draft-rosenberg-sip-target-uri-delivery-00.txt
> 	Pages           : 12
> 	Date            : 2008-10-26
>
> When a Session Initiation Protocol (SIP) proxy receives a request
> targeted at a URI identifying a user or resource it is responsible
> for, the proxy translates the URI to a registered contact URI of an
> agent representing that user or resource.  In the process, the
> original URI is removed from the request.  Numerous use cases have
> arisen which require this information to be delivered to the user
> agent.  This document describes these use cases and defines an
> extension to the History-Info header field which allows it to be used
> to support those cases.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-rosenberg-sip-target-uri-delivery-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> <mime-attachment>_______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 31 Oct 2008 13:51:58 +0100

Hi,

The draft-holmberg-sip-target-uri-delivery-01.txt draft contained text
on why the P-Called-Party-ID header was used. Would it be a good idea to
keep that text in this spec, because I have already received questions
regarding that.

Regards,

Christer

> > Internet-Draft directories: http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip