Subject: Re: [Sip] configuration NOTIFY in example 9.1 of outbound i-d

From: Dean Willis <[email-masked]>
Date: Thu, 2 Oct 2008 17:55:31 -0500

On Sep 29, 2008, at 3:26 PM, Paul Kyzivat wrote:

>
>
> Francois Audet wrote:
>>> > Section 4.3 states (UA procedures):
>>> >    If the UAC is sending a dialog-forming request, and wants all
>>> >    subsequent requests in the dialog to arrive over the same  
>>> flow, the
>>> >    UAC adds an 'ob' parameter to its Contact header.  Typically  
>>> this is
>>> >    desirable, but it is not necessary for example if the Contact  
>>> is a
>>> >    GRUU [I-D.ietf-sip-gruu].
>>> if contact is gruu, does it mean that 'ob' param is implicitly  
>>> included?
>> I am not sure why this is worded like this. I was thinking that  
>> using a GRUU as a contact in a dialog-forming request would mandate  
>> that
>> requests sent to that Contact would be sent using the same flow, but
>> I see no such rule in draft-ietf-sip-gruu.
>
> Gruu isn't dependent on outbound.
>
>

So explain this one for me, please.

Is it that, if the gruu was formed using outbound (that is, the "real"  
contact for which the gruu is an alias has an "ob") use of the gruu  
will use the "ob" in the dereferencing at the gruu-provider?

So for the example referenced above may be correct, but incomplete --  
it should talk about whether or not the gruu was formed using  
outbound, not just whether or not the contact isa gruu.

--
Dean

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 2 Oct 2008 18:09:37 -0500

My take on this is that Juha is right and the document should really say:

	If the UAC is sending a dialog-forming request, and wants all
	subsequent requests in the dialog to arrive over the same
	flow, the UAC MUST add an 'ob' parameter to its Contact header.  
      [ DELETE NEXT SENTENCE ENTIRELY ]

In other words, GRUU is orthogonal and does NOT imply "ob" behavior.

Clean and simple, and I *think* this was our intent (i.e., I think
this is an historical oversight).

Cullen, can you confirm or clarify?

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]] 
> Sent: Thursday, October 02, 2008 15:56
> To: Paul Kyzivat
> Cc: Audet, Francois (SC100:3055); Cullen Jennings; Rohan 
> Mahy; [email-masked]
> Subject: Re: [Sip] configuration NOTIFY in example 9.1 of outbound i-d
> 
> 
> >> I am not sure why this is worded like this. I was thinking 
> that using 
> >> a GRUU as a contact in a dialog-forming request would mandate that 
> contact for which the gruu is an alias has an "ob") use of 
> the gruu will use the "ob" in the dereferencing at the gruu-provider?
> 
> So for the example referenced above may be correct, but 
> incomplete -- it should talk about whether or not the gruu 
> was formed using outbound, not just whether or not the 
> contact isa gruu.
> 
> --
> Dean
> 
> 
> 
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 02 Oct 2008 19:18:01 -0400

Dean Willis wrote:
>>>> >    subsequent requests in the dialog to arrive over the same flow, 
>>>> the
>>>> >    desirable, but it is not necessary for example if the Contact is a
>>> I am not sure why this is worded like this. I was thinking that using 
> contact for which the gruu is an alias has an "ob") use of the gruu will 
> use the "ob" in the dereferencing at the gruu-provider?

Sure. When the translation of the gruu takes place the contact, with the 
ob param, will go in the R-URI. And then of course that influences how 
it is routed.

> So for the example referenced above may be correct, but incomplete -- it 
> should talk about whether or not the gruu was formed using outbound, not 
> just whether or not the contact isa gruu.

Yes, I think you are right. The UA needs to either use a contact with 
'ob', or a gruu that maps to a contact with 'ob'.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 02 Oct 2008 19:20:41 -0400

I guess our replies overlapped.

> In other words, GRUU is orthogonal and does NOT imply "ob" behavior.

Not quite. If you have obtained a gruu after registering a contact with 
outbound, you don't have to put "ob" on the gruu. It wouldn't help, 
since it would get lost in the process of translating the gruu.

	Thanks,
	Paul

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 2 Oct 2008 18:37:09 -0500

I see what you mean.

Can you propose replacement text? 

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Thursday, October 02, 2008 16:21
> To: Audet, Francois (SC100:3055)
> Cc: Dean Willis; Cullen Jennings; Rohan Mahy; [email-masked]
> Not quite. If you have obtained a gruu after registering a 
> contact with outbound, you don't have to put "ob" on the 
> gruu. It wouldn't help, since it would get lost in the 
> process of translating the gruu.
> 
> 	Thanks,
> 	Paul
> 
> >> Cc: Audet, Francois (SC100:3055); Cullen Jennings; Rohan Mahy; 
> >> [email-masked]
> the gruu 
> incomplete --

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 03 Oct 2008 09:11:59 -0400

> Can you propose replacement text? 

Dean beat me to it. And his text is good - better than I would have done.

	Thanks,
	Paul