Subject: [Sip] Clarification on RFC 4458: SIP URIs for Applications such as Voicemail and Interactive Voice Response (IVR)

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 8 Apr 2009 18:06:59 +0200

RFC 4458 defines two SIP URI parameters.

I can find no specific language in the document that indicates whether these two URI parameters can be used independently of each other, or whether there is an expectation that both URI parameters should only exist in the presence of each other. Specifically does an implementation that only includes the "cause" SIP URI parameter and not the "target" sip URI parameter conform to this specification?

All the text and examples seem to carry the implication that where one exists, the other one will also. 

Could one of the authors or some other interested party clarify what they believe the intention is?

regards

Keith

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 8 Apr 2009 11:09:59 -0500

I believe the intention was that target was mandatory, but not cause.

I don't believe having cause but not target would make any sense. 

> -----Original Message-----
> From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
> Sent: Wednesday, April 08, 2009 09:07
> To: [email-masked]
> Cc: Cullen Jennings; Audet, Francois (SC100:3055); Elwell, John
> Subject: Clarification on RFC 4458: SIP URIs for Applications 
> such as Voicemail and Interactive Voice Response (IVR)
> 
> I can find no specific language in the document that 
> indicates whether these two URI parameters can be used 
> independently of each other, or whether there is an 
> expectation that both URI parameters should only exist in the 
> presence of each other. Specifically does an implementation 
> that only includes the "cause" SIP URI parameter and not the 
> "target" sip URI parameter conform to this specification?
> 
> All the text and examples seem to carry the implication that 
> where one exists, the other one will also. 
> 
> Could one of the authors or some other interested party 
> clarify what they believe the intention is?
> 
> regards
> 
> Keith
>

---

From: <[email-masked]>
Date: Thu, 9 Apr 2009 06:32:17 +0200

Hi, 

It is certainly true for those parameters in the R-URI but in the History-Info header it is less obivous because if RFC4244 is respected, the retargeting is yet present in a hi-entry (the proof is that the target parameter has not been especially recommended to be used in 3GPP for CDIV service). The benefit to add the target parameter in the R-URI in the hi-entry is to have in the same hi-entry the redirecting user and the cause-param. So that we can be sure of the redirecting user identity (which could be in an other hi-entry than the one "just before"). But after that, it is still necessary to search in hi-entries the entry concerning the redirecting address to have the Privacy indication (eg. to deliver or not the redireting user identity to the diverted-to user) and to know if the retargeting is caused by a SIP response or not (if the Reason header is escaped).

Regards,
Marianne

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Francois Audet
Envoyé : mercredi 8 avril 2009 18:10
À : DRAGE, Keith (Keith); [email-masked]
Cc : Cullen Jennings; Elwell,John
Objet : Re: [Sip] Clarification on RFC 4458: SIP URIs for Applications suchas Voicemail and Interactive Voice Response (IVR)

> Subject: Clarification on RFC 4458: SIP URIs for Applications such as 
> Voicemail and Interactive Voice Response (IVR)
> 
> I can find no specific language in the document that indicates whether 
> these two URI parameters can be used independently of each other, or 
> whether there is an expectation that both URI parameters should only 
> exist in the presence of each other. Specifically does an 
> implementation that only includes the "cause" SIP URI parameter and 
> not the "target" sip URI parameter conform to this specification?
> 
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 8 Apr 2009 21:42:52 -0700

Thanks, good point. I was only thinking of the R-URI.

On Apr 8, 2009, at 21:32, "[email-masked]" <[email-masked] 
 > wrote:

> Hi,
>
> It is certainly true for those parameters in the R-URI but in the  
> History-Info header it is less obivous because if RFC4244 is  
> respected, the retargeting is yet present in a hi-entry (the proof  
> is that the target parameter has not been especially recommended to  
> be used in 3GPP for CDIV service). The benefit to add the target  
> parameter in the R-URI in the hi-entry is to have in the same hi- 
> entry the redirecting user and the cause-param. So that we can be  
> sure of the redirecting user identity (which could be in an other hi- 
> entry than the one "just before"). But after that, it is still  
> necessary to search in hi-entries the entry concerning the  
> redirecting address to have the Privacy indication (eg. to deliver  
> or not the redireting user identity to the diverted-to user) and to  
> know if the retargeting is caused by a SIP response or not (if the  
> Reason header is escaped).
>
> Regards,
> Marianne
>
> Objet : Re: [Sip] Clarification on RFC 4458: SIP URIs for  
> Applications suchas Voicemail and Interactive Voice Response (IVR)
>
>> All the text and examples seem to carry the implication that where  
>> one
>> exists, the other one will also.
>>
> This list is for NEW development of the core SIP Protocol Use [email-masked] 
>  for questions on current sip Use [email-masked] for new  
> developments on the application of sip

---

From: Hans Erik van Elburg <[email-masked]>
Date: Fri, 10 Apr 2009 10:05:42 +0200

Specifications that only include the cause value mappings as specified in
RFC4458 reuse only that part of RFC4458.

Such reuse is of course fine, but carefull wording is required not to imply
full conformance with RFC4458 as that would lead to the wrong
implications/expectations.

/Hans Erik van Elburg

On Wed, Apr 8, 2009 at 6:06 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> these two URI parameters can be used independently of each other, or whether
> there is an expectation that both URI parameters should only exist in the
> presence of each other. Specifically does an implementation that only
> includes the "cause" SIP URI parameter and not the "target" sip URI
> parameter conform to this specification?
>
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 11 Apr 2009 02:45:19 +0200

And which part of the wording in RFC 4458 do you use to justify that?

The whole point of the question is that we are trying to ascertain what is a legitimate conformance with RFC 4458.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hans Erik van Elburg
Sent: Friday, April 10, 2009 9:06 AM
To: DRAGE, Keith (Keith)
Cc: [email-masked]; Cullen Jennings; Francois Audet; Elwell, John
Subject: Re: [Sip] Clarification on RFC 4458: SIP URIs for Applications such as Voicemail and Interactive Voice Response (IVR)

Specifications that only include the cause value mappings as specified in RFC4458 reuse only that part of RFC4458.

Such reuse is of course fine, but carefull wording is required not to imply full conformance with RFC4458 as that would lead to the wrong implications/expectations.

/Hans Erik van Elburg

On Wed, Apr 8, 2009 at 6:06 PM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
RFC 4458 defines two SIP URI parameters.

regards

Keith
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked]<mailto:[email-masked]> for questions on current sip
Use [email-masked]<mailto:[email-masked]> for new developments on the application of sip

---

From: Hans Erik van Elburg <[email-masked]>
Date: Sun, 12 Apr 2009 13:39:47 +0200

OK, I assumed the question arose because of usage of RFC4458 cause value 
mapping as indicated in my previous mail. My assumption might be wrong.

Going over RFC4458 again, it does not specify what proxies complying to 
this RFC  should do. Therefore claiming compliance might be pretty 
meaningless.

But if you look at the descriptive text and the examples it seems to 
indicate that both parameters will be added .

/Hans Erik

DRAGE, Keith (Keith) wrote:
> The whole point of the question is that we are trying to ascertain 
> what is a legitimate conformance with RFC 4458.
>  
> regards
>  
> Keith
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]] *On
>     Behalf Of *Hans Erik van Elburg
>     *Sent:* Friday, April 10, 2009 9:06 AM
>     *To:* DRAGE, Keith (Keith)
>     *Cc:* [email-masked]; Cullen Jennings; Francois Audet; Elwell, John
>     *Subject:* Re: [Sip] Clarification on RFC 4458: SIP URIs for
>     Applications such as Voicemail and Interactive Voice Response (IVR)
>
>     Specifications that only include the cause value mappings as
>     specified in RFC4458 reuse only that part of RFC4458.
>
>     Such reuse is of course fine, but carefull wording is required not
>     to imply full conformance with RFC4458 as that would lead to the
>     wrong implications/expectations.
>
>     /Hans Erik van Elburg
>
>
>     On Wed, Apr 8, 2009 at 6:06 PM, DRAGE, Keith (Keith)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         I can find no specific language in the document that indicates
>         whether these two URI parameters can be used independently of
>         each other, or whether there is an expectation that both URI
>         parameters should only exist in the presence of each other.
>         Specifically does an implementation that only includes the
>         "cause" SIP URI parameter and not the "target" sip URI
>         Use [email-masked]
>         <mailto:[email-masked]> for questions on
>         current sip
>         Use [email-masked] <mailto:[email-masked]> for new

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 13 Apr 2009 11:11:43 -0500

What we had in mind when writting this was the equivalent to the Q.931 Redirecting Number information element (and whatever it's ISUP equivalent is, or even Diversion header for that matter).
 
The target maps to the Number digits (which is always there), and the cause maps to the "Reason for redirection,octet 3b", which is optional. Absence means the reason is unknown. I would say that if cause is
not there, then it means the same as cause=404.
 
Also, if target is not there, I guess it means that the number is not known. 
 
But you are right, I don't believe the text in 4458 explains it properly.

	From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
	Sent: Friday, April 10, 2009 17:45
	To: Hans Erik van Elburg
	Cc: [email-masked]; Cullen Jennings; Audet, Francois (SC100:3055); Elwell, John
	Subject: RE: [Sip] Clarification on RFC 4458: SIP URIs for Applications suchas Voicemail and Interactive Voice Response (IVR)

	 
	regards
	 
	Keith

		
		
		/Hans Erik van Elburg

		On Wed, Apr 8, 2009 at 6:06 PM, DRAGE, Keith (Keith) <[email-masked]> wrote:

			

			regards
			
			Keith