Subject: [Sip] TCP to UDP rtcp media attributes in SDP not passing through nextone

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Feb 2010 07:33:12 -0500

Dear Friend,

I have some query about UDP & TCP for signaling.

Basically I am using TCP protocol for signaling from my customer to SBC and
then SBC to Vendor using UDP for signaling. I mean CS user TCP to SBC, UDP
to carrier.  And OCS sends initial 183 with sdp that contains rtcp media
attribute information and SBC does not forward formation to carrier via UDP.

Call Flow is like this.

UAC (Private)                    SBC
UAS(Public)

|-----------Invite(TCP)---------->
|                                                       |
|
|                                                       |
|<-------- 100 Trying ------------ |
                                          |
|                                        | ----------- Invite
(UDP)----------------------->|
|
|                                                       |
|                                        |<--------- 100 Trying
---------------------------|
|
|                                                       |
                                         | <---- 183 SDP Session
Progress-------|
|                                        |(183 SDP with RTCP Media
    |
|                                        |Attribute).
                                       |
|<--------- 183 SDP -------------
|
|
| 183 SDP Session
progress|                                                       |
| Without RTCP Media         |
                                               |
|Attribute
|                                                       |
|
|                                                       |
|
|                                                       |
|
|                                                       |

Could anyone please help me out on this scenario. Why it’s not sending the
RTCP attribute to my UAC? Is there anything related to standard.

I can share the Traces, if its required.

Thanks,
Nitin Kapoor

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Feb 2010 07:37:59 -0500

Dear Friend,

Call Flow is like this.

UAC (Private)                    SBC
UAS(Public)

Thanks,
Nitin Kapoor

---

From: aayush bhatnagar <[email-masked]>
Date: Fri, 12 Feb 2010 13:42:47 +0030

Can you paste wireshark logs for both ends of the SBC?

-- 
aayush
http://in.linkedin.com/in/abhatnagar19
======

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Feb 2010 08:16:38 -0500

Aayush,

Please find the attached Traces for both legs.

Thanks,
Nitin Kapoor

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 12 Feb 2010 14:16:21 +0100

If you are going to do this, please respect the size limits on posting. Otherwise put on a website and send a link, or send directly.

regards

Keith 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of aayush bhatnagar
> Sent: Friday, February 12, 2010 1:13 PM
> To: Nitin Kapoor
> Cc: [email-masked]
> Subject: Re: [Sip] TCP to UDP rtcp media attributes in SDP 
> not passing through nextone
> 
> > Basically I am using TCP protocol for signaling from my customer to 
> > SBC and then SBC to Vendor using UDP for signaling. I mean 
> CS user TCP 
> > to SBC, UDP to carrier.  And OCS sends initial 183 with sdp that 
> > contains rtcp media attribute information and SBC does not 
> forward formation to carrier via UDP.
> >
> >
> > Call Flow is like this.
> >
> > UAC (Private)                    SBC
> > UAS(Public)
> >
> > Could anyone please help me out on this scenario. Why it’s 
> not sending 
> > the RTCP attribute to my UAC? Is there anything related to standard.
> >
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
>

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Feb 2010 10:22:37 -0500

Could any please help me out on this.

Thanks,
Nitin Kapoor

---

From: Adam Roach <[email-masked]>
Date: Fri, 12 Feb 2010 09:54:20 -0600

At the bottom of every mail on this email list -- including the ones 
that you're sending -- you'll find the following helpful information:

This list is for NEW development of the core SIP Protocol
[email-masked]  for questions on current sip

Please respect the designated purposes of these mailing lists. Thank you.

/a

On 2/12/10 07:16, Feb 12, Nitin Kapoor wrote:
> On 12 February 2010 08:12, aayush bhatnagar 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     On 12/02/2010, Nitin Kapoor <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     > Dear Friend,
>     >
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip