Subject: [Sip] Getting "Media Format = 0"

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Mar 2010 09:06:57 -0500

Hello Friends,

I am facing the problem with one of my client. I can see we are getting the
2 codecs in SDP(G.711 & G.729) with payload "0, 101, 19".

Now here is my doubt is that whenver my client is sending the SDP in initial
OFFER with G.729 its offering "Media format = 0".But when i checked the RFC
3264 and others, then i observed that it can be possible if you have two
codecs in one SDP then one media format can be "0".

Below is the OFFERED SDP from my SOURCE UA.

Media Description, name and address (m): audio 17890 RTP/AVP 0 101 19
Media Type: audio
Media Port: 17890
Media Protocol: RTP/AVP
Media Format: ITU-T G.711 PCMU
Media Format: DynamicRTP-Type-101
Media Format: Comfort noise (old)

Connection Information (c): IN IP4 212.48.160.163
Connection Network Type: IN
Connection Address Type: IP4
Connection Address: 212.48.160.163

Media Attribute (a): rtpmap:0 PCMU/8000
Media Attribute Fieldname: rtpmap
Media Format: 0
MIME Type: PCMU
Sample Rate: 8000

Media Attribute (a): rtpmap:101 telephone-event/8000
Media Attribute Fieldname: rtpmap
Media Format: 101
MIME Type: telephone-event
Sample Rate: 8000

Media Attribute (a): fmtp:101 0-16
Media Attribute Fieldname: fmtp
Media Format: 101 [telephone-event]
Media format specific parameters: 0-16
Media Attribute (a): rtpmap:19 CN/8000
Media Attribute Fieldname: rtpmap
Media Format: 19
MIME Type: CN
Sample Rate: 8000

Media Attribute (a): ptime:20
Media Attribute Fieldname: ptime
Media Attribute Value: 20

Here is SDP is offered by my Remote Entity in 183 Session progress in the
correspondence of of INITIAL INVITE.

Media Description, name and address (m): audio 5870 RTP/AVP 0 101
Media Type: audio
Media Port: 5870
Media Protocol: RTP/AVP
Media Format: ITU-T G.711 PCMU
Media Format: DynamicRTP-Type-101
Media Attribute (a): rtpmap:0 PCMU/8000
Media Attribute Fieldname: rtpmap
Media Format: 0
MIME Type: PCMU
Sample Rate: 8000
Media Attribute (a): sendrecv
Media Attribute (a): rtpmap:101 telephone-event/8000
Media Attribute Fieldname: rtpmap
Media Format: 101
MIME Type: telephone-event
Sample Rate: 8000

Now the problem which i am facing is that after  doing the Negotiation and
the ACK of 200 OK in the correspondence in INITIAL OFFER/INVITE, i am
getting a BYE  immediately from my source UA.

Could anyone please help me to diagnose this.

Thanks,
Nitin kapoor

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 12 Mar 2010 13:57:00 -0500

Hello,

Can anyone please help me out on the below issue.

Thanks,
Nitin Kapoor

On 12 March 2010 09:06, Nitin Kapoor <[email-masked]> wrote:

> Now here is my doubt is that whenver my client is sending the SDP in
> initial OFFER with G.729 its offering "Media format = 0".But when i checked
> the RFC 3264 and others, then i observed that it can be possible if you have
> two codecs in one SDP then one media format can be "0".
>

---

From: Vijay Tiwari <[email-masked]>
Date: Sat, 13 Mar 2010 21:57:15 +0530

Hello Nitin

If you are talking about codec payload then

" I can see we are getting the 2 codecs in SDP(G.711 & G.729) with payload
"0, 101, 19". "

in this payload there is no G.729 because for G.729 payload is 18.

thanks
vijay

On Fri, Mar 12, 2010 at 7:36 PM, Nitin Kapoor <[email-masked]>wrote:

> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is essentially closed and only used for finishing old business.
> Use [email-masked] for questions on how to develop a SIP
> implementation.
> Use [email-masked] for new developments on the application of sip.
> Use [email-masked] for issues related to maintenance of the core SIP
> specifications.
>

-- 
They can because they think they can.

---

From: Nitin Kapoor <[email-masked]>
Date: Sat, 13 Mar 2010 11:33:06 -0500

Yes.. i agree with you.. i haven't seen payload 18 on any SDP( niether from
source nor from remote).

Now here is my doubt about media format...is the correct to leave it "0"

Thanks,
Nitin Kapoor
On 13 March 2010 11:27, Vijay Tiwari <[email-masked]> wrote:

>> I am facing the problem with one of my client. I can see we are getting
>> the 2 codecs in SDP(G.711 & G.729) with payload "0, 101, 19".
>>
>> Use [email-masked] for questions on how to develop a
>> SIP implementation.