Subject: [Sip] SIP Uri including user=phone parameter

From: 杨运勇 <[email-masked]>
Date: Wed, 10 Mar 2010 11:50:34 +0800

Hi all,

I have a question about Sip Uri including user=phone parameter.

whether

sip:[email-masked] <[email-masked]>;user=phone;cause=302

equals to

*sip:[email-masked];cause=302;user=phone*
**
**
*Thanks in advance.*
**
*Kevin*

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Wed, 10 Mar 2010 12:02:21 +0800

Kevin,
 
The two are equivalent per sec 19 of RFC3261
 
<snip>
The ordering of parameters and header fields is not significant in comparing SIP and SIPS URIs.
</snip>
 
-Rockson
________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of 杨运勇
Sent: Wednesday, March 10, 2010 11:51 AM
To: [email-masked]
Subject: [Sip] SIP Uri including user=phone parameter

Hi all,
�
I have a question about Sip Uri including user=phone parameter.
�
whether
�
sip:[email-masked] <mailto:[email-masked]> ;user=phone;cause=302
�
equals to 
�
sip:[email-masked];cause=302;user=phone
�
�
Thanks in advance.
�
Kevin