Subject: [Sipbrandy] Open Issue in draft-ietf-sipbrandy-osrtp-00 - AVP offer/SAVP answer

From: Alan Johnston <[email-masked]>
Date: Thu, 8 Sep 2016 16:23:33 -0700

All,

To move the Opportunistic SRTP draft-ietf-sipbrandy-osrtp forward, it would
be good to get some discussion on one open issue.

Open Issue: AVP offer/SAVP answer.

Currently, the draft does not discuss this case.  Strictly speaking, an SDP
offer with AVP profile receiving an SDP answer with an SAVP profile
violates offer answer.  However, some implementations support this.  For
example, the IMTC security document has this text:

“An offerer that prefers the use of SRTP SHOULD be lenient when receiving
an answer.  It SHOULD interpret either: 1) RTP/AVP with the crypto
attribute or 2) RTP/SAVP with the crypto attribute as indicating that the
answerer is capable of supporting, and does support, SRTP encryption.”

It would be good if OSRTP allowed this, although I don't think it should be
the normal behavior.  Here is a proposed text change in Section 3:

OLD:

   If the SDP answer contains SRTP keying attributes, then that particular
   SRTP key management approach is followed and SRTP media is used for
   this session.

NEW:

   If the SDP answer contains the AVP profile with SRTP keying attributes
or the
   SAVP profile with SRTP keying attributes, then that particular SRTP key
management
   approach is followed and SRTP media is used for this session.

If there are other open issues in the draft, please raise them as this is
the only issue known to the authors.

- Alan -

---

From: "Asveren, Tolga" <[email-masked]>
Date: Fri, 9 Sep 2016 10:00:08 +0000

I agree that it is a bit of an odd case but I also agree that including it in the draft wouldn’t hurt/would help interoperability.

Thanks,
Tolga

From: Sipbrandy [mailto:[email-masked]] On Behalf Of Alan Johnston
Sent: Thursday, September 08, 2016 7:24 PM
To: [email-masked]
Subject: [Sipbrandy] Open Issue in draft-ietf-sipbrandy-osrtp-00 - AVP offer/SAVP answer

All,

To move the Opportunistic SRTP draft-ietf-sipbrandy-osrtp forward, it would be good to get some discussion on one open issue.

Currently, the draft does not discuss this case.  Strictly speaking, an SDP offer with AVP profile receiving an SDP answer with an SAVP profile violates offer answer.  However, some implementations support this.  For example, the IMTC security document has this text:

“An offerer that prefers the use of SRTP SHOULD be lenient when receiving an answer.  It SHOULD interpret either: 1) RTP/AVP with the crypto attribute or 2) RTP/SAVP with the crypto attribute as indicating that the answerer is capable of supporting, and does support, SRTP encryption.”

It would be good if OSRTP allowed this, although I don't think it should be the normal behavior.  Here is a proposed text change in Section 3:

OLD:

NEW:

   If the SDP answer contains the AVP profile with SRTP keying attributes or the
   SAVP profile with SRTP keying attributes, then that particular SRTP key management
   approach is followed and SRTP media is used for this session.

If there are other open issues in the draft, please raise them as this is the only issue known to the authors.

- Alan -

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 19 Sep 2016 09:48:18 +0300

All,

please, send your comments on Alan's proposal below and let us know if
there are more issues related to the draft you would like to discuss.

Cheers,

Gonzalo

On 09/09/2016 1:00 PM, Asveren, Tolga wrote:
> I agree that it is a bit of an odd case but I also agree that including
> it in the draft wouldn’t hurt/would help interoperability.
> 
>  
> 
> Thanks,
> 
> Tolga
> 
>  
> 
> *From:*Sipbrandy [mailto:[email-masked]] *On Behalf Of *Alan
> Johnston
> *Sent:* Thursday, September 08, 2016 7:24 PM
> *To:* [email-masked]
> *Subject:* [Sipbrandy] Open Issue in draft-ietf-sipbrandy-osrtp-00 - AVP
> offer/SAVP answer
> 
>  
> 
> All,
> 
>  
> 
> To move the Opportunistic SRTP draft-ietf-sipbrandy-osrtp forward, it
> would be good to get some discussion on one open issue.
> 
>  
> 
> Currently, the draft does not discuss this case.  Strictly speaking, an
> SDP offer with AVP profile receiving an SDP answer with an SAVP profile
> “An offerer that prefers the use of SRTP SHOULD be lenient when
> receiving an answer.  It SHOULD interpret either: 1) RTP/AVP with the
> crypto attribute or 2) RTP/SAVP with the crypto attribute as indicating
> that the answerer is capable of supporting, and does support, SRTP
> encryption.”
> 
>  
> 
> It would be good if OSRTP allowed this, although I don't think it should
> be the normal behavior.  Here is a proposed text change in Section 3:
> 
>  
> 
> OLD:
> 
>  
>