Subject: [sipcore] Extensions to the reg event package

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 21 Oct 2010 13:44:25 -0400

I've noticed that extensions to the reg event package are done by introducing new namespaces.  Since extensions usually add only one or two data items to the package, the result can be an XML document with many namespaces,  most of which have a very few element types being used.  It seems to me to be more natural for extensions to add elements to the original XML schema.  And since the interpreter of the XML document will ignore any elements that it does not recognize, this practice would be upward-compatible.  I suspect that there is some formal reason why extending an existing namespace is not done.

Dale

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 21 Oct 2010 13:53:19 -0400

My knowledge of XML schemas is limited to cutting and pasting from 
existing ones, and attempting to follow apparent conventions I see used.
(Equivalent to implementing SIP based on wireshark output.)

It would be great if somebody who knows better were to write a best 
practices document for applying XML to SIP stuff. And perhaps there 
should be some sort of official XML review of drafts.

	Thanks,
	Paul

On 10/21/2010 1:44 PM, Worley, Dale R (Dale) wrote:
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Fri, 22 Oct 2010 06:25:31 +0800

> practice would be upward-compatible.  I suspect that there is some
> formal reason why extending an existing namespace is not done.

In practice, a processor that uses the original schema definitions is likely to reject a document that uses the modified structure.

For instance, the original might define (A, B, *) where * is an extension point, and the extension defines (A, B, C, *).  Because if the way that * is defined, it means anything not in this namespace.  If the original sees C, which claims to be in the same namespace, it rejects it.

The size of namespace declarations is a common source of complaints.  The usual response is to point folks at ASN.1+?ER.  I wouldn't dream of being so rude.

--Martin