Subject: AW: AW: [Sipping-tispan] TISPAN requirements, first requiements

From: "Schmidt, Christian" <[email-masked]>
Date: Wed, 24 Aug 2005 12:53:31 +0200

Hi Miguel,

some more comments inline.

Best Regards,
Christian Schmidt

-----Ursprüngliche Nachricht-----
Von: Miguel Garcia [mailto:[email-masked]] 
Gesendet: Mittwoch, 24. August 2005 12:02
An: Schmidt, Christian
Cc: [email-masked]; Alexeitsev, D; [email-masked]
Betreff: Re: AW: [Sipping-tispan] TISPAN requirements, first requiements

Hi Christian:

Thansk for reading this document. Inline comments.

Schmidt, Christian wrote:

> Some comments:
> 
> 2. Overview
> "small variations are expected when compared with the equivalent ISTD/PSTN supplementary services"
> Can you provide an example for such a variation?

I'll give you one example that came to my mind. Many of the 
supplementary services in PSTN/ISDN assume that there is only one 
line/terminal per user, so if the user is already busy from that 
terminal/line, he won't be able to take a new call, thus, services such 
as Call Forwarding on Busy will apply.

This is not exactly the same in SIP, where a user can be using several 
terminal simultaneously, and there isn't a concept of a "line" or 
"channel". Therefore, the fact that a user is busy from one terminal 
does not necessarily imply anything with respect his busy condition. 
This is a change with respect the PSTN/ISDN services.

Christian: This information should be added somehow, perhaps:
"small variations are expected in some services (for example CCBS, because of different busy definitions) are expected.....".

> 
> 3.1 General Requirements
> "the user should receive the service without any degradation"
> This seems to be somehow in contradiction with the "variation" passage in the overview section. Or do you mean variation as addon only?

The requirement means that, if one user is in the NGN and the other in 
the PSTN, the NGN user should not receive a degradation with respect the 
NGN simulation service (read the "native network" in the text). 
Similarly, the PSTN user should not receive a degradation with respect 
the PSTN/ISDN supplementary service provided in the PSTN.

I think this isn't in contradiction with the "variation" passage.

Christian: OK, now I understand. But I am still a little concerned about the requirement. For example in case of CCBS. When the called PSTN subscriber get free, the CCBS call will be presented to the called subscriber with priority, to avoid other terminating calls to come first. How do you want to achieve this with SIP? Without this feature, this is a kind of service degradation for CCBS. Perhaps, you should modify to "without significant degradation".

> There should also be a general requirement included:
> GEN-3: "SIP UA not providing this simulation service should not be influenced, they are simple not able to provide the related service."

I agree with the idea, but I don't think it is a requirement, but a 
property or expectation of the system. But I can add some clarification 
text indicating that we don't expect SIP UAs that do not implement the 
services to provide the service to the user.

Christian: It is a requirement for the selection of a proper solution. Do not select a solution which is not backwards compatible. And the statement
should avoid discussions, that with introduction of this services, all SIP UAs would have to be changed.

Best Regards
Christian Schmidt

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 24 Aug 2005 14:50:26 +0300

more inlince comments, just restricted to the point of discussion.

> "small variations are expected in some services (for example CCBS, because of different busy definitions) are expected.....".

Ok, we can add the clarification in the introduction.
> Christian: OK, now I understand. But I am still a little concerned about the requirement. For example in case of CCBS. When the called PSTN subscriber get free, the CCBS call will be presented to t…

I think the requirement is "without any degradation", as far as I 
understand. Whether that is achievable or not, that is another story, 
but the requirement is clear. We can discuss the implementation of CCBS 
when we reach that point, perhaps it is not the right time to do it now.

> should avoid discussions, that with introduction of this services, all SIP UAs would have to be changed.

OK, I guess the requirement makes no harm, so I will add it. I am not 
quite convinced that we need it, but no problem, I will add it.

BR,

     Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland