Subject: RE: [Sipping-tispan] [CCBS/CCNR]

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 1 Sep 2005 14:00:05 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Miguel Garcia
> Sent: Thursday, September 01, 2005 5:19 AM
> To: [email-masked]
> Subject: [Sipping-tispan] [CCBS/CCNR]
> 
> Hi:
> 
> with respect the added CCBS/CCNR requirements, I think 
> something is still missing.
> 
> - A bit more elaboration on the queue management, precisely, 
> what are the implications for the service (I think there is 
> the concept of a "timeslot" in which a user can return a 
> call, and if it doesn't happen, the user misses his turn in 
> the queue ... or somethign like that.

How about:

The submission of a CCBS/CCNR queue request must include a time limit.

The CCBS/CCNR queue service may adjust the request time limits based on
local policy.

> - A definition of a "CCBS/CCNR request", which at the moment, 
> misleads me in the interpretation of the service. It can mean 
> two different
> things: "Please add me to the CCBS/CCNR queue of the callee", 
> or "this is a session returned as a result of an indication 
> from CCBS/CCNR".

and:

The CCBS/CCNR callee must have the means to inform a queued caller that
the callee is free along with the means for the caller to originate the
subsequent session setup such that it can be distinguished by the callee
from other possible session setups.

Mike

> - Perhaps and explanation that the queue manager must be able 
> to distinguish between "call in return to CCBS/CCNR free 
> indication" from regular calls. This is related to the 
> "timeslot" concept as well.
> 
> Anyone with further information of the requirements, please comment.
> 
> /Miguel
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> sip:[email-masked]
> Nokia Research Center      Helsinki, Finland
> 
> 
> _______________________________________________
> Sipping-tispan mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sipping-tispan
> 

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 02 Sep 2005 14:54:52 +0300

Hi Michel:

Inline comments.

> The submission of a CCBS/CCNR queue request must include a time limit.

Probably this isn't a must, but a may, but otherwise I agree. That 
wasn't my question either, but the principle is ok.

> The CCBS/CCNR queue service may adjust the request time limits based on

Sure as well.

> from other possible session setups.

Yes, also agreed.

/Miguel