Subject: RE: [Sipping-tispan] Re: CCBS/CCNR in Version -02f

From: "GARCIN Sebastien RD-CORE-ISS" <[email-masked]>
Date: Thu, 29 Sep 2005 19:35:22 +0200

Paul,

The process you describe 1,2,3, and 4 sounds nice. The trouble is that 1&2 is something that TISPAN has been working upon for some time now for a number of legacy services some of them not even mentionned in the requirements draft.  

Would it not be possible for IETF to reference to TISPAN documentation as far as 1&2 are concerned and focuse on 3&4 ? Of course the TISPAN people are there to answer any questions which can help when working upon 3&4.

sebastien

-----Message d'origine-----
De : Paul Kyzivat [mailto:[email-masked]] 
Envoyé : jeudi 29 septembre 2005 18:44
À : GARCIN Sebastien RD-CORE-ISS
Cc : Tom-PT Taylor; Tessa Silvia; [email-masked]
Objet : Re: [Sipping-tispan] Re: CCBS/CCNR in Version -02f

GARCIN Sebastien RD-CORE-ISS wrote:
> Paul,
> 
> As far as I know there has been yet no firm decision from TISPAN on this particular point. 
> 
> On this mailing list our efforts should focuse on getting the necessary SIP extension understood and agreed, the competent body for taking service decisions is clearly not IETF.

I have agreed with you on this.

> The problem we are discussing here requires no protocol extension and hence should not be inserted in the draft.   

But I don't know how you can say no protocol extension is required without knowing what decision will be taken to this point.

In general, I don't see how we can agree whether protocol extensions are required or not without understanding the definition of the service.

In fact, I think one must consider the possible implementations to the service definition before one can decide that an extension is or is not needed. (One solution may require an extension, while another solution does not.)

I am not happy with the way this exercise is going. It seems to be trying to avoid stating the details of the service requirements, or the proposed solution, while stating requirements for extensions needed for some unstated solution.

I think what we need is:

1. a thorough statement of the how the feature is expected to
    appear to users. (Not PSTN users, but users of sip devices that have
    the emulated services.)

2. an outline of a proposed implementation (or alternative
    implementations)

3. a list of the requirements for currently nonexistent sip features
    that prevent 2 from being implemented.

4. specifications for new extensions that satisfy 2&3.

I believe the very first submission came close to providing 2&4, but lacked 1&3. I had thought the intent was to provide 1, and then to move on to 2,3&4. But instead it seems like now the goal is to just do 3&4, without 1&2.

I just don't see how we can make an informed decision on that basis.

	Paul

> sébastien
> 
> -----Message d'origine-----
> De : Paul Kyzivat [mailto:[email-masked]] Envoyé : jeudi 29 
> septembre 2005 16:47 À : GARCIN Sebastien RD-CORE-ISS Cc : Tom-PT 
> Taylor; Tessa Silvia; [email-masked] Objet : Re: 
> [Sipping-tispan] Re: CCBS/CCNR in Version -02f
> 
> 
> 
> GARCIN Sebastien RD-CORE-ISS wrote:
> 
>>Thanks for clarifying the question which is of interest but out of scope of the mailing list. 
>>
>>I invite John and anybody else interested to participate to TISPAN meetings were those questions are debated.
> 
> 
> I agree that debating which way TISPAN *wants* this to work is out of scope here.
> 
> But it seems there is still confusion about which choice TISPAN *has
> made* about this. That needs to be cleared up here.
> 
> I'm now pretty sure that TISPAN wants all the caller's UAs to alert 
> when it is time for the CCBS/CCNR request to be completed, but I think 
> my understanding of this is via discussion rather than what is in the 
> document. (I just checked the -02g document and I can find nothing 
> that states which choice is intended.)
> 
> So I believe the document needs to be updated to reflect this in the description of the service, and via explicit requirements.
> 
> 	Paul
> 
> 
>>sebastien
>> 
>>
>>-----Message d'origine-----
>>De : Tom-PT Taylor [mailto:[email-masked]] Envoyé : jeudi 29 
>>septembre 2005 15:46 À : GARCIN Sebastien RD-CORE-ISS Cc : Elwell, 
>>John; Miguel Garcia; Michael Hammer (mhammer); Tessa Silvia; 
>>[email-masked] Objet : Re: [Sipping-tispan] Re: CCBS/CCNR in 
>>Version -02f
>>
>>Paul has already given his response to the substance of John's question, but I thought I would try to make it clearer to you.  Suppose the caller has multiple devices, say a cell phone and a fixed line, as possible contacts, all through the same address of record.  John is asking whether the call returned by CCBS must come back to the cell phone if that is where the original call came from, or whether any of the devices associated with that address of record could receive the return call.
>>
>>GARCIN Sebastien RD-CORE-ISS wrote:
>>
>>
>>>John,
>>>
>>>I am not sure I understand your question. I assume you are asking about how the O-AS gets the calling party issue the CCBS/CCNR recall or ...?
>>>
>>>If this is the case, we are studying several possibilities (3rd party call, REFER...) in TISPAN but none of them have SIP extension requirements.
>>>
>>>Could you please be more specific as to what requirement you feel needs to be captured?
>>>
>>>sébastien
>>>
>>>
>>>
>>>-----Message d'origine-----
>>>De : Elwell, John [mailto:[email-masked]] Envoyé : jeudi 29 
>>>septembre 2005 14:22 À : GARCIN Sebastien RD-CORE-ISS; Miguel Garcia; 
>>>Michael Hammer (mhammer) Cc : Tessa Silvia; [email-masked] 
>>>Objet : RE: [Sipping-tispan] Re: CCBS/CCNR in Version -02f
>>>
>>>Sebastien,
>>>
>>>Irrespective of the need for a service provider on the caller side, what is the requirement concerning the call resulting from CCBS/CCNR - should it use the same caller UA as that which issued the CCBS/CCNR request, or should it use any UA registered as contact for the AoR concerned?
>>>
>>>John
>>>
>>>
>>>
>>>
>>>
>>>>-----Original Message-----
>>>>From: GARCIN Sebastien RD-CORE-ISS
>>>>[mailto:[email-masked]]
>>>>Sent: 29 September 2005 12:58
>>>>To: Elwell, John; Miguel Garcia; Michael Hammer (mhammer)
>>>>Cc: Tessa Silvia; [email-masked]
>>>>Subject: RE: [Sipping-tispan] Re: CCBS/CCNR in Version -02f
>>>>
>>>>John,
>>>>
>>>>Basically it enables "service interactions", "charging model", 
>>>>"control of subscriber rights to the service", "playing CCBS related 
>>>>announcement"...Having the service logic embedded in an Application 
>>>>Server serving the originating user makes all this possible.
>>>>
>>>>If you want a more detailed to understand the role of the service 
>>>>provider acting of behalf of the caller, I suggest you read the 
>>>>related section dealing with the originating exchange in ITU-T Q.733 
>>>>or contact your Siemens collegues that participate to TISPAN.
>>>>
>>>>Regards,
>>>>sébastien
>>>>
>>>>
>>>>
>>>>
>>>>-----Message d'origine-----
>>>>De : Elwell, John [mailto:[email-masked]] Envoyé : jeudi 29 
>>>>septembre 2005 13:11 À : GARCIN Sebastien RD-CORE-ISS; Miguel 
>>>>Garcia; Michael Hammer (mhammer) Cc : Tessa Silvia; 
>>>>[email-masked] Objet : RE: [Sipping-tispan] Re: CCBS/CCNR 
>>>>in Version -02f
>>>>
>>>>Sebastien,
>>>>
>>>>I was not trying to open up an old debate. I was simply continuing 
>>>>the recent debate about on whose behalf the service provider is 
>>>>acting, and whether there are two service providers or one. I can 
>>>>see a role for a service provider acting on behalf of the callee, 
>>>>since it needs to look out for different UAs registered for the AoR 
>>>>concerned that might be in a position to satisfy the CCBS/CCNR 
>>>>request. I am not sure I understand what a service provider acting 
>>>>on behalf of the caller would do. It would be good to get an answer 
>>>>to my question about whether a CCBS/CCNR request results in a call 
>>>>from the same UA as that
>>>
>>>>from which the request was made or any UA registered as contact for
>>>
>>>
>>>>the caller's AoR.
>>>>
>>>>John
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>>-----Original Message-----
>>>>>From: GARCIN Sebastien RD-CORE-ISS
>>>>>[mailto:[email-masked]]
>>>>>Sent: 29 September 2005 09:11
>>>>>To: Elwell, John; Miguel Garcia; Michael Hammer (mhammer)
>>>>>Cc: Tessa Silvia; [email-masked]
>>>>>Subject: RE: [Sipping-tispan] Re: CCBS/CCNR in Version -02f
>>>>>
>>>>>John,
>>>>>
>>>>>You seems to want try and open the endless debate about where the 
>>>>>intelligence should be placed in the network or in the
>>>>
>>>>terminals. The
>>>>
>>>>
>>>>
>>>>>approach you are proposing is not something that TISPAN
>>>>
>>>>will accept so
>>>>
>>>>
>>>>
>>>>>I suggest that we move out of this debate.
>>>>>
>>>>>sébastien
>>>>>
>>>>>
>>>>>-----Message d'origine-----
>>>>>De : [email-masked] 
>>>>>[mailto:[email-masked]] De la part de Elwell, John 
>>>>>Envoyé : jeudi 29 septembre 2005 08:20 À : Miguel Garcia; Michael 
>>>>>Hammer (mhammer) Cc : Tessa Silvia; [email-masked] Objet :
>>>>>RE: [Sipping-tispan] Re: CCBS/CCNR in Version -02f
>>>>>
>>>>>Miguel,
>>>>>
>>>>>In-line,
>>>>>
>>>>>John
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>>-----Original Message-----
>>>>>>From: Miguel Garcia [mailto:[email-masked]]
>>>>>>Sent: 28 September 2005 10:31
>>>>>>To: Michael Hammer (mhammer)
>>>>>>Cc: Tessa Silvia; [email-masked]
>>>>>>Subject: Re: [Sipping-tispan] Re: CCBS/CCNR in Version -02f
>>>>>>
>>>>>>Hi Mike:
>>>>>>
>>>>>>Inline discussion.
>>>>>>
>>>>>>Michael Hammer (mhammer) wrote:
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>>Miguel,
>>>>>>>
>>>>>>>I think there is still a little bit of schizophrenia in the 
>>>>>>>requirements.  I assume that a server is acting on behalf
>>>>>>
>>>>>>of either the
>>>>>>
>>>>>>
>>>>>>
>>>>>>>caller or the callee, but not both because each could be
>>>>>
>>>>>served by a
>>>>>
>>>>>
>>>>>
>>>>>>>different host, domain, or organization.  The first
>>>>>>
>>>>>>requirement seems to
>>>>>>
>>>>>>
>>>>>>
>>>>>>>assume that the CCBS is a terminating service of the
>>>>>
>>>>>callee.  Other
>>>>>
>>>>>
>>>>>
>>>>>>>requirements seem to assume that the CCBS is a service of
>>>>>>
>>>>>>the caller.
>>>>>>
>>>>>>
>>>>>>
>>>>>>>Which is it?
>>>>>>
>>>>>>Both. It has been demonstrated that CCBS is a service
>>>>
>>>>that requires
>>>>
>>>>
>>>>
>>>>>>cooperation of both the originating and terminatine service
>>>>>
>>>>>providers.
>>>>>
>>>>>
>>>>>
>>>>>>This cooperation is mostly required to manage queues of both the 
>>>>>>caller and callee, and to manage susped/resume states.
>>>>>
>>>>>[JRE] It is not clear to me what the involvement of the originating 
>>>>>service provider is. Perhaps this comes down to what
>>>>
>>>>exactly are the
>>>>
>>>>
>>>>
>>>>>requirements for notifying the caller that a call may now
>>>>
>>>>succeed. Is
>>>>
>>>>
>>>>
>>>>>this notification constrained to go to the same UA that requested 
>>>>>CCBS/CCNR in the first place, or should it go to any UA currently 
>>>>>registered as a contact for the caller's AoR? In my opinion
>>>>
>>>>the former
>>>>
>>>>
>>>>
>>>>>is sufficient and indeed probably preferable. If I request
>>>>
>>>>CCBS/CCNR
>>>>
>>>>>from a particular UA I would expect to receive the notification on
>>>>
>>>>
>>>>>that same UA and make the new call attempt from there. In the 
>>>>>relatively infrequent event that I move to a different UA in the 
>>>>>intervening period, I could simply request CCBS/CCNR again from the 
>>>>>new UA.
>>>>>
>>>>>So on the assumption that CCBS/CCNR involves only a single
>>>>
>>>>UA on the
>>>>
>>>>
>>>>
>>>>>caller side, what service does the originating service provider 
>>>>>perform? Why can't the UA directly request CCBS/CCNR and
>>>>
>>>>communicate
>>>>
>>>>
>>>>
>>>>>with the service provider on the callee side to achieve this? The 
>>>>>caller's UA will receive notification when a the call can
>>>>
>>>>be made and
>>>>
>>>>
>>>>
>>>>>can present that information to the caller somehow, allowing the 
>>>>>caller to choose when to proceed with that call, e.g., whether to 
>>>>>interrupt any ongoing communications in order to make that call.
>>>>>
>>>>>
>>>>>_______________________________________________
>>>>>Sipping-tispan mailing list
>>>>>[email-masked]
>>>>>https://www1.ietf.org/mailman/listinfo/sipping-tispan
>>>>>
>>>>
>>>_______________________________________________
>>>Sipping-tispan mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/sipping-tispan
>>>
>>>
>>
>>
>>
>>_______________________________________________
>>Sipping-tispan mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/sipping-tispan
>>
> 
> 

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Sep 2005 14:05:44 -0400

> Would it not be possible for IETF to reference to TISPAN documentation as far as 1&2 are concerned and focuse on 3&4 ? Of course the TISPAN people are there to answer any questions which can help w…

If you want IETF participation here it would be good to make it easy.

I looked up the references for this feature. I got what appear to be 
ISDN specifications. They in no way consider how the feature is impacted 
by the environment of a SIP environment. So IMO they don't don't come 
close to addressing 1&2.

I have no doubt that you have discussed 1&2 in some forum, but I don't 
see how I would discover the results of that. Am I not properly 
following the references?

	Paul