Subject: RE: AW: [Sipping-tispan] draft-jesske-sipping-tispan-requirements-02c

From: "Hans Erik van Elburg (RY/ETM)" <[email-masked]>
Date: Thu, 1 Sep 2005 11:54:57 +0200

Hi,

I quite liked the previous proposal from Miguel, I'm not sure about why we have yet another counter proposal here.

Is your reasoning Christian that if "The originating network shall be able to indicate to the terminating network, that the caller has requested anonymity." that an omission of this indication indicates that the network is the source of the restriction and not the caller and hence that ACR can forward this communication to the caller?

I don't know I think I prefer the explicit requirement that Miguel formulated.

Then we get:
> REQ-ACR-1: The originating network shall be able to indicate to the
>            terminating network, that the caller has requested anonymity.
> 
> REQ-ACR-2: The ACR simulation service requires the caller to be
>            informed that the communication was rejected because the
>            SIP request was anonymous and the callee had the ACR
>            service activated."
REQ-ACR-3: "The originating terminating network shall be able to indicate to the 
terminating network that the caller of an anonymous communication is 
authorized to bypass the ACR service at the callee's network."

/Hans Erik
sip:[email-masked]

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Miguel Garcia
Sent: Thursday, September 01, 2005 11:01 AM
To: Schmidt, Christian
Cc: [email-masked]; Alexeitsev, D
Subject: Re: AW: [Sipping-tispan]
draft-jesske-sipping-tispan-requirements-02c

This is ok, but can we remove the "override" feature?

/Miguel

Schmidt, Christian wrote:

> Hi,
> 
> if the override request is skipped, we can simplify the ACR requirements to
>  
> "This service allows a callee to instruct the network to automatically reject
> incoming communications when the caller has requested anonymity.  The ACR
> supplementary service is described in ETSI EN 300 798 [13].
> 
> ACR is a regulatory service.
> 
> REQ-ACR-1: The originating network shall be able to indicate to the
>            terminating network, that the caller has requested anonymity.
> 
> REQ-ACR-2: The ACR simulation service requires the caller to be
>            informed that the communication was rejected because the
>            SIP request was anonymous and the callee had the ACR
>            service activated."
> 
> What do you think about?
> Christian
> 
> 
> 
> 
> 
> 
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Miguel Garcia
> Gesendet: Donnerstag, 1. September 2005 09:50
> An: [email-masked]
> Cc: Alexeitsev, D
> Betreff: [Sipping-tispan] draft-jesske-sipping-tispan-requirements-02c
> 
> 
> Hi:
> 
> I have put a new working copy of the requirements draft.
> 
> http://people.nokia.net/~miguel/drafts/pre/draft-jesske-sipping-tispan-requirements-02c.txt
> http://people.nokia.net/~miguel/drafts/pre/draft-jesske-sipping-tispan-requirements-02c.html
> 
> Changes with respect the previous version.
> 
> - ACR: added a second requirement (REQ-ACR-2) that was discussed here in 
> the list, but I kept the old REQ-ACR-2 that now becomes -3.
> 
> - I have added CCBS/CCNR, combined into a single set of requirements.
> 
> I will start a separate thread , per topic, on both requirements, I 
> think we need more changes. Please comment on these or any other service 
> as you wish.
> 
> /Miguel
> 

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 01 Sep 2005 12:58:30 +0300

Hann Erik:

According to the discussion, the override requirement is related to the 
category of the calling party, and affects not only ACR, but also other 
services. Therefore, it has been decided to separate ACR from the 
override. The override feature will be required when we go into the 
REQ-CAT- requirements.

/Miguel

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Sep 2005 09:27:09 -0400

> override. The override feature will be required when we go into the 

Hmm. That seems questionable to me. It means that there will be an 
important requirement on ACR that is specified independently of the main 
body of specification of ACR requirements.

I would think it clearer if there is a requirement for calling party 
category as a general mechanism, and then, if ACR is expected to behave 
differently in the presence of calling party category, that should be 
called out as an ACR requirement.

I think it is merely a matter getting the references done correctly. 
Perhaps this particular requirement can't be finalized until the REQ-CAT 
is finalized.

	Paul

>> I quite liked the previous proposal from Miguel, I'm not sure about 
>> why we have yet another counter proposal here.
>>
>> Is your reasoning Christian that if "The originating network shall be 
>> able to indicate to the terminating network, that the caller has 
>> requested anonymity." that an omission of this indication indicates 
>> that the network is the source of the restriction and not the caller 
>> and hence that ACR can forward this communication to the caller?
>>
>> REQ-ACR-3: "The originating terminating network shall be able to 
>> indicate to the terminating network that the caller of an anonymous 
>> communication is authorized to bypass the ACR service at the callee's 
>> network."
>>
>>
>> /Hans Erik
>>> Von: [email-masked] 
>>> [mailto:[email-masked]] Im Auftrag von Miguel Garcia
>>> - ACR: added a second requirement (REQ-ACR-2) that was discussed here 
>>> in the list, but I kept the old REQ-ACR-2 that now becomes -3.
>>>
>>> think we need more changes. Please comment on these or any other 
>>> service as you wish.
>>>
>>> /Miguel
>>>
>>
>>
>

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 01 Sep 2005 17:04:10 +0300

Hi Paul:

Yeap, you are right. I am leaning to think that some dependency from ACR 
to CAT might be missing, but we will sort this out when we are with CAT.

For the time being, and in the seek of progress, I will prefer to just 
model the ACR base requirements. We will come back to the override 
feature when we have CAT completely done.

/Miguel

Paul Kyzivat wrote:

> 
> 
> Miguel Garcia wrote:
> 
>> Hann Erik:
>>
>> According to the discussion, the override requirement is related to 
>> the category of the calling party, and affects not only ACR, but also 
>> other services. Therefore, it has been decided to separate ACR from 
>> the override. The override feature will be required when we go into 
>> the REQ-CAT- requirements.
> 
> 
>>>> - ACR: added a second requirement (REQ-ACR-2) that was discussed 
>>>> here in the list, but I kept the old REQ-ACR-2 that now becomes -3.
>>>>