Subject: AW: [Sipping-tispan] [CCBS/CCNR]

From: "Schmidt, Christian" <[email-masked]>
Date: Thu, 1 Sep 2005 13:46:20 +0200

Some additional questions / comments:
- Are CCBS / CCNR related to a terminal or an AOR of caller/callee?
- A more precise definition of state change is needed (e.g. using BYE or INVITE for a call, avoiding busy/idle expression)
- What is the meaning of "the callee showed activity"? Could this be WWW search as well?
- A message toward the caller about state change of the callee is missing
- Are multiple request possible for CCNR as with CCBS?
- Is it possible for a caller to have simultaneous CCBS and CCNR requests?
- If a CCBS / CCNR request is cancelled from the network, should the caller be informed?
- The same expression as in the other requirements should be used, meaning caller and callee instead of UAC and UAS. Or UAC and UAS have to be explained in this context.
Regards,
Christian

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Miguel Garcia
Gesendet: Donnerstag, 1. September 2005 11:19
An: [email-masked]
Betreff: [Sipping-tispan] [CCBS/CCNR]

Hi:

with respect the added CCBS/CCNR requirements, I think something is 
still missing.

- A bit more elaboration on the queue management, precisely, what are 
the implications for the service (I think there is the concept of a 
"timeslot" in which a user can return a call, and if it doesn't happen, 
the user misses his turn in the queue ... or somethign like that.
- A definition of a "CCBS/CCNR request", which at the moment, misleads 
me in the interpretation of the service. It can mean two different 
things: "Please add me to the CCBS/CCNR queue of the callee", or "this 
is a session returned as a result of an indication from CCBS/CCNR".
- Perhaps and explanation that the queue manager must be able to 
distinguish between "call in return to CCBS/CCNR free indication" from 
regular calls. This is related to the "timeslot" concept as well.

Anyone with further information of the requirements, please comment.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 05 Sep 2005 14:30:07 +0300

Some (inline) thoughts.

> - Are CCBS / CCNR related to a terminal or an AOR of caller/callee?

I guess they are related to an AOR, not to a terminal.

> - A more precise definition of state change is needed (e.g. using BYE or INVITE for a call, avoiding busy/idle expression)

Seems reasonable to me

> - What is the meaning of "the callee showed activity"? Could this be WWW search as well?

I guess so, if the terminal implements HTTP... I think you have in mind 
a computer, so if the user returns and the computer registers activity 
on the keyboard, then the user is no longer idle, and an indication 
could be sent... this looks like presence

> - A message toward the caller about state change of the callee is missing

Ok

> - Are multiple request possible for CCNR as with CCBS?

I guess so, providing they are addressed to different users.

> - Is it possible for a caller to have simultaneous CCBS and CCNR requests?

Why not?

> - If a CCBS / CCNR request is cancelled from the network, should the caller be informed?

yes, definitely. I am not sure if the network can cancel such request, 
but the user should be informed.

> - The same expression as in the other requirements should be used, meaning caller and callee instead of UAC and UAS. Or UAC and UAS have to be explained in this context.

Good point.

Thanks

      MIguel