Subject: Re:Re: [Sipping-tispan] Requirements -02g

From: zhouqing 45678 <[email-masked]>
Date: Sun, 02 Oct 2005 13:39:59 +0800

Hi, Miguel,

As I understood, REQ-CDIV-1 is the basic of REQ-CDIV-3 and REQ-CDIV-4,
if the callee and the network intermediaries do not know the communication is deverted,
the reason for the redirection and the identity of the caller is not useful for them.

In previous example, the voice mail server is also required to know the communication is deverted,
Only when the call is deverted, the voice mail server can provide the personalized services 
according to the redirection reason and the caller identity.

Best Regards,
Justin

----- 原邮件 -----
从: Miguel Garcia <[email-masked]>
日期: 星期五, 九月 30日, 2005 下午4:04
主题: Re: [Sipping-tispan] Requirements -02g

> Hi Justin:
> 
> Thanks for your comments, inline discussion.
> 
> ZhouQing(Justin) wrote:
> > Hi Migule,
> > 
> > In case CDIV, I think it's better to change REQ-CDIV-1 as 

> followed to make it consistent with REQ-CDIV-3 and REQ-CDIV-4,
> > From:
> > It must be possible that the caller is informed that a 
> communication is being diverted. 
> > To: 
> > It must be possible for the caller, the callee, and network 
> intermediaries to be informed that a communication is being 
> diverted. 
> > How do you think?
> > 
> 
> I think we don't have such requirements. REQ-CDIV-3 and -4 
> indicate that 
> thue network intermediaries (e.g., the voice mail server where my 
> calls 
> are diverted) need to u. I think requirements are ok if you want to 
> provide personalized services, like a different welcome message in 
> the 
> voice mail server, depending on the reason why the call ended up 
> in the 
> voice mail server. For example, the callee is busy will have a 
> different 
> welcome message than when a telemarketer is my black list.
> 
> But, in case of REQ-CDIV-1, I wonder whether we have a requirement 
> to 
> inform the callee that the call is being diverted. And I don't see 
> either for network intermediaries.
> 
> > A short tiping error in REQ-CDIV-4, callee instead of caleee.
> 
> Fixed.
> 
> Regards,
> 
>       Miguel
> > 
> > Regards,
> > Justin
> > 
> > ----- Original Message ----- 
> > From: "Miguel Garcia" <[email-masked]>
> > To: <[email-masked]>
> > Cc: "Alexeitsev, D" <[email-masked]>
> > Sent: Wednesday, September 28, 2005 7:25 PM
> > Subject: [Sipping-tispan] Requirements -02g
> > 
> > 
> > 
> >>Hi:
> >>
> >>I have this working copy of the requirements, version -02g:
> >>
> >>http://people.nokia.net/~miguel/drafts/pre/draft-jesske-sipping-
> tispan-requirements-02g.txt
> >>http://people.nokia.net/~miguel/drafts/pre/draft-jesske-sipping-
> tispan-requirements-02g.html
> >>
> >>And a diff version with respect -02f:
> >>
> >>http://people.nokia.net/~miguel/drafts/pre/draft-jesske-sipping-
> tispan-requirements-02f-to-g.html
> >>
> >>The changes in this version are:
> >>- Grouping of the CCBS/CCNR requirements for better understing
> >>- A few clarifications to the CDIV requirements
> >>- Addition of the Calling Party Category requirements.
> >>
> >>Now, I have a few questions.
> >>
> >>- The Calling Party Category requirements do not constitute a 
> service by 
> >>  itself. In my opinion, they should be General requirements 
> listed a 
> >>REQ-GEN-4 and REQ-GEN-5. Does anyone oppose to move them to the 
> General 
> >>section?
> >>
> >>- We had a pending action point to revisit the ACR requirements 
> once we 
> >>have drafted the Calling Party Category requirements. Now we 
> have 
> >>achieved this state, and my opinion is that we don't need to add 
> any 
> >>extra wording to ACR, since the Calling Party Category 
> requirements 
> >>cover the use case we have been discussing (police anonymously 
> call a 
> >>user with ACR activated).
> >>
> >>Last, but not least, WE ARE ALMOST DONE with the requirements. 
> So please 
> >>take a look at this draft and comment on any pending issue. I 
> would like 
> >>to solve issues as soon as possible and submit the draft for 
> publication.>>
> >>Regards,
> >>
> >>         Miguel
> >>
> >>-- 
> >>Miguel A. Garcia           tel:+358-50-4804586
> >>sip:[email-masked]
> >>Nokia Research Center      Helsinki, Finland
> >>
> >>
> >>_______________________________________________
> >>Sipping-tispan mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/sipping-tispan
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> sip:[email-masked]
> Nokia Research Center      Helsinki, Finland
> 
> 

_______________________________________________
Sipping-tispan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-tispan

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 03 Oct 2005 15:18:18 +0300

Hi Justin:

So... I think I don't yet agree with you.

To me REQ-CDIV-1 is about realtime information that "something is
happening right here right now". And this information has to be
communicated to the caller only.

REQ-CDIV-3 and -4 are about "something has happened, and this is what
happened".

So far, I don't see and I haven't seen in the ISDN specs any requirement
for the any other than the caller to be aware that "something is going
on right here right now", other than for the caller, but we seem to have
requirement for the network intermediaries to be aware that "something
went on" (-3 and -4).

Do we have other opinions?

/Miguel

---

From: "ZhouQing(Justin)" <[email-masked]>
Date: Sat, 08 Oct 2005 11:57:32 +0800

Hi Miguel,

I have a holiday last week and sorry for the delay.

Thanks for your detail, it is clear and reasonable, it makes me 
agree with you that the callee and the network intermediaries
may not have the requirements obviously to be aware that "something 
is going on right here right now". 

As we seem, it has requirement for the network intermediaries to be 
aware that "something went on" (-3 and -4), so I think that the network 
intermediaries have the requirements to be aware that the communication 
was diverted or not, so that the network intermediaries(eg. voice mail 
server) can provide personalized services according to the communication
diverted information.

Do you think we have the requirements for the callee and the network
intermediaries to be aware that the communication was diverted? 
Thank you. 

Justin

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 10 Oct 2005 16:26:42 +0300

Hi Justin:

Inline.

> intermediaries to be aware that the communication was diverted? 

Yes, we discussed this in the past, and some use cases were explained...
 like a voicemail type of intermediary... So I think we have the
requirements.

/Miguel

---

From: "ZhouQing(Justin)" <[email-masked]>
Date: Tue, 11 Oct 2005 10:06:11 +0800

Hi Miguel,

Thanks for your clarification.

As our discussion in the past, there is a requirement as followed:
It must be possible for the callee and network intermediaries to be informed
that the communication was diverted.

It is a new requirement and is not included in the last draft, so we need to add it.

I suggest to add a requirement REQ-CDIV-XX as followed::
It must be possible for the callee, and network intermediaries to be informed that the communication was diverted. 

It is similar with REQ-CDIV-1, can we combine these 2 requirements? or include it in the exist requirements, eg. REQ-CDIV-3? 
You have more experiences, so I think maybe you have a better way to add it.

Regards,
Justin

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 11 Oct 2005 10:08:35 +0300

Hi Justin:

I guess the easiest way is to add a new requirement between REQ-CDIV-1 
and REQ-CDIV-2 that reads what you proposed below:

It must be possible for the callee, and network intermediaries to be 
informed that the communication was diverted.

I will add it to my working copy.

/Miguel

---

From: "ZhouQing(Justin)" <[email-masked]>
Date: Tue, 11 Oct 2005 20:38:09 +0800

Hi Miguel,

It is ok and thanks for your great efforts.

Regards,
Justin