Subject: RE: [Sipping] How to Get Outbound Services from A Non-Local Proxy ?

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 14:05:55 -0400

> -----Original Message-----
> From: Michael Hammer [mailto:[email-masked]]
> Sent: Wednesday, August 22, 2001 1:59 PM
> To: Neil Deason
> Cc: Jonathan Rosenberg; 'Dean Willis'; Drage, Keith (Keith); Henning
> Schulzrinne; Sipping (E-mail)
> Subject: RE: [Sipping] How to Get Outbound Services from A Non-Local
> Proxy ?
> 
> 
> Neil,
> 
> Wasn't the indication concerning pop on sending or pop on 
> reception that 
> Dave Oran proposed essentially the "looseness" indicator you 
> say can't be done?
> 
> I would think the goal of a single routing mechanisms would be 
> desirable. 

I agree. 

The main issue is handling backwards compatibility. The proposed loose
routing mechanism is different in that the top element is popped off when
its you, but the next element is not placed in the request URI. The result
is that the original request URI remains unchanged until you get to the end
of the loose source list, which is a good thing. However, there is just no
way this is going to work in backwards compatible manner. All it takes is
one proxy that pops the top Route, puts it into the R-URI, and its game
over.

I will note that the properties of the loose routing discussed during the
meeting are met as well by the proposed user=url approach to encapsulating
the actual destination in the user part of the r-uri. The encoding is far,
far uglier, I will admit, but it has the advantage of requiring only the
proxies that are the targets of the loose "hops" to understand the
extension. Using a parameter in Route requires all the proxies to understand
it. 

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Neil Deason" <[email-masked]>
Date: Thu, 23 Aug 2001 10:55:13 +0100

> From: Jonathan Rosenberg [mailto:[email-masked]]
>

Yes, but I am wondering if we really must have this pop on
sending or pop on receiving behavior to solve the problem
of routing for outbound services.

> routing mechanism is different in that the top element is
> popped off when its you, but the next element is not placed in the
request
> URI. The result is that the original request URI remains unchanged
until you
> get to the end of the loose source list, which is a good thing.
However,
> there is just no way this is going to work in backwards compatible
manner. All
> it takes is one proxy that pops the top Route, puts it into the R-URI,
> and its game over.

How I had imagined this param was that it would be
nothing more than a hint as to whether it is OK to
ignore the route entry.

Taking a step back. We arrived here through a discussion
of how Dean could get his outbound services. The first
part of the problem was there needed to be a mechanism
to learn where to send initial INVITEs. Taking that as
solved for now, there then needed to be a way to get this
destination into the signalling path. Pre-loaded routes are
an obvious way, but there is a problem. If his UA has a
pre-loaded route pointing to his home services platform,
and it is observed strictly, then the request may never
get to the FW controlling Proxies etc needed to exit a
visited network successfully. So can we accept that a Route
be treated 'loosely' in the spec? By this I mean that
you can ignore it provided you don't touch it.

Then the UA could ignore the pre-loaded route and send
to the local outbound proxy on the visited network. This
local outbound proxy can also ignore the route and send
onto the FW controlling proxy that polices access to the
network. This Proxy is then the first one to load the route
into the Req-URI and use it. Of course this relies on
entities knowing through local config policy what is the
right thing to do rather than being explicit. However, as
I read it this is not even an option according to the
present bis Routing text which states that Route headers
are equivalent to strict source routing in IP.

> I will note that the properties of the loose routing
> discussed during the meeting are met as well by the proposed user=url
approach to
> encapsulating the actual destination in the user part of the r-uri.
The
> encoding is far, far uglier, I will admit, but it has the advantage of
> requiring only the proxies that are the targets of the loose "hops" to
understand the
> extension. Using a parameter in Route requires all the
> proxies to understand it.

Hmmmm if you had this in the Req-URI and a pre-loaded Route
how would they interact?

Cheers,
Neil.
--
Ubiquity Software Corporation, UK        http://www.ubiquity.net

---

From: "Dean Willis" <[email-masked]>
Date: Sat, 25 Aug 2001 15:52:57 -0500

You may recall we also discussed having a seperate Loose-Route header that
would store loose routes.

The alternative proposal was that if Route is present, it is followed to
exhaustion. Of course, the Loose-Route header would simply be ignored  by
proxies that don't support it. One could use a Proxy-Require in the unlikely
scenario that one "absolutely must have" loose routing in every proxy.

This seems to fix the when-do-we-change-the-Request-URI problem and the
"what happens if one of the proxies doesn't get it" problem.

Of course, it doesn't allow interleaving of loose and hard routes.

SIP 3.0, anybody?

--
Dean

----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>
To: "'Michael Hammer'" <[email-masked]>; "Neil Deason"
<[email-masked]>
Cc: "Jonathan Rosenberg" <[email-masked]>; "'Dean Willis'"
<[email-masked]>; "Drage, Keith (Keith)" <[email-masked]>;
"Henning Schulzrinne" <[email-masked]>; "Sipping (E-mail)"
<[email-masked]>
Sent: Wednesday, August 22, 2001 1:05 PM
Subject: RE: [Sipping] How to Get Outbound Services from A Non-Local Proxy ?

---

From: Kim Liu <[email-masked]>
Date: Mon, 27 Aug 2001 07:59:24 -0400

Dean Willis wrote:
[snipped]
> SIP 3.0, anybody?

Please!

Kim Liu
Senior Software Engineer
Lucent Technologies
Clearwater, FL