Subject: [Sipping] User and phone-context param placement in URI?

From: Doug Hurtig <[email-masked]>
Date: Thu, 02 Aug 2001 10:36:11 -0500

Hi,

 I have a question regarding the use of the "user=phone"
 and "phone-context=n" URL parameters. 

 Looking at the URLs for Telephone Calls draft it
 shows that the phone-context parameter is part of the
 tel URL. If as according to the ISUP to SIP Mapping
 draft the tel URL represents either the entire URI or
 the user portion of a SIP URI the phone-context parameter
 would appear before the host portion (if present) in the
 SIP URI.

 To: sip:1234567;phone-context=[email-masked]

 Do it matter if phone-context appears before or after the host portion?

> 
>                                                                                                         Sipping -- SIPPING Working Group (applications of SIP)
> 
> 
> 
>  About Sipping
> 
>  This is the official IETF Mailing List for the SIPPING Working Group. This WG is engaged in the application of SIP (RFC2543).
> 
>  To see the collection of prior postings to the list, visit the Sipping Archives.
> 
>  Using Sipping
> 
>  To post a message to all the list members, send email to [email-masked].
> 
>  You can subscribe to the list, or change your existing subscription, in the sections below.
> 
>  Subscribing to Sipping
> 
>  Subscribe to Sipping by filling out the following form. You will be sent email requesting confirmation, to prevent others from gratuitously subscribing you. This is a hidden list, which means that the members list is available only to the list administrator.
> 
>        Your email address:                                                                                                                                      €»¨
>        You must enter a privacy password. This provides only mild security, but should prevent others from messing with your subscription. Do not use valuable passwords! Once a month,
>        your password will be emailed to you as a reminder.
>        Pick a password:                                                                                                                                         etf.
>        Reenter password to confirm:                                                                                                                             isti
>        Would you like to receive list mail batched in a daily digest?                                     No  Yes
> 
>  Sipping Subscribers
> 
>  The subscribers list is only available to the list administrator.
> 
>  Enter your admin address and password to visit the subscribers list:
> 
>                                                                                                                      Admin address:  Password:
> 
>  To change your subscription (set options like digest and delivery modes, get a reminder of your password, or unsubscribe from Sipping), enter your subscription email address:
> 
> 
> 
>   --------------------------------------------------------------------------------
> Sipping list run by [email-masked], [email-masked], [email-masked]
> 
> [Delivered by Mailman] v 1.0

 I have seen the user=phone header in examples before the host
 portion and after the host portion. Is the user=phone parameter
 a TEL URL parameter or is it a url parameter as shown in 
 2543?

 To: sip:+1234567890;user=[email-masked] 

		or

 To: sip:[email-masked];user=phone

-- 
Regards,
Doug Hurtig

Tekelec
2425 N. Central Expressway
Richardson, Texas 75080

[email-masked]
972.301.1203

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: James Undery <[email-masked]>
Date: Thu, 02 Aug 2001 17:21:08 +0100

>  Do it matter if phone-context appears before or after the host portion?

A quick note a TEL URI and a SIP URI in telephone-subscriber form aren't isomorpic.
sip:[email-masked];user=phone could be considered to be the same as sip:[email-masked];user=phone if you are treating them as phone numbers, however, these are different SIP URIs and may be routed very differently :-).

Also including url-parameters in the user portion of a SIP URI is illegal.

Sorry if I am answering a question you didn't ask.

James

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 02 Aug 2001 20:15:39 +0300

Hello,

> Also including url-parameters in the user portion of a SIP URI is illegal.

There is another thread discussing the inclusion of URLs as the user
part of a SIP URL. This is effectively what user=phone means. However,
it indicates that the URL contained in the user part of the SIP URL is a
TEL URL. Therefore, the parameters before the host part of the SIP URL
belong to the TEL URL.

We do not write sip:tel:[email-masked];user=phone because user=phone
already indicates that the user part is a TEL URL. Therefore, we can
omit the "tel:"

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: Doug Hurtig <[email-masked]>
Date: Thu, 02 Aug 2001 12:00:27 -0500

James,

 I am still not sure of your last
 comment. I maintain based on the URLs for Telephone Calls that
 the phone-context is part of the telephone subscriber portion of
 the uri. 

 The 2454bis states that if the userinfo portion of the SIP URL contains
 a telephone subscriber that the telephone-subscriber portion of the
 sip URI is formatted as described in 2806.  The 2806 document describes
 only the telephone-subscriber portion of the SIP URL. It clearly shows
 that the phone-context is part of the telephone-subscriber. The phone-context
 is the area-specifier in the global or local phone number ant not
 a SIP URL uri-parameter.

 The host parameter is not part of the telephone subscriber field
 and thus comes after the telephone subscriber.

 This is also implied when looking  at the ISUP to SIP Mapping
 draft.

 Do you have documentation that states otherwise?

 Thanks for your help!

Doug

James Undery wrote:
> sip:[email-masked];user=phone could be considered to be the same
> as sip:[email-masked];user=phone if you are treating them as
> phone numbers, however, these are different SIP URIs and may be routed very
> differently :-).
> 

-- 
Regards,
Doug Hurtig

Tekelec

[email-masked]
972.301.1203

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 02 Aug 2001 22:45:49 +0300

Hello Doug,

Since the phone-context is a tel URL parameter (see RFC2806bis):
http://search.ietf.org/internet-drafts/draft-antti-rfc2806bis-00.txt

The correct format is:

Regards,

Gonzalo

---

From: James Undery <[email-masked]>
Date: Fri, 03 Aug 2001 09:13:28 +0100

> already indicates that the user part is a TEL URL. Therefore, we can

And this URL is also just plain wrong, it says the user is tel and her password is 1224.

James

---

From: James Undery <[email-masked]>
Date: Fri, 03 Aug 2001 12:36:26 +0100

>  the phone-context is part of the telephone subscriber portion of

I'd forgotten the user-unreserved, although "In general a character is reserved if
the semantics of the URI changes if the character is replaced with its escaped
US-ASCII encoding" and ";" definitely muddies the water.

>  is the area-specifier in the global or local phone number ant not

This is just my interpretation so feel free to tell me I am a fool, I get the
feeling that this is just for the inclusion of a phone number in sip URIs, if you
want tel URI parameters use a tel URI. Using sip URIs allows more potential for
trouble if you want tel URI functionality.

>  This is also implied when looking  at the ISUP to SIP Mapping

Again I read this as recommending tel URIs, or using just the number part in a sip
URI.

James

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 06 Aug 2001 18:39:49 +0300

Hello,

> And this URL is also just plain wrong, it says the user is tel and her password is 1224.

The point that I was making was exactly that. The URL of the example was
wrong.

Regards,

Gonzalo