Subject: RE: [Sipping] How to Get Outbound Services from A Non-Local Proxy ?

From: [email-masked]
Date: Thu, 9 Aug 2001 02:24:49 +0300

Hi Gonzalo,

> -----Original Message-----
> From: ext Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 09 August, 2001 1:17
> To: [email-masked]
> Cc: 'Henning Schulzrinne'; [email-masked]; Sipping (E-mail)
> Subject: Re: [Sipping] How to Get Outbound Services from A Non-Local
> Proxy?
> 
> 
> Hello,
> 
> The problem with this thread is that we have mixed two things:
> 
> 1) How to perform source routing
> 2) How to get services from a non-local proxy
> 
> Since 2 can be acomplish using 1, we have been discussing 1 all the
> time. However, it would be good if in the 3GPP architecture 2 could be
> acomplished without using 1.
> 
> In the 3GPP architecture the proxy providing services is the 
> S-CSCF and
> the UA only knows about his outbound proxy (P-CSCF).
> 
> A way to resolve their problem without using source routing 
> would be to
> make an extra querry to the HSS (a location server), for instance.
> 

What you say is true. However, what is also true is that in 3GPP the
solution that you mention has been turned down already (several times). In
my understanding at least one reason was that loading of HSS with extra
queries was not wanted. So I believe the issue in _3GPP_ is closed (for
Release 5). 

> I do not know which of all these issues we want to discuss 
> tomorrow, but
> if, as Henning suggested, some 3GPP people could attend it would be a
> very useful discussion.
>

Right.
 
> Best regards,
> Gonzalo

Markus

> [email-masked] wrote:
> > 
> > Path: is a pre-loaded Route:.
> > This works *for the 3GPP architecture* but it is
> > ugly. It is the same problem with the exception
> > that the UA is not involved. The Path: header
> > (pre-loaded Route:) is handled entirely by the
> > proxies (local and non-local outbound proxies).
> > The UA only knows about the local outbound proxy
> > in the 3GPP architecture because the non-local
> > outbound proxy is effectively hidden from the
> > end user.
> > 
> > cheers,
> > Sean Olson
> > Ericsson Inc.
> > 
> > >-----Original Message-----
> > >From: Henning Schulzrinne [mailto:[email-masked]]
> > >Sent: Monday, August 06, 2001 7:07 PM
> > >To: [email-masked]
> > >Cc: Sipping (E-mail)
> > >Subject: Re: [Sipping] How to Get Outbound Services from A 
> Non-Local
> > >Proxy?
> > >
> > >
> > >Rumor has it that 3GPP is planning to 'enhance' SIP by a 
> header called
> > >Path. It might be helpful if the 3GPP experts could 
> indicate whether
> > >this is the same problem.
> > >
> > >Eric Burger wrote:
> > >>
> > >> I guess the bang reminded me why I didn't want to hack the
> > >Request-URI in
> > >> the first place.
> > >>
> > >> I will readily concede that
> > >sip:[email-masked]
> > >> will work if myproxy.com understands to parse the RHS and
> > >continue routing,
> > >> and that
> > >sip:[email-masked];user=url will always
> > >> work.
> > >>
> > >> However...
> > >>
> > >> We seem to really be mixing the meaning of a Request-URI.  I
> > >think that's
> > >> why we're getting such push-back and counter-suggestions
> > >like preloading
> > >> Route (won't work), maddr (works sometimes), etc.
> > >>
> > >
> > >_______________________________________________
> > >Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> > >This list is for NEW development of the application of SIP
> > >Use [email-masked] for questions on current sip
> > >Use [email-masked] for new developments of core SIP
> > >
> > 
> > _______________________________________________
> > Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> 
> -- 
> Gonzalo Camarillo                    Phone :   +1 212 939 71 71
> Columbia University                  Mobile:  +358 40 702 35 35
> 472 Computer Science Building        Fax   :  +358  9 299 30 52
> 1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
> New York, NY 10027                   
> USA                              [email-masked]
> 
> _______________________________________________
> Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 09 Aug 2001 12:54:37 +0300

Hello Markus,

> queries was not wanted. So I believe the issue in _3GPP_ is closed (for

Well, this might not be entirely correct. 3GPP has to define a new
extension, namely "path" in order to be able to skip that extra querry
to the HSS. If the extension is not aproved by the IETF (and so far it
has not), I am not sure how 3GPP would proceed on this.

Therefore, I would like to see a presentation of the "path" solution
somewhere. The IETF will decide if it is a well engineered solution or
if, on the other hand, an alternative solution is preferrable.

I personally do not like the "path" solution, but this is just my
personal opinion.

Regards,

Gonzalo