Subject: RE: [Sipping] Call transfer implementation on a SIP-IP phone

From: Pascal Doré <[email-masked]>
Date: Tue, 7 Aug 2001 09:59:26 -0400

Hi Jonathan,

Why the transferor (POTS interface) will have to mix the media coming from
party A and C ?  

Party A was put on hold before the POTS interface make its second call to
party C.  Even if the party C answers the call very quickly as you
mentionned, no mixing is need because party A is on hold.

Maybe I missed something ?

Pascal Doré, B. Eng.
Program Manager
R&D Program Management Group
_________________________________
Mediatrix Telecom, inc.
Empowering the Edge of the Network 
À la frontière des nouvelles technologies

4229 Garlock street           www.mediatrix.com
Sherbrooke, Quebec J1L 2C8    mailto:[email-masked]
Canada                        tel: +1-819-829-2161 ext:258
                              fax: +1-819-829-5100

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Friday, August 03, 2001 16:52
To: [email-masked]'; Gonzalo Camarillo
Cc: [email-masked]
Subject: RE: [Sipping] Call transfer implementation on a SIP-IP phone

The transfer target will respond with a 200 OK to the request pretty quickly
though, and if this happens before the onhook, you will need to mix the
media.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: VIDHI RASTOGI [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 7:33 AM
> To: Gonzalo Camarillo
> Cc: [email-masked]
> Subject: RE: [Sipping] Call transfer implementation on a SIP-IP phone
> 
> 
> Hi Gonzalo,
> Thanks for the reply..
> 
> I just modified the blind transfer call-flow a bit.. so that no mixing
> capabilities are required at the transferor phone. Please see 
> the following
> call-flow:
> 
> 
>  	A 		SIP-IP phone (POTS interface) 	C
>     (Transferee)		(Transferor)		    
> (transfer target)
>       |                       |
> 	|     active call       |
> 	|XXXXXXXXXXXXXXXXXXXXXXX|
> 	|                       |flash
> 	|INV (c=0)/200OK/ACK    |
> 	|<----------------------|
> 	|				|digits
> 	|	                  |                         |
> 	|	                  |        INV              |
>                               |------------------------>|
> 	|                       |onhook                   |
>       |                       |        CANCEL/200 OK    |
>       |                       |------------------------>|
>       |      REFER(Refer-To:C)|                         |
> 	|<----------------------|
> 
> 
> PLease give your comments?
> 

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "VIDHI RASTOGI" <[email-masked]>
Date: Wed, 8 Aug 2001 09:17:58 +0530

Hi,
Another query on the same lines... Instead of mixing the media at
transferor, for the blind transfer case, can the transferor send an
INV(hold) to C as soon as the 200OK arrives and send a REFER to A.

Do you think there would be a lot of delay before party C receive the RTP?

regards
Vidhi

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Pascal Doré
> Sent: Tuesday, August 07, 2001 7:29 PM
> To: 'Jonathan Rosenberg'
> Cc: [email-masked]; [email-masked]'; Gonzalo Camarillo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 08 Aug 2001 15:52:31 +0300

Hello,

The delay should be very short, so, if you don't want to mix media,
don't do it. The only thing is that party C will pick up a phone that is
on hold... I do not know if party C is expecting that. If party C was
me, I would hang up after having said a couple of times: "Hello, anybody
there?".

Therefore, you have a race condition: who is faster, the call transfer
or party C hanging up?

Regards,

Gonzalo

VIDHI RASTOGI wrote:
>   ------------------------------------------------------------------------
>                            Name: Wipro_Disclaimer.txt
>    Wipro_Disclaimer.txt    Type: Plain Text (text/plain)
>                        Encoding: 7bit

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: Varadarajan S <[email-masked]>
Date: Sat, 11 Aug 2001 12:20:20 +0531

Hi,

A  clarrification on the same lines.

This call flow looks to be working in the same way as that of a FLASH HOOK
concept of PSTN. Is mixing involved here?Please give your comments on the same.

Explanation:

When Transferor hangs, it will send both BYE and CANCEL.
If transfer target has sent 200OK, CANCEL has no effect but BYE will clear the
call ( The case of Consultation transfer).
If transfer target is still ringing, BYE has no effect but CANCEL will clear the
call.

By this way, it looks that similar to POTS interface, Call transfer can be
iniated.

     (Transferee)            (Transferor)                   (transfer target)
|                       |        CANCEL/200 OK
                                  and BYE/200 OK          |

Regards,
Varadarajan