Subject: RE: [Sipping] How to Get Outbound Services from A Non-Local Proxy ?

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 01:56:25 -0400

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 12:24 PM
> To: Drage, Keith (Keith)
> Cc: Henning Schulzrinne; Sipping (E-mail)
> Subject: Re: [Sipping] How to Get Outbound Services from A Non-Local
> Proxy ?
> 
> 
> Going forward, I suggest we do two things:
> 
> 1) Create a submission to SIPPING explicitly defining the 
> requirements 
> for a general solution to the outbound-services problem.
> 
> 2) Work with SIP to define appropriate mechnaisms. We left the 
> ad-hocwith a todo assigned to Jonathan -- verifying whether the Route 
> syntac in RFC2543 provides for a way to do a "loose route" 
> modifier on a 
> Route element.

Not in rfc2543 proper. I was afraid of that. One of the bigger "oops" in
rfc2543 was the omission of extension params in a few key headers, including
Route. This was fixed right away, so that its possible in bis, but not in
rfc2543. I suspect most people have implemented this aspect of bis, at
least, and ignore unknown params in pretty much all headers.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Neil Deason" <[email-masked]>
Date: Wed, 22 Aug 2001 11:48:09 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> Jonathan Rosenberg
>

FWIW if there are not already any takers I will volunteer
for this.

> least, and ignore unknown params in pretty much all headers.

There is no way to add a modifier indicating looseness
to the Route element but I am not convinced this is a show
stopper. Provided we can accept the premise that you may
treat Route entries loosely provided you don't touch them.
UAs that do not support DNS already set a precedence for
'disobeying' Routes.

Cheers,
Neil.
--
Ubiquity Software Corporation, UK        http://www.ubiquity.net

---

From: Michael Hammer <[email-masked]>
Date: Wed, 22 Aug 2001 13:58:35 -0400

Neil,

Wasn't the indication concerning pop on sending or pop on reception that 
Dave Oran proposed essentially the "looseness" indicator you say can't be done?

I would think the goal of a single routing mechanisms would be 
desirable.  Another way of looking at it is whether a node on the path can 
insert someone else into the path so long as the objective is to get to the 
next node on the list.  So long as the proxy has an indication of "strict" 
or "loose" it can know whether it can improvise along the way or 
not.  Isn't the main point to have the message touch the mandatory bases.

Mike

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 22 Aug 2001 16:33:35 -0500

What do we need to do to define looserouting in the route header? New draft
in SIP, I suppose. I'm considering tackling the requirements draft for
sipping myself.

I'm NOT going to the Helsinki CN1 next week (cost, memberhsip issues, too
much other work) so I might be able to tackle some of this to compensate for
my feelings of guilt and inadequacy for not showing up.

--
Dean

----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>