Subject: AW: [Sipping] Immediate NOTIFIES change in sip-events-01

From: Brazier Lachlan <[email-masked]>
Date: Fri, 9 Nov 2001 13:20:59 +0100

Hello,
comments inline.
> >
> > >
> > > In the diminutive case where the first NOTIFY contains 
> actual Event
> > > information, the use of a separate ACK just increases the
> > > number of messages
> > > required. Also regardless of whether proxy should or should
> > > not treat ACK as
> > > a separate transaction, I'll bet this will cause many
> > > problems existing
> > > proxies.
> > >
> > I would say, NOTIFY's from several clients to the subscriber
> > including the
> > responses is a higher network load as one forked ACK.
> 
> The idea of adding an ACK is so broken I can't even believe it's being
> discussed. ACK isn't even a real request it is used to quench the
> retranmission of 200 responses to INVITEs. (INVITEs which are 
> handled in a
> totally different manner to all other requests.) Using ACKs 
> for SUBSCRIBE
> would require giving SUBSCRIBE all INVITE's behaviour this is 
> not backwardly
> compatible and would require the bis being changed to include 
> SUBSCRIBE or
> break handling of unknown requests.
>

Sorry for being unclear; I did'nt say to use the ACK like with the INVITE.
Because of the SUBSCRIBE request, only one 2xx response will be carried
upstream. The the ACK will be forked from the proxy to every endpoint (=
presentity). This way every endpoint will know wheter it's response was
received or not (because only the right tag in the To header will match).
I thought this was what we wanted.
General I don't see why the ACK request should be "untouchable". 

> > > I think the immediate NOTIFY mechanism seems to work well 
> within the
> > > existing SUB/NOT framework for all our reliability
> > > requirements (with the
> > > addition on a Subscription-Status header).
> >
> > My problem was not the mechanism itself, but the handling of several
> > NOTIFY's at the SUBSCRIBER.
> 
> Your problem is probably the fact that my presence may be 
> described by an
> amalgamation of several PAs i.e. my mobile, my office phone 
> and a PA on
> whatever computer I am currently logged onto. If you limit 
> yourself to the
> presence of my mobile your concerns will go away, however, 
> you're cut off a
> whole world of potentially useful functionality. Obviously it 
> also applies
> to things other than presence i.e. subscribing to the state 
> of a production
> line could be used to return multiple readings from various 
> sites along the
> line, rather than subscribing to each sensor individual.
> 

I agree that I would loose this solution. I always thought the presentity
draft was intended for the user, and not for the end points of the user (who
or what ever is behind the user's URL).

Cu 
Lachlan

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "James Undery" <[email-masked]>
Date: Fri, 9 Nov 2001 13:28:53 -0000

> General I don't see why the ACK request should be "untouchable".

The problem is unreliable transport and specfically retransmission in this
case. You'd have to alter ACK behaviour to cope with non-INVITE requests,
this is ugly.

James

---

From: "Bob Penfield" <[email-masked]>
Date: Fri, 9 Nov 2001 08:51:14 -0500

I'm in total agreement with James on using ACK with SUBSCRIBE. It is a
really bad idea. There would be no way for a proxy to tell the difference
between an ACK for a SUBSCRIBE and for an INVITE. Especially since you are
proposing that it have different behavior than an INVITE/200/ACK. I think it
will just create a big mess.

(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Brazier Lachlan" <[email-masked]>
To: "'James Undery'" <[email-masked]>; "Brazier Lachlan"
<[email-masked]>; "'Fairlie-Cuninghame, Robert'"
<[email-masked]>; "'Bob Penfield'" <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>
Sent: Friday, November 09, 2001 7:20 AM
Subject: AW: [Sipping] Immediate NOTIFIES change in sip-events-01