Subject: [Sipping] SIP URL's with telephony numbers

From: "Michael O'Doherty" <[email-masked]>
Date: Mon, 12 Nov 2001 17:24:49 -0000

Hi,

A question about the use of SIP URL's with the username in the form of a tel
URL:

If we want the SIP address to be treated as a SIP address rather than as a
telephone number (e.g. we might want to reach the SIP address associated
with a particular PSTN number) two approaches come to mind that clearly
avoid any confusion with a SIP URL which is intended to be routed to the
PSTN:

 (a)    SIP:[email-masked];user=SIP

 (b)    SIP:[email-masked];

The first option (a) is effectively saying "even though the left part of the
SIP URL looks like a telephone number I want it to be treated as a SIP
address".  While it can be argued that this is the default anyway, it makes
it explicit if we can use the user field like this.

The second option achieves the same thing but arguably not as cleanly.

Any opinions on which is the better approach ?

Cheers,

Mick O'Doherty
Nortel Networks

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 20 Nov 2001 17:04:31 -0600

SIP URL's with telephony numbershttp://www.softarmor.com/sipping/drafts/draft-ietf-sipping-e164-00.txt seems to clearly state the that determination of whether the left-hand-part of a SIP URI will be treated as a name or as a number is a policy decision made by the node identified by the right-hand-part of the URL.

In other words, the called-party policy overrides the calling-party preference.

So, I'd say neither suggested approach makes sense to me . . .

--
Dean

  ----- Original Message ----- 
  From: Michael O'Doherty 
  To: [email-masked]' 
  Sent: Monday, November 12, 2001 11:24 AM
  Subject: [Sipping] SIP URL's with telephony numbers

  Hi, 

  A question about the use of SIP URL's with the username in the form of a tel URL: 

  If we want the SIP address to be treated as a SIP address rather than as a telephone number (e.g. we might want to reach the SIP address associated with a particular PSTN number) two approaches come to mind that clearly avoid any confusion with a SIP URL which is intended to be routed to the PSTN:

  The first option (a) is effectively saying "even though the left part of the SIP URL looks like a telephone number I want it to be treated as a SIP address".  While it can be argued that this is the default anyway, it makes it explicit if we can use the user field like this.

  Cheers, 

  Mick O'Doherty 
  Nortel Networks

---

From: Ben Campbell <[email-masked]>
Date: Wed, 21 Nov 2001 15:49:11 -0600

Michael O'Doherty wrote:

> If we want the SIP address to be treated as a SIP address rather than as 
> a telephone number (e.g. we might want to reach the SIP address 
> associated with a particular PSTN number) two approaches come to mind 
> that clearly avoid any confusion with a SIP URL which is intended to be 
> routed to the PSTN:
> 
> The first option (a) is effectively saying "even though the left part of 
> the SIP URL looks like a telephone number I want it to be treated as a 
> SIP address".  While it can be argued that this is the default anyway, 
> it makes it explicit if we can use the user field like this.
> 
Neither. In your example, the interpretation of the number is entirely owned by telco.co.uk. 

In the first case, at best your are giving it a hint that you would 
prefer an VoIP endpoint, but how the domain handles the hint is up to 
it. In the second, you are specifying a completely different resource. 
If telco.co.uk just happens to have a resouce 
SIPClientassicatedwith+441628434234, it will use it. Of course, it could 
be using a location service that has that address registered back to 
PSTN number, so even then the control lies on the receiving side.

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP