Subject: [Sipping] Server Load Balancer Integration?

From: Steve Gardell <[email-masked]>
Date: Mon, 5 Nov 2001 08:39:53 -0500

Is there any experience or analysis of the integration of a 
"Server Load Balancer" such as the Cisco CSS or the Alteon
Websystems box with SIP? These devices typically front 
Web-server farms to provide load balancing and redundancy
but they are also used to support other protocols such as FTP
and POP3. Obviously, this is more straight-forward with 
SIP entities such as a stateless proxy...

Steven Gardell
Principal Engineer, Iperia Inc. 
781-993-3544

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Agboh, Charles" <[email-masked]>
Date: Mon, 26 Nov 2001 18:32:38 +0100

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Monday, November 26, 2001 5:50 PM
> To: [email-masked]
> Subject: RE: [Sipping] Server Load Balancer Integration?
> 
> 
> 
> Random assignment with weighting according to capacity sounds fine in
> theory but it is very difficult to explain to the field how 
> to correctly
> deploy this. The issue is knowing capacity. It's not like all 
> the proxy
> vendors are publishing SipStone numbers for tons of hardware
> configurations so it makes it hard for a technician to get the correct
> weighting. Not to motion what happens when some computer gets 
> upgraded and
> so on. Automatic discovery of capacity is very desirable to reduce

Can this be achieved with a the NOTIFY/SUSCRIBE presence methods? 
> provisioning difficulties and once we start down this path we 
> end up with
> these weird protocols that estimate load based on response 
> time and so on.

> Cullen

Charles
> -----Original Message-----
> From: [email-masked] 
[mailto:[email-masked]]On Behalf Of
Henning G. Schulzrinne
Sent: Tuesday, November 06, 2001 9:45 AM
To: Jonathan Rosenberg
Cc: Steve Gardell; [email-masked]'
Subject: Re: [Sipping] Server Load Balancer Integration?

Jonathan Rosenberg wrote:

Just some additional points, not disagreements.

>
> 1. SRV doesn't allow for more intelligent load balancing, based on
available
> capacity or other dynamic metrics of the next hop elements,

As long as the work-per-request is small, tracking load is probably
wasted effort. Random assignment, with weighting according to capacity,
will be close enough.