Subject: RE: [Sipping] QSIG Vs DPNSS MIME

From: "Mark Watson" <[email-masked]>
Date: Thu, 13 Feb 2003 09:25:42 -0000

Q.SIG and DPNSS are private NNI protocols, certainly not UNIs. They can both
be used for connection of private networks to virtual private network
services offered by the public network, but in these cases the public
network 'emulates' a private network exchange, so although there is a
physical connection between private and public networks, it is still
logically a private NNI.

...Mark

> -----Original Message-----
> From: Ranjith Mukundan [mailto:[email-masked]]
> Sent: 13 February 2003 04:52
> To: Adam Roach; Peterson, Jon; Jonathan Rosenberg
> Cc: [email-masked]; Watson, Mark [MOP:EP10:EXCH]
> Subject: RE: [Sipping] QSIG Vs DPNSS MIME
> 
> 
> PRI, DASS2 etc are all 'true' UNI protocols - but not QSIG 
> and DPNSS. I
> would qualifiy DPNSS & QSIG as UUI (user-to-user) protocols 
> as they are used
> between PBXs (PINX in QSIG terminology) in a private network 
> (PISN in QSIG
> terminology). I mean, you could view QSIG and DPNSS as an
> ISUP-protocol-equivalent for private networks. QSIG and ISDN are
> peer-to-peer/end-to-end protocols unlike PRI (and DASS2) - 
> making it both
> SIP-like (atleast to the same extent as ISUP) from the *protocol
> architecture* point of view.
> 
> From the protocol message semantic point of view, DPNSS 
> matches SIP messages
> to a larger extent than QSIG - esp wrt the session 
> setup/progress/tear-down
> messages (as opposed to the link/circuit maintenance 
> messages) used for the
> basic call *and* supplementary services like call transfer, three way
> conference etc. As an example that I cited in an earlier 
> mail, mid call QSIG
> messages like INFO, NOTIFY & FAC would *all* get carried in SIP INFO
> method - where as, in case of DPNSS, the only mid call 
> message, and which
> has a direct parlance to SIP INFO is EEM (end to end message; 
> equivalent to
> ISUP PAM and to some extent ISUP APM). For this reason, I'd 
> think, DPNSS
> message semantics matches SIP atleast to the same extent as 
> it does for
> ISUP.
> 
> cheers,
> - ranjith..
> 
> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Thursday, February 13, 2003 1:19 AM
> To: 'Ranjith Mukundan'; Peterson, Jon; Jonathan Rosenberg
> Cc: [email-masked]; 'Mark Watson'
> Subject: RE: [Sipping] QSIG Vs DPNSS MIME
> 
> 
> > -----Original Message-----
> > From: Ranjith Mukundan [mailto:[email-masked]]
> >
> > In case of DPNSS too the message semantics matches SIP
> > messages - atleast to
> > the same extent as it does for ISUP.
> 
> I think you mean "at least to the same extent as it does
> for QSIG."
> 
> DPNSS, QSIG, and ISDN are all UNI protocols. ISUP is
> an NNI protocol. SIP is end-to-end, which really
> ends up acting more like an NNI protocol than a UNI
> protocol.
> 
> /a
> 
>

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Thu, 13 Feb 2003 15:35:17 +0530

RE: [Sipping] QSIG Vs DPNSS MIMEyes. this *private NNI* was what i was
refering to as "UUI".
  -----Original Message-----
  From: Watson, Mark [MOP:EP10:EXCH] [mailto:[email-masked]]
  Sent: Thursday, February 13, 2003 2:56 PM
  To: 'Ranjith Mukundan'; Adam Roach; Peterson, Jon; Jonathan Rosenberg
  Cc: [email-masked]
  Subject: RE: [Sipping] QSIG Vs DPNSS MIME

  Q.SIG and DPNSS are private NNI protocols, certainly not UNIs. They can
both be used for connection of private networks to virtual private network
services offered by the public network, but in these cases the public
network 'emulates' a private network exchange, so although there is a
physical connection between private and public networks, it is still
logically a private NNI.

  ...Mark