Subject: [Sipping] I-D ACTION:draft-ietf-sipping-req-history-02.txt

From: [email-masked]
Date: Wed, 12 Feb 2003 09:22:18 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.

	Title		: SIP Generic Request History Capability û Requirements
	Author(s)	: M. Barnes, M. Watson, C. Jennings, J. Peterson
	Filename	: draft-ietf-sipping-req-history-02.txt
	Pages		: 11
	Date		: 2003-2-11
	
Many services that SIP is anticipated to support require the ability 
to determine why and how the call arrived at a specific application.  
Examples of such services include (but are not limited to) sessions 
initiated to call centers via 'click to talk' SIP URLs on a web page, 
'call history/logging' style services within intelligent 'call 
management' software for SIP UAs and calls to voicemail servers and 
call centers.  While SIP implicitly provides the redirect/retarget 
capabilities that enable calls to be routed to chosen applications, 
there is currently no standard mechanism within SIP for communicating 
the history of such a request. This 'request history' information 
allows the receiving application to determine hints about how and why 
the call arrived at the application/user.     
This draft discusses the motivations in support of a mechanism for 
recording the 'request history', and proposes detailed requirements 
for such a generic 'request history' capability.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-req-history-02.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sipping-req-history-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sipping-req-history-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Mary Barnes" <[email-masked]>
Date: Wed, 12 Feb 2003 11:05:15 -0600

Hi all,

There's really only one minor change to this document:
- The last paragraph in section 5 was re-worded based on Mark suggestion per
the email discussion on the capturing of request history in outgoing
messages:
http://www.ietf.org/mail-archive/working-groups/sipping/current/msg03695.htm
l

John E. had suggested additional wording, but I think the one sentence
captures the essence of the requirement and the additional wording is more
appropriately addressed in the solution draft (which I think it now is per
the updated solution draft - per my next email). 

There was also some minor changes to correct "funny characters", but I can
see that there is still one in the title that I'll fix the next round.  But,
other than that, this document should be complete.

Regards,
Mary H. Barnes
[email-masked]
972-684-5432

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 12, 2003 8:22 AM
Cc: [email-masked]
Subject: [Sipping] I-D ACTION:draft-ietf-sipping-req-history-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Session Initiation Proposal Investigation
Working Group of the IETF.

	Title		: SIP Generic Request History Capability û
Requirements
	Author(s)	: M. Barnes, M. Watson, C. Jennings, J. Peterson
	Filename	: draft-ietf-sipping-req-history-02.txt
	Pages		: 11
	Date		: 2003-2-11

Send a message to:
	[email-masked].
In the body type:

-----
To: 
Subject: 
Date: Wed, 12 Feb 2003 09:25:18 -0600
X-Mailer: Internet Mail Service (5.5.2653.19)

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP