Subject: RE: [Sipping] Facing Up to Realities in SIP Deployments in Carrie r networks

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 28 Feb 2003 15:16:27 -0500

Richard

I don't think getting into speculation on what motivates carriers
to deploy SIP is germane.  What is germane is:
·	If SIP-related standardization efforts has been slowing deployment.
·	If there are significant difficulties in interworking different
vendors' products in laboratory trials of both SIP to SIP and SIP to legacy
network element interoperability.  
·	If Efforts to provide lawful intercept and emergency services will
be hampered by the nature of SIP-based networks. 
·	If potential users have difficulty comparing products because
everyone uses different scalability metrics
·	If NAT and firewall traversal is a major issue limiting the
deployment of SIP
·	If a standard framework for basic authentication and privacy of
SIP-based communication is required
·	If there are significant new security issues relating to:
-	Interception of signaling and media traffic
-	Introduction of malicious traffic through open interfaces to SIP
endpoints or other networks
-	The need to authenticate endpoints through insecure networks
-	Securing network and service management interfaces based on open
standards.

Note that the above list is largely text lifted from the document.

If I think through these issues, I think most of them are just flat out
true.
It may be that some service providers don't care about them, but I think
most will.  I think that it is well worth our while to sort through this
list and figure out if the problems can be solved, and how they should be
solved.  It may be that IETF is not the right place to solve all of them.

Brian

> -----Original Message-----
> From: Richard Shockey [mailto:[email-masked]]
> Sent: Friday, February 28, 2003 2:46 PM
> To: Rosen, Brian; [email-masked]'
> Subject: Re: [Sipping] Facing Up to Realities in SIP Deployments in
> Carrier networks
> 
> 
> At 01:45 PM 2/28/2003 -0500, Rosen, Brian wrote:
> >I urge you to read:
> >http://www.vasaforum.org/Docs/SIPRFIAnalysisFinal-Web1202.doc
> >
> >It contains a sobering assessment of where we are in SIP deployment
> >in carrier networks.  Of course, carrier networks are not the
> >only place SIP has a place, but this assessment still rings of
> >truth to me beyond this specific market, and spurs me to ask what
> >we in the IETF SIPish community can do to address the issues this
> >report cites.
> >
> >First, read it.  Then we can talk.
> >
> >Brian
> 
> 
> Brian ..why would anything in this report suprise you ..its 
> essentially 
> written by and for existing carriers who essentially look at VoIP as 
> cannibalistic to their existing revenue streams. Where SIP is 
> deploying in 
> competitive greenfield carrier environments such as 
> Yahoo/Japan, Vonage, 
> China etc its working very well and we all have heard of 
> extremely positive 
> user experiences from ordinary consumers.
> 
> I can almost agree with some the LEC's, to them there is no 
> justification 
> for SIP. Why should they engineer themselves out of monopoly 
> profits ( and 
> jobs ) to provide real and tangeable consumer benefits of 
> lower costs and 
> greater choice of services when the existing regulatory 
> environment does 
> not reward them for doing so..
> 
> I agree there are still major issues here ..DTMF,  E911 and other 
> government mandated services..
> 
> and If I hear any more whining about OoS from people who have 
> never made a 
> SIP phone call I'm just going to scream..
> 
> 
>  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Richard Shockey, Senior Manager, Strategic Technology Initiatives
> NeuStar Inc.
> 46000 Center Oak Plaza  -   Sterling, VA  20166
> Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 815.333.1237
> <mailto:[email-masked]> or <mailto:[email-masked]>
>   <http://www.neustar.biz> ; <http://www.enum.org>
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 28 Feb 2003 15:06:21 -0600

I am not sure this is the right place for this discussion and that the
points here are really true or even more, are they relevant?

Not to speak of

> > SIP phone call I'm just going to scream..

Get used to it: IP-IP phone calls over the public Internet are just
better than the PSTN and lab tests have shown the same for SIP based IP
conferencing.

With such concerns, we would not have a booming mobile phone industry
today, and as we know, concerns or not, mobile phones and the Internet
have already started to bite into the "carrier grade" networks where all
these concerns are presumably well taken care of. I will spare this list
of why/who is already using or is going to use SIP, and for very good
reasons :-)>

>It may be that IETF is not the right place to 
> solve all of them.

Right. 

Thanks, Henry

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Rosen, Brian
> Sent: Friday, February 28, 2003 2:16 PM
> To: 'Richard Shockey'; [email-masked]'
> Subject: RE: [Sipping] Facing Up to Realities in SIP 
> Deployments in Carrie r networks
> 
> 
> Richard
> 
> I don't think getting into speculation on what motivates 
> carriers to deploy SIP is germane.  What is germane is:
> .	If SIP-related standardization efforts has been slowing 
> deployment.
> .	If there are significant difficulties in interworking different
> vendors' products in laboratory trials of both SIP to SIP and 
> SIP to legacy network element interoperability.  
> .	If Efforts to provide lawful intercept and emergency 
> services will
> .	If potential users have difficulty comparing products because
> .	If NAT and firewall traversal is a major issue limiting the
> deployment of SIP
> .	If a standard framework for basic authentication and privacy of
> .	If there are significant new security issues relating to:
> If I think through these issues, I think most of them are 
> just flat out true. It may be that some service providers 
> don't care about them, but I think most will.  I think that 
> it is well worth our while to sort through this list and 
> figure out if the problems can be solved, and how they should 
> be solved.  It may be that IETF is not the right place to 
> solve all of them.
> 
> Brian
> 
> > >in carrier networks.  Of course, carrier networks are not the only 
> > >place SIP has a place, but this assessment still rings of 
> truth to me 
> > >beyond this specific market, and spurs me to ask what we 
> in the IETF 
> > >SIPish community can do to address the issues this report cites.
> > >
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>