Subject: RE: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Fri, 21 Feb 2003 17:16:04 +0200

Hi,

> I doubt any service providers will agree vendors are entitled to speak
> for them, wired or wireless.

I guess Jari was not speaking on behalf of wireless operators, rather He was
just reporting what has been standardized in 3GPP by both vendors and
operators i.e. AAA for IP multimedia services based on Diameter.

Consequently 3G wireless service providers will deploy Diameter.
I guess an IETF standard on SIP-AAA based on Diameter is needed to avoid
divergent solutions across multiple networks, which perhaps end up
in interoperability problems. 

Best Regards
Marco

> -----Original Message-----
> From: ext Henry Sinnreich [mailto:[email-masked]]
> Sent: 21 February, 2003 16:46
> To: [email-masked]; [email-masked]
> Cc: Loughney John (NRC/Helsinki); [email-masked]
> Subject: RE: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> >  > Any of the 3G operators count for this? I'm not sure how many
> >  > of the subscribe to this group though, even if their vendors
> >  > do...
> 
> I doubt any service providers will agree vendors are entitled to speak
> for them, wired or wireless. The service providers on this list have
> given solid arguments why we prefer RADIUS at present. As for 
> what comes
> beyond RADIUS, we have the OSP token I-D
> 
> http://www.ietf.org/internet-drafts/draft-johnston-sip-osp-tok
> en-04.txt
> 
>  and the IETF work at
> 
> http://www.aaaarch.org/charter.html
> 
> DIAMETER is just too little, too late IMHO, when looking at 
> the options
> in these links.
> 
> Question: Has anyone predetermined in SIPPING that DIAMETER good for
> service providers? Interesting...
> 
> Thanks, Henry
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of Jari Arkko
> > Sent: Friday, February 21, 2003 3:04 AM
> > To: [email-masked]
> > Cc: 'John Loughney'; [email-masked]
> > Subject: Re: [Sipping] New version of the SIP-AAA reqs draft
> > 
> > 
> > [email-masked] wrote:
> > > Jari Arkko writes:
> > > 
> > >  > Henry Sinnreich wrote:
> > >  > > Is there any service provider planning to use 
> SIP-DIAMETER? If 
> > > yes,  > > please speak up.  >
> > >  > Any of the 3G operators count for this? I'm not sure how many
> > >  > of the subscribe to this group though, even if their vendors
> > >  > do...
> > > 
> > > it depends.  will the vendors really give 3g operators a 
> > free choice 
> > > which diameter server they want to use in their 3g network?  which
> > 
> > I'm not quite sure what you mean by free choice in this 
> > context, but perhaps you are after standardized interfaces? 
> > These would be publicly available in the form of RFCs (eg 
> > DIAMETER base) and 3G specifications on how DIAMETER is used 
> > for multimedia application.
> > 
> > > diameter servers has nokia tested interoperability against? 
> >  does any 
> > > of
> > 
> > I don't know but there's been Diameter interoperability 
> > events. Perhaps you John could dig up the Nokia information 
> > from those if you participated? I know Ericsson particpated 
> at least.
> > 
> > > these servers come from non-3g vendors?  or is the use of 
> > diameter in 
> > > 3g networks similar fake as use of sip in 3g im?
> > 
> > The question was if anyone was going to deploy and I answered ;-)
> > 
> > I don't fully agree with the way 3G sets up their AAA. But we 
> > are discussing the creation of an IETF standard for SIP AAA. 
> > 3G folks had to create a multimedia AAA application because 
> > the IETF does not have one. My opinion is that we need an 
> > IETF standard in this space, so that the 3G folks, SIP vendor 
> > groups, or other parties don't all diverge on how to do this. 
> > IMHO, this is really crucial for SIP. My belief is also that 
> > the IETF standard will be better than any of these groups 
> > could do themselves. As far as 3G goes, my understanding was 
> > that they are happy to switch to an IETF standard when it 
> > becomes available.
> > 
> > Jari
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 21 Feb 2003 09:36:38 -0600

> Diameter is needed to avoid divergent solutions across 
> multiple networks, which perhaps end up in interoperability problems. 

Yes, DIAMETER will be divergent with the existing RADIUS base serving
100's of millions Internet users. 

That's why we should make

http://www.watersprings.org/pub/id/draft-schulzrinne-sipping-radius-acco
unting-00.txt

 and

http://www.watersprings.org/pub/id/draft-byerly-sip-radius-00.txt

 should be the first WG design items.

Henry

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, February 21, 2003 9:16 AM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; [email-masked]
> I guess Jari was not speaking on behalf of wireless 
> operators, rather He was just reporting what has been 
> standardized in 3GPP by both vendors and operators i.e. AAA 
> for IP multimedia services based on Diameter.
> 
> Consequently 3G wireless service providers will deploy 
> Diameter. I guess an IETF standard on SIP-AAA based on 
> Diameter is needed to avoid divergent solutions across 
> multiple networks, which perhaps end up in interoperability problems. 
> 
> Best Regards
> Marco
> 
> > >  > Any of the 3G operators count for this? I'm not sure 
> how many  > 
> > > of the subscribe to this group though, even if their vendors  > 
> > > do...
> > 
> > given solid arguments why we prefer RADIUS at present. As for what 
> > comes beyond RADIUS, we have the OSP token I-D
> > 
> > > > > of the subscribe to this group though, even if their 
> vendors  > 
> > > > do...
> > > > 
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listi> nfo/sipping
> > > This list 
> is for NEW development of the 
> application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
>

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 21 Feb 2003 20:33:33 +0200

> Consequently 3G wireless service providers will deploy Diameter.

that is	fine with me although i'm not sure what	the walled garden of
3gpp im has to do with this working group.

 > in interoperability problems.

other operators than 3g are already using radius for sip aaa and this
cannot be ignored by this working group.  we and many others are using
radius authentication according to the sterman draft are very happy with
it.

-- juha