Subject: RE: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Tue, 11 Feb 2003 16:58:21 +0200

Hi Henry,

> > We will now try to get the work on the diameter-based 
> solution going.
> 
> As has been mentioned here, 99.999% (five nines :-0>) of existing
> implementations and deployment are RADIUS. After RADIUS come the web
> services. 
> 
> I suggest therefore to start with RADIUS instead.

RADIUS is extremely limited in a number of cases - security, transport
issues, reliability and is most likely illegal in many jurisdictions
for use with token-based accounting (due to the non-reliable nature
of RADIUS).  

What I think you are more concerned for the solution to work with
RADIUS, correct?  It may be pre-mature to discuss solutions, but
one option is develop a solution using Diameter in RADIUS-compatibility
mode.  The alert reader then may be able to determine how to use RADIUS
in such circumstances.  However, it is unlikely that the IESG will
approve using RADIUS for SIP-AAA needs because of the well-documented
short comings of RADIUS.

br,
John
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 11 Feb 2003 12:38:07 -0600

>but one option is develop a solution using 
> Diameter in RADIUS-compatibility mode.

OK, this is better than nothing. We'll take what we can :-)

As mentioned, the installed base is RADIUS, no matter how voluminous the
DIAMETER literature may be.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of [email-masked]
> Sent: Tuesday, February 11, 2003 8:58 AM
> To: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> Hi Henry,
> 
> 
> RADIUS is extremely limited in a number of cases - security, 
> transport issues, reliability and is most likely illegal in 
> many jurisdictions for use with token-based accounting (due 
> to the non-reliable nature of RADIUS).  
> 
> What I think you are more concerned for the solution to work 
> with RADIUS, correct?  It may be pre-mature to discuss 
> solutions, but one option is develop a solution using 
> Diameter in RADIUS-compatibility mode.  The alert reader then 
> may be able to determine how to use RADIUS in such 
> circumstances.  However, it is unlikely that the IESG will 
> approve using RADIUS for SIP-AAA needs because of the 
> well-documented short comings of RADIUS.
> 
> br,
> John
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: [email-masked]
Date: Wed, 19 Feb 2003 07:47:47 +0200

> for use with token-based accounting (due to the non-reliable nature

how does that differ from sip itself?  one can always run radius over
ipsec.

-- juha