Subject: RE: [Sipping] New version of the SIP-AAA reqs draft

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 21 Feb 2003 17:48:16 -0000

If DIAMETER was a 3GPP protocol, then treating the work with the same status as P-headers would be a perfectly valid statement, but DIAMETER is an approved IETF protocol as draft standard currently sitting in the RFC editors queue and therefore is on the same IETF standards track as RADIUS. 

Further, DIAMETER was chosen by 3GPP because RADIUS does not meet the 3GPP requirements for that particular interface. Available implementations comes secondary to those requirements (after all 3GPP have specified RFC 3261 rather than RFC 2543 and there are not many deployed implementations of that either).

What you appear to be saying is that DIAMETER should not have been created in the first place (presumably with a view that RADIUS should have been enhanced to deal with its shortcomings). That is an issue you must take up with the IESG and the WG responsible, not try and blame 3GPP for it.

And finally to reiterate the point of my previous mail, 3GPP is asking IETF to provide DIAMETER support. In my view, that has zero impact on whether RADIUS is done as well. The input that work should not be done on RADIUS is coming from within the IETF, and is nothing to do with 3GPP.

Keith

P.S. I cannot quote T1 yet because the release 5 specifications have not yet been endorsed by the SDOs, of which T1 is one (that stage in the process will occur shortly). And the reason for quoting those groups was not to say that my group is better that yours, it was to make clear that the choice of DIAMETER is well known in 3GPP (and therefore by the nature of the 3G market by all operators deploying 3GPP) by publically available information from those groups.

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: 21 February 2003 16:51
> To: 'Drage, Keith (Keith)'
> Cc: [email-masked]
> Subject: RE: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> Keith, the confusion stems from the fact: Why if 3GPP has decided on
> DIAMETER, this should not be treated in the WG as all the other "p"
> labels for SIP used by 3GPP? No problem with what 3GPP folks 
> decide, but
> that should be labeled "p" (standing here for proprietary, 
> private and I
> bet, also for provisional, since I don't believe 3GPP 
> operetors will not
> eventually deploy some form of web services XML etc. for AAA).
> 
> As for quoting 3GPP SA2, CN4, SA and CN, we could equally 
> qoute T1, etc.
> The world is bigger than the 3GPP universe :-)
> 
> Henry
> 
> > -----Original Message-----
> > From: Drage, Keith (Keith) [mailto:[email-masked]] 
> > Sent: Friday, February 21, 2003 10:25 AM
> > To: 'Henry Sinnreich'
> > Cc: [email-masked]
> > Subject: RE: [Sipping] New version of the SIP-AAA reqs draft
> > 
> > 
> > Henry, you seem to have reached the point where you have 
> > totally confused two questions that ought to be taken independently.
> > 
> > 1)	Should IETF specify RADIUS for use with SIP. This is 
> > apparently what you want. It is not required by the operators 
> > or vendors represented in 3GPP, but nobody from 3GPP is 
> > telling you not to do it. 
> > 
> > 2)	Should IETF specify DIAMETER for use with SIP. That 
> > decision to use DIAMETER in association with SIP has been 
> > made in 3GPP in an open forum for all 3GPP interested vendors 
> > and operators, and that decision is well known throughout the 
> > industry. Those decisions are documented in meeting reports 
> > from 3GPP SA2, CN4, SA and CN, and specified in approved 3GPP 
> > specifications all of which are publically available. If you 
> > wish to change that decision, then by all means join 3GPP and 
> > make the appropriate proposal. To the best of my knowledge 
> > nobody has suggested that RADIUS is even suitable for use in 
> > the 3GPP environment here (despite RADIUS already appearing 
> > elsewhere in the 3GPP architecture), and IMS cannot be 
> > deployed without these capabilities. Further, while 3GPP 
> > release 5 uses proprietary extensions to DIAMETER to provide 
> > service codes (these are provided in an informational RFC), 
> > 3GPP has undertaken to replace these in release 6 with an 
> > IETF worked proposal. If IETF does n!
> > ot do that work (with appropriate 3GPP support), then 3GPP 
> > cannot meet that agreement.
> > 
> > Therefore from a 3GPP perspective the point is that for 
> > question 1, we have no position and for question 2, we need 
> > the work from IETF in order to complete agreements we have 
> > already made with IETF.
> > 
> > Keith
> > 
> > Keith Drage
> > Lucent Technologies
> > Tel: +44 1793 776249
> > Email: [email-masked] 
> > 
> > > -----Original Message-----
> > > From: Henry Sinnreich [mailto:[email-masked]]
> > > Sent: 21 February 2003 14:46
> > > To: [email-masked]; [email-masked]
> > > Cc: 'John Loughney'; [email-masked]
> > > Subject: RE: [Sipping] New version of the SIP-AAA reqs draft
> > > 
> > > 
> > > >  > Any of the 3G operators count for this? I'm not sure 
> > how many  > 
> > > > of the subscribe to this group though, even if their vendors  > 
> > > > do...
> > > 
> > > I doubt any service providers will agree vendors are 
> > entitled to speak 
> > > for them, wired or wireless. The service providers on this 
> > list have 
> > > given solid arguments why we prefer RADIUS at present. As 
> for what 
> > > comes beyond RADIUS, we have the OSP token I-D
> > > 
> > > http://www.ietf.org/internet-drafts/draft-johnston-sip-osp-tok
> > > en-04.txt
> > > 
> > >  and the IETF work at
> > > 
> > > http://www.aaaarch.org/charter.html
> > > 
> > > DIAMETER is just too little, too late IMHO, when looking at
> > > the options
> > > in these links.
> > > 
> > > Question: Has anyone predetermined in SIPPING that DIAMETER 
> > good for 
> > > service providers? Interesting...
> > > 
> > > Thanks, Henry
> > > 
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]
> > > > On Behalf Of Jari Arkko
> > > > Sent: Friday, February 21, 2003 3:04 AM
> > > > To: [email-masked]
> > > > Cc: 'John Loughney'; [email-masked]
> > > > Subject: Re: [Sipping] New version of the SIP-AAA reqs draft
> > > > 
> > > > 
> > > > [email-masked] wrote:
> > > > > Jari Arkko writes:
> > > > > 
> > > > >  > Henry Sinnreich wrote:
> > > > >  > > Is there any service provider planning to use
> > > SIP-DIAMETER? If
> > > > > yes,  > > please speak up.  >
> > > > >  > Any of the 3G operators count for this? I'm not sure 
> > how many  
> > > > > > of the subscribe to this group though, even if their 
> > vendors  > 
> > > > > do...
> > > > > 
> > > > > it depends.  will the vendors really give 3g operators a
> > > > free choice
> > > > > which diameter server they want to use in their 3g 
> > network?  which
> > > > 
> > > > I'm not quite sure what you mean by free choice in this
> > > > context, but perhaps you are after standardized interfaces? 
> > > > These would be publicly available in the form of RFCs (eg 
> > > > DIAMETER base) and 3G specifications on how DIAMETER is used 
> > > > for multimedia application.
> > > > 
> > > > > diameter servers has nokia tested interoperability against?
> > > >  does any
> > > > > of
> > > > 
> > > > I don't know but there's been Diameter interoperability
> > > > events. Perhaps you John could dig up the Nokia information 
> > > > from those if you participated? I know Ericsson particpated 
> > > at least.
> > > > 
> > > > > these servers come from non-3g vendors?  or is the use of
> > > > diameter in
> > > > > 3g networks similar fake as use of sip in 3g im?
> > > > 
> > > > The question was if anyone was going to deploy and I 
> answered ;-)
> > > > 
> > > > I don't fully agree with the way 3G sets up their AAA. But we
> > > > are discussing the creation of an IETF standard for SIP AAA. 
> > > > 3G folks had to create a multimedia AAA application because 
> > > > the IETF does not have one. My opinion is that we need an 
> > > > IETF standard in this space, so that the 3G folks, SIP vendor 
> > > > groups, or other parties don't all diverge on how to do this. 
> > > > IMHO, this is really crucial for SIP. My belief is also that 
> > > > the IETF standard will be better than any of these groups 
> > > > could do themselves. As far as 3G goes, my understanding was 
> > > > that they are happy to switch to an IETF standard when it 
> > > > becomes available.
> > > > 
> > > > Jari
> > > > 
> > > > _______________________________________________
> > > > Sipping mailing list  
> > https://www1.ietf.org/mailman/listi> nfo/sipping
> > > > This list 
> > is for NEW development of the 
> > application of SIP Use 
> > > > [email-masked] for questions on 
> current sip Use 
> > > > [email-masked] for new developments of core SIP
> > > > 
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 21 Feb 2003 12:02:34 -0600

> What you appear to be saying is that DIAMETER should not have 
> been created in the first place (presumably with a view that 
> RADIUS should have been enhanced to deal with its 
> shortcomings). That is an issue you must take up with the 
> IESG and the WG responsible, not try and blame 3GPP for it.

On this we can agree. 3GPP is not the problem for us. DIAMETER is.

Henry

> Sent: Friday, February 21, 2003 11:48 AM
> To: 'Henry Sinnreich'
> Cc: [email-masked]
> If DIAMETER was a 3GPP protocol, then treating the work with 
> the same status as P-headers would be a perfectly valid 
> statement, but DIAMETER is an approved IETF protocol as draft 
> standard currently sitting in the RFC editors queue and 
> therefore is on the same IETF standards track as RADIUS. 
> 
> Further, DIAMETER was chosen by 3GPP because RADIUS does not 
> meet the 3GPP requirements for that particular interface. 
> Available implementations comes secondary to those 
> requirements (after all 3GPP have specified RFC 3261 rather 
> than RFC 2543 and there are not many deployed implementations 
> of that either).
> 
> What you appear to be saying is that DIAMETER should not have 
> been created in the first place (presumably with a view that 
> RADIUS should have been enhanced to deal with its 
> shortcomings). That is an issue you must take up with the 
> IESG and the WG responsible, not try and blame 3GPP for it.
> 
> And finally to reiterate the point of my previous mail, 3GPP 
> is asking IETF to provide DIAMETER support. In my view, that 
> has zero impact on whether RADIUS is done as well. The input 
> that work should not be done on RADIUS is coming from within 
> the IETF, and is nothing to do with 3GPP.
> 
> Keith
> 
> P.S. I cannot quote T1 yet because the release 5 
> specifications have not yet been endorsed by the SDOs, of 
> which T1 is one (that stage in the process will occur 
> shortly). And the reason for quoting those groups was not to 
> say that my group is better that yours, it was to make clear 
> that the choice of DIAMETER is well known in 3GPP (and 
> therefore by the nature of the 3G market by all operators 
> deploying 3GPP) by publically available information from those groups.
> 
> 
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked] 
> 
> > labels for SIP used by 3GPP? No problem with what 3GPP 
> folks decide, 
> > but that should be labeled "p" (standing here for proprietary,
> > private and I
> > > > DIAMETER is just too little, too late IMHO, when looking at the 
> > > > options in these links.
> > > > 
> > > > > From: [email-masked] 
> [mailto:[email-masked]] On 
> > > > > Behalf Of Jari Arkko
> > > > > I'm not quite sure what you mean by free choice in 
> this context, 
> > > > > but perhaps you are after standardized interfaces? 
> These would 
> > > > > be publicly available in the form of RFCs (eg 
> DIAMETER base) and 
> > > > > 3G specifications on how DIAMETER is used for multimedia 
> > > > > application.
> > > > > 
> > > > > I don't know but there's been Diameter 
> interoperability events. 
> > > > > Perhaps you John could dig up the Nokia information 
> from those 
> > > > > if you participated? I know Ericsson particpated
> > > > at least.
> > > > > 
> > > > > are discussing the creation of an IETF standard for 
> SIP AAA. 3G 
> > > > > folks had to create a multimedia AAA application because the 
> > > > > IETF does not have one. My opinion is that we need an IETF 
> > > > > standard in this space, so that the 3G folks, SIP 
> vendor groups, 
> > > > > or other parties don't all diverge on how to do this. 
> IMHO, this 
> > > > > is really crucial for SIP. My belief is also that the IETF 
> > > > > standard will be better than any of these groups could do 
> > > > > themselves. As far as 3G goes, my understanding was that they 
> > > > > are happy to switch to an IETF standard when it becomes 
> > > > > available.
> > > > > 
> > > > > Jari
> > > > >