Subject: RE: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Wed, 19 Feb 2003 11:34:38 +0200

Hi Juha,

Isn't this a chicken-and-egg problem? Diameter just got to proposed standard - back in 1999 if you had asked the same set of questions about RFC 2543, I bet we'd all be talking about H.323 or something... ;)

Cheers,
Aki

 > -----Original Message-----
 > From: ext [email-masked] [mailto:[email-masked]]
 > Sent: 19 February, 2003 10:37
 > To: [email-masked]
 > Cc: Henry Sinnreich; 'Gonzalo Camarillo'; 'sipping'; Loughney John
 > (NRC/Helsinki)
 > Subject: Re: [Sipping] New version of the SIP-AAA reqs draft
 > 
 > 
 > is there any open source diameter server implementations similar to
 > freeradius?  
 > 
 > is there a good number of commercial diameter server 
 > implementations for
 > me to choose from?
 > 
 > is there any open source diameter client libraries similar to
 > radiusclient?
 > 
 > is there any commercial diameter client libraries for me to 
 > choose from?
 > 
 > i don't mind using diameter for sip once answers to most of the above
 > questions is "yes".  as long it isn't, it makes no sense to 
 > base sip aaa
 > work on diameter.
 > 
 > -- juha
 > 
 > _______________________________________________
 > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
 > This list is for NEW development of the application of SIP
 > Use [email-masked] for questions on current sip
 > Use [email-masked] for new developments of core SIP
 > 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Wed, 19 Feb 2003 12:18:35 +0200

[email-masked] writes:

 > Isn't this a chicken-and-egg problem? Diameter just got to proposed
 > standard - back in 1999 if you had asked the same set of questions
 > about RFC 2543, I bet we'd all be talking about H.323 or
 > something... ;)

sure it is ok to develop new protocols.  however, nobody takes a
protocol seriously that doesn't have a good number of interoperable
implementations.  thus i consider it a mistake to make the sip community
a guinea pig for the diameter protocol and would stick to radius until
diameter has proven itself in products and real world deployments.

-- juha