Subject: [Sipping] RE: [Sipforum-discussion] SIP Telephony Device Requirements, Configuration and Data

From: Henry Sinnreich <[email-masked]>
Date: Thu, 13 Feb 2003 14:27:27 -0600

Gunnar Hellström wrote:

> SIP-xx, analogue text support:

> SIP-zz, digital text support:

> In 4.11 Ringer Behaviour 

> Add to References
> -----------------
> [y] G. Hellstrom: "RTP Payload for Text Conversation.", RFC 
> 2793, IETF, May 2000. [z] ITU-T Recommendation V.18 

Are all excellent points that we will add. Thanks for the comments!

Henry

> -----Original Message-----
> From: Gunnar Hellström [mailto:[email-masked]] 
> Sent: Thursday, February 13, 2003 2:22 PM
> To: Henry Sinnreich; 'Jörgen Björkner'; 
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sipforum-discussion] SIP Telephony Device 
> Requirements, Configuration and Data
> 
> 
> Henry,
> 
> It is mentioned in the introduction to the document that 
> "text shall be kept in mind".
> 
> I suggest some specific text items to be entered that are in 
> line with existing standardisation, and accessibility needs 
> and useful for all:
> 
> --------------------------------------------------------------
> --------------
> -------------------
> SIP-xx, analogue text support: SIP adapter devices (for 
> analog phone lines)
>   MUST support conversion between real time text transmission 
> using RFC 2793 [y]
>   and text telephones according to ITU-T V.18 [x] allowing 
> alternating use of
>   text and voice. SIP clients MUST fallback to G.711 if 
> RFC2793 connection fails.
> 
> 
> SIP-zz, digital text support: SIP telephone devices MUST support
>   real time text conversation using RFC 2793 [y] for the text stream.
>   It MUST be possible to use text simultaneously with voice.
> 
> 
> 
> ---------------------------------------------
> In 4.11 Ringer Behaviour  : add the section below for the 
> purpose of deaf, hearing impaired, deaf-blind people and 
> people in the garden and noisy
> locations:
> 
> SIP Telephony devices MUST provide an external interface to
> an external alerting system.
> 
> 
> 
> Add to References
> -----------------
> [y] G. Hellstrom: "RTP Payload for Text Conversation.", RFC 
> 2793, IETF, May 2000. [z] ITU-T Recommendation V.18 
> "Operational and interworking requirements for DCEs operating 
> in the text telephone mode", November 2000 with amendment 
> November 2002.
> 
> --------------------------------------------------------------
> --------------
> -------
> 
> 
> 
> 
> Thanks
> -------------------------------------------
> Gunnar Hellström
> Omnitor AB
> Renathvägen 2
> SE 121 37 Johanneshov
> SWEDEN
> +46 8 556 002 03
> Mob: +46 708 204 288
> www.omnitor.se
> [email-masked]
> --------------------------------------------
> 
> > -----Ursprungligt meddelande-----
> > Från: [email-masked]
> > [mailto:[email-masked]]För Henry Sinnreich
> > Skickat: den 10 februari 2003 15:49
> > Till: 'Jörgen Björkner'; [email-masked]
> > Ämne: [Sipforum-discussion] SIP Telephony Device Requirements, 
> > Configuration and Data
> >
> >
> > For everyone interested SIP phones and other SIP communication 
> > devices, and the 56 IETF  coming next month, please see if 
> you like or 
> > dislike or don't care about the draft:
> >
> > 
> http://www.ietf.org/internet->
drafts/draft-sinnreich-sipdev-req-00.txt
> >
> > The idea is to have discussions on the lists, and if there 
> is interest 
> > and rough consensus to move ahead with an informational RFC. Would 
> > appreciate your comments to
> >
> > [email-masked] , and also to
> >
> > [email-masked]
> >
> > Thanks, Henry
> >
> > Henry Sinnreich
> > WorldCom
> > 400 International Parkway
> > Richardson, Texas 75081
> > USA
> >
> >
> >
> 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gunnar Hellström <[email-masked]>
Date: Thu, 13 Feb 2003 21:21:41 +0100

Henry,

It is mentioned in the introduction to the document that "text shall be kept
in mind".

I suggest some specific text items to be entered that are in line with
existing standardisation, and accessibility needs and useful for all:

----------------------------------------------------------------------------
-------------------
SIP-xx, analogue text support: SIP adapter devices (for analog phone lines)
  MUST support conversion between real time text transmission using RFC 2793
[y]
  and text telephones according to ITU-T V.18 [x] allowing alternating use
of
  text and voice. SIP clients MUST fallback to G.711 if RFC2793 connection
fails.

---------------------------------------------
In 4.11 Ringer Behaviour  : add the section below for the purpose of deaf,
hearing impaired, deaf-blind people and people in the garden and noisy
locations:

Add to References
-----------------
[y] G. Hellstrom: "RTP Payload for Text Conversation.", RFC 2793, IETF, May
2000.
[z] ITU-T Recommendation V.18 "Operational and interworking requirements for
DCEs operating in the text telephone mode", November 2000 with amendment
November 2002.

----------------------------------------------------------------------------
-------

Thanks

> For everyone interested SIP phones and other SIP communication devices,
> and the 56 IETF  coming next month, please see if you like or dislike or
> don't care about the draft:
>
> http://www.ietf.org/internet-drafts/draft-sinnreich-sipdev-req-00.txt
>
> The idea is to have discussions on the lists, and if there is interest

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 20 Feb 2003 08:06:29 -0600

> RFC2793 connection fails.

This and the other below are excellent points! Thanks for the
contribution. Will add in the next version of 

Henry

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Gunnar Hellström
> Subject: [Sipping] Re: [Sipforum-discussion] SIP Telephony 
> Device Requirements, Configuration and Data
> 
> 
> Henry,
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>