Subject: [sipping] draft-burger-sipping-netann-03.txt (Early media announcement)

From: [email-masked]
Date: Mon, 3 Feb 2003 17:17:46 +0100

Eric,
In early media announcement scenario, you suggest to send a 487 REQUEST
TERMINATED, once the anouncement is played.
But in RFC 3261, the 487 response is said to be used only when the previous
request has been terminated with a BYE or a CANCEL.
It is not the case in early media  announcement scenario.
So my question is ca:n we consider that the early media annoucement
scenario is compliant with RFC 3261?

We've faced a case in which a softphone refuses to close a call (screen
still active) because it has received a 487 without any previous
BYE or CANCEL. Is this terminal not compliant with RFC3261?(below is the
call flow of the call)

Softphone           PROXY (SER)             MS
  INVITE ---------->          -------------->
  <-----------------          ---------------183
                      PLAY of 10 s
  <------------------         ---------------487
  ACK--------------->         ---------------->

After the ACK is sent, the call is still active.

pascal

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Eric Burger" <[email-masked]>
Date: Mon, 10 Feb 2003 01:10:51 -0500

The idea of an early media announcement is that there is an implicit CANCEL.  That reasoning still holds for RFC 3261.  Do you have a better thought for a more appropriate result code?

In the case of the soft phone you mention, I would offer the soft phone is not compliant with RFC 3261.  It should tear down the dialog on any 4xx response.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, February 03, 2003 11:18 AM
> To: Eric Burger
> Cc: [email-masked]; [email-masked]
> Subject: [sipping] draft-burger-sipping-netann-03.txt (Early media
> announcement)
> 
> 
> 
> Eric,