Subject: [Sipping] Question about call flow in draft-ietf-sipping-service-examples-0 3

From: "Miao, Kai" <[email-masked]>
Date: Tue, 11 Feb 2003 16:23:28 -0700

Could someone provide an answer to the following question:
 
In the first example, Call Hold, given in
draft-ietf-sipping-service-examples-03.txt, why F10, i.e., INVITE(hold), has
a=sendonly in its SDP message and F12, i.e., 200 OK, has no "a=" attribute
at all while "No RTP Sent!" is marked in the call flow diagram? 
 
Shoudn't F12 contain a=recvonly or a=inactive, following the Offer/Answer
model? Why there is "no RTP sent" in the diagram when there is "a=sendonly"
in F10?
 
Thanks,
Kai Miao
Intel

---

From: Ajit Kalele <[email-masked]>
Date: Wed, 12 Feb 2003 10:47:35 +0530

Hi,

I think there is an error in the call flows.

Either A has to respond with an "a=inactive", so that there is no RTP
flow between the UAs, or else there should be unidirectional RTP flow
between the 2 UAs.

Best Regards
- Ajit

"Miao, Kai" wrote:

>  Could someone provide an answer to the following question:In the
> first example, Call Hold, given
> in draft-ietf-sipping-service-examples-03.txt, why F10, i.e.,
> INVITE(hold), has a=sendonly in its SDP message and F12, i.e., 200 OK,
> has no "a=" attribute at all while "No RTP Sent!" is marked in the
> call flow diagram? Shoudn't F12 contain a=recvonly or a=inactive,
> following the Offer/Answer model? Why there is "no RTP sent" in the
> diagram when there is "a=sendonly" in F10?Thanks,Kai MiaoIntel

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com