Subject: [Sipping] Rationale for the support of RFC2793/T.140 in SIP Telephone

From: "Barry Dingle" <[email-masked]>
Date: Tue, 1 Jul 2003 16:50:31 +1000

Hi all,

 Following discussions on a side email group, I have tried to provide some background information about some of the thinking behind
the RFC2793/T.140 issue that will be raised at SIPPING in Vienna.

 /Barry DINGLE
Project Manager - ACIF Any-to-Any Text Connectivity Options WG
Telecommunications Consultant
Fellow of the University of Melbourne

[email-masked]

Mob: +61 41 911 7578
Fixed: +61 3 9725 3937

 ==================================

 Purpose
--------------
Enable real-time text communication services on SIP Telephones for general purpose use and for use by people who are deaf or have
hearing and/or speech impairments.

 Background
-----------------
Real-time Text communication services are very useful for people with hearing and/or speech impairments as well as for any person
who wants to converse in text mode eg. to transfer precise details (eg. money amounts, email addresses).

 About 5% of the population has hearing problems [3GPP]. The population is aging so hearing related communication problems are
likely
to increase. In some countries, there are Regulatory requirements for 'mainstream' telephone networks to support "equivalent"
service for people with disabilities for accessing emergency services - usually implemented real-time Text services.

 Real-time text communication is a service provided on the PSTN and now on mobile/cellular telephone networks using TTYs and
Textphones to enable people who are deaf or have hearing or speech impairment to communicate.

Some countries are actively considering how to remove the TTY - over time - because of the problems that are experienced by the
networks and the restricted terminal options that a 'special' device causes.

 One of the main problems that has restricted the provision of real-time Text service in the PSTN to the hearing and speech impaired
has been the use of different Textphone specifications making development of new services very difficult. The ITU-T V.18
specification defines both interworking between different Textphone devices and a new, multimedia aligned Textphone specification.
That new Textphone specification is based on the T.140 presentation protocol.

 T.140 is a very simple protocol that is defined for use by Text services in Video telephony/conferencing (ISDN, H.323, SIP based).
(The details of T.140 are contained in 5 ITU-T pages!)  T.140 specifies the use of UTF-8 transmission.

 << T.140 is an integral part of the 'Total Conversation' concept used by ITU-T , ETSI, IETF and 3GPP - incorporating text, speech
and video. (See F.703, WISDOM project, RFC3351 and 3GPP 22.226.) >>

 RFC2793 defines the use of T.140 with RTP to support text services. It also has an optional redundancy capability to further
improve
the text transfer reliability.

 SIP is a session initiation protocol that facilitates the establishment of multimedia communication between two entities, including
voice, video, and text communication. SIP allows true real-time text communication services to be supported consistently across many
technologies.

 Next Generation Networks (NGNs) is actively looking at providing equivalent PSTN/ISDN services over IP technology. The requirements
of PSTN will be carried into the IP environment particularly where Regulations are service based and not technology based.

 Messaging is a related, similar service. The non-real-time nature can be a problem in some communication situations - including
regulatory. Interworking between real-time text services and Messaging services is desirable. A consistent approach to real-time
text services will assist the interworking.

 Rationale
-------------
1. There is growing interest in providing for text communication services as 'mainstream' instead of an 'added extra' - to benefit
users, suppliers and carriers.

 2. The work towards Next Generation Networks is looking at replacing PSTN networks (over time) with IP-based networks. The key to
the success of such activity is the provision of at least equivalent services. Migration of telephone calls from PSTN to IP-based
networks will be facilitated if the legacy services are supported.

 3. T.140 is very simple and is important in providing a smooth interface between legacy text services in the PSTN/ISDN and IP-based
real-time text services whilst minimising gateway functionality.

 4. SIP should support equivalent TTY service - but not be forced to ONLY support ancient TTYs and their non-standard modems over
IP.
(Comment - assumes that the support of TTY/Textphone over IP ie. carriage of TTY-type modem tones, is only be a fallback call case.)

 5. Support of RFC2793 in SIP terminals would provide an indication to terminal suppliers, networks, servers, gateways that support
for text services is required. (Any breakdown in the end-to-end capability will remove the end-to-end service.)

 Recommendation
-------------------------

 All SIP Telephones MUST support RFC2793 in order that legacy text services and interworking with TTY/Textphones can be supported in
an IP-friendly manner.

 ========================

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 01 Jul 2003 15:47:50 -0500

Barry, I like your summary, but have to take exception in the IETF
context to 

>Next Generation Networks (NGNs)

The NGN is the Internet and it is not "next generation", but here today,
for 'our generation" and to stay. Unless you want to define it
technically NGN as IP v.6  ;-)

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Barry Dingle
> Sent: Tuesday, July 01, 2003 1:51 AM
> To: SIPPING
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; A vWijk; Rajesh 
> Kumar; Barry Dingle
> Subject: [Sipping] Rationale for the support of RFC2793/T.140 
> in SIP Telephone
> 
> 
> 
>  Hi all,
> 
>  Following discussions on a side email group, I have tried to 
> provide some background information about some of the 
> thinking behind the RFC2793/T.140 issue that will be raised 
> at SIPPING in Vienna.
> 
>  /Barry DINGLE
> Project Manager - ACIF Any-to-Any Text Connectivity Options 
> WG Telecommunications Consultant Fellow of the University of Melbourne
> 
> Enable real-time text communication services on SIP 
> Telephones for general purpose use and for use by people who 
> are deaf or have hearing and/or speech impairments.
> 
>  Background
> -----------------
> Real-time Text communication services are very useful for 
> people with hearing and/or speech impairments as well as for 
> any person who wants to converse in text mode eg. to transfer 
> precise details (eg. money amounts, email addresses).
> 
>  About 5% of the population has hearing problems [3GPP]. The 
> population is aging so hearing related communication problems 
> are likely to increase. In some countries, there are 
> Regulatory requirements for 'mainstream' telephone networks 
> to support "equivalent" service for people with disabilities 
> for accessing emergency services - usually implemented 
> real-time Text services.
> 
>  Real-time text communication is a service provided on the 
> PSTN and now on mobile/cellular telephone networks using TTYs 
> and Textphones to enable people who are deaf or have hearing 
> or speech impairment to communicate.
> 
> Some countries are actively considering how to remove the TTY 
> - over time - because of the problems that are experienced by 
> the networks and the restricted terminal options that a 
> 'special' device causes.
> 
>  One of the main problems that has restricted the provision 
> of real-time Text service in the PSTN to the hearing and 
> speech impaired has been the use of different Textphone 
> specifications making development of new services very 
> difficult. The ITU-T V.18 specification defines both 
> interworking between different Textphone devices and a new, 
> multimedia aligned Textphone specification. That new 
> Textphone specification is based on the T.140 presentation protocol.
> 
>  T.140 is a very simple protocol that is defined for use by 
> Text services in Video telephony/conferencing (ISDN, H.323, 
> SIP based). (The details of T.140 are contained in 5 ITU-T 
> pages!)  T.140 specifies the use of UTF-8 transmission.
> 
>  << T.140 is an integral part of the 'Total Conversation' 
> concept used by ITU-T , ETSI, IETF and 3GPP - incorporating 
> text, speech and video. (See F.703, WISDOM project, RFC3351 
> and 3GPP 22.226.) >>
> 
>  RFC2793 defines the use of T.140 with RTP to support text 
> services. It also has an optional redundancy capability to 
> further improve the text transfer reliability.
> 
>  SIP is a session initiation protocol that facilitates the 
> establishment of multimedia communication between two 
> entities, including voice, video, and text communication. SIP 
> allows true real-time text communication services to be 
> supported consistently across many technologies.
> 
>  Next Generation Networks (NGNs) is actively looking at 
> providing equivalent PSTN/ISDN services over IP technology. 
> The requirements of PSTN will be carried into the IP 
> environment particularly where Regulations are service based 
> and not technology based.
> 
>  Messaging is a related, similar service. The non-real-time 
> nature can be a problem in some communication situations - 
> including regulatory. Interworking between real-time text 
> services and Messaging services is desirable. A consistent 
> approach to real-time text services will assist the interworking.
> 
> 
>  Rationale
> -------------
> 1. There is growing interest in providing for text 
> communication services as 'mainstream' instead of an 'added 
> extra' - to benefit users, suppliers and carriers.
> 
>  2. The work towards Next Generation Networks is looking at 
> replacing PSTN networks (over time) with IP-based networks. 
> The key to the success of such activity is the provision of 
> at least equivalent services. Migration of telephone calls 
> from PSTN to IP-based networks will be facilitated if the 
> legacy services are supported.
> 
>  3. T.140 is very simple and is important in providing a 
> smooth interface between legacy text services in the 
> PSTN/ISDN and IP-based real-time text services whilst 
> minimising gateway functionality.
> 
>  4. SIP should support equivalent TTY service - but not be 
> forced to ONLY support ancient TTYs and their non-standard 
> modems over IP. (Comment - assumes that the support of 
> TTY/Textphone over IP ie. carriage of TTY-type modem tones, 
> is only be a fallback call case.)
> 
>  5. Support of RFC2793 in SIP terminals would provide an 
> indication to terminal suppliers, networks, servers, gateways 
> that support for text services is required. (Any breakdown in 
> the end-to-end capability will remove the end-to-end service.)
> 
>  Recommendation
>  All SIP Telephones MUST support RFC2793 in order that legacy 
> text services and interworking with TTY/Textphones can be 
> supported in an IP-friendly manner.
> 
>  ========================
> 
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: "Barry Dingle" <[email-masked]>
Date: Wed, 2 Jul 2003 09:40:56 +1000

Hi Henry,

I agree that the Internet is the next generation network.

However the capitalised "Next Generation Networks" (NGN) is a term used by TIA, ATMF, 3GPP, ITU-T, ETSI and many others  to refer to
the migration of legacy PSTN/ISDN networks to a full service network. Almost everyone agrees that this network will use IP
technology with improved QoS and PSTN-similar services so facilitate service migration.

SIP is seen by most to be a key protocol in the NGN.

Cheers,

/Barry DINGLE
Project Manager - Any-to-Any Text Connectivity Options WG
Telecommunications Consultant
Fellow of the University of Melbourne

Mob: 041 911 7578
Fixed: 03 9725 3937

----- Original Message -----
From: "Henry Sinnreich" <[email-masked]>
To: "'Barry Dingle'" <[email-masked]>; "'SIPPING'" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; "'A vWijk'" <[email-masked]>; "'Rajesh Kumar'" <[email-masked]>
Sent: Wednesday, July 02, 2003 6:47 AM
Subject: RE: [Sipping] Rationale for the support of RFC2793/T.140 in SIP Telephone