Subject: [Sipping] Question on INVITE Initiated Dialog Event Package and Automatic C allback

From: Stupka Jean-Marie <[email-masked]>
Date: Wed, 9 Jul 2003 12:39:50 +0200

Hello All,

As said in RFC 3265 it is possible to create an event subscription within a pre-existing dialog, e.g. a dialog created by an INVITE. In my understanding, this is the intention of draft-ietf-sipping-dialog-package-02.txt.

According to the (PSTN) Automatic Callback given as example application in the introduction of this draft, user A can request a callback when user B hangs-up. User A off course needs to get the information that user B is busy before requesting the automatic callback, i.e. receive a "486 Busy Here" message. However, all early dialogs are considered terminated upon reception of a non-2xx final response (13.2.2.3 of RFC 3261). As consequence, the dialog and thus the data of the preceding call attempt are no more available and the callback cannot be requested.

Can somebody provide clarification of the applicability of RFC 3265 and the draft-ietf-sipping-dialog-package-02.txt to Automatic Callback?

Regards,

Jean-Marie

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 14 Jul 2003 04:18:07 -0400

The dialog package can be used by subscriptions made both within, and 
outside, of a dialog. So, in the case of automatic callback, the 
caller would, after receiving a 486, send a SUBSCRIBE request for the 
dialog package, and do so outside of any dialog.

-Jonathan R.

Stupka Jean-Marie wrote:

> Hello All,
> 
> As said in RFC 3265 it is possible to create an event subscription
> within a pre-existing dialog, e.g. a dialog created by an INVITE.
> In my understanding, this is the intention of
> draft-ietf-sipping-dialog-package-02.txt.
> 
> According to the (PSTN) Automatic Callback given as example
> application in the introduction of this draft, user A can request a
> callback when user B hangs-up. User A off course needs to get the
> information that user B is busy before requesting the automatic
> callback, i.e. receive a "486 Busy Here" message. However, all
> early dialogs are considered terminated upon reception of a non-2xx
> final response (13.2.2.3 of RFC 3261). As consequence, the dialog
> and thus the data of the preceding call attempt are no more
> available and the callback cannot be requested.
> 
> Can somebody provide clarification of the applicability of RFC 3265
> and the draft-ietf-sipping-dialog-package-02.txt to Automatic
> Callback?
> 
> Regards,
> 
> Jean-Marie
> 
> 
> _______________________________________________ Sipping mailing
> list  https://www1.ietf.org/mailman/listinfo/sipping This list is
> for NEW development of the application of SIP Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments of core SIP
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com