Subject: AW: [Enum] Fwd: [Sipping] I-D ACTION:draft-ietf-sipping-e164-03.t xt

From: "Stastny Richard" <[email-masked]>
Date: Sat, 5 Jul 2003 12:08:56 +0200

See below

	-----Ursprüngliche Nachricht----- 
	Von: Patrik Fältström [mailto:[email-masked]] 
	Gesendet: Sa 05.07.2003 05:14 
	An: Peterson, Jon 
	Cc: Stastny Richard; Shockey, Richard; [email-masked]; [email-masked]' 
	Betreff: Re: [Enum] Fwd: [Sipping] I-D ACTION:draft-ietf-sipping-e164-03.t xt

	On fredag, jul 4, 2003, at 20:05 Europe/Stockholm, Peterson, Jon wrote:
	
	> I agree this is an important issue. While I acknowledge that
	> "wildcards" are
	> possible according to the syntax, what's the use-case that motivates
	> wildcards for ENUM?
	
	Because support for wildcards is a MUST when you implement the NAPTR
	record, which ENUM inherits from the DDDS application. If you don't
	implement it, you loose. You don't have a DDDS compliant implementation.
	
	So, I don't understand why you do this recommendation. What is it
	supposed to help wit, as implementations still have to implement the
	regexp according to the NAPTR specification.
	
	     paf
	-------

	To which I reply to Jon and Patrik:

	Martin Streller gave already one example. 

	it is used for pointing to whole range of partial numbers of a PBX. The term "Partial numbers" is used here in the context of E.164 Annex B. What you call partial numbers I call incomplete numbers.

	I have to admit that also within our trails there are two schools of thought: One proposing the use of wildcards and regexp for this, the others (mostly DNS people having an horror of wildcards) are proposing just to generate zone entries for each full number.

	The first approach has the drawback that it only works if all enties are similar and also if there is only one NAPTR per number pointing to the same service (e.g. sip). Especially you should like this ;-)

	The other example is the even more generic approach Patrik was talking about and why we wanted the enum-URI or the "all" or "*" enumservice: Its the code-split example, e.g if you have two different area codes running parallel. BTW Patrik, I do not understand quite your example.

	There may be more examples.

	Just one comment to your draft 

	in general: I also consider it necessary to have same kind of BCP on enum, but IMHO it is still too early to do this. We need more practical experience still. And it should be done by the enum WG, maybe with inputs from other groups.

	regards

	Richard

�����f��)��+-��i����
bz���j)fj��b��?�*i�x�+%��b��+4E�z�����������bq�b�zH�Ա�"�)��鞞�+���[�n&�v�讫��ب��'r��z{l��,zȩ��_������ׯzZ)�����ܢ��

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 5 Jul 2003 13:50:37 +0200

On lördag, jul 5, 2003, at 12:08 Europe/Stockholm, Stastny Richard 
wrote:

> 	I have to admit that also within our trails there are two schools of 
> thought: One proposing the use of wildcards and regexp for this, the 
> others (mostly DNS people having an horror of wildcards) are proposing 
> just to generate zone entries for each full number.

Don't mix up using wildcard in DNS with the regular expression issues. 
They are two different issues, and should be kept separate. That's why 
I gave an example without the wildcard in DNS.

    paf

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP