Subject: RE: [Sipping] DTMF: Why Not A New Method?

From: Adam Roach <[email-masked]>
Date: Thu, 24 Jul 2003 15:22:12 -0500

Paul Kyzivat [mailto:[email-masked]] writes:
> Adam Roach wrote:
> > Can anyone express something more than an extremely vague
> > sense of unease with using a new method?
> > 
> > If not, can we *please* move along in the most obvious direction
> > which has no outstanding technical objections?
> 
> I have no technical objections to this.

Good. Anyone else?

/a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 24 Jul 2003 16:36:24 -0400

As promised in Vienna, a draft will be forthcoming.  With text, people can pick out what's good or bad...

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Wed, July 23, 2003 9:53 AM
> To: sipping
> Subject: [Sipping] DTMF: Why Not A New Method?
> 
> 
> Chris Boulton writes:
> > By defining a new METHOD, all of these discussions go away.
> 
> Excellent point.
> 
> I have raised some very concrete and technical problems with the
> use of both implicit subscriptions and MESSAGE.
> 
> The sole expressed objection to using a new method has been a
> rather indistinct and wishy-washy, "that seems too specialized."
>

---

From: Gordon Ledgard <[email-masked]>
Date: Thu, 24 Jul 2003 16:38:24 -0400

Lest we get lost in the metaphors, the real questions are these:

1) Is there something wrong with the Subscribe/Notify methodology that makes

DTMF difficult or impossible?

2) Is there a way to solve the problems presented by S/N by using a new
method, or are the problems inherent in the protocol?

If the answer to 2) is "yes" then a new method is warranted.
If the anwer to 2) is "no", you are just making another truck
with the same problems as the old truck.

Gordon

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Thursday, July 24, 2003 4:25 PM
To: 'Paul Kyzivat'; Adam Roach
Cc: sipping
Subject: RE: [Sipping] DTMF: Why Not A New Method?

> IMO it is as if we have a truck for carrying apples, and have 
> decided we need a different truck to carry oranges.

The point that I have been trying to make is that your truck
re-use scheme is just great until someone tries to back an
apple truck full of oranges up to an applesauce factory, and
everyone is left wondering why the applesauce is all runny,
bitter, stringy and orange this time around.

/a

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 24 Jul 2003 15:39:15 -0500

I fully agree with Adam.  Reusing MESSAGE just opens the door for other uses
in this gray zone and introduces the potential for other "misuses".  The
reuse of MESSAGE creates a situation much like that which currently exists
with INFO.  I find this particularly ironic given that this solution is
intended to replace all the exisiting and differing proprietary mechanisms
for DTMF based on INFO.  

Mary. 

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Thursday, July 24, 2003 3:25 PM
To: 'Paul Kyzivat'; Adam Roach
Cc: sipping
Subject: RE: [Sipping] DTMF: Why Not A New Method?

/a

---

From: Gordon Ledgard <[email-masked]>
Date: Thu, 24 Jul 2003 16:42:21 -0400

I meant MESSAGE of course.

-----Original Message-----
From: Gordon Ledgard [mailto:[email-masked]]
Sent: Thursday, July 24, 2003 4:38 PM
To: 'Adam Roach'; 'Paul Kyzivat'
Cc: sipping
Subject: RE: [Sipping] DTMF: Why Not A New Method?

Gordon

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Thursday, July 24, 2003 4:25 PM
To: 'Paul Kyzivat'; Adam Roach
Cc: sipping
Subject: RE: [Sipping] DTMF: Why Not A New Method?

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 24 Jul 2003 15:54:41 -0500

> 1) Is there something wrong with the Subscribe/Notify 
> methodology that makes DTMF difficult or impossible?

**EXPLICIT** subscriptions work just fine (although we
need to add a mechanism to get a SIP GRUU from the
endpoint to the KPML server; and this, of course, would
make such a solution predicated on a deployed GRUU
architecture.)

**IMPLICIT** subscriptions are broken in all sorts of
horrible and nasty ways, several of which I posted to
the list earlier.

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 24 Jul 2003 15:56:52 -0500

Oh, in that case...

 +------------------------------------------------------------+
 |  You have received an IM of type "application/kpml+xml",   |
 |  which is not a registered media type.                     |
 |                                                            |
 |  [x] Save it as a file                                     |
 |  [ ] Open it with application: ________________            |
 |                                                            |
 |  [x] Always ask when handing type "application/kpml+xml"   |
 |                                                            |
 |                                             [OK]  [Cancel] |
 +------------------------------------------------------------+

/a

> Sent: Thursday, July 24, 2003 15:42
> To: Gordon Ledgard; 'Adam Roach'; 'Paul Kyzivat'
> Cc: sipping
> methodology that makes