Subject: Re: [Sipping] Re: Call Waiting - who does the tone

From: Cullen Jennings <[email-masked]>
Date: Thu, 24 Jul 2003 15:48:29 -0700

Completely agree with Henry and point out that even my two line PSTN phone
implements this in the phone.

Cullen

On 6/17/03 13:53, "Henry Sinnreich" <[email-masked]> wrote:

> There is another argument for call waiting to be implemented in the
> endpoints: No extra integration testing and regression testing by
> service provider labs with many other network elements - a very costly
> proposition if done for every call feature. My personal two cents.
> 
> Thanks, Henry
> 
> Henry Sinnreich
> MCI
> 400 International Parkway
> Richardson, Texas 75081
> USA
> 
> Have you disconnected the PBX?
> 
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> On Behalf Of Alan Hawrylyshen
>> Sent: Monday, June 16, 2003 5:01 PM
>> To: [email-masked]'
>> Subject: [Sipping] Re: Call Waiting - who does the tone
>> 
>> 
>> On Saturday, Jun 14, 2003, at 01:27 Canada/Mountain, Satish Bansal!
>> wrote:
>>> 
>>> There could be two options. First as you said,  a dump phone should
>>> handle call waiting. It would mean that we are making  end nodes
>>> intelligent.
>>> 
>>> Second option is that intelligence is in the  network, the inbound
>>> proxy should be call statefull and should use 3pcc for
>> playing tone & 
>>> annc. through a server to  the party.
>> 
>> Certainly both solutions work, but keeping the implementation of this
>> feature in the UA would be , in my opinion, more in keeping with the
>> SIP design philosophies of keeping the core relatively free of
>> complexity.  With this support in the end-UAs you will see
>> better user 
>> experiences in mixed domain deployments (e.g. receipt of a call via
>> direct URL dialing while in a pre-existing session
>> established through
>> the proxy handling your registered AOR).
>> 
>> Although it raises the bar a little bit for the UA implementors, I
>> certainly feel that it will scale better and reduce the
>> overall cost to 
>> maintain and deploy the ’core’ portion of a SIP network
>> infrastructure.
>> 
>> I would agree w/ Brian on this; this could be appropriate for
>> inclusion 
>> in a BCP document.
>> 
>> De-lurking,
>> 
>> Alan Hawrylyshen              Jasomi Networks Inc.
>> sip:[email-masked]         mailto:[email-masked]
>> 
>> _______________________________________________
>> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>> This list is for NEW development of the application of SIP
>> Use [email-masked] for questions on current
>> sip Use [email-masked] for new developments of core SIP
>> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Stevens, Del" <[email-masked]>
Date: Fri, 25 Jul 2003 08:31:29 -0700

Don't forget to consider emergency service (E911) requirements. A user
connected to 911 cannot be interrupted by call waiting. If the UA is
responsible for the tone it will also be responsible for knowing local
country requirements for emergency service.

Del Stevens
Siemens Network Convergence
5500 Broken Sound Blvd
Boca Raton, FL  33487

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]]
Sent: Thursday, July 24, 2003 6:48 PM
To: Henry Sinnreich; Alan Hawrylyshen; [email-masked]
Subject: Re: [Sipping] Re: Call Waiting - who does the tone

Cullen

On 6/17/03 13:53, "Henry Sinnreich" <[email-masked]> wrote:

>> maintain and deploy the 'core' portion of a SIP network
>> infrastructure.
>>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 25 Jul 2003 13:30:55 -0400

I think there are several reasons for the phone understanding that
a particular call is an emergency call, but I'm not sure how
it will figure it out.

Then again, having the "network" handling call waiting tone just
moves the problem.  If this is a hard requirement, it means we have
to somehow mark emergency calls.  In general, doing that reliably
without a spoof attack possibility is pretty hard.

Brian

> From: Stevens, Del [mailto:[email-masked]]
> Sent: Friday, July 25, 2003 11:31 AM
> To: 'Cullen Jennings'; Henry Sinnreich; Alan Hawrylyshen;
> [email-masked]
> Subject: RE: [Sipping] Re: Call Waiting - who does the tone
> 
> 
> >> Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping