Subject: [Sipping] about digest authentication

From: "wendy" <[email-masked]>
Date: Wed, 29 Oct 2003 14:41:14 +0800

Hi,

I meet a trouble when developping a b2bua as a SIP ALG to traverse NAT.
The network topology is like this:

private UA --- SIP ALG --- SIP Server (public)

When the private UA registers to the SIP Server,
the SIP ALG can forward authentication CHALLENGE from the SIP Server to the private UA,
and forward authentication RESPONSE from the private UA to the SIP Server.

In some cases, e.g. the public IP address of the SIP ALG is changed,
I hope the SIP ALG can initiate a registration as a substitute of the private UA.
Thus, the private UA does not need to care the SIP ALG's changes.
But how can the SIP ALG be authenticated successfully,
if the administrator of the SIP ALG does not want to configure manually the
usernames/passwords
of all private users?

Thanks a lot!

regards,
Wendy

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Scott Lawrence <[email-masked]>
Date: Wed, 29 Oct 2003 08:10:18 -0500

> I meet a trouble when developping a b2bua as a SIP ALG to traverse NAT.

 This question would be more appropriately asked on
 [email-masked] (questions on current sip)

> usernames/passwords of all private users?

What changes do you want to make in the ALG that would invalidate the
authentication parameters?

-- 
Scott Lawrence        
  Pingtel Corp.