Subject: [Sipping] Re: PRACK vs. UPDATE in 3Pcc

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 16 Oct 2003 22:43:37 +0300

The answer is in page 10 of RFC 3262:

  "If the UAC receives a reliable provisional response with an offer
    (this would occur if the UAC sent an INVITE without an offer, in
    which case the first reliable provisional response will contain the
    offer), it MUST generate an answer in the PRACK."

Gonzalo

Lueken Joachim wrote:

> Hi,
> 
> In several flows of the 3PCC draft the sending of PRACK for one leg of the call depends on the reception of a message on the other leg of the call, e.g. in figure 8 the PRACK is sent to B once the 200 w/ answer2 is received from A.
> 
> Why did you not consider to use UPDATE here. Thus PRACK is no longer of end-to-end relevance and acknowledges reception of responses related to only one SIP call leg. I thought this was the intention behind PRACK. Although we introduce two additional message it looks much cleaner to me.
> 
> The flow in figure 8 would then look like this:
> 
> A                 Controller                  B        
> |                      |                      |        
> |(1) INVITE offer1     |                      |        
> |no media              |                      |        
> |<---------------------|                      |        
> |                      |                      |        
> |<ring>                |                      |        
> |                      |                      |        
> |<answer>              |                      |        
> |                      |                      |        
> |(2) 200 answer1       |                      |        
> |no media              |                      |        
> |--------------------->|                      |        
> |(3) ACK               |                      |        
> |<---------------------|                      |        
> |                      |(4) INVITE no SDP     |        
> |                      |--------------------->|        
> |                      |                      |<ring>  
> |                      |(5) 183 offer2        |        
> |                      |<---------------------|        
> |(6) INVITE offer2'    |(6a) PRACK            |        
> |<---------------------|--------------------->|       
> |(7) 200 answer2'      |(6c) 200 PRACK        |        
> |--------------------->|<---------------------|        
> |(8) ACK               |                      |        
> |<---------------------|                      |        
> |                      |(9) UPDATE answer2    |        
> |                      |--------------------->|        
> |                      |(10) 200 UPDATE       |        
> |                      |<---------------------|        
> |(11) RTP              |                      |        
> |.............................................|        
> |                      |                      |<answer>
> |                      |(12) 200 OK           |        
> |                      |<---------------------|        
> |                      |(13) ACK              |        
> |                      |--------------------->|        
> 
> 
> Best regards / Mit freundlichen Gruessen
> Joachim Lueken
>  
> ---------------------------------------- 
> SIEMENS 
> Dept. ICN CP D NC B 
> Hofmannstr. 51, 81359 Munich, Germany 
> Tel: +49 89 722-63251 
> Fax: +49 89 722-28770 
> eMail: [email-masked]
> ---------------------------------------- 
> 
>  
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Lueken Joachim <[email-masked]>
Date: Thu, 16 Oct 2003 17:09:18 +0200

Hi,

A                 Controller                  B        
|                      |                      |        
|(1) INVITE offer1     |                      |        
|no media              |                      |