Subject: Re: [Sipping] I-D ACTION:draft-ietf-sipping-dialog-package-03.txt

From: Diego B <[email-masked]>
Date: Tue, 28 Oct 2003 20:16:25 +0200

Hi;
This is right?

"
    Automatic Callback: In this basic Public Switched Telephone Network
       (PSTN) application, user A calls user B. User B is busy. User A
       would like to get a callback when user B hangs up. When B hangs
       up, user A's phone rings. When A picks it up, they here ringing,
       and are being connected to B. To implement this with SIP, a
       mechanism is required for B to receive a notification when the
                                 ^
       dialogs at A are complete.
                  ^
"
In this example, 'A' may receive notifications on the state of 'B'
dialog.

Tnx

Diego Besprosvan

MailVision Ltd.
Haganim 10/a
German Colony, Haifa
Israel
e-mail: [email-masked]
www.mailvision.com

[email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.
> 
> 	Title		: An INVITE Inititiated Dialog Event Package for the Session Initiation Protocol (SIP)
> 	Author(s)	: J. Rosenberg, H. Schulzrinne
> 	Filename	: draft-ietf-sipping-dialog-package-03.txt
> 	Pages		: 30
> 	Date		: 2003-10-27
> 	
> This document defines a dialog event package for the SIP Events
> architecture, along with a data format used in notifications for this
> package. The dialog package allows users to subscribe to another
> user, an receive notifications about the changes in state of INVITE
> initiated dialogs that the user is involved in.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-dialog-package-03.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-sipping-dialog-package-03.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-sipping-dialog-package-03.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 28 Oct 2003 09:52:01 -0800

Good catch.  The roles are backwards in the last sentence.

thanks,
-rohan

On Oct 28, 2003, at 10:16, Diego B wrote:

>> http://www.ietf.org/shadow.html or  
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Michael Hammer <[email-masked]>
Date: Tue, 28 Oct 2003 13:46:00 -0500

Also known as Completion of Calls to Busy Subscriber (CCBS), I.253.3?

Mike

At 09:52 AM 10/28/2003 -0800, Rohan Mahy wrote:
>>>         Title           : An INVITE Inititiated Dialog Event Package 
>>> for the Session
>>>Initiation Protocol (SIP)