Subject: [Sipping] draft-rosenberg-sipping-ice-01 & draft-camarillo-mmusic-alt-02.tx t

From: "Francois Audet" <[email-masked]>
Date: Thu, 23 Oct 2003 10:34:46 -0700

Jonathan,

Is there any plan to update the ICE draft with the changes made by Gonzallo
and 
yourself to the draft-camarill-mmusic-alt-02?

In particular:

1 - In ICE, do you intend to keep the address priority based on the qvalue
(similar 
    to alt-01), or do you intend to go with the simple prioritized list
approach 
    as per alt-02? In both cases, I'm assuming you are keeping the alt
parameter.

2 - Is the intent that IPv6 addresses in SDP be expressed in ICE using the
IPV 
    format, or does it follow the IPv4 format as per the current example in
ICE? 
    Section 5.3 of ICE talks briefly about IPv6 addresses, but there is no
example 
    on how it would be expressed. I believe that the intent is to use the
IPV format
    in ICE for IPv6 addresses. Is this accurate?

3 - References: ICE should refer to alt-2 not alt-1 in the reference.

4 - Is the intent that STUN requests in ICE be receivable only on IPv4
addresses?
    This would assume that IPv6 addresses are always reachable. I believe
this is
    the intent.

In other words, to take the example A's offer in ICE section 9.1.1 (Figure
5), 
if there was also an IPv6 address, which of the following SDP (A, B or C)
would be 
correct:

A: Using IPV, but keeping the qvalue for IPv4

   v=0
   o=alice 2890844730 2890844731 IN IP4 host.example.com
   s=
   t=0 0
   a=group:IPV 1 2
   m=audio 6886 RTP/AVP 0
   c=IN IP6 2201:056D::112E:144A:1E24
   a=mid:1
   m=audio 8076 RTP/AVP 0
   c=IN IP4 192.0.2.10
   a=alt:1 1.0 : user 9kksj== 10.0.1.1 1010
   a=alt:2 0.8 : user1 9kksk== 192.0.2.1 9988 192.0.2.1 9990
   a=alt:3 0.4 : user2 9kksl== 192.0.2.10 8076
   a=mid:2

B: Using IPV, using simple ordered list instead of qvalue for IPv4

   v=0
   o=alice 2890844730 2890844731 IN IP4 host.example.com
   s=
   t=0 0
   a=group:IPV 1 2
   m=audio 6886 RTP/AVP 0
   c=IN IP6 2201:056D::112E:144A:1E24
   a=mid:1
   m=audio 8076 RTP/AVP 0
   c=IN IP4 192.0.2.10
   a=alt:1 user 9kksj== 10.0.1.1 1010
   a=alt:2 user1 9kksk== 192.0.2.1 9988 192.0.2.1 9990
   a=alt:3 user2 9kksl== 192.0.2.10 8076
   a=mid:2

C: As per current ICE draft. This implies that we would be running a STUN
server 
   on the IPv6 address as well to check for connectivity.

   v=0
   o=alice 2890844730 2890844731 IN IP4 host.example.com
   s=
   c=IN IP4 192.0.2.10
   t=0 0
   m=audio 8076 RTP/AVP 0
   a=alt:1 1.0 : user 9kksi = IP6 2201:056D::112E:144A:1E24  (note that I've
added 
   a=alt:1 0.9 : user0 9kksj== IP 4 10.0.1.1 1010             an IP6 and
IP4)
   a=alt:2 0.8 : user1 9kksk== IP4 192.0.2.1 9988 192.0.2.1 9990
   a=alt:3 0.4 : user2 9kksl== IP4 192.0.2.10 8076

I think the intent is either A or B. Can you clarify?

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 24 Oct 2003 08:10:10 +0300

Francois,

> 1 - In ICE, do you intend to keep the address priority based on the 
> qvalue (similar

Within an m line, we intend to use the alt lines defined in ICE using 
qvalues.

> 2 - Is the intent that IPv6 addresses in SDP be expressed in ICE using 
> the IPV
>     format, or does it follow the IPv4 format as per the current example 
> in ICE?

The IPv6 addresses will use the IPV format.

>     Section 5.3 of ICE talks briefly about IPv6 addresses, but there is 
> no example
>     on how it would be expressed. I believe that the intent is to use 
> the IPV format

Yes.

>     This would assume that IPv6 addresses are always reachable. I 
> believe this is
>     the intent.

If you added alt lines to an IPv6 line, you could run STUN on it... the 
idea is presenting user agents with an IPv6 and an IPv4 address for a 
stream. Once the UA picks up a media line (corresponding to an address), 
it does whatever that media line tells it to do (e.g, running STUN).

> In other words, to take the example A's offer in ICE section 9.1.1 
> (Figure 5),
> if there was also an IPv6 address, which of the following SDP (A, B or 
> C) would be
> correct:

Option A would be correct (use IPV and alt lines with qvalues). We 
actually have a draft that contains a similar example (I believe 
Jonathan submitted before the cut-off...). This is an SDP taken from 
that draft:

     v=0
     o=bob 280744730 28977631 IN IP6 host.example.com
     s=
     t=0 0
     a=group:IPV 1 2
     m=audio 6886 RTP/AVP 0
     c=IN IP6 2001:056D::112E:144A:1E24
     a=mid:1
     m=audio 22334 RTP/AVP 0
     c=IN IP4 192.0.0.1
     a=mid:2
     a=alt:1 1.0 : user 9kksj== 192.0.0.1 22334

Thanks,

Gonzalo

> C: As per current ICE draft. This implies that we would be running a 
> STUN server
>    a=alt:1 1.0 : user 9kksi = IP6 2201:056D::112E:144A:1E24  (note that 
> I've added

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP