Subject: [Sipping] Completing URIs with port

From: Szelényi Csaba <[email-masked]>
Date: Wed, 7 Jan 2004 15:43:44 +0100

Hi,

According to RFC3261 chapter 19.1.4 two URIs are not the same if one of them contains no port description and the other one does contain the default port. E.g.:

   sip:[email-masked]                   (can resolve to different ports)
   sip:[email-masked]:5060

The CISCO 7960 completes the received URI with the ':5060' string in the following cases:
 - when the Contact URI is used as Request-URI in the next request (e.g. in case of redirection)
 - when the Record-Route is copied to the Route header in case of loose routing.

Is it legal? IMHO it is not, but I would like to be sure.

Thank you very mush for any input in advance!

Regards,

Szelényi Csaba
T-Systems RIC
mailto:[email-masked]
+36 1 456 5507
+36 20 477 7778

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 7 Jan 2004 13:40:41 -0500

> According to RFC3261 chapter 19.1.4 two URIs are not the same 
> if one of them contains no port description and the other one 
> does contain the default port. E.g.:
> 
> Is it legal?

Within rfc2543, sip:[email-masked] and
sip:[email-masked]:5060 were considered equivalent.
Within rfc3261, they are no longer considered equivalent.
This is one of the various non backward compatibilities.

Because the adding of an extraneous port can break 
rfc3263 functionality within your example, you should
inquire when the product intends to become rfc3261
compliant concerning not extraneously adding port 5060.

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 7 Jan 2004 15:19:28 -0800

The Cisco 7960 does not claim to be fully RFC-3261 compliant.

thanks,
-rohan

On Wednesday, January 7, 2004, at 06:43 AM, Szelényi Csaba wrote:

> Hi,
>
> According to RFC3261 chapter 19.1.4 two URIs are not the same if one 
> of them contains no port description and the other one does contain 
> the default port. E.g.:
>