Subject: RE: [Sipping] Case-sensitivty of the branch parameter

From: [email-masked]
Date: Tue, 13 Jan 2004 16:47:01 +0530

Regards,
Nataraju A.B. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Szelényi Csaba
Sent: Tuesday, January 13, 2004 4:35 PM
To: [email-masked]
Subject: [Sipping] Case-sensitivty of the branch parameter

Hi All,

It seems to me, that the branch parameter is case-sensitive (the magic cookie contains upper and lower case characters). I could find only the following paragraph regarding the case-sensitivity of the branch parameter in rfc3261:

7.3.1 Header Field Format
...
   When comparing header fields, field names are always case-
   insensitive.  Unless otherwise stated in the definition of a
   particular header field, field values, parameter names, and parameter
   values are case-insensitive.  Tokens are always case-insensitive.
   Unless specified otherwise, values expressed as quoted strings are
   case-sensitive.  For example,

Neither chapter 8.1.1.7, nor chapter 20.42 states anything regarding the case-sensitivity of branch. So, according to rfc3261, the branch is case insensitive! 

Is the Via branch parameter case sensitive?

 [ABN] Yes Branch parameter MUST be case sensitive. It's not been explicitly   mentioned in any section. I guess it should have been mentioned in some section about the case sensitiveness...

Thank you very much in anticipation for any input regarding this topic!

Regards,
Csaba

Szelényi Csaba
T-Systems RIC
mailto:[email-masked]
+36 1 456 5507
+36 20 477 7778

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Steve Pellegrino <[email-masked]>
Date: Tue, 13 Jan 2004 08:00:41 -0500

Actually, the branch parameter is case insensitive.  This has been 
logged as bug 661:
http://www.sipwg.org/sipwg/show_bug.cgi?id=661

Regards,
Steve

[email-masked] wrote:

> It seems to me, that the branch parameter is case-sensitive (the magic 
> cookie contains upper and lower case characters). I could find only 
> the following paragraph regarding the case-sensitivity of the branch 
> parameter in rfc3261:
>
> Neither chapter 8.1.1.7, nor chapter 20.42 states anything regarding 
> the case-sensitivity of branch. So, according to rfc3261, the branch 
> is case insensitive!
>
>  [ABN] Yes Branch parameter MUST be case sensitive. It's not been 
> explicitly   mentioned in any section. I guess it should have been 
> mentioned in some section about the case sensitiveness...
>