Subject: [Sipping] Re: [Sip] SIP DTMF

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 13 Jan 2004 22:34:16 -0500

There is also RFC 2833.

The app interaction framework:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-app-interaction-framework-00.txt

describes the framework for dtmf and other stimulus signaling, and 
KPML, as indicated, is used in conjunction with this framework.

-Jonathan R.

[email-masked] wrote:

> Wendy,
> 
> There was a discussion in the list some time back and it was decided
> that SIP-INFO method should not be used to 
> Send the DTMF info.
> 
> It was proposed that it is better to you kpxml for sending DTMF tones.
> 
> Please look in to the SIP-Kpxml draft for sending DTMF tomes in-midcall
> processing and all.... 
> 
> 
> Regards,
> Sreeram
> 
> =====================================================
> Sreeram Kanumuri                Plot No 72, Keonics Electronics City
> 			              Hosur Main Road
> Wipro Technologies              Bangalore -29 INDIA
> [email-masked]      Phone: 8520408 Ex:3208
> [email-masked]             ESN  :
> www.wipro.com                   Mobile:
> ======================================================
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of wendy
> Sent: Wednesday, January 14, 2004 8:08 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] SIP DTMF
> 
> 
> Hello all, 
> 
> Who can tell me whether there is a RFC or I-D on DTMF in SIP which is
> still not expired? I remember someone proposed using SIP INFO method for
> DTMF one or two years ago. Is the DTMF relay implemented only by RTP
> now?
> 
> 
> Regards,
> Wendy
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Wed, 14 Jan 2004 08:36:28 +0530

Wendy,

Regards,
Sreeram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of wendy
Sent: Wednesday, January 14, 2004 8:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sip] SIP DTMF

Hello all, 

Regards,
Wendy

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 18 Jan 2004 10:17:51 -0800

I have talked to the authors of the various proposal for doing DTMF. For the
case where it is not in the media (ie 2833), I believe the only proposal
that the current authors plan to keep moving forward is the
App-Interaction/KPML stuff. I don't believe there is any intention to
resubmit the DTMF in INFO or DTMF over SUB/NOT proposals.

Cullen