Subject: [Sipping] Question related to netann draft

From: "Rajiv Dharmadhikari" <[email-masked]>
Date: Sun, 31 Oct 2004 22:18:00 -0800

Eric,

This is a resend as I am not sure original email got posted on the mailing list. 

Section 4 of 'netann' draft describes how VoiceXML applications can be invoked by an external Application Server. It is also expected that results would be posted back to application server via HTTP POST mechanism. In true SIP and VoiceXML world this works fine. When it comes to legacy IN networks, you may not have a true application server. Even if there is some way to launch VoiceXML scripts through 'netann' model, posting results is tricky. Would some mid-call signaling method like SIP INFO to send results be violating spirit of 'netann'? 

I am copying this to the mailing list to see if others have opinion on this topic.

Thanks,

-Rajiv

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Eric Burger <[email-masked]>
Date: Fri, 5 Nov 2004 15:59:03 -0500

Netann just says how to launch something, so mid-call events via INFO would
not violate netann.

That said, returning results from VoiceXML in SIP is a MAJOR VIOLATION OF
THE VOICEXML MODEL.  Big, Bad No-No.  We've discussed this here and in the
W3C.
See:
http://www1.ietf.org/mail-archive/web/sipping/current/msg03015.html
http://lists.w3.org/Archives/Public/www-voice/2004AprJun/0028.html (the
whole thread isn't there; that's the summary; go to the beginning of the
thread for the full juice of why this is a VERY BAD idea).

The big breakdown is a voice browser expects the next page after a submit.
One could recreate HTTP with SIP INFO's, but I don't think that would get
much traction here :)

> -----Original Message-----
> From: Rajiv Dharmadhikari [mailto:[email-masked]]
> Sent: Monday, November 01, 2004 1:18 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Question related to netann draft
> 
> 
> Eric,
> 
> Section 4 of 'netann' draft describes how VoiceXML 
> applications can be invoked by an external Application 
> Server. It is also expected that results would be posted back 
> to application server via HTTP POST mechanism. In true SIP 
> and VoiceXML world this works fine. When it comes to legacy 
> IN networks, you may not have a true application server. Even 
> if there is some way to launch VoiceXML scripts through 
> 'netann' model, posting results is tricky. Would some 
> mid-call signaling method like SIP INFO to send results be 
> violating spirit of 'netann'? 
>