Subject: [Sipping] RE: Comments to cc-conferencing-05 (WGLC)

From: "Johnston, Alan" <[email-masked]>
Date: Tue, 16 Nov 2004 01:53:08 +0000

Miguel,

Thanks for your detailed comments.  We will make the corrections and changes
you suggested.  A few comments are below in your snipped comments.

Thanks,
Alan Johnston
MCI
sip:[email-masked]

> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]] 
> Sent: Thursday, November 04, 2004 6:21 AM
> To: Johnston, Alan; Orit Levin
> Cc: sipping
> Subject: Comments to cc-conferencing-05 (WGLC)
> 
> 
> Alan, Orit (and SIPPING):
> 
> I have some comments to 
> draft-ietf-sipping-cc-conferencing-05.txt. They 
> are mostly nits. I hope you can take them into account.
> 

<snip>

> - Also Section 3.1 reads in the third paragraph:
> 
>    "A focus SHOULD support the Replaces [8] header field."
> 
> At this stage, since the usage of the Replaces headers have not been 
> introduced, it would be good to have some motivation 
> introductory text, 
> something like:
> 
>     "In order to support advanced features, where a session 
> established 
> between two endpoints can migrate to a centralized 
> conference, a focus 
> SHOULD support the Replaces [8] header field."
> 
> - And more on section 3.1:
> 
> I also think we need some text in this section regarding the 
> support of 
> the Join header and the GRUU in the focus.
> 
> - Question on section 3.4:
> 
> Should the conference-aware UA support the replaces, join and GRUU? I 
> guess it should be strongly recommended to implement it 
> (perhaps a MUST).

While I think it is an excellent idea for any UA to support replaces, join,
and GRUU, a MUST level would imply interoperability failures if they didn't
support, which isn't true.

> 
> - Section 4, Call flows, General.
> 
> I think all the Supported headers should always contain: 
> join, replaces, 
> gruu. There are some of them that do not contain 'join',  others not 
> even gruu.

I will double check, but I think only non-focus UAs occasionally do not
support join and GRUU, which is acceptable.

<snip> 

> - Section 4.2
> 
> I think the payloads in NOTIFYes F7 and F9 are exchanged 
> somehow. Alice is already a participant of the conference, so 
> her NOTIFY F9 can 
> be contain a partial information. Carol's NOTIFY F7 is the 
> first NOTIFY 
> she receives, so it should contain a full event package.
> 

Agreed.

> However, F7 contains a <conference-state> with version="0" and 
> state="full",

This is exactly what you say in your previous statement, right?

 when it should be version="1" (or other number) and 
> state="partial".
> 
> F9 contains the correct version="0", but the state="partial", when it 
> should be "full".

No, F9 is sent to Alice, so it is partial, just as you say above.  Do I have
this wrong somehow?

> 
> - Section 4.2, Changing User Agents within a Conference
> 

You mean, section 4.2, right?

> This is an interested case, but certainly there is nothing 
> peculiar to 
> the conferencing. In other words, this will be applicable to the 
> one-to-one session. So if there is something remarkable when we apply 
> this case to the conferencing framework, please explain. Otherwise, I 
> don't know what is the value of this use case.

This is the use case for why the focus SHOULD support Replaces.  I will add
text earlier referring to this example to make this clear.

<snip>

> 
> 
> Best regards,
> 
>         Miguel
> 
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> Nokia Research Center      Helsinki, Finland
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 16 Nov 2004 14:17:42 +0200

Hi Alan:

Thanks for your reply. I am just reducing the text to these points that 
need further discussion.

> No, F9 is sent to Alice, so it is partial, just as you say above.  Do I have

Ok, I reviewed again the flow and it is correct. So, forget about my 
initial comments, and my apology for the possible waste of time created. 
The flow is correct as is.

> You mean, section 4.2, right?

4.9, I meant 4.9, "Chaging User Agents within a Conference".

> text earlier referring to this example to make this clear.

OK to me.

Regards,

         Miguel