Subject: Re: [Sipping] automatic answer

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Nov 2004 16:14:11 -0500

I still don't understand why the answering machine wouldn't know that it
is an answering machine. As long as it knows, it can know to pick up
immediately.

I do see value in allowing an answering machine to tell a caller that it
has reached an answering machine. We have that capability in RFC 3840,
which allows the UAS to indicate, through capability parameters in its
Contact header field in the 200 OK, that it is an answering machine.

Thanks,
Jonathan R.

David wrote:

> Hi Dean.
> 
> While I totally agree that the network should not control the edges,
> however, I would contend that there is a difference between controlling and
> informing. I do not see the harm in a network providing extra services to
> the edges in the form of additional information regarding the request about
> to be made. Whether in the case of voice mail or spam, I think that if the
> network has some info that it wishes to share it should do so and allow the
> edge to decide what to do with this information. Thus, in this particular
> case the network does not have to KNOW that the edge is an answering
> machine, rather it could say "By the way, if you are an answering machine
> ...". 
> 
> David Schwartz 
> 
> 
>>-----Original Message-----
>>From: [email-masked] 
>>[mailto:[email-masked]] On Behalf Of Dean Willis
>>Sent: Thursday, October 28, 2004 8:15 PM
>>To: ???
>>Cc: [email-masked]
>>Subject: Re: [Sipping] automatic answer
>>
>>황진경 (Jinkyung Hwang) wrote:
>>
>>
>>>Hi,
>>> 
>>>Is there any I-D regarding params for SIP phone to answer 
>>>automatically ? (for answering machine functionality)
>>> 
>>>I would like to know when the call arrives a phone, by which 
>>>param/header value the phone answers without ringing.
>>> 
>>> 
>>
>>This generally isn't something that is signaled to the 
>>answering machine, it's just something the answering machine 
>>does because it KNOWS it's an answering machine.
>>
>>Remember, SIP isn't about network control of edge devices. 
>>Rather, it is about how a bunch of edge devices can find and 
>>engage each other in an appropriate  and useful manner.
>>
>>The routing infrastructure and the calling party generally 
>>don't know that a specific device is an answering machine. 
>>They know that it's a possible endpoint, and they MAY know 
>>something about previous routing attempts or decisions made 
>>elsewhere in the network. Consequently, having them insert 
>>some sort of special parameter to make the device "act like 
>>an answering machine" is probably inappropriate.
>>
>>For example, I sometimes use an Asterisk box to provide 
>>voice-mail services for my SIP phone. No special paramters or 
>>singaling are sent from my proxy to the Asterisk box to 
>>invoke it. Instead, it REGISTERs to my AOR just like all my 
>>other SIP endpoints. But rather than answering immediately on 
>>receiving a 200 OK, it is configured to wait ten seconds. 
>>Consequently, if I answer at one of my SIP phones in a timely 
>>fashion, the Asterisk VM is never connected, but if I don't 
>>answer, it picks up the call.
>>
>>
>>That being said, they are two places that useful information 
>>might be conveyed.
>>
>>If the asnwering machine is being reached as a result of a 
>>call forwarding action performed by a proxy (perhaps as a 
>>result of a CPL script), then the URI for the answering 
>>machine can be constructed and configured into the forwarding 
>>proxy to convey meaningful information, which MIGHT include 
>>device-specific parameters. This approach is dicsussed in 
>>Cullen Jenning's draft,  draft-jennings-sip-voicemail-uri-03.
>>
>>Another possibility would be for the call-forwarding action 
>>to be presented in the request delivered to the answering 
>>machine in the format specified by the history-info document 
>>that I announced a working-group last call on earlier today. 
>>While this may be useful for certain PSTN-interaction cases, 
>>I personally find it an unattractive approach for 
>>implementing general-purpose voice mail solutions of the kind 
>>I described above.
>>
>>--
>>Dean
>>
>>
>>
>>_______________________________________________
>>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>>This list is for NEW development of the application of SIP 
>>Use [email-masked] for questions on current 
>>sip Use [email-masked] for new developments of core SIP
>>
>>---
>>Incoming mail is certified Virus Free.
>>Checked by AVG anti-virus system (http://www.grisoft.com).
>>Version: 6.0.784 / Virus Database: 530 - Release Date: 10/27/2004
>> 
>>
> 
> 
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.784 / Virus Database: 530 - Release Date: 10/27/2004
>  
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Gordon Ledgard" <[email-masked]>
Date: Thu, 11 Nov 2004 16:54:16 -0500

I assume that the functionality you are trying to achieve is to have the called parties UA decide,
based on something about the call, to either ring the phone or immediately direct the phone call
to an answering machine because you do not want to be bothered by some certain set of calls.

This is acheiveable in a variety of ways without having the network add any more garbage to the INVITE.

I'm entirely with Jonathan on this. What possible paradigm would the "by the way, if you are an
answering machine...." be of use, and how on earth would the network know or understand this context?

Gordon Ledgard

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Jonathan Rosenberg
Sent: Thursday, November 11, 2004 4:14 PM
To: David
Cc: [email-masked]; 'Dean Willis'
Subject: Re: [Sipping] automatic answer

Thanks,
Jonathan R.