Subject: [Sipping] Conference speaker controll

From: Oliver Schwaneberg <[email-masked]>
Date: Mon, 22 Nov 2004 16:27:21 +0100

Hi everybody!
I'm new here and I like to know if there's any approach to determine
which participant of an conference is actually talking?

For example:
If you're using a central mixer it would be possible to scan for talking
participants (silence sound suppression, level detection, etc.). In that
case the Mixer could send NOTIFY-Messages in order to inform every
participant about the talking-state of every other participant.

So back to my question: Is there already something like this?

Thank you in advance!

Oliver Schwaneberg

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Johnston, Alan" <[email-masked]>
Date: Mon, 22 Nov 2004 20:22:49 +0000

Hi Oliver,

An RTP (SSRC) approach is possible using the SIP conference package.  See
Section 6.1.7.3 of draft-ietf-sipping-conference-package-06.txt.  This has
the advantage of being synchronized with the media (unlike a SIP NOTIFY
approach) but does require the RTP mixer to include SSRC identifiers.

Thanks,
Alan Johnston
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Oliver Schwaneberg
> Sent: Monday, November 22, 2004 9:27 AM
> To: sipping
> Subject: [Sipping] Conference speaker controll
> 
> 
> Hi everybody!
> I'm new here and I like to know if there's any approach to 
> determine which participant of an conference is actually talking?
> 
> For example:
> If you're using a central mixer it would be possible to scan 
> for talking participants (silence sound suppression, level 
> detection, etc.). In that case the Mixer could send 
> NOTIFY-Messages in order to inform every participant about 
> the talking-state of every other participant.
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>