Subject: RE: [Sipping] Conference speaker control

From: "Even, Roni" <[email-masked]>
Date: Mon, 29 Nov 2004 12:11:47 +0200

Hi Alan,
The approach described in the SIP conference package section 6.1.7.3
describes how a RTP mixer will behave, Most conference bridges are not
RTP mixers and will not supply the list of contribution resources.
The current draft is missing this function that identify the current
talked as well as who is being seen in each of the sub windows in a
multi window view. 
I expect that there will be more information when the package will be
extended as a result of the work in the XCON group.
Roni Even

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Johnston, Alan
Sent: Monday, November 22, 2004 10:23 PM
To: 'Oliver Schwaneberg'; sipping
Subject: RE: [Sipping] Conference speaker controll

Hi Oliver,

An RTP (SSRC) approach is possible using the SIP conference package.
See
Section 6.1.7.3 of draft-ietf-sipping-conference-package-06.txt.  This
has
the advantage of being synchronized with the media (unlike a SIP NOTIFY
approach) but does require the RTP mixer to include SSRC identifiers.

Thanks,
Alan Johnston
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Oliver Schwaneberg
> Sent: Monday, November 22, 2004 9:27 AM
> To: sipping
> Subject: [Sipping] Conference speaker controll
> 
> 
> Hi everybody!
> I'm new here and I like to know if there's any approach to 
> determine which participant of an conference is actually talking?
> 
> For example:
> If you're using a central mixer it would be possible to scan 
> for talking participants (silence sound suppression, level 
> detection, etc.). In that case the Mixer could send 
> NOTIFY-Messages in order to inform every participant about 
> the talking-state of every other participant.
> 
> So back to my question: Is there already something like this?
> 
> Thank you in advance!
> 
> Oliver Schwaneberg
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 29 Nov 2004 08:10:59 -0500

Roni

I'm not following this.  Most conference bridges are not RTP mixers, but if
they aren't RTP mixers than they aren't being used for SIP conferencing.  So
what?  If you have a SIP conference, then you would have an RTP mixing
bridge, you would have SSRCs, and the conference package would work as Alan
suggested, right?  What am I missing here?  Are you suggesting that some SIP
conference bridges don't do this?  If so, should we provide other
mechanisms, or suggest that the bridges should follow the RFC? 

Agree that we need more here than the package as specified provides, but
agree that it's XCON that will work on it.

Brian

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Even, Roni
> Sent: Monday, November 29, 2004 5:12 AM
> To: Johnston, Alan; Oliver Schwaneberg; sipping
> Subject: RE: [Sipping] Conference speaker control
> 
> Hi Alan,