Subject: [Sipping] Re: draft-rahman-sipping-device-info-01.txt

From: Brijesh Kumar <[email-masked]>
Date: Sat, 06 Nov 2004 12:27:07 -0500

Hi Paul:

Thanks for reading the draft and raising some very relevant questions.
Please see the response inline.

----- Original Message -----
From: Paul Kyzivat <[email-masked]>
Date: Friday, November 5, 2004 6:22 pm

> I'm not getting a clear understanding from this draft of what the 
> granularity of a device is, or how you intend to address a device.

A device in the draft correspond to an AOR. A device can be a pure 
software instantiation, or a hardware plus software instantiation.

> For example, lets assume I have a PC. On it I have two sip 
> software 
> agents: a softphone and an IM client. The softphone supports two 
> "lines" 
> (addresses), and the IM client supports a third address. For each 
> of 
> these addresses, there is an AOR, and a local contact that is 
> registered 
> with the corresponding AOR. The PC is behind a NAT, so it doesn't 
> have 
> stable contact addresses. So each time it registers, it requests a 
> GRUU.
> Summarizing:
> 
> PC IP address: 10.0.1.1
> 
> Softphone
> - local sip address: 10.0.1.1:5060
> - NATed address: 192.0.2.88:8866
> - line 1
>   - AOR: sip:[email-masked]
>   - contact: sip:[email-masked]:5060;instance=id="uuid:stuff"
>   - GRUU: sip:[email-masked];grid=1
> - line 2
>   - AOR: sip:[email-masked]
>   - contact: sip:[email-masked]:5060;instance-id="uuid:stuff"
>   - GRUU: sip:[email-masked];grid=2
> IM client
> - local sip address: 10.0.1.1:7654
> - NATed address: 192.0.2.88:8872
> - AOR: sip:[email-masked]
> - contact: sip:10.0.1.1:7654;instance-id="uuid:something"
> - GRUU: sip:[email-masked]
> 
> How does the device-info event package get used in this context?

We treat each AOR  (sip:[email-masked],[email-masked],
and sip:[email-masked]) as  a separate sip device.
 
> - from your point of view, how many devices are there here?

We will treat them as three devices since there are three AORs.

> - which of the above addresses can I use to invoke it?
>   (Or do you imagine a separate "device address"?)

Any of the above - but status returned would be different in each
case. Basically, we need to treat each device separately depending 
upon whose status we are interested in monitoring.

> - does the answer I get depend on which address I use?

Yes - beacuse each device represents separate operating
status which is independent from other devices (though
there may be some correlation in depending upon 
implementations, and how status information is maintained.)

> - should there be any tie between the data in the device info
>   package and the instance-id used for GRUU?

NO - this is not needed.

Thanks for your input. We will add some more 
clarification to the draft in the future revision.

regards,

--brijesh and mahfuz

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 07 Nov 2004 14:30:26 -0500

Brijesh,

I think this notion of device needs further exploration.

You are suggesting to equate it to AOR. But there can be multiple 
registrations against the same AOR, in which case requests for 
device-info would fork.

Also, a distinction between device and service is being worked out in 
SIMPLE. The Service corresponds to a contact address, and there can be a 
many-many relationship between service and device.

At the very least we will have major confusion if we utilize different 
notions of the granualarity of device and relationship to other things. 
So at least the names need to be changed to protect the innocent.

	Paul