Subject: RE: [Sipping] ToIP Requirements Draft

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Sun, 24 Jul 2005 21:19:53 -0400

Lawrence:
 
Let me clarify the things as follows:
 
1. If ToIP is just another application as other applications are, then it is NOT a problem as you are saying. In this case, we have to limit ourselves as we do for other applications: ToIP <--> ToIP communications. The framework document is NOT doing this. In this case, we do not need transcoding and many other things as we are saying in this framework draft. Is it clear?
 
2. The framework draft is going beyond ToIP <--> ToIP communications. It is also dealing with ToIP <--> Non-ToIP real-time communications. In this case, it mandates transcoding as well. Is this clear?
 
3. The framework document also deals with PSTN-IP GW and cellular mobile network. In the same token, it also needs to deal with wireless LAN/WiFi and cellular wireless-WiFi interworking for completeness.
 
Hope this clarifies the things.
 
Now, we like to see what are your concerns with respect to the above, if there are any.
 
Best regards,
Radhika

________________________________

From: lconroy [mailto:[email-masked]]
Sent: Sun 7/24/2005 5:03 PM
To: Guido Gybels
Cc: Roy, Radhika (AEAD); [email-masked]
Subject: Re: [Sipping] ToIP Requirements Draft

Hi Guido, Radhika, folks,

At the risk of saying "me too", I sure hope that ToIP is just another 
application. If not, then we're doing a disservice to the users, and 
throwing away a great deal of work by a number of different people 
active in this area.

SIP needs transcoding - every blasted thing needs transcoding - at 
the risk of being just as painfully repetitive as the previous mails, 
so what? That's why there's a transcoding draft.

We are years beyond individual customised islands of klunky cobbled-
together kit with a N! Babel of boxes needed to interconnect these. 
This framework shows just how simple things can be, and quite 
correctly does not drift off into things that are general parts of 
the overall XoIP architecture.

Please don't change the ToIP framework document - it does what it 
says on the tin.

all the best,
   Lawrence

On 24 Jul 2005, at 11:21, Guido Gybels wrote:
> Radhika,
<snip>
> <<ToIP is just another application>>
> And that is exactly what it should be. We haven't worked for years 
> to mainstream ToIP only to now decide to go back to the "niche 
> market" situation.
>
> <<ToIP framework mandates that transcodings must be provided. So, 
> the framework MUST reflect with the requirements considering 
> transcoding as a part of it. By the way, the transcoding in SIP is 
> an "indirect" outcome of this requirements. This important 
> functional entity imposes new requirements for signaling, media 
> transport, and QOS.>>
>
> I can't parse the above sorry. And you missed my point: by 
> definition, the framework can only refer to specific SIP based 
> mechanisms for transcoding, it can and MUST NOT establish a 
> separate one. I am not aware of any *new* requirements that would 
> be needed other than the ones already part of the work people like 
> Gonzalo and Arnoud have been doing as part of the transcoding work.
<snip>
> <<The above clarifications provide you the clear idea what I have 
> been suggesting.>>
>
> Sorry, it failed to give me any clear idea whatsoever. I simply do 
> not agree with the assertion that ToIP should introduce its own 
> specific mechanisms for dealing with things like transcoding. If 
> you believe that text media needs any specific attention with 
> regard to transcoding, then the transcoding drafts are the ones you 
> need to target, not the ToIP one.
<snip>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 25 Jul 2005 07:18:41 -0700

Unfortunately the IP-nonIP cases are a mess as with all other applications
and ToIP cannot avoid it as well as Guido says. This should give everybody
an incentive to move to IP-IP everything, including VoIP and ToIP ASAP. True
e2e IP with no evil intermediaries.

Thansk, Henry  

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roy, Radhika (AEAD)
Sent: Sunday, July 24, 2005 6:20 PM
To: lconroy; Guido Gybels
Cc: [email-masked]
Subject: RE: [Sipping] ToIP Requirements Draft

Lawrence:

1. If ToIP is just another application as other applications are, then it is
NOT a problem as you are saying. In this case, we have to limit ourselves as
we do for other applications: ToIP <--> ToIP communications. The framework
document is NOT doing this. In this case, we do not need transcoding and
many other things as we are saying in this framework draft. Is it clear?

2. The framework draft is going beyond ToIP <--> ToIP communications. It is
also dealing with ToIP <--> Non-ToIP real-time communications. In this case,
it mandates transcoding as well. Is this clear?

3. The framework document also deals with PSTN-IP GW and cellular mobile
network. In the same token, it also needs to deal with wireless LAN/WiFi and
cellular wireless-WiFi interworking for completeness.

Now, we like to see what are your concerns with respect to the above, if
there are any.

Best regards,

Radhika

  _____  

all the best,
   Lawrence

<snip>
<snip>
<snip>