Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 25 Jul 2005 13:04:39 -0400

Replace "community" with "carrier" and "edge proxy" with "session border
controller" and you'll see that it starts to quack and waddle the same.

Mike

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]] 
> Sent: Monday, July 25, 2005 11:24 AM
> To: Michael Hammer (mhammer); [email-masked]; 'Dean Willis'
> Cc: [email-masked]
> Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
> Mike,
> 
> >Could someone clarify what the difference is between "inter-domain 
> >interface" and "NNI" used in the "voip peering" sense?
> 
> It seems that VoIP peering, see 
> http://darkwing.uoregon.edu/~llynch/voipeer/
> is very different from Inter-Domain Requirements for 
> SIP/SIMPLE, see 
> http://www.ietf.org/internet-drafts/draft-levin-simple-interdo
> main-reqs-02.t
> xt  
> 
> This will make the BOF on VoIP peering interesting to attend 
> and that was one reason why I had suggested Inter-Domain 
> Requirements for SIP/SIMPLE should be made a SIPPING WG item, 
> so as to bring clarity to the matter.
> (Maybe NNI just makes no sense at all, so why trying to 
> understand it :->)
> 
> Thanks, Henry
> 
>  
> 
> -----Original Message-----
> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Monday, July 25, 2005 7:44 AM
> To: [email-masked]; Dean Willis; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
> Henry,
> 
> Could someone clarify what the difference is between 
> "inter-domain interface" and "NNI" used in the "voip peering" sense?
> 
> Note, this would be at least the 3rd group doing this type of work.
> Given that there is much basic protocol work in queue, and 
> given that there are other groups willing to do the 
> system-level work, does it make sense for SIPPING to also do 
> that work?
> 
> Mike
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of [email-masked]
> > Sent: Monday, July 25, 2005 10:19 AM
> > To: 'Dean Willis'; [email-masked]
> > Cc: [email-masked]
> > Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> > 
> > >Could we just poll the mailing list instead?
> > 
> > http://www.ietf.org/internet-drafts/draft-levin-simple-interdo
> > main-reqs-02.t
> > xt
> > 
> > What are the opinions on this list? Should it become a SIPPING WG 
> > item?
> > 
> > Thanks, Henry
> > 
> > -----Original Message-----
> > From: Dean Willis [mailto:[email-masked]]
> > Sent: Sunday, July 24, 2005 6:50 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> > 
> > 
> > On Jul 23, 2005, at 9:53 AM, Henry Sinnreich wrote:
> > 
> > > The I-D Inter-Domain Requirements for SIP/SIMPLE
> > > 
> http://www.ietf.org/internet-drafts/draft-levin-simple-interdomain-
> > > reqs-02.t
> > > xt
> > >
> > > is not only a very good document but is also very timely 
> for other 
> > > inter-domain communications, such as between all the 
> emerging VoIP 
> > > islands (the islands are a regrettable fact at present).
> > >
> > > I suggest therefore having a 5 minute hum so as to make it
> > a SIPPING WG
> > > item.
> > 
> > 
> > Henry, I'm pretty sure that if we ask the working group to 
> hum for 5 
> > minutes that the resulting anoxia would preclude further 
> useful work 
> > for the remainder of the meeting.
> > 
> > Could we just poll the mailing list instead?
> > 
> > --
> > Dean
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Henry Sinnreich" <[email-masked]>
Date: Tue, 26 Jul 2005 09:59:06 -0700

>It should definitely become a SIPPING WG item. This document is great. 

If Dean thought this request can be dismissed with a joke: We will be
persistent.

Especially in view of the VoIP Peering BOF.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Jake Salinger
Sent: Monday, July 25, 2005 7:30 AM
To: [email-masked]
Subject: Re: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

It should definitely become a SIPPING WG item. This document is great.

----- Original Message -----
From: <[email-masked]>
To: "'Dean Willis'" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 25, 2005 4:18 PM
Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

> >Could we just poll the mailing list instead?
http://www.ietf.org/internet-drafts/draft-levin-simple-interdomain-reqs-02.t
> xt
>
> What are the opinions on this list? Should it become a SIPPING WG item?
>
> Thanks, Henry
>
> > is not only a very good document but is also very timely for other
> > inter-domain communications, such as between all the emerging VoIP
> > islands
> > (the islands are a regrettable fact at present).
> >
> > I suggest therefore having a 5 minute hum so as to make it a SIPPING WG
> > item.
>
>
> Henry, I'm pretty sure that if we ask the working group to hum for 5
> minutes that the resulting anoxia would preclude further useful work

---

From: "Orit Levin" <[email-masked]>
Date: Tue, 26 Jul 2005 14:05:25 -0700

We (i.e. the co-authors) obviously think that the document is useful. It
has served us very well as a working tool for deploying public to
enterprise IM connectivity. We are still constantly referring our
customers and competitors interested in this type of interconnection to
it.

We planned to present the draft at SIMPLE or SIPPING, but currently
there are no time slots available on either. The reason for presenting
the draft was to figure out the best way forward: an individual
informational RFC vs. a WG BCP. In other words, we wanted to raise the
exact three questions that Michael is asking below in his email.

Regarding presenting the draft at the VoIP Peering BoF - the authors
feel very hesitant about it. For the "profile" and the specific SIMPLE
requirements talked about in this draft - there is really no need to
establish a new WG. We believe that they all naturally fall under SIP
and SIMPLE. It is true that Service Providers will most probably need a
similar profile as a part of their connectivity but they are currently
looking for a much broader scope - beyond the standard SIP/SIMPLE.

I am bcc-ing SIMPLE as well, but let's keep this thread on SIPPING.

Thanks,
Orit.

> [mailto:[email-masked]] On Behalf Of Michael Hammer 
> (mhammer)
> Sent: Tuesday, July 26, 2005 11:03 AM
> To: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; Jake Salinger; [email-masked]; 
> Dean Willis
> I too agree that there is some good information in this 
> document.  But, my question to the group is whether that is 
> sufficient reason for the group to take on this *type* of 
> work.  My impression is that in the past such work was deemed 
> out of scope.  (Implementation-oriented, "we don't do 
> profiles", etc.)  The questions that should be addressed before this
> one:
> 
> 1.  Will adding this to the workload delay existing WG items further?
> 
> 2.  Will adding this to the workload preclude other more core 
> protocol work from being added as WG items and addressed in a 
> timely fashion?
> 
> 3.  How will this group deal with other fora that are doing 
> similar work?
> 
> Perhaps the VoIP Peering BoF will also touch on the above.
> 
> Mike
> 
> 
> > [mailto:[email-masked]] On Behalf Of Henry Sinnreich
> > Sent: Tuesday, July 26, 2005 12:59 PM
> > To: [email-masked]; [email-masked]; 
> [email-masked]; 
> > [email-masked]
> > Cc: [email-masked]; 'Jake Salinger'; 
> [email-masked]; 'Dean 
> > Willis'
> > Subject: FW: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> > 
> > 
> > [mailto:[email-masked]] On Behalf Of Jake Salinger
> > > > I suggest therefore having a 5 minute hum so as to make
> > it a SIPPING
> > > > WG item.
> > >
> > >
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: "Khan, Sohel Q [NTK]" <[email-masked]>
Date: Wed, 27 Jul 2005 09:48:31 -0500

I share the same opinion of the following from Avshalom.

Thanks.

Sohel Khan

Sprint-TR&D

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Avshalom Houri
Sent: Wednesday, July 27, 2005 8:50 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

Being one of the authors of the draft it is not surprising that I fully 
agree with you. Thanks for your support. 

I want to emphasize several points: 

* The IETF can not expect that defining a protocol is the end of the
work. 
presence and IM and other protocols that the IETF is currently defining
are in 
a much higher level then TCP or UDP or any network protocol. The interop

issues are not only technical but imply a lot of other concerns that
need to be 
solved in order have a real interop. 

* SIP interoperability is not flying. It is very hard to do when
components from 
different companies are involved and it is very hard to do when several 
communities are involved. It is actually impossible to do without
negotiating 
what will be that actual interop and what will be allowed and what will
not be 
allowed. I may be wrong but it seems that the shift from peer to peer or
a single 
deployment paradigm to interoperability between enterprises and
different 
deployment have not happened yet. 

We need to get these kind of items to the top priority of the SIPPING
working 
group even in the expense of not adding new features to SIP in order to
make sure 
that SIP will really be something that all will feel convenient
regarding its 
interoperability. 

Avshalom 

Henry Sinnreich wrote on 27/07/2005 03:42:22 PM:

> Mike,
> 
> >question to the group is whether that is sufficient reason 
> >for the group to take on this *type* of work
> 
> Internet communications are a prime focus of the IETF, otherwise we
would
> not have all the WGs: SIP, SIPPING, SIMPLE, IPTEL, MMUSIC, AVT, etc.
dealing
> with this and related topics.
> 
> The practical results, though impressive, are however overshadowed by
the
> fact that almost all SIP communication islands interconenct only using
the
> PSTN. This is nothing short of scandalous and should be a real source
of
> concern to the IETF.
> 
> The industry has now forwarded two proposals, that are conceptually on
the
> opposite side of the solutions spectrum:
> 
> - The Internet-wide Inter-Domain Requirements for SIP/SIMPLE, and
>  
>
http://www.ietf.org/internet-drafts/draft-levin-simple-interdomain-reqs-
02.t
> xt 
> 
> - The (3GPP-IMS inspired?) SBC based architecture as proposed in the
VoIP
> Peering BOF
> Given this state of affairs, the proposed Inter-Domain Requirements
for
> SIP/SIMPLE should be IMHO on the top of the list of the SIPPING WG.
> 
> Thanks, Henry
> 
> 
> 
>  
> 
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; Jake Salinger; [email-masked]; Dean
Willis
> I too agree that there is some good information in this document.
But,
> my question to the group is whether that is sufficient reason for the
> group to take on this *type* of work.  My impression is that in the
past
> such work was deemed out of scope.  (Implementation-oriented, "we
don't
> do profiles", etc.)  The questions that should be addressed before
this
> 2.  Will adding this to the workload preclude other more core protocol
> work from being added as WG items and addressed in a timely fashion?
> 
> 3.  How will this group deal with other fora that are doing similar
> work?
>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 27 Jul 2005 16:47:52 -0400

Henry,
 
Depends on:
- what you think the "Internet" is,
- what you mean by "advance", and
- what you mean by "e2e".  :)
 
You seem to be excluding all the domains operated by some service
providers.
You clearly don't think all service providers are advancing.
You might intend e2e=p2p, in which case maybe all proxies go away too.
 
So my answer is probably yes (and no).  But, seriously I would hope that
participation in those groups would strive to be as close to principles,
while still enabling the service providers who invest capital and
operating expenses in making the Internet work to also provide an ROI to
their investors and avoid an Internet Tragedy of the Commons.
 
Mike

________________________________

	From: Henry Sinnreich [mailto:[email-masked]] 
	Sent: Wednesday, July 27, 2005 3:01 PM
	To: Michael Hammer (mhammer); 'Avshalom Houri'
	Cc: [email-masked]
	Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

	Mike,

	I don't get it:

	>ITU-T is working on this.  

	>ATIS is working on this.  

	>ETSI TISPAN is working on this.  

	>3GPP is working on this.  

	>3GPP2 is working on this.  

	Do you mean these organizations are working to advance the
Internet (and its e2e principle)?

	Thanks, Henry

________________________________

	From: Michael Hammer (mhammer) [mailto:[email-masked]] 
	Sent: Wednesday, July 27, 2005 9:48 AM
	To: Avshalom Houri; [email-masked]
	Cc: [email-masked]
	Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

	I agree whole-heartedly with Henry that reliance on the PSTN to
interconnect SIP islands is not the way to go.  However, I believe that
this is a near-term reality.  Many groups (service providers and
standards fora) throughout the world have been working on ways to
interconnect SIP networks for some time now.  It does take time to do
this right.  Tinker-toy networks can be slapped together overnight; but,
ironclad national infrastructures require more thorough examination.
That system-level architectural work is already in-progress, and there
may be more than just the two models Henry cites.

	The IETF has in the past avoided this type of work by declaring
it unnecessary.  I'm glad to see the recognition now that it is needed.
But, here is the issue:  

	ITU-T is working on this.  

	ATIS is working on this.  

	ETSI TISPAN is working on this.  

	3GPP is working on this.  

	3GPP2 is working on this.  

	SIP Forum is working on this.  

	MSF is working on this.

	And probably more I have missed.

	How do you slow down a project?  Add another programmer.

	How do you slow down a standard?  Add another standards forum.

	I suspect that it is the same set of folks going to yet another
set of meetings, using another set of procedures and tools.  I have
noticed that folks are attending IETF meetings to address specific
protocol needs.  I am just wondering if the reverse might also help.  If
you don't like the way the architectures are progressing, show up at the
meetings and convince the group otherwise.  From some of the names I
have seen attending, I think that is already happening.  What adding
this work to SIPPING suggests is that the collaboration agreements
between IETF and say ITU are not working to their full potential.
Perhaps the ADs who worked so hard to forge those ought to be asking why
not.

	Mike

________________________________

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Avshalom Houri
		Sent: Wednesday, July 27, 2005 9:50 AM
		To: [email-masked]
		Cc: [email-masked]
		Subject: RE: [Sipping] Inter-Domain Requirements for
SIP/SIMPLE

		Being one of the authors of the draft it is not
surprising that I fully 
		agree with you. Thanks for your support. 

		* The IETF can not expect that defining a protocol is
the end of the work. 
		presence and IM and other protocols that the IETF is
currently defining are in 
		a much higher level then TCP or UDP or any network
protocol. The interop 
		issues are not only technical but imply a lot of other
concerns that need to be 
		solved in order have a real interop. 
		
		* SIP interoperability is not flying. It is very hard to
do when components from 
		different companies are involved and it is very hard to
do when several 
		communities are involved. It is actually impossible to
do without negotiating 
		what will be that actual interop and what will be
allowed and what will not be 
		allowed. I may be wrong but it seems that the shift from
peer to peer or a single 
		deployment paradigm to interoperability between
enterprises and different 
		deployment have not happened yet. 
		
		We need to get these kind of items to the top priority
of the SIPPING working 
		group even in the expense of not adding new features to
SIP in order to make sure 
		that SIP will really be something that all will feel
convenient regarding its 
		interoperability. 
		
		Avshalom 

		Henry Sinnreich wrote on 27/07/2005 03:42:22 PM:
		
		> Internet communications are a prime focus of the IETF,
otherwise we would
		> not have all the WGs: SIP, SIPPING, SIMPLE, IPTEL,
MMUSIC, AVT, etc. dealing
		> The practical results, though impressive, are however
overshadowed by the
		> fact that almost all SIP communication islands
interconenct only using the
		> PSTN. This is nothing short of scandalous and should
be a real source of
		> concern to the IETF.
		> 
		> The industry has now forwarded two proposals, that are
conceptually on the
		> xt 
		> 
		> - The (3GPP-IMS inspired?) SBC based architecture as
proposed in the VoIP
		> Given this state of affairs, the proposed Inter-Domain
Requirements for
		> To: [email-masked]; [email-masked];
[email-masked];
		> Cc: [email-masked]; Jake Salinger;
[email-masked]; Dean Willis
		> I too agree that there is some good information in
this document.  But,
		> group to take on this *type* of work.  My impression
is that in the past
		> such work was deemed out of scope.
(Implementation-oriented, "we don't
		> do profiles", etc.)  The questions that should be
addressed before this

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 29 Jul 2005 21:48:28 +0300

Henry,

I suggest that the chairs introduce this draft at the beginning of the 
meeing (we will do this with a number of other drafts). We can then have 
discussions on whether or not this is something we want to tackle in 
SIPPING.

We would appreciate if the authors could send the chairs one or maximum 
two slides presenting the draft.

Thanks,

Gonzalo

Henry Sinnreich wrote:
> Gonzalo,
> 
> Since several people here on the list also consider the I-D should be 
> the top agenda item for the SIPPING GW meeting, see
> 
> http://www.softarmor.com/sipping/meets/ietf63/agenda.html
> 
> What if we choose a simple criteria: Drop some items that are new and 
> have version 00 and/or 01 and make adequate time to discuss if the 
> Inter-Domain Requirements for SIP/SIMPLE should be made a WG item.
> 
> My sincere apology to the well deserved authors of the I-Ds that may be 
> affected, but what is the purpose of perfecting something that we cannot 
> use between different Internet domains?
> 
> Thanks, Henry
> 
> ------------------------------------------------------------------------
> 
> *From:* Avshalom Houri [mailto:[email-masked]]
> *Sent:* Wednesday, July 27, 2005 8:50 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
>  
> 
> 
> 
> * The IETF can not expect that defining a protocol is the end of the work.
> deployment paradigm to interoperability between enterprises and different
>>  Internet communications are a prime focus of the IETF, otherwise we would
>>  The practical results, though impressive, are however overshadowed by the
>>  fact that almost all SIP communication islands interconenct only using the
>>  PSTN. This is nothing short of scandalous and should be a real source of
>>  concern to the IETF.
>>
>>  The industry has now forwarded two proposals, that are conceptually on the
>>  - The (3GPP-IMS inspired?) SBC based architecture as proposed in the VoIP
>>  Peering BOF
>>  Given this state of affairs, the proposed Inter-Domain Requirements for
>>  Cc: [email-masked]; Jake Salinger; [email-masked]; Dean Willis
>>  I too agree that there is some good information in this document.  But,
>>  group to take on this *type* of work.  My impression is that in the past
>>  such work was deemed out of scope.  (Implementation-oriented, "we don't
>>  do profiles", etc.)  The questions that should be addressed before this
>>  one:
>>
> ------------------------------------------------------------------------
> 
> Subject:
> RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> From:
> "Khan, Sohel Q [NTK]" <[email-masked]>
> Date:
> Wed, 27 Jul 2005 09:48:31 -0500
> To:
> "Avshalom Houri" <[email-masked]>, <[email-masked]>
> 
> To:
> "Avshalom Houri" <[email-masked]>, <[email-masked]>
> CC:
> <[email-masked]>
> 
> 
> Sprint—TR&D
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Avshalom Houri
> *Sent:* Wednesday, July 27, 2005 8:50 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
>  
> 
> 
> 
> * The IETF can not expect that defining a protocol is the end of the work.
> deployment paradigm to interoperability between enterprises and different
>>  Internet communications are a prime focus of the IETF, otherwise we would
>>  The practical results, though impressive, are however overshadowed by the
>>  fact that almost all SIP communication islands interconenct only using the
>>  PSTN. This is nothing short of scandalous and should be a real source of
>>  concern to the IETF.
>>
>>  The industry has now forwarded two proposals, that are conceptually on the
>>  - The (3GPP-IMS inspired?) SBC based architecture as proposed in the VoIP
>>  Peering BOF
>>  Given this state of affairs, the proposed Inter-Domain Requirements for
>>  Cc: [email-masked]; Jake Salinger; [email-masked]; Dean Willis
>>  I too agree that there is some good information in this document.  But,
>>  group to take on this *type* of work.  My impression is that in the past
>>  such work was deemed out of scope.  (Implementation-oriented, "we don't
>>  do profiles", etc.)  The questions that should be addressed before this
>>  one:
>>

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo