Subject: [Sipping] mingqiang-sipping-session-mobility-media-00

From: "Cullen Jennings" <[email-masked]>
Date: Fri, 29 Jul 2005 23:47:58 -0400

Seems like a better solution might be to have something like ...

A invites B and sets up session relaying media to B over the PAN like you
have now.

Then A sends Refer to CN.
CN sends INVITE with Replaces to B.
B sees that this is replacing the session with from A and waits until it has
the new session all buffered and streaming nicely then switches.
B sends BYE to A to end the original session.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Xu Ming Qiang(徐明強)<[email-masked]>
Date: Mon, 1 Aug 2005 02:25:29 +0900

Hi, Cullen,

Thanks for your suggestion.

It should be a good solution for session mobility.
But the delay caused by buffering will still be perceived
by user because device B has to wait until it has buffered
the media before switches. That is why we proposed to
forward the data to device B previously before session
transfer.

Thanks and regards

Xu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Cullen Jennings
Sent: Saturday, July 30, 2005 12:48 PM
To: [email-masked]
Subject: [Sipping] mingqiang-sipping-session-mobility-media-00

A invites B and sets up session relaying media to B over the PAN like
you
have now.

B sees that this is replacing the session with from A and waits until it
has