Subject: [Sipping] New draft on exceptional procedure call flow examples

From: Miki HASEBE <[email-masked]>
Date: Thu, 14 Jul 2005 10:51:41 +0900

Folks,

I would like to bring the attention of the group to a new internet
draft on exceptional-procedure call flow examples.
This draft is the update of semi-regular call flow examples.
I changed the title and added four sequences to the draft.

I had been thinking of the new title because
the meaning of "Semi Regular" is unclear.
Although there was also a proposals called
"race condition" or "glare condition",
I found the expression of "Exceptional Procedure" in
other standard documents, so I adapted the phrase.
- original title : "Session Initiation Protocol Semi Regular Examples"
- new title : "Session Initiation Protocol Exceptional Procedure Examples"

The draft can be found at
http://www.ietf.org/internet-drafts/draft-hasebe-sipping-exceptional-procedure-example-00.txt
I'll appreciate any comments and thoughts.

Regards,
Miki HASEBE

Forwarded by HASEBE Miki <[email-masked]>
----------------------- Original Message -----------------------
A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title: Session Initiation Protocol Exceptional
                          Procedure Examples
Author(s): M. Hasebe, et al.
Filename: draft-hasebe-sipping-exceptional-procedure-example-00.txt
Pages: 50
Date: 2005-7-12

   This document gives examples of Session Initiation Protocol (SIP)
   exceptional-procedure call flows. This is the problem (or
   confusing) scenario and this is the best practice to handle it. 
   The elements in these call flows include SIP User Agents and
   Clients. The scenarios include SIP session establishment. Call
   flow diagrams and message details are shown.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hasebe-sipping-exceptional-procedure-example-00.txt

To remove yourself from the I-D Announcement list, send a message to 
i-d-announce-request at ietf.org with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
"get draft-hasebe-sipping-exceptional-procedure-example-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
mailserv at ietf.org.
In the body type:
"FILE /internet-drafts/draft-hasebe-sipping-exceptional-procedure-example-00.txt".

NOTE:The mail server at ietf.org can return the document in
MIME-encoded form by using the "mpack" utility.  To use this
feature, insert the command "ENCODING mime" before the "FILE"
command.  To decode the response(s), you will need "munpack" or
a MIME-compliant mail reader.  Different MIME-compliant mail readers
exhibit different behavior, especially when dealing with
"multipart" MIME messages (i.e. documents which have been split
up into multiple messages), so check your local documentation on
how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
--------------------- Original Message Ends --------------------

---------------------------------------------------------
Miki HASEBE
Research and Development Center
NTT-east Corporation

Telephone  +81 3 5359 5104
Facsimile  +81 3 5359 4768
E-mail: [email-masked]
19-2 Nishi-shinjuku 3-chome Shinjuku-ku Tokyo 163-8019 Japan
---------------------------------------------------------

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Darshan Bildikar <[email-masked]>
Date: Thu, 14 Jul 2005 14:48:21 +0530

Just one comment. 

In your early dialog example, there seem to be two answers to the initial
offer (to Alice). SDP 3 should be a new offer in an UPDATE message which
should be forwarded and the answer to that should be forwarded in the ACK to
Carol.  

Can the 180 with tag 2 to alice contain a new offer? (with an incremented
RSeq)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Miki HASEBE
Sent: Thursday, July 14, 2005 7:22 AM
To: [email-masked]
Subject: [Sipping] New draft on exceptional procedure call flow examples

Folks,

The draft can be found at
http://www.ietf.org/internet-drafts/draft-hasebe-sipping-exceptional-procedu
re-example-00.txt
I'll appreciate any comments and thoughts.

Regards,
Miki HASEBE

----------------------- Original Message -----------------------
A New Internet-Draft is available from the on-line Internet-Drafts
directories.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hasebe-sipping-exceptional-procedu
re-example-00.txt

To remove yourself from the I-D Announcement list, send a message to 
i-d-announce-request at ietf.org with the word unsubscribe in the body of
the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Send a message to:
mailserv at ietf.org.
In the body type:
"FILE
/internet-drafts/draft-hasebe-sipping-exceptional-procedure-example-00.txt".

---

From: Miki HASEBE <[email-masked]>
Date: Tue, 19 Jul 2005 18:04:52 +0900

> Can the 180 with tag 2 to alice contain a new offer? (with an incremented

My understanding is that multiple ealy dialogs and sessions
can be established even though the initial INVITE includes
only one offer.
Therefore, you don't have to send an UPDATE with a new offer of SDP.

The SDP in first 180 response from Carol will be the answer to
ini-INVITE although it is allowed to include SDP with the 180 response.
(When there is no offer in the ini-INVITE,
you may copy an offer of 200 OK to 180)  

Please let me know if you have any additional sequences.

Regards,

Miki