Subject: Re: RE : [Sipping] Voicemail in P2P SIP systems

From: Cullen Jennings <[email-masked]>
Date: Tue, 12 Jul 2005 08:31:01 -0400

And to think that I thought a P2P voicemail systems was a device called an
answering machine  - I did not realize it was so complex :-)

On 4/2/05 1:22 AM, "JESTIN Jean-Francois RD-CORE-LAN"
<[email-masked]> wrote:

> 
> I completely agree with Brian that voicemail question is related to producing
> a P2P SIP system.
> In fact the question can be generalized to: "how render services (voicemail,
> call transfer when unregistered and many others, see SIP services examples
> draft) with SIP in a P2P?".
> This is obvious that in a centralized system, services logic can be located on
> top of the proxy: how ensure the same level (availability, scalability,
> diversity without replicating all the services in all the UA !,...) of
> services in a P2P SIP system ?
> I think this is the main challenge (maybe with authentication) of a P2P SIP
> system.
> 
> Nevertheless concerning Voicemail, the first solution I see is to store the
> message and starting duplicate it from the caller UA.
> 
> Best Regards
> 
> Jean-Francois
> 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Philip Matthews
> Envoyé : vendredi 1 avril 2005 20:31
> À : Seamus Gilchrist
> Cc : Sipping
> Objet : [Sipping] Voicemail in P2P SIP systems
> 
> Brian Rosen wrote:
>> We can, if you want, start a thread on how you might make a completely
>> distributed voicemail system, but that is a completely different problem
>> from a P2P SIP system.
> 
> Though I don't agree that the voicemail question is unrelated to
> producing a P2P SIP system, I am happy to start a separate thread
> on the topic to make things easier for other readers of this list.
> 
> 
> Seamus Gilchrist wrote:
>> The problem would seem to be making sure that the resource (the PC) or
>> resources in the case that the voice mail is partially stored on a number
>> of
>> machines, is available when you want to retrieve the voice mail from it.
>> And since it is not really feasible to do this, P2P voice mail service
>> might
>> need to be hosted (and possibly replicated) on some number of reliable
>> PCs.
>> 
> 
> I completely agree that, to increase the reliability of the voicemail system,
> there needs to be multiple copies of the message stored on different PCs
> (or hard phones or whatever).
> 
> 
> - Philip
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Tue, 12 Jul 2005 08:15:41 -0500

An implementation for offline messages is given with some detail in

http://www1.cs.columbia.edu/~library/TR-repository/reports/reports-2004/cucs
-044-04.pdf  

P2P voice mail can be experienced first hand using Skype :-)

Thanks, Henry