Subject: [Sipping] RE: I-D ACTION:draft-jennings-sipping-pay-02.txt

From: [email-masked]
Date: Wed, 20 Jul 2005 10:17:20 -0500

This is an interesting proposal and deserves some attention.

The title of the ID could be better chosen, even if longer or by some
abbreviation, so as to indicate it is an option from SPIT prevention and not
for VoIP payments which are either flat rate (mostly) or have some complex
3rd party business models.

Also, in the introduction, a short comparison with other SPIT prevention
mechanism would be helpful, as well as presenting the motivation for
choosing this particular approach.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, July 19, 2005 2:50 PM
To: [email-masked]
Subject: I-D ACTION:draft-jennings-sipping-pay-02.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Payment for Services in Session Initiation
                          Protocol (SIP)
	Author(s)	: C. Jennings, et al.
	Filename	: draft-jennings-sipping-pay-02.txt
	Pages		: 22
	Date		: 2005-7-19
	
Communication systems require that a person receiving a call be able
   able to charge the caller when they are from different administrative
   domains.  This is necessary for making fair exchanges of service
   between two different communicating parties and is a major strategy
   for reducing the viability of SPAM.  This draft proposes an approach
   for doing this in SIP.  The approach relies on a third party to act
   as a payment service provider and is optimized for very simple, low
   value transactions.  It does not provide the full range of services
   that are desirable in typical online trading systems.

   This draft is being discussed on the [email-masked] mailing list.
   There is currently work to substantially change this draft to use
   SAML.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-jennings-sipping-pay-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-jennings-sipping-pay-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-jennings-sipping-pay-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Wed, 20 Jul 2005 19:16:10 +0200

henry, 

i forgot to mention one issue:

the fact that the customer is offered a flat rate still requires authentication and authorization of the user. 
there is only the question of how to perform the message exchange. 

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: Henry Sinnreich [mailto:[email-masked]] 
> Gesendet: Mittwoch, 20. Juli 2005 18:48
> An: Tschofenig, Hannes; [email-masked]; 'sipping WG'
> Betreff: RE: [Sipping] RE: I-D 
> ACTION:draft-jennings-sipping-pay-02.txt 
> 
> 
> >could you elaborate a bit more on your statement about 
> >voip payments using either flat rate or complex 3rd party 
> business models?
> 
> Most VoIP consumer services on the market have flat rates, 
> such as $20/month
> unlimited. See for example http://www.packet8.net/ 
> (unlimited) that I happen
> to use. Many PSTN consumer services are also flat rate, see 
> for example
> http://consumer.mci.com/TheNeighborhood/res_local_service/jsps
> /default.jsp 
> 
> There are also many mobile services with flat rate, such as
> http://sprintpcs.com/ 
> 
> My apology for picking service examples I am most familiar with.
> 
> Third party consumer-business payment models could involve a 
> search engine
> to deliver product information along some advertismens and finally a
> click-to-call service to connect the buyer with the seller. 
> Such calls are
> obviously much more valuable to the seller and the revenue 
> sharing models
> are an interesting topic apart.
> 
> I would be still interested in the motivation for choosing 
> the particular
> approach in this I-D as well as the pros and cons, though the 
> reference
> <draft-ietf-sipping-spam-00.txt> is most welcome. This is more of a
> discussion paper after all, since no experimental data are 
> available, as
> required for a standards track document.
> 
> Last but not least, these nits are only meant to enahnce the 
> proposal that I
> believe is very interesting.
> 
> Thanks, Henry
> 
>  
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Tschofenig, Hannes
> Sent: Wednesday, July 20, 2005 10:50 AM
> To: [email-masked]; sipping WG
> Subject: AW: [Sipping] RE: I-D 
> ACTION:draft-jennings-sipping-pay-02.txt 
> 
> hi henry, 
> 
> thanks for pointing to the draft. 
> i think a comparison with other spit proposals is not really 
> necessary given
> the detailed description in 
> <draft-ietf-sipping-spam-00.txt> 
> 
> could you elaborate a bit more on your statement about voip 
> payments using
> either flat rate or complex 3rd party business models?
> 
> ciao
> hannes
> 
> > -----Ursprüngliche Nachricht-----
> > Von: [email-masked] 
> > [mailto:[email-masked]] Im Auftrag von [email-masked]
> > Gesendet: Mittwoch, 20. Juli 2005 17:17
> > An: 'sipping WG'
> > Betreff: [Sipping] RE: I-D ACTION:draft-jennings-sipping-pay-02.txt 
> > 
> > 
> > You can also visit 
> > https://www1.ietf.org/mailman/listinfo/I-D-announce