Subject: [Sipping] SIP - P2P Doubt

From: "Tarun Abhichandani" <[email-masked]>
Date: Mon, 25 Jul 2005 16:48:33 -0700

The Internet-Draft, A P2P Approach to SIP Registration, recommends altering SIP headers to implement DHT operations for P2P infrastructure. What SIP registration does is to bind Uri to IP address location. But DHTs do this in a more efficient way. So can we separate URI binding and lookup done via DHT but once we know the IP address, we directly contact the destination via INVITE?

A node would advertise its IP address as node key, using put and get DHT functionalities. A node supplies SIPURI - key and IP address - value, as a form of registration through DHT. Another node in DHT is responsible for this binding. 

I guess the question I have is that if P2P using DHTs turn out to be more efficient for some scenarios, why do we even need SIP? Is it because its a standard?

Thanks,

Tarun

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Marc Bailly <[email-masked]>
Date: Tue, 26 Jul 2005 10:03:57 +0200

Hi Tarun,

Here are some advantages which have been mentionned of using SIP protocol to 
implement the DHT algorithm :
- 

no dependance on external P2P project
- easier to standardize

n 
 - P2P messages using SIP protocol can be distinguished from other classic 
P2P protocols. No risk to be rejected.
- built-in NAT/media relays

Here are some drawbacks :
- SIP transport has a high overhead and transactional state cost.
- It doesn't leave the P2P layer independent of SIP. Thus the P2P layer 
doesn't beneficiate from the latest optimizations of P2P algorithm. The DHT 
can not be used for other applications that run on the devices in the 
network that have nothing to do with SIP. 

Regards

Marc Bailly

On 7/26/05, Tarun Abhichandani <[email-masked]> wrote:
> 
> The Internet-Draft, A P2P Approach to SIP Registration, recommends 
> altering SIP headers to implement DHT operations for P2P infrastructure. 
> What SIP registration does is to bind Uri to IP address location. But DHTs 
> do this in a more efficient way. So can we separate URI binding and lookup 
> done via DHT but once we know the IP address, we directly contact the 
> destination via INVITE?
> 
> A node would advertise its IP address as node key, using put and get DHT 
> functionalities. A node supplies SIPURI - key and IP address - value, as a 
> form of registration through DHT. Another node in DHT is responsible for 
> this binding. 
> 
> I guess the question I have is that if P2P using DHTs turn out to be more 
> efficient for some scenarios, why do we even need SIP? Is it because its a 
> standard?
> 
> Thanks,
> 
> Tarun
>  

-- 
-------------------
Marc Bailly

---

From: "Brijesh Kumar" <[email-masked]>
Date: Tue, 26 Jul 2005 10:29:45 -0400

Tarun:

You raised some interesting points.

Here are the two core models possible for P2P:

- P2P with SIP
- SIP over P2P

The David and Cullen's P2P draft uses the first approach of P2P 
with SIP. This model is what they call in the industry "vertical integration" - i.e.,
no dependence on any thing outside your domain. The design can
specify every thing how to maintain DHT, and use it to locate the other
end of the communication and for message routing.

SIP over P2P, on the other hand is an example of "horizontal integration" 
- basically do what you know best and leave the rest to others that know 
it the best. The problem  here, at present, is that there is no "standard" 
way to do P2P. Even though some people  believe that this may be a 
more efficient way to do P2P SIP, this is likely to be highly contentious 
model for any standardization effort in IETF.

cheers,

--brijesh

  ----- Original Message ----- 
  From: Tarun Abhichandani 
  To: [email-masked] 
  Sent: Monday, July 25, 2005 7:48 PM
  Subject: [Sipping] SIP - P2P Doubt

  Thanks,

  Tarun

------------------------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 26 Jul 2005 09:59:06 -0700

See also
http://ietfreport.isoc.org/ids/draft-johnston-sipping-p2p-ipcom-01.txt 

Henry

  _____  

From: Brijesh Kumar [mailto:[email-masked]] 
Sent: Tuesday, July 26, 2005 7:30 AM
To: Tarun Abhichandani; [email-masked]
Subject: Re: [Sipping] SIP - P2P Doubt

Tarun:

- P2P with SIP

- SIP over P2P

with SIP. This model is what they call in the industry "vertical
integration" - i.e.,

cheers,

--brijesh

----- Original Message ----- 

From: Tarun <mailto:[email-masked]>  Abhichandani 

To: [email-masked] 

The Internet-Draft, A P2P Approach to SIP Registration, recommends altering
SIP headers to implement DHT operations for P2P infrastructure. What SIP
registration does is to bind Uri to IP address location. But DHTs do this in
a more efficient way. So can we separate URI binding and lookup done via DHT
but once we know the IP address, we directly contact the destination via
INVITE?

Thanks,

Tarun

  _____