Subject: [Sipping] draft-ietf-sipping-cc-transfer-05 error in section 6.2?

From: "Frank Shearar" <[email-masked]>
Date: Tue, 19 Jul 2005 17:12:30 +0100

Section 6.2, message F5 looks like this:

   F5 REFER Transferor -> Transfer Target

   REFER sips:[email-masked];grid=8594958 SIP/2.0
   Via: SIP/2.0/TLS pc33.atlanta.example.com;branch=z9hG4bKnashds9
   Max-Forwards: 70
   To: <sips:[email-masked];grid=8594958>
   From: <sips:[email-masked]>;tag=1928301774
   Call-ID: a84b4c76e66710
   CSeq: 314159 REFER
   Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY
   Supported: gruu, replaces, tdialog
   Require: tdialog
   Refer-To: <sips:[email-masked];grid=3413kj2ha?Replaces=
    090459243588173445%3Bto-tag%3D31431%3Bfrom-tag%3D7553452>
    592435881734450904;local-tag=9m2n3wq;remote-tag=763231
   Contact: <sips:[email-masked];grid=723jd2d>
   Content-Length: 0

Shouldn't the third-last line say

    Target-Dialog: 592435881734450904;local-tag=9m2n3wq;remote-tag=763231

?

I thought at first it was a wrapped header, but then it'd need a leading semicolon because the Refer-To's closed its URI with an angle bracket.

frank

*******************************************************************
This email and attachments (if any) must be swept for viruses before opening. Their contents may be confidential or privileged and are intended solely for the named recipient. If you are not the intended recipient and you have received this email in error you must not read or use this email and should notify RNID on: +44 (0) 20 7296 8282.

RNID, Registered Office 19-23 Featherstone Street, London EC1Y 8SL No. 454169 (England, Registered Charity No. 207720)

********************************************************************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Johnston, Alan" <[email-masked]>
Date: Tue, 19 Jul 2005 19:28:07 +0000

Hi Frank,

You are right - the Target-Dialog header name just disappeared for some
reason ;-)

Thanks for pointing this out.

Thanks,
Alan.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Frank Shearar
> Sent: Tuesday, July 19, 2005 11:13 AM
> To: [email-masked]
> Subject: [Sipping] draft-ietf-sipping-cc-transfer-05 error in 
> section 6.2?
> 
> 
>    Refer-To: 
> <sips:[email-masked];grid=3413kj2ha?Replaces=
>     Target-Dialog: 
> I thought at first it was a wrapped header, but then it'd 
> need a leading semicolon because the Refer-To's closed its 
> URI with an angle bracket.
> 
> frank
> 
> 
> This email and attachments (if any) must be swept for viruses 
> before opening. Their contents may be confidential or 
> privileged and are intended solely for the named recipient. 
> If you are not the intended recipient and you have received 
> this email in error you must not read or use this email and 
> should notify RNID on: +44 (0) 20 7296 8282.
> 
>  
> 
> RNID, Registered Office 19-23 Featherstone Street, London 
> EC1Y 8SL No. 454169 (England, Registered Charity No. 207720)
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>