Subject: [Sipping] DTMF digits through RTP or INFO

From: Prince Arimboor Philip <[email-masked]>
Date: Thu, 11 May 2006 12:20:26 +0530

Hi all,

what is the recommended way of communicating the DTMF digits?

Also please tell me which is the mechanism used by most of the SIP end 
points to communicate the DTMF digits?

thanks in advance,
Prince

***********************  FSS- Confidential   ***********************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Thu, 11 May 2006 06:40:40 -0500

Prince,
 
KPML, http://tools.ietf.org/wg/sipping/draft-ietf-sipping-kpml, which is
in the RFC ed. queue, waiting for the authors final update (oh)
 
Martin

________________________________

From: Prince Arimboor Philip
[mailto:[email-masked]] 
Sent: Thursday, May 11, 2006 2:50 AM
To: [email-masked]; [email-masked]
Subject: [Sipping] DTMF digits through RTP or INFO

Hi all, 

thanks in advance, 
Prince

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 May 2006 10:29:47 -0400

There is also RFC 2833, which carries them inband. The app interaction 
framework:

http://www.ietf.org/internet-drafts/draft-ietf-sipping-app-interaction-framework-05.txt

describes the relative roles of the two.

Thanks,
Jonathan R.

Dolly, Martin C, ALABS wrote:

> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Gaurav Kulshreshtha <[email-masked]>
Date: Thu, 11 May 2006 10:55:14 -0400

Prince,
 All the VoIP equipments support RFC 2833. However for backward 
compatibilty with existing equipments they also support DTMF. So you end 
up with a configurable option on most devices.
 
Cheers
Gaurav Kulshreshtha
Jonathan Rosenberg wrote:
>> [mailto:[email-masked]] Sent: Thursday, May 
>> 11, 2006 2:50 AM
>> thanks in advance, Prince
>>
>>

---

From: Kapil Nayar <[email-masked]>
Date: Fri, 12 May 2006 17:13:43 +0100 (BST)

Prince,

RTP DTMF as per RFC 2833 is still "out of
band"...although it is sometimes referred to as inband
in context to separate signalling path.
So, you have multiple options for out-of-band -RFC
2833, SIP INFO, SIP NOTIFY. Ideally(only) from
interoperability perspective your equipment should be
prepared to receive DTMF based upon any method
(including in-band) and send it only thru' the method
published by the peer end. 
Typically, SIP level lack of support can be detected
only thru' a 5xx error which causes unacceptable delay
for transmitting DTMF on media path, therefore it
might also be a good idea to offer DTMF options as
configurable on your equipment (although this may
reduce on the fly interoperability...may be acceptable
in certain cases)

I have seen IP equipments offer RTP DTMF in SDP by
default but are prepared to receive RTP DTMF by all
means. And, would send RTP DTMF only if peer end
publishes the same in SDP else use SIP INFO method.

hope this helps,
-kapil nayar

--- Prince Arimboor Philip
<[email-masked]> wrote:

> ***********************  FSS- Confidential  
***********************>
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping

___________________________________________________________ 
Yahoo! Photos – NEW, now offering a quality print service from just 7p a photo http://uk.photos.yahoo.com