Subject: [Sipping] sipping-config-framework: "profile-type" parameter value in quotes?

From: <[email-masked]>
Date: Fri, 5 May 2006 16:11:29 +0200

Hello, 

I am not sure if the value of "profile-type" parameter of Event header
in SUBSCRIBE requests should be enclosed in quotes or not. 

draft-ietf-sipping-config-framework, par. 7.2.:

Profile-type   = "profile-type" EQUAL profile-value
   profile-value  = profile-types / token
   profile-types  = "device" / "user" / "application" / "local-network"

I'd say that no quotes should be there, but the examples later in the
draft are inconsistent. Some contain quoted values, some don't:

   Event: ua-profile;profile-type=device;
               vendor="vendor.example.com";model="Z100";version="1.2.3"

   Event: ua-profile;profile-type="user";
    vendor="premier";model="trs8000";version="5.5"

So how should it be? Or are both possibilities acceptable.

Thank you

Silvestr Peknik
Software Specialist
TietoEnator

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Rohan Mahy" <[email-masked]>
Date: Mon, 8 May 2006 16:57:28 -0700

Hi,

The profile-type should not be in quotes.

thanks,
-rohan