Subject: [Sipping] Comments on draft-wu-sipping-media-recording-00.txt

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 12 Jun 2006 15:06:24 +0300

Hi,

draft-wu-sipping-media-recording-00.txt refers to the consent documents
as presented in the last IETF. However, per the consensus reached in
that meeting, the consent mechanism has been simplified. One of the
agreed changes was to use MESSAGE requests instead of CONSENT requests.
The reason was backward compatibility.

I have already submitted the new consent drafts. Until they are
available on the archives, you can fetch a copy from:

http://users.piuha.net/gonzalo/temp/draft-ietf-sipping-consent-framework-05.txt
http://users.piuha.net/gonzalo/temp/draft-camarillo-sipping-consent-format-01.txt
http://users.piuha.net/gonzalo/temp/draft-camarillo-sipping-pending-additions-00.txt

Cheers,

Gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Xiaotao Wu" <[email-masked]>
Date: Mon, 12 Jun 2006 11:26:52 -0400

Hi Gonzelo,

Thanks for the update. I will update my draft accordingly.

About using MESSAGE requests instead of CONSENT requests,
sorry that I did not see such a discussion in the sipping mailing list.
In fact, I don't think that using MESSAGE helps much for backward
compatibility. If an entity cannot understand the consent 
document in a CONSENT request, using MESSAGE method cannot
make the entity to process the request either. 

Thanks!

BTW, the draft is not on the archives yet. A copy of the draft can
be found at
http://www1.cs.columbia.edu/~xiaotaow/draft-wu-sipping-media-recording-00.tx
t

-Xiaotao

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Monday, June 12, 2006 8:06 AM
> To: sipping
> Cc: Xiaotao Wu; 'Krishnaswamy, Venkatesh (Venkatesh)'; 'Mary 
> Barnes'; [email-masked]; [email-masked]
> Subject: Comments on draft-wu-sipping-media-recording-00.txt
> 
> Hi,
> 
> draft-wu-sipping-media-recording-00.txt refers to the consent 
> documents as presented in the last IETF. However, per the 
> consensus reached in that meeting, the consent mechanism has 
> been simplified. One of the agreed changes was to use MESSAGE 
> requests instead of CONSENT requests.
> I have already submitted the new consent drafts. Until they 
> are available on the archives, you can fetch a copy from:
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 13 Jun 2006 14:47:17 +0300

Hi,

> sorry that I did not see such a discussion in the sipping mailing list.

it is in the minutes of the last SIPPING meeting.

> make the entity to process the request either. 

that's why the MESSAGE will carry a human-readable body part as well.

Thanks,

Gonzalo