Subject: RE: [Sipping] WGLC: draft-ietf-sipping-capacity-attribute-01.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 5 Sep 2006 15:28:05 -0400

Capacity always mislead me too, even though as an English speaker I know
the alternate meaning of the word.  My fear is that those for whom
English is non-native will have a hard time.

"Role" is a simpler and probably better understood to use throughout the
document.

Mike

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]] 
> Sent: Tuesday, September 05, 2006 2:08 PM
> To: [email-masked]; 
> [email-masked]; [email-masked]
> Cc: 'Mary Barnes'
> Subject: RE: [Sipping] WGLC: 
> draft-ietf-sipping-capacity-attribute-01.txt
> 
> I have simple, but significant concern with this draft, 
> namely the word "capacity".  For those who have not read it, 
> it has nothing to do with a quantity (the capacity of the 
> room, or what I thought it might mean, something to do with 
> messages/calls per second); it has to do with implementing a 
> cc:, and bcc: mechanism.  The other word used in the document 
> is "role".
> 
> I protest that we create confusion when we choose the word 
> "capacity" for this purpose.  It is not correct to say the 
> capacity of the URI is "bcc".
> It's not even correct to say that the role is bcc.  You would 
> say "Please send this URI a blind carbon copy of the message")
> 
> There is no one nice replacement word I can think of.  I 
> suggest "copyControl".
> 
> The text doesn't even say that the purpose of the document is 
> to implement a cc and bcc mechanism.  Shouldn't it explicitly 
> say that somewhere in Section 1?
> 
> Brian
> 
> > -----Original Message-----
> > From: Mary Barnes [mailto:[email-masked]]
> > Sent: Tuesday, September 05, 2006 12:43 PM
> > To: [email-masked]
> > Subject: [Sipping] WGLC: 
> draft-ietf-sipping-capacity-attribute-01.txt
> > 
> > Hi all,
> > 
> > This is to announce Working Group Last Call on the following draft 
> > (slightly later than originally planned):
> > 
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-capacity-attrib
> > ut
> > e-01.txt
> > 
> > We would like to recruit at least 2 more volunteers to serve as 
> > dedicated reviewers.
> > If you are interested and willing to review this draft, 
> please send an 
> > email to the SIPPING chairs.  The spreadsheets tracking the 
> > reviews/deadlines will be updated shortly.
> > 
> > As always, anyone else that gets a chance to review should 
> also send 
> > their feedback to the authors and copy the SIPPING mailing list.
> > 
> > This WGLC will end on Sept 19th, 2006 (two weeks time).
> > 
> > Thanks,
> > Mary
> > SIPPING WG co-chair
> > 
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 05 Sep 2006 23:09:05 +0300

Hi,

thanks for the feedback. I do not care about the exact word we use for 
the attribute. If Brian likes "copycontrol", I would be fine with that. 
Any other suggestions for the attribute's name?

Thanks,

Gonzalo

---

From: Scott W Brim <[email-masked]>
Date: Tue, 05 Sep 2006 16:17:20 -0400

> "Role" is a simpler and probably better understood to use throughout the

I like Brian Rosen's "copyControl" better, but "role" is tolerable.

(I suspect "capacity" came from current usage such as "in my capacity
as secretary of the committee", which is probably not faithful to its
original use.)

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 06 Sep 2006 08:31:58 +0300

Point taken. We will change the name of the attribute to "copyControl", 
and as per Brian's request, we will add some text indicating that the 
purpose of this extension is to allow a cc and bcc mechanism.

Thanks for your comments.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 06 Sep 2006 08:47:24 +0300

Hi,

> as secretary of the committee", which is probably not faithful to its

yes, it came from that type of use... but we will use copycontrol instead.

Cheers,

Gonzalo

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 6 Sep 2006 08:43:35 +0200

Agree with the new term, suggestion to use "copycontrol" ("copy-control" is 
perhaps better?) only with values "cc" and "bcc", and omit "to".

Also suggest to rename the namespace 
'xmlns:cp="urn:ietf:params:xml:ns:capacity"' to 
'xmlns:cc="urn:ietf:params:xml:ns:copy-control', such that the example would 
become

<?xml version="1.0" encoding="UTF-8"?>
   <resource-lists xmlns="urn:ietf:params:xml:ns:resource-lists"
             xmlns:cc="urn:ietf:params:xml:ns:copy-control">
     <list>
       <entry uri="sip:[email-masked]"/>
       <entry uri="sip:[email-masked]" cc:anonymize="true"/>
       <entry uri="sip:[email-masked]"  cc:anonymize="true"/>
       <entry uri="sip:[email-masked]"   cc:copy-control="cc"/>
       <entry uri="sip:[email-masked]" cc:copy-control="cc" 
cc:anonymize="true"/>
       <entry uri="sip:[email-masked]"   cc:copy-control="bcc"/>
       <entry uri="sip:[email-masked]"  cc:copy-control="bcc"/>
     </list>
   </resource-lists>Regards,
Jeroen

----- Original Message ----- 
From: "Miguel Garcia" <[email-masked]>
To: "Scott W Brim" <[email-masked]>
Cc: "Mary Barnes" <[email-masked]>; <[email-masked]>; 
<[email-masked]>; "Michael Hammer (mhammer)" 
<[email-masked]>
Sent: Wednesday, September 06, 2006 7:31 AM
Subject: Re: [Sipping] WGLC: draft-ietf-sipping-capacity-attribute-01.txt

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 06 Sep 2006 09:51:58 +0300

Why should we omit "to"?

The default copycontrol is "bcc", so if we don't have to, we don't have 
the means to indicate main recipients.

/Miguel

Jeroen van Bemmel wrote:
> Agree with the new term, suggestion to use "copycontrol" ("copy-control" 
> is perhaps better?) only with values "cc" and "bcc", and omit "to".
> 
> 'xmlns:cc="urn:ietf:params:xml:ns:copy-control', such that the example 
> would become
> 
> ----- Original Message ----- From: "Miguel Garcia" 
> <[email-masked]>
>> Point taken. We will change the name of the attribute to 
>> "copyControl", and as per Brian's request, we will add some text 
>> indicating that the purpose of this extension is to allow a cc and bcc 
>> mechanism.
>>

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 6 Sep 2006 09:17:54 +0200

Miguel,

I did a quick grep on the document - "to" is only and always used in 
combination with "cc" (as in "This new URI-list includes the list of 
non-anonymous "to" and "cc" targets"). So what is the difference in 
treatment between "to" and "cc"?

If the difference is only "include in the recipient-list-history or not", I 
would suggest a Boolean value ( "bcc=true" )

Regards,

Jeroen

----- Original Message ----- 
From: "Miguel Garcia" <[email-masked]>
To: "Jeroen van Bemmel" <[email-masked]>
Cc: "Scott W Brim" <[email-masked]>; "Mary Barnes" 
<[email-masked]>; <[email-masked]>; 
<[email-masked]>; "Michael Hammer (mhammer)" 
<[email-masked]>
Sent: Wednesday, September 06, 2006 8:51 AM
Subject: Re: [Sipping] WGLC: draft-ietf-sipping-capacity-attribute-01.txt

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 6 Sep 2006 09:48:17 +0200

To answer my own question: no difference for the URI list server, but needed 
so the recipient can tell whether he was on "to" or "cc"

I wonder - for e-mail To, CC and BCC are basically a grouping of the 
addresses into 3 (possibly overlapping) lists. So what about:

<?xml version="1.0" encoding="UTF-8"?>
<resource-lists xmlns="urn:ietf:params:xml:ns:resource-lists" 
xmlns:cc="urn:ietf:params:xml:ns:copy-control">
<list name="recipients">
<list name="to">
 <entry uri="sip:[email-masked]"/>
 <entry uri="sip:[email-masked]" cc:anonymize="true"/>
 <entry uri="sip:[email-masked]"  cc:anonymize="true"/>
</list>
<list name="cc">
 <entry uri="sip:[email-masked]"/>
 <entry uri="sip:[email-masked]" cc:anonymize="true"/>
</list>
<list name="bcc">
 <entry uri="sip:[email-masked]"/>
 <entry uri="sip:[email-masked]"/>
</list>
</list>
</resource-lists>

This seems more natural to me: treatment of entries simply depends on the 
list they are in.

Regards,

Jeroen

> If the difference is only "include in the recipient-list-history or not", 
> I would suggest a Boolean value ( "bcc=true" )
>
> Regards,
>
> Jeroen
>
>>> Subject: Re: [Sipping] WGLC:

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 06 Sep 2006 10:47:26 +0300

Hi,

the difference between "to" and "cc" is well understood by email users,
even though it does not have any influence in how the email is delivered
to them. For example, this email will be equally delivered to you and to
the folks in the cc, but you are the main recipient of this email. We
would like to keep the same concept here.

Thanks,

Gonzalo

Jeroen van Bemmel wrote:
> If the difference is only "include in the recipient-list-history or 
> not", I would suggest a Boolean value ( "bcc=true" )
> 
> Regards,
> 
> Jeroen
> 
> <[email-masked]> To: "Jeroen van Bemmel"
> <[email-masked]> Cc: "Scott W Brim" <[email-masked]>; "Mary
> Barnes" <[email-masked]>; <[email-masked]>; 
> <[email-masked]> Sent: Wednesday, September 06, 2006 8:51 AM 
>> The default copycontrol is "bcc", so if we don't have to, we don't
>>  have the means to indicate main recipients.
>> 
>> /Miguel
>> 
>> Jeroen van Bemmel wrote:
>>> Agree with the new term, suggestion to use "copycontrol" 
>>> ("copy-control" is perhaps better?) only with values "cc" and
>>> "bcc", and omit "to".
>>> 
>>> 'xmlns:cc="urn:ietf:params:xml:ns:copy-control', such that the 
>>> example would become
>>> 
>>> <?xml version="1.0" encoding="UTF-8"?> <resource-lists
>>> xmlns="urn:ietf:params:xml:ns:resource-lists" 
>>> xmlns:cc="urn:ietf:params:xml:ns:copy-control"> <list> <entry
>>> uri="sip:[email-masked]"/> <entry uri="sip:[email-masked]"
>>> cc:anonymize="true"/> <entry uri="sip:[email-masked]"
>>> cc:anonymize="true"/> <entry uri="sip:[email-masked]"
>>> cc:copy-control="cc"/> <entry uri="sip:[email-masked]"
>>> cc:copy-control="cc" cc:anonymize="true"/> <entry
>>> uri="sip:[email-masked]"   cc:copy-control="bcc"/> <entry
>>> uri="sip:[email-masked]"  cc:copy-control="bcc"/> </list> 
>>> </resource-lists>Regards, Jeroen
>>> 
>>> <[email-masked]> To: "Scott W Brim"
>>> <[email-masked]> Cc: "Mary Barnes" <[email-masked]>;
>>> <[email-masked]>; <[email-masked]>; "Michael
>>> Hammer (mhammer)" <[email-masked]> Sent: Wednesday, September
>>> 06, 2006 7:31 AM Subject: Re: [Sipping] WGLC: 
>>>> "copyControl", and as per Brian's request, we will add some
>>>> text indicating that the purpose of this extension is to allow
>>>> a cc and bcc mechanism.
>>>> 
>>>>>> Capacity always mislead me too, even though as an English
>>>>>> speaker I know the alternate meaning of the word.  My fear
>>>>>> is that those for whom English is non-native will have a
>>>>>> hard time.
>>>>>> 
>>>>>> "Role" is a simpler and probably better understood to use 
>>>>>> throughout the document.
>>>>>> 
>>>>>> Mike
>>>>> 
>>>>> (I suspect "capacity" came from current usage such as "in my
>>>>> capacity as secretary of the committee", which is probably
>>>>> not faithful to its original use.)
>>>> 
>>>> -- Miguel A. Garcia           tel:+358-50-4804586 
>>>> sip:[email-masked] Nokia Research Center
>>>> Helsinki, Finland
>>>> 
>>>> _______________________________________________ Sipping mailing
>>>> list  https://www1.ietf.org/mailman/listinfo/sipping This list
>>>> is for NEW development of the application of SIP Use
>>>> [email-masked] for questions on current sip 
>> -- Miguel A. Garcia           tel:+358-50-4804586 
>> sip:[email-masked] Nokia Research Center      Helsinki,
>> Finland
>

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 6 Sep 2006 09:48:17 +0200

Regards,

Jeroen

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 06 Sep 2006 10:47:26 +0300

Hi,

Thanks,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 06 Sep 2006 10:52:40 +0300

Hi,

I do not see any advantage in dividing the URIs in different lists the 
way you propose. If in the future we need to add yet another attribute, 
we will not be able to divide the URIs in different groups for different 
values of each attribute, for example.

Cheers,

Gonzalo

Jeroen van Bemmel wrote:
> To answer my own question: no difference for the URI list server, but 
> needed so the recipient can tell whether he was on "to" or "cc"
> 
> This seems more natural to me: treatment of entries simply depends on 
> the list they are in.
> 
> Regards,
> 
> Jeroen
> 
> 
>> Miguel,
>>
>>>> ("copy-control" is perhaps better?) only with values "cc" and "bcc", 
>>>> and omit "to".
>>>>
>>>>> indicating that the purpose of this extension is to allow a cc and 
>>>>> bcc mechanism.
>>>>>
>>>>>>> throughout the

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 06 Sep 2006 11:12:03 +0300

Jeroen:

The To and Cc values represent the intention of the sender when he sent 
you a SIP request. For example, this is more visible if the sender sent 
you a MESSAGE request, where similarly to e-mail, you can be a main 
recipient or just receive a carbon copy (or even be blindly copied).

/Miguel