Subject: RE: [Sipping] 503 for retransmisison after 200OK

From: Jeroen Van Bemmel <[email-masked]>
Date: Fri, 15 Sep 2006 08:55:34 +0200

On second thought: assuming the UAS uses different to-tags for the 200 and the 503, this situation is the same as what you might get in case of a forking proxy. So ideally the UAC should be able to deal with it, and it should succeed in setting up the dialog involving the 200

>From this perspective, the UAS is not broken

Regards,
Jeroen 

-----Oorspronkelijk bericht -----
Van: "Jeroen van Bemmel" <[email-masked]>
Aan: "Paul Kyzivat" <[email-masked]>; "Avshalom Houri" <[email-masked]>
CC: [email-masked]
Verzonden: 14-9-06 20:45
Onderwerp: Re: [Sipping] 503 for retransmisison after 200OK

Avshalom,

The UAS should perform transaction matching before sending 503. If it is too loaded to do transaction matching, it should not send the 503 response at all, but rather drop the request.

Regards,

Jeroen

  ----- Original Message ----- 
  From: Avshalom Houri 
  To: Paul Kyzivat 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 15 Sep 2006 08:50:08 -0500

Jeroen Van Bemmel wrote:
> On second thought: assuming the UAS uses different to-tags for the
> 200 and the 503, this situation is the same as what you might get in
> case of a forking proxy. So ideally the UAC should be able to deal
> with it, and it should succeed in setting up the dialog involving the
> 200

A forking proxy will only send one 200 response, or one non-2xx
response to the UAC.  It will never send a 200 first and a 503
later.  It may, of course, send multiple 200 to the UAC.

UACs are equipped to deal with multiple 200 with different To
tags arriving, but may throw a hissy fit when a 5xx arrives
on a transaction that is in completed state.  In the best case,
they ignore it, and if they are good citizens, they may even
ACK it and then forget about it.

Thanks.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)