Subject: RE: [Sipping] Comments on draft-malas-performance-metrics-05.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 31 Oct 2006 08:50:32 -0500

Is there an issue associated with when "cut through" really occurs?

In other words, in some cases each media path may be available at
different times.  So, perhaps the setup times should be relative to each
unidirectional path.

Also, is the focus of "session" the media or signaling?  Just trying to
be sure it is clear what we intend to measure.

Mike

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Tuesday, October 31, 2006 3:00 AM
> To: sipping
> Cc: [email-masked]
> Subject: [Sipping] Comments on draft-malas-performance-metrics-05.txt
> 
> Hi,
> 
> a few comments on draft-malas-performance-metrics-05.txt.
> 
> The Section "Conventions used in this document", which 
> currently appears between the Abstract and the TOC, is 
> usually part of the Terminology Section instead.
> 
> Expand acronyms (e.g., UAC, UAS) on their first use.
> 
> Section 3.1.2: RRD is defined as:
> 
> "the interval is defined from the initial REGISTER request 
> and the final response indicating a failure received from the 
> destination registrar or interim proxies."
> 
> However, in the example, the UAC receives an error response, 
> it sends a new REGISTER, and then gives up. RRD is calculated 
> until the UAC gives up. Therefore, the description needs to 
> clarify which final responses are taking into account to 
> calculate RRD (i.e., when the UAC gives up) and which ones 
> are not (e.g., authentication challenges).
> 
> Section 3.2 talks about the Session Request Delay (SSD and 
> says that is telephony applications of SIP is known as Post 
> Dial Delay.
> 
> The ITU defines the post-selection delay as:
> 
> "Post-selection delay (en bloc sending) is defined as the 
> time interval from the instant the first bit of the initial 
> SETUP message containing all the selection digits is passed 
> by the calling terminal to the access signalling system until 
> the last bit of the first message indicating call disposition 
> is received by the calling terminal (ALERTING message in case 
> of successful call)."
> 
> However, the draft defines Time Begin as:
> 
>    "TB occurs when the designated request has been processed by the
>     application and last bit of the request packet has been 
> sent from the
>     proxy or UA (and is externally observable at some physical
>     interface)."
> 
> Therefore, while for the ITU, TB relates to the first bit of 
> the message, for the draft TB relates to the last bit of the 
> message. We should either use the first bit of the message as 
> well of clarify that the Post Dial Delay is not the same thing as SRD.
> 
> Section 3.4 defines the Session Duration Time as an interval 
> starting with a 200 OK response. However, session 
> establishments involving an answer in the ACK cannot be 
> considered to be established until the ACK arrives to the 
> UAS. These sessions can be considered to be "accepted", 
> though. Section 3.4 should clarify this point.
> 
> The example in Section 4 does not seem to relate to any of 
> the ways to provide finer granularity, which are described 
> right before the example.
> 
> Cheers,
> 
> Gonzalo
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Tue, 31 Oct 2006 07:58:31 -0600

The timing of cut-thru is extremely important, as it relates to tones
and announcements that occur before answer. 

-----Original Message-----
From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Tuesday, October 31, 2006 8:51 AM
To: Gonzalo Camarillo; sipping
Cc: [email-masked]
Subject: RE: [Sipping] Comments on
draft-malas-performance-metrics-05.txt

Mike

---

From: "Malas, Daryl" <[email-masked]>
Date: Tue, 31 Oct 2006 11:02:24 -0700

As I mentioned in another response, the intention of this document is
the focus of "session" as it relates only to signaling.  I don't see a
necessity to understand when "cut through" really occurs.

> Sent: Tuesday, October 31, 2006 6:51 AM
> Cc: Malas, Daryl

---

From: "Malas, Daryl" <[email-masked]>
Date: Tue, 31 Oct 2006 10:33:04 -0700

All of the metrics in this draft deal with signaling indicators to TB
and TS.  They have nothing to do with media.  The "session" deals with
signaling not media.  The correction Gonzalo mentioned is to an example
call flow in section 3.9.1.

Do we need a metric that measures the actual receipt and sending of
media as related to the UAC and UAS?  If that is the case, then I think
there are two types of media that should be considered here.  First, do
we care about "early-media" as related to a 183 w/ SDP?  Second,
"session-media" as related to media generated by the UAC and UAS after a
200 OK and the reception of the ACK by the UAS.

I personally cannot think of any metrics we should consider that deal
with the media portion, which aren't dealt with in RFC 3550 and 3611 (or
elsewhere such as ITU-T P.862, etc.).  Mike, you seemed to begin to
mention some.  Thoughts?

--Daryl

> From: Dolly, Martin C, ALABS [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2006 6:59 AM
> To: Michael Hammer (mhammer); Gonzalo Camarillo; sipping
> Cc: Malas, Daryl