Subject: [Sipping] Re: draft-littlefield-sipping-mgmt-event-01.txt

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Oct 2006 10:08:04 -0400

Did you consider, as an alternative, simply sending a REFER to the 
device, with a Refer-To: snmp:whatever ?

	Paul

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: A Management Request Event Package for the Session Initiation Protocol (SIP)
> 	Author(s)	: J. Littlefield
> 	Filename	: draft-littlefield-sipping-mgmt-event-01.txt
> 	Pages		: 19
> 	Date		: 2006-10-22
> 	
> In many environments, firewall, NAT and IP addressing issues make
>    remote management of devices containing SIP user agents difficult.
>    This document defines a SIP event package for notifying a user agent
>    that it should initiate a session with a management entity for
>    management operations.  This type of "call-home" management avoids
>    the need to maintain persistent TCP connections, or generate
>    additional STUN traffic, with the management entity.  This event
>    package is intended not to tunnel management protocols or otherwise
>    provide management itself, but instead to provide a means for
>    signaling a SIP UA that a management session is desired.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-littlefield-sipping-mgmt-event-01.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-littlefield-sipping-mgmt-event-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-littlefield-sipping-mgmt-event-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Josh Littlefield <[email-masked]>
Date: Fri, 27 Oct 2006 11:45:33 -0400

Hi Paul,

> device, with a Refer-To: snmp:whatever ?

I guess that's an interesting idea for what I've defined as the NOTIFY 
end of this (assuming we can define sufficiently descriptive URIs for 
the mgmt protocols).

It leaves open the question of how the UA indicates it's availability 
and interest in being managed, and its mgmt capabilities.  The SUBSCRIBE 
from the managed entity provides a way to do that, but they REFER would 
seem to arrive sort of spontaneously from the management station.

Maybe that could be solved through presence (this is getting out of my 
depth), but I'm not sure how much infrastructure is desirable to be 
pulled into solving this problem.

-josh

>> the message. You can also visit 
>> https://www1.ietf.org/mailman/listinfo/I-D-announce to change your 
>> subscription settings.
>>
>> logging in, type "cd internet-drafts" and then "get 
>> draft-littlefield-sipping-mgmt-event-01.txt".
>>
>> http://www.ietf.org/shadow.html or 
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>

-- 
=====================================================================
Josh Littlefield                                  Cisco Systems, Inc.
[email-masked]                             1414 Massachusetts Avenue
tel: 978-936-1379  fax: 978-936-2226       Boxborough, MA  01719-2205