Subject: Re: [Sipping] Config Framework: extending HTTP?

From: Cullen Jennings <[email-masked]>
Date: Tue, 3 Oct 2006 21:23:39 -0700

Ok - I'm clueless. I'm missing what you guys are talking about here.  
Can you clue me in? Also, any ETA on update of this critical draft?

On Jul 8, 2006, at 11:21 PM, Dan Petrie wrote:

> Ok you caught me.  I did not think the HTTP police
> were watching.
>
> What is your recommendation?  Shall we use a form
> variable called Event?
>
> Cheers,
> Dan
>
> --- Adam Roach <[email-masked]> wrote:
>
>> There is a procedure described in the current config framework
>> document
>>
> (http://www.ietf.org/internet-drafts/draft-ietf-sipping-config- 
> framework-08.txt),
>>
>> starting on page 26, which effectively allows the device to bootstrap
>>
>> configuration using an HTTPS URI. In this procedure, the client
>> includes
>> the RFC3265 "Event" header field, so as to communicate a set of
>> relatively critical parameters.
>>
>> At the very least, I think this requires some discussion in the IANA
>> section to add this header's use in HTTP (the proper registry, I
>> believe, is
>>
> http://www.iana.org/assignments/message-headers/message-header- 
> index.html,
>>
>> defined in RFC3864).
>>
>> I would also think that the general usage of an HTTP header in this
>> way
>> should probably be run by the http community.
>>
>> Sorry if this has been brought up in the past, but I don't recall
>> discussions along these lines, and a quick search through the mailing
>>
>> list archives didn't turn anything up.
>>
>> /a
>>
>> _______________________________________________
>> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>> This list is for NEW development of the application of SIP
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments of core SIP
>>
>
>
> SIPez LLC
> SIP VoIP, IM and Presence Consulting
> http:/www.sipez.com
> tel: +1 (617) 273-4000
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Daniel Petrie <[email-masked]>
Date: Wed, 4 Oct 2006 07:23:52 -0700 (PDT)

The config draft proposes using an Event header for the
profile HTTP GET to carry the Event parameters such as
vendor, model, version.  The data in these parameters are
necessary, mostly in the boot strapping from HTTP situation
so that the profile delivery server can provide the correct
profile data.

I checked with Lisa in Montreal when Adam brought this issue
up and she said it was reasonable for applications to add
new HTTP headers.  I announced this at the WG meeting.  Sorry,
I should have propagated it to the list as well.  I have cleaned up
the IANA section for both HTTP and SIP in the config. draft.

As for the config draft status, I think that it is ready to submit for
WG LC.  It is checked in and ready to submit.  I just need to confirm
that I have resolved two of the issues that were brought up on the list
at Montreal.

Cheers,
Dan

SIPez LLC

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 04 Oct 2006 10:58:03 -0400

I will note that the RELO draft of mine in GEOPRIV makes exactly the 
same addition to HTTP. Maybe you can steal the text...

I believe there's clearly a need for a mechanism of this nature.