Subject: RE: [Sipping] SIP method for sending telephony signals

From: "Attila Sipos" <[email-masked]>
Date: Fri, 4 May 2007 12:57:39 +0100

Hi Gaurav,
 
Thanks for the link.
 
So basically it was done and then people cried.
 
Like I said, I think people are going to use event 16 for Flash anyway
(which means leave it as it is in everyone's existing implementation)

Thanks,
Attila

-----Original Message-----
From: Gaurav Kheterpal [mailto:[email-masked]]
Sent: 04 May 2007 12:51
To: Attila Sipos; [email-masked]
Subject: RE: [Sipping] SIP method for sending telephony signals

SIP INFO is one (not very elegant:-() way 'flash' events can still be communicated. 

Here is what the RFC 4733 author says on the AVT Mailing List about deprecating 'flash' event from RFC 4733 (aka RFC 2833):-

http://www1.ietf.org/mail-archive/web/avt/current/msg08031.html

Regards,
Gaurav

  _____  

From: Attila Sipos [mailto:[email-masked]] 
Sent: Friday, May 04, 2007 4:42 PM
To: [email-masked]
Subject: RE: [Sipping] SIP method for sending telephony signals

   +-------------+---------------------------------------+-------------+
   | Event Codes | RFC 2833 Description                  | Disposition |
   +-------------+---------------------------------------+-------------+
   |        0-15 | DTMF digits                           | RFC 4733    |
   |          16 | Line flash (deprecated)               | Reserved    

So, does anyone know how "flash" events are to be communicated?

(I have no idea why the flash was decided to be deprecated.

 I suspect that many vendors will still support it because

 they'll want to work with older equipment)

Regards,

Attila

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Fri, 4 May 2007 14:16:56 +0200

Why not reuse events being used in Media Gateway protocols like Megaco?? 
this could be defined in a document

Ronald Behar Aldana
CTAC Wireline Spain
+34 913305322

"Attila Sipos" <[email-masked]>
04/05/2007 13:57
 
        To:     "Gaurav Kheterpal" <[email-masked]>, 
<[email-masked]>
        cc: 
        Subject:        RE: [Sipping] SIP method for sending telephony 
signals

Hi Gaurav,
 
Thanks for the link.

Thanks,
Attila

-----Original Message-----
From: Gaurav Kheterpal [mailto:[email-masked]]
Sent: 04 May 2007 12:51
To: Attila Sipos; [email-masked]
Subject: RE: [Sipping] SIP method for sending telephony signals

SIP INFO is one (not very elegantL) way ‘flash’ events can still be 
communicated. 
 
Here is what the RFC 4733 author says on the AVT Mailing List about 
deprecating ‘flash’ event from RFC 4733 (aka RFC 2833):-

Regards,
Gaurav

 

Regards,
 
Attila