Subject: [Sipping] Re: I-D ACTION:draft-vakil-sipping-notify-pause-01.txt

From: Paul Kyzivat <[email-masked]>
Date: Tue, 08 May 2007 19:23:40 -0400

This looks pretty good.

But you didn't comment on Michael Proctor's suggestion to use 
Suppress-Notify-If-Match: *. Also, you always mention full notifies. 
There must be a role for deltas here too. It would be good to discuss 
how that relates.

	Thanks,
	Paul

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: An Extension to Session Initiation Protocol (SIP) Events for Pausing and Resuming Notifications
> 	Author(s)	: M. Vakil
> 	Filename	: draft-vakil-sipping-notify-pause-01.txt
> 	Pages		: 14
> 	Date		: 2007-5-8
> 	
> The Session Initiation Protocol (SIP) events framework enables a
>    subscriber to receive asynchronous notification of various events
>    from other SIP user agents.  It defines mechanisms to create,
>    refresh, terminate subscriptions.  This framework also defines
>    mechanism to fetch (poll) an event state of a resource without
>    creating persistent subscriptions.  There is no mechanism to
>    temporarily pause the notifications, while still maintaining a
>    subscription on the server.  This lack of functionality sometime
>    results in a lot of superfluous notification traffic, and put
>    unnecessary load on the server.  This draft defines an extension to
>    SIP events that allows the subscriber to pause, un-pause
>    notifications, and be able to perform fetch (poll) subscriptions
>    within an established (created) subscription dialog.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-vakil-sipping-notify-pause-01.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-vakil-sipping-notify-pause-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-vakil-sipping-notify-pause-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Mohammad Vakil <[email-masked]>
Date: Tue, 8 May 2007 18:00:28 -0700

Thanks Paul for doing a quick read.

Suppress-Notify-If-Match: * would only be applicable if one is supporting subnot-etag. It made sense (as you suggested) to support fetch within paused stream. Thus, if one is only supporting notify-pause, wouldn't be able to leverage fetch in a paused stream.

As I discussed it with Aki, and try to allude earlier, these are multiple tools for optimization at our disposal:

- subnot-etag
- notify throttling (don't know where it stands?)
- notify-pause

could be applicable, based on application needs. No one tool satisfies all the performance requirements.

Regarding partial notifies, I wanted to shy away getting into specifics of a certain event package, e.g. partial notifications, are only defined in for presence event package. Rather, this optimization is at 3265 level. Any suggestions? Because, I think outside paused stream (un-paused state), those filtering functions should kick in and become applicable.

Thanks,
-Mohammad

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Tuesday, May 08, 2007 4:24 PM
To: sipping
Subject: [Sipping] Re: I-D ACTION:draft-vakil-sipping-notify-pause-01.txt

This looks pretty good.

        Thanks,
        Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 08 May 2007 22:29:26 -0400

> Suppress-Notify-If-Match: * would only be applicable if one is supporting subnot-etag. It made sense (as you suggested) to support fetch within paused stream. Thus, if one is only supporting notify…

I haven't thought about this too much - in particular I haven't kept up 
with the etag stuff. So I'll take your word for this.

> Regarding partial notifies, I wanted to shy away getting into specifics of a certain event package, e.g. partial notifications, are only defined in for presence event package. Rather, this optimiza…

I only had the feeling that the way you worded things seemed to be 
*excluding* use of partial notifies. If you don't mean to exclude them 
(nor require them) maybe you should just make a statement somewhere that 
they are potentially applicable together.

If partial notifies are being used, then I would think they could apply 
for polling when notification has been paused.

	Paul

---

From: Mohammad Vakil <[email-masked]>
Date: Tue, 8 May 2007 22:03:56 -0700

Agreed, makes sense to clarify how it could co-exist in the presence of possible partial notifications. I'll do that in 03.

Thanks,
-Mohammad

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Tuesday, May 08, 2007 7:29 PM
To: Mohammad Vakil
Cc: sipping
Subject: Re: [Sipping] Re: I-D ACTION:draft-vakil-sipping-notify-pause-01.txt

        Paul