Subject: [Sipping] Call-Id Changes ?

From: "Robins George" <[email-masked]>
Date: Fri, 2 Nov 2007 14:38:14 +0530

is there any chance of changing Call-Id when we make call through pbx or
proxy server ?

thanks

-- 
" Building Insights,
Breaking Boundaries."
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 2 Nov 2007 11:22:12 -0700

Some B2BUAs and some SBCs will change the Call-Id.  Search for "Call-Id" in
draft-ietf-sipping-sbc-funcs.

-d

> -----Original Message-----
> From: Robins George [mailto:[email-masked]] 
> Sent: Friday, November 02, 2007 2:08 AM
> To: [email-masked]
> Subject: [Sipping] Call-Id Changes ?
> 
> is there any chance of changing Call-Id when we make call 
> through pbx or proxy server ?
> 
> thanks 
> 
> -- 
> " Building Insights,
> Breaking Boundaries." 
>

---

From: Dean Willis <[email-masked]>
Date: Fri, 2 Nov 2007 14:33:39 -0500

On Nov 2, 2007, at 4:08 AM, Robins George wrote:

> is there any chance of changing Call-Id when we make call through  
> pbx or proxy server ?
>

Respectively, yes, and no.

That is to say, there's no telling what a PBX might do (as this term  
isn't defined wrt IETF SIP specs) Proxies, by definition, preserve  
the Call-ID. There are, however, things that are almost proxies but  
don't obey all the rules. So if it changes the Call-ID, then it isn't  
an RFC3261-compliant proxy.

--
Dean