Subject: [Sipping] stateful and stateless 503 within overload slides

From: "Brett Tate" <[email-masked]>
Date: Tue, 4 Dec 2007 16:38:45 -0500

For the benefit of those unable to attend today's SIPPING meeting, what
is the meaning of stateful and stateless 503 within Jonathan's Overload
Design Team slides?  The jabber logs only reflected that the question
was asked.

Thanks,
Brett

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Saverio Niccolini" <[email-masked]>
Date: Tue, 4 Dec 2007 23:30:22 +0100

The answer should be
-- stateless 503: the server receives the requests, answers and then
forget about the transactions
statuful 503: the server does not forget about the transactions

This is what I got.

Cheers,
Saverio

============================================================
Dr. Saverio Niccolini
Senior Researcher
NEC Laboratories Europe, Network Research Division	
Kurfuerstenanlage 36, D-69115 Heidelberg
Tel.     +49 (0)6221 4342-118
Fax:     +49 (0)6221 4342-155
e-mail:  [email-masked] <-- !!! NEW ADDRESS !!!
============================================================
NEC Europe Limited Registered Office: NEC House, 1 Victoria
Road, London W3 6BL Registered in England 2832014

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]] 
> Sent: Tuesday, December 04, 2007 10:39 PM
> To: [email-masked]
> Subject: [Sipping] stateful and stateless 503 within overload slides
> 
> For the benefit of those unable to attend today's SIPPING 
> meeting, what is the meaning of stateful and stateless 503 
> within Jonathan's Overload Design Team slides?  The jabber 
> logs only reflected that the question was asked.
> 
> Thanks,
> Brett
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Volker Hilt <[email-masked]>
Date: Tue, 04 Dec 2007 14:41:13 -0800

Saverio,

you are correct. With stateless 503, the server sends 503s in response 
to incoming INVITEs during overload. It does not lookup up transactions 
and does not create one. The idea is that a server can do this very 
quickly and respond to lots of INVITEs (which is much better than 
dropping them). Stateful 503 is regular processing of 503s.

Cheers,

Volker

> statuful 503: the server does not forget about the transactions
04 17:41:26 2007
Date: Tue, 04 Dec 2007 14:41:13 -0800
From: Volker Hilt <[email-masked]>
To: Saverio Niccolini <[email-masked]>
Subject: Re: [Sipping] stateful and stateless 503 within overload slides
Cc: [email-masked], Brett Tate <[email-masked]>

Saverio,

you are correct. With stateless 503, the server sends 503s in response 
to incoming INVITEs during overload. It does not lookup up transactions 
and does not create one. The idea is that a server can do this very 
quickly and respond to lots of INVITEs (which is much better than 
dropping them). Stateful 503 is regular processing of 503s.

Cheers,

Volker

-- 
Volker Hilt                      Bell Labs / Alcatel-Lucent
phone: +1 732 332 6432           101 Crawfords Corner Rd
email: [email-masked]     Holmdel, NJ 07733

-- 
Volker Hilt                      Bell Labs / Alcatel-Lucent
phone: +1 732 332 6432           101 Crawfords Corner Rd
email: [email-masked]     Holmdel, NJ 07733