Subject: [Sipping] RE: Comments on draft - draft-ietf-sipping-sip-offeranswer-04.txt

From: <[email-masked]>
Date: Mon, 3 Dec 2007 10:05:00 +0530

The modifications looks fine with me.

Regards,
Nataraju A B
 
> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Friday, November 30, 2007 8:55 PM
> To: Nataraju Alilughatta basavaraju (WT01 - TES-Mobility & 
> Carrier Infrastructure)
> Cc: [email-masked]; [email-masked]
> Subject: Re: Comments on draft - 
> draft-ietf-sipping-sip-offeranswer-04.txt
> 
> 
> 
> [email-masked] wrote:
> >> "Note that an offer/answer exchange initiated by an INVITE 
> request  
> >> must follow exactly one of the patterns 1, 2, 3, 4.
> >>  <snip>
> >>  Pattern 2 and pattern 4 can occur only when the INVITE 
> request does  
> >> not include an offer. 'The first reliable non-failure 
> message' must  
> >> have an offer if there is no offer in the INVITE request. 
> This means  
> >> that UA which receives the INVITE request without an offer must  
> >> include an offer in the first reliable response with 100rel  
> >> extension. If no reliable provisional response has been 
> sent, the UAS  
> >> must include an offer when sending 2xx response."
> >>
> > 
> > The complete paragraph makes sense, but I still think 1st sentence 
> > does confuse. Particularly the word ***AND*** confuses even though 
> > subsequent sentences makes the complete logic clear.
> > I was thinking changing the phrase from "Pattern 2 AND 
> pattern 4" to 
> > "Pattern 2 OR pattern 4" makes it clear enough.
> > 
> > If I am still confusing you, you can ignore this comment since the 
> > complete paragraph makes it clear about delayed O/A.
> 
> I get your point but the paragraph seems a little awkward to 
> me that way. What about:
> 
>     Note that an offer/answer exchange initiated by an INVITE request
>     must follow exactly one of the patterns 1, 2, 3, 4. When 
> an initial
>     INVITE causes multiple dialogs due to forking, an offer/answer
>     exchange is carried out independently in each distinct dialog.
>     When an INVITE request contains no offer, only pattern 2 or
>     pattern 4 apply. 'The first reliable non-failure message' must
>     have an offer if there is no offer in the INVITE request. 
> This means
>     that UA which receives the INVITE request without an offer must
>     include an offer in the first reliable response with 100rel
>     extension. If no reliable provisional response has been 
> sent, the UAS
>     must include an offer when sending 2xx response.
> 
> This only changes the ordering of the words, but it makes it 
> more consistent with the earlier part of the paragraph and 
> seems slightly clearer to me.
> 
[ABN] This looks fine with me... At least no confusion...:)

> 	Paul

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Takuya Sawada <[email-masked]>
Date: Mon, 3 Dec 2007 13:47:37 +0900

Looks fine with me, too.
Thanks, Paul.

Regards,
Takuya

> The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments. 
> 
> WARNING: Computer viruses can be transmitted via email. The recipient should check this email and any attachments for the presence of viruses. The company accepts no liability for any damage caused by any virus transmitted by this email.
>  
> www.wipro.com

--------
Takuya Sawada
KDDI Corporation (KDDI)
Garden Air Tower, 3-10-10, Iidabashi, 
Chiyoda-ku, Tokyo 102-8460, Japan
Tel: +81-3-6678-2997
Fax: +81-3-6678-0286
[email-masked]