Subject: RE: [Sipping] FW: NewVersionNotificationfordraft-petrie-sipping-voip-features-dataset-02

From: "Elwell, John" <[email-masked]>
Date: Mon, 03 Dec 2007 04:59:27 +0000

Christer,

I read 2.3 of voip-featurs-dataset as being concerned only with the
configuration of call waiting.

John 

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]] 
> Sent: 30 November 2007 09:21
> To: Elwell, John; Mary Barnes; Ganesan Sam-W00184; 
> [email-masked]; [email-masked]; Jason Fischl
> Subject: RE: [Sipping] FW: 
> NewVersionNotificationfordraft-petrie-sipping-voip-features-dataset-02
> 
> 
> Hi,
> 
> My concern is not related to the configuration parts.
> 
> But, chapter 2.3 is more than configuration - it is Call 
> Waiting feature
> definition.
> 
> Regards,
> 
> Christer
> 
> 
> > -----Original Message-----
> > From: Elwell, John [mailto:[email-masked]] 
> > Sent: 30. marraskuuta 2007 10:24
> > To: Mary Barnes; Christer Holmberg; Ganesan Sam-W00184; 
> > [email-masked]; [email-masked]; Jason Fischl
> > Subject: RE: [Sipping] FW: New 
> > VersionNotificationfordraft-petrie-sipping-voip-features-dataset-02
> > 
> > Christer,
> > 
> > Just an addition to what Mary says. Although in the context 
> > of the automatic call handling (ACH) topic in BLISS, one of 
> > the concerns identified is to do with configuration, if this 
> > were to lead to protocol work it would not necessarily be 
> > done in BLISS. In fact, if it requires enhancement to the 
> > config framework and its profile datasets, then I would 
> > expect BLISS to ask SIPPING to do that work.
> > 
> > John
> > 
> > > -----Original Message-----
> > > From: Mary Barnes [mailto:[email-masked]]
> > > Sent: 30 November 2007 00:18
> > > To: Christer Holmberg; Ganesan Sam-W00184; [email-masked]
> > > Subject: RE: [Sipping] FW: New Version
> > > Notificationfordraft-petrie-sipping-voip-features-dataset-02
> > > 
> > > Christer,
> > > 
> > > I would agree for the services that BLISS is chartered to 
> describe, 
> > > this document should be consistent. However, you have to 
> > keep in mind 
> > > that the work in this area significantly pre-dates the 
> > BLISS WG. And, 
> > > BLISS isn't the only other work area to consider. For 
> example, the 
> > > Emergency section needs to consider the work in ECRIT and likely 
> > > reference phone-bcp.  So, yes, there is some major reworking that 
> > > needs to happen with this particular document.
> > > 
> > > The most important document of the "petrie-sipping-*-dataset" 
> > > series set
> > > is draft-petrie-sipping-profile-datasets-05.txt, which 
> defines the 
> > > general approach for profile data. That document is a 
> > dependency for 
> > > the policy work in SIP and SIPPING WGs.  So, feedback on that 
> > > particular document (detailed and general readiness to 
> > progress as a 
> > > Working Group
> > > item) would be especially appreciated.
> > > 
> > > Thanks,
> > > Mary. 
> > > 
> > > -----Original Message-----
> > > From: Christer Holmberg [mailto:[email-masked]]
> > > Sent: Wednesday, November 21, 2007 4:58 AM
> > > To: Ganesan Sam-W00184; [email-masked]
> > > Subject: RE: [Sipping] FW: New Version Notification
> > > fordraft-petrie-sipping-voip-features-dataset-02
> > > 
> > > 
> > > Isn't this partly overlapping with the BLISS work?
> > > 
> > > Regards,
> > > 
> > > Christer
> > > 
> > > > -----Original Message-----
> > > > From: Ganesan Sam-W00184 [mailto:[email-masked]]
> > > > Sent: 20. marraskuuta 2007 15:01
> > > > To: [email-masked]
> > > > Subject: [Sipping] FW: New Version Notification
> > > > fordraft-petrie-sipping-voip-features-dataset-02
> > > > 
> > > >  
> > > > 
> > > > -----Original Message-----
> > > > From: IETF I-D Submission Tool [mailto:[email-masked]]
> > > > Sent: Sunday, November 18, 2007 5:50 PM
> > > > To: Ganesan Sam-W00184
> > > > Cc: [email-masked]; [email-masked]
> > > > Subject: New Version Notification for
> > > > draft-petrie-sipping-voip-features-dataset-02
> > > > 
> > > > 
> > > > A new version of I-D,
> > > > draft-petrie-sipping-voip-features-dataset-02.txt
> > > > has been successfuly submitted by Sam Ganesan and posted to
> > > the IETF
> > > > repository.
> > > > 
> > > > Filename:	 draft-petrie-sipping-voip-features-dataset
> > > > Revision:	 02
> > > > Title:		 The Session Initiation Protocol User Agent VoIP
> > > > Features Data Set
> > > > Creation_date:	 2007-11-17
> > > > WG ID:		 Independent Submission
> > > > Number_of_pages: 13
> > > > 
> > > > Abstract:
> > > > This document defines the properties and format for the SIP
> > > user agent
> > > 
> > > > VoIP Features data set.  The properties defined in this
> > > document are
> > > > expected to be common to most SIP user agents that provide VoIP 
> > > > capabilities.  These VoIP Feature properties are 
> > considered to be a 
> > > > data set.  Several types of datasets may be combined into 
> > documents 
> > > > that are provided to SIP user agents so that they can
> > > operate with the
> > > 
> > > > desired behavior.
> > > >  
> > > > 
> > > > 
> > > > 
> > > > The IETF Secretariat.
> > > > 
> > > > 
> > > > 
> > > > 
> > > > _______________________________________________
> > > > Sipping mailing list  
> > https://www1.ietf.org/mailman/listinfo/sipping
> > > > This list is for NEW development of the application of SIP Use 
> > > > [email-masked] for questions on 
> current sip Use 
> > > > [email-masked] for new developments of core SIP
> > > > 
> > > 
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP 
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 3 Dec 2007 13:15:50 +0100

Hi,
 
The text says:
 
"Call Waiting is a feature where the user while on a call in an
establish INVITE dialog can receive indication of incoming INVITE for
a new dialog.  When call waiting is enabled, the uesr agent SHOULD
give indication of incoming INVITEs for new dialogs if a INVITE
dialog is already established.  When call waiting is disabled, the
user agent SHOULD send a 486 Busy response to incoming INVITE
requests for new dialogs if an INVITE dialog is already established."
 
To me this is a little more than "configuration"...
 
Regards,
 
Christer

________________________________

Lähettäjä: Elwell, John [mailto:[email-masked]]
Lähetetty: ma 3.12.2007 5:59
Vastaanottaja: Christer Holmberg; Mary Barnes; Ganesan Sam-W00184; [email-masked]; [email-masked]; Jason Fischl
Aihe: RE: [Sipping] FW: NewVersionNotificationfordraft-petrie-sipping-voip-features-dataset-02

Christer,

John

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 03 Dec 2007 15:02:38 +0000

Christer,

Yes, you're right. Some of the wording seems a little inappropriate for a configuration document. 

John

> Sent: 03 December 2007 12:16
> Subject: VS: [Sipping] 
> FW:NewVersionNotificationfordraft-petrie-sipping-voip-features
> -dataset-02
> 
> Hi,
>  
> The text says:
>  
> Vastaanottaja: Christer Holmberg; Mary Barnes; Ganesan 
> Sam-W00184; [email-masked]; [email-masked]; Jason Fischl
> Aihe: RE: [Sipping] FW: