Subject: [Sipping] Post-WGLC review: draft-ietf-sipping-nat-scenarios-09.txt

From: "Mary Barnes" <[email-masked]>
Date: Thu, 25 Sep 2008 15:22:48 -0500

Hi Folks,

Chris has updated the document to reflect the WGLC comments on the -08 version:
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-gurbani.txt
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-wing.txt
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-keranen.txt
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-yin.txt
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-matthews.txt
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-sipping-nat-scenarios-08-denis-courmont.txt

If the past reviewers that have not already commented (Vijay Gurbani, Dan Wing, Ali Keranen, Phillip Matthews and Remi Denis-Courmant), could please re-review (or review the diff) and make sure previous comments have been satisfactorily addressed, that would be very helpful in determining if this document is ready to progress. 

As always, others in the WG are encouraged to provide any final comments NOW. It's far better to raise any remaining issues or concerns before the document leaves the WG.  We had been waiting to progress this document due to TURN dependencies, but it looks like TURN should be completed in the BEHAVE WG fairly soon.

Finally, if you have read the doc and thinks it's ready, please send a note to the list. 

The deadline for comments is Oct 15, 2008. 

Thanks,
Mary. 
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, September 17, 2008 4:30 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] I-D Action:draft-ietf-sipping-nat-scenarios-09.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.

	Title           : Best Current Practices for NAT Traversal for Client-Server SIP
	Author(s)       : C. Boulton, et al.
	Filename        : draft-ietf-sipping-nat-scenarios-09.txt
	Pages           : 61
	Date            : 2008-09-17

Traversal of the Session Initiation Protocol (SIP) and the sessions it establishes through Network Address Translators (NATs) is a complex problem.  Currently there are many deployment scenarios and traversal mechanisms for media traffic.  This document aims to provide concrete recommendations and a unified method for NAT traversal as well as documenting corresponding flows.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-nat-scenarios-09.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Rémi Denis-Courmont" <[email-masked]>
Date: Fri, 26 Sep 2008 09:44:23 +0300

On Thursday 25 September 2008 23:22:48 ext Mary Barnes, you wrote:
> If the past reviewers that have not already commented (Vijay Gurbani, Dan
> Wing, Ali Keranen, Phillip Matthews and Remi Denis-Courmant), could please
> re-review (or review the diff) and make sure previous comments have been
> satisfactorily addressed, that would be very helpful in determining if this
> document is ready to progress.

Looks ok to me.

-- 
Rémi Denis-Courmont
Maemo Software, Nokia Devices R&D

---

From: Philip Matthews <[email-masked]>
Date: Mon, 29 Sep 2008 15:22:33 -0400

Just an comment on the TURN dependency as TURN editor.

There is good news and bad news on the TURN front.

The bad news is that there is a new version of TURN (TURN-10) as of  
today, with a bunch of changes that will make any detailed examples of  
TURN now out-of-date. These changes were introduced to address  
concerns raised in Dublin and subsequently on the mailing list. Of  
particular note is the new CreatePermission transaction which is  
required for clients to receive data from a peer when using the Send/ 
Data mechanism in TURN -- this was introduced to address security  
concerns.

The good news is that I believe TURN-10 is ready for WGLC (in BEHAVE),  
and I am waiting to see if Dan Wing (the chair) agrees with me. If so,  
there is hope that TURN will finish soon.

- Philip

On Thu, 25-Sep-08, at 16:22 , Mary Barnes wrote:

> If the past reviewers that have not already commented (Vijay  
> Gurbani, Dan Wing, Ali Keranen, Phillip Matthews and Remi Denis- 
> Courmant), could please re-review (or review the diff) and make sure  
> previous comments have been satisfactorily addressed, that would be  
> very helpful in determining if this document is ready to progress.
>
> As always, others in the WG are encouraged to provide any final  
> comments NOW. It's far better to raise any remaining issues or  
> concerns before the document leaves the WG.  We had been waiting to  
> progress this document due to TURN dependencies, but it looks like  
> TURN should be completed in the BEHAVE WG fairly soon.
>
> Traversal of the Session Initiation Protocol (SIP) and the sessions  
> it establishes through Network Address Translators (NATs) is a  
> complex problem.  Currently there are many deployment scenarios and  
> traversal mechanisms for media traffic.  This document aims to  
> provide concrete recommendations and a unified method for NAT  
> traversal as well as documenting corresponding flows.
>
> Below is the data which will enable a MIME compliant mail reader  
> implementation to automatically retrieve the ASCII version of the  
> Internet-Draft.
>

---

From: "Mary Barnes" <[email-masked]>
Date: Tue, 30 Sep 2008 12:23:51 -0500

Philip,

Yes, we should wait on progressing this document until we can double check TURN impacts (which we're hoping you'll help us with :)  Also, Dan was the prime reviewer for the section most impacted by TURN (section 4.2.1.2 in the -08, 5.2.1.2 in the -09), so hopefully he could also help catch any impacts.  If there are any changes, folks can easily check the diff prior to progressing the document. 

Thanks,
Mary. 

-----Original Message-----
From: Philip Matthews [mailto:[email-masked]] 
Sent: Monday, September 29, 2008 2:23 PM
To: Barnes, Mary (RICH2:AR00)
Cc: sipping; Vijay K. Gurbani; Dan Wing; Ari Keränen; Rémi Denis-Courmont; [email-masked]
Subject: Re: Post-WGLC review: draft-ietf-sipping-nat-scenarios-09.txt

The bad news is that there is a new version of TURN (TURN-10) as of today, with a bunch of changes that will make any detailed examples of TURN now out-of-date. These changes were introduced to address concerns raised in Dublin and subsequently on the mailing list. Of particular note is the new CreatePermission transaction which is required for clients to receive data from a peer when using the Send/ Data mechanism in TURN -- this was introduced to address security concerns.

The good news is that I believe TURN-10 is ready for WGLC (in BEHAVE), and I am waiting to see if Dan Wing (the chair) agrees with me. If so, there is hope that TURN will finish soon.

- Philip

On Thu, 25-Sep-08, at 16:22 , Mary Barnes wrote:

> http://www.softarmor.com/sipping/process/wg-review/reviews/draft-ietf-
> sipping-nat-scenarios-08-denis-courmont.txt
>
>
> If the past reviewers that have not already commented (Vijay Gurbani, 
> Dan Wing, Ali Keranen, Phillip Matthews and Remi Denis- Courmant), 
> could please re-review (or review the diff) and make sure previous 
> comments have been satisfactorily addressed, that would be very 
> helpful in determining if this document is ready to progress.
>