Subject: [Sipping] RAI Review: draft-ietf-sipping-presence-scaling-requirements-01.txt

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 18 Sep 2008 13:08:32 +1000

I have been tasked to review
draft-ietf-sipping-presence-scaling-requirements-01.txt. Here are my
comments:

- The introduction fails to explain what interdomain scaling is. It also
fails to explain the problem statement in detail. More text is required.

- Req-001 includes as a last sentence "No changes may be required of
existing servers to interoperate". Firsly, this should be seperated into a
new requirment. Secondly, I don't fully understand this requirement. Is it a
MAY NOT or SHOULD NOT? My opinion is that it is not feasible to require that
no modifications are to be made to existing servers and expect them to work
with the solution. There may be changes needed at the server side.

- Req-002 should also be split into 2, one about functionality and the other
about security. While the former can have a SHOULD NOT strength, I believe
that latter should be a MUST NOT.

NIT
- Section 3. "In this sections lists" should be "This section lists".

Regards,
Hisham
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sriram Parameswar <[email-masked]>
Date: Fri, 19 Sep 2008 00:51:50 -0700

Hisham,

Thank you for taking the time to review the document. I will work with the co-authors to make the necessary edits and submit at the earliest.

Regards,

Sriram Parameswar
adCenter

From: Hisham Khartabil [mailto:[email-masked]]
Sent: Wednesday, September 17, 2008 8:09 PM
To: [email-masked]; [email-masked]; [email-masked]; Sriram Parameswar; [email-masked]; [email-masked]; [email-masked]
Subject: RAI Review: draft-ietf-sipping-presence-scaling-requirements-01.txt

I have been tasked to review draft-ietf-sipping-presence-scaling-requirements-01.txt. Here are my comments:

- The introduction fails to explain what interdomain scaling is. It also fails to explain the problem statement in detail. More text is required.

- Req-001 includes as a last sentence "No changes may be required of existing servers to interoperate". Firsly, this should be seperated into a new requirment. Secondly, I don't fully understand this requirement. Is it a MAY NOT or SHOULD NOT? My opinion is that it is not feasible to require that no modifications are to be made to existing servers and expect them to work with the solution. There may be changes needed at the server side.

- Req-002 should also be split into 2, one about functionality and the other about security. While the former can have a SHOULD NOT strength, I believe that latter should be a MUST NOT.

NIT

Regards,
Hisham