Subject: [Sipping] XCAP and confg-framework

From: "Krishna Prasad Kalluri" <[email-masked]>
Date: Mon, 8 Sep 2008 13:53:30 +0200

Hi,

What is the difference (and/or relation) between XCAP and
ietf-sipping-config-framework? 

XCAP: Http interface where UE can write and read about user data. 

Config-framework: Server can send the profile data to user and server
can notify profile changes. 
Is it possible for an user to write (change) the profile data using
config-framework?  

Related to config framework there are some more documents describing the
data model. 

So a UE has to implement both XCAP and Config-framework if it wishes to
modify the config data and also if its interested to know about the
profile changes?

Regards
Krishna
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Bo, Hu (NSN - CN/Beijing)" <[email-masked]>
Date: Mon, 8 Sep 2008 20:06:27 +0800

Hi,

I think the ietf-sipping-config-framework define ua-profile packages you can subscribe(RFC3265) the changes of xcap resources as ua-profile.

Config framework is similar to presence and rls-list package. It's a subscribe and notify framework.
 
Only way to manipulate xcap resources it by xcap as its purpose.

Best Regards
Hu Bo 

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Krishna Prasad Kalluri
	Sent: 2008年9月8日 7:54 PM
	To: [email-masked]
	Subject: [Sipping] XCAP and confg-framework

	Hi, 

	What is the difference (and/or relation) between XCAP and ietf-sipping-config-framework? 

	Config-framework: Server can send the profile data to user and server can notify profile changes. 
	Is it possible for an user to write (change) the profile data using config-framework?  

	Related to config framework there are some more documents describing the data model. 

	So a UE has to implement both XCAP and Config-framework if it wishes to modify the config data and also if its interested to know about the profile changes?

	Regards 
	Krishna