Subject: [Sipping] Referred-by extension: feedback on draft loreto-sipping-3892bis

From: Salvatore Loreto <[email-masked]>
Date: Wed, 15 Oct 2008 10:47:29 +0300

We submitted this draft (http://tools.ietf.org/id/draft-loreto-sipping-3892bis-00.txt) before IETF62
and we would like to get more feedback from the list before trying to submit a new version
with a complete set of use cases and requirements.

this draft explains the need to extend the Referred-By to allow it to carry up to two values.
In fact Referred-by, as specified in RFC3892, is allowed to carry only one value.
however there are use cases where include only one value not seems to be correct.

consider the following scenario:

SIP has a mechanism for conveying the asserted identity of the
originator of a request by means of the P-Asserted-Identity header
field. 
When exploding a SIP MESSAGE request to a pre-defined group
URI and when exploding a SIP INVITE request to an ad-hoc group or to
a pre-defined group URI, the Referred-By header field in the
resulting exploded requests is set to the P-Asserted-Identity header
field or to the From header field.  
Since the P-Asserted-Identity header field may carry up to two values, 
the Referred-By definition needs to be extended to allow up to two values as well.

what it is possible to do at present, and what most implementations do, is to copy 
ONLY one value to the Referred-By header:for example copy the TEL URI and drop the SIP URI. 
That is fine if you deal with UA that support only one URI, however for the UAs who have more 
flexibility in their address book, this behavior does not seem to be correct.

best regards
Sal

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 15 Oct 2008 09:32:02 +0100

Sal,

Please be aware that in draft-ietf-sipping-update-pai-07 we are taking
steps to permit more than two URIs in the future. Although only two are
permitted to be sent at present, an implementation must not object to
the presence of more than two URIs (or to unexpected URI schemes).

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Salvatore Loreto
> Sent: 15 October 2008 08:47
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [Sipping] Referred-by extension: feedback on 
> draftloreto-sipping-3892bis
> 
> We submitted this draft 
> (http://tools.ietf.org/id/draft-loreto-sipping-3892bis-00.txt)
>  before IETF62

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 15 Oct 2008 14:59:01 +0300

John,

thanks for your reply.

With this draft we want to specify the possibility for the Referred-By 
to contains two URIs
as it is already possible for the P-Asserted-Identity.

However I am aware of the fact that the draft-ietf-sipping-update-pai-07 
is taking
steps to permit in the P-Asserted-Identity more then two URIs,
and yes we will take it in account in the eventual next version of our draft
to extend the Referred-By header accordingly: saying that also for the 
Referred-By
header an implementation must not object to the presence of more than 
two URIs
(or to unexpected URI schemes).

Sal