Subject: [Sipping] draft-ietf-sipping-update-pai-07: ACK and CANCEL

From: "Brett Tate" <[email-masked]>
Date: Mon, 13 Oct 2008 10:53:28 -0400

Hi John,

Asking again since I didn't notice changes from version -06 concerning
ACK and CANCEL.

Draft-ietf-sipping-update-pai-07 still allows P-Asserted-Identity within
ACK and CANCEL (section 3.2 and 4.4).  Don't they have the same
authenticity/authentication issue as responses?  And if so, should such
concerns also be discussed within the draft?

Thanks,
Brett

> -----Original Message-----
> From: Elwell, John [mailto:[email-masked]] 
> Sent: Tuesday, September 23, 2008 3:54 PM
> To: Brett Tate; [email-masked]
> Subject: RE: draft-ietf-sipping-update-pai-06: ACK and CANCEL
> 
> Brett,
> 
> Good point. I will bear in mind for next draft.
> 
> John 
> 
> > -----Original Message-----
> > From: Brett Tate [mailto:[email-masked]]
> > Sent: 23 September 2008 14:59
> > To: Elwell, John; [email-masked]
> > Subject: draft-ietf-sipping-update-pai-06: ACK and CANCEL
> > 
> > Greetings,
> > 
> > Since the draft allows inclusion of P-Asserted-Identity 
> > within ACK and CANCEL (section 3.2 and 4.4.1), don't 
> > they have the same authenticity/authentication issue 
> > as responses?  And if so, should such concerns also 
> > be discussed within the draft?
> > 
> > Thanks,
> > Brett
> > 
> 
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 13 Oct 2008 16:20:03 +0100

Brett,

Apologies, I forgot to mention this topic. I guess the logical
conclusion is that if we can't specify PAI in responses, also we can't
specify PAI in ACK and CANCEL. However, there was earlier group
consensus that we should allow PAI with ALL methods. So I need further
input from the group in order to resolve this.

Thanks,

John 

> Sent: 13 October 2008 15:53
> To: Elwell, John
> Cc: [email-masked]
> Subject: draft-ietf-sipping-update-pai-07: ACK and CANCEL
> 
> Hi John,
>