Subject: Re: [Sipping] Comments ondraft-loreto-sipping-context-id-requirements-00

From: Paul Kyzivat <[email-masked]>
Date: Tue, 03 Feb 2009 14:29:36 -0500

Elwell, John wrote:
>  
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Salvatore Loreto
>> Sent: 25 January 2009 10:22
>> To: Dale Worley
>> Cc: SIPPING
>> Subject: Re: [Sipping] Comments 
>> ondraft-loreto-sipping-context-id-requirements-00
>>
>> Hi Dale,
>>
>> sorry to be late on this answer, I agree that have a clear 
>> understanding 
>> of the capabilities
>> we want for the mechanism is necessary to clearly write down the 
>> requirement.
>>
>> In my mind I have an Idea equal on what you expressed in Req A
>>
>> Req A:  It must be possible, when establishing a dialog, to 
>> specify that
>> it be correlated with one or more already existing dialogs, which
>> dialogs, at the time they were created, did not need to specify that
>> they might be correlated with in the future.
> [JRE] I don't think this is a valid requirement, because it has a
> particular class of solutions in mind. In my opinion the basic
> requirement should be something along the lines of "It must be possible
> to establish, modify and clear down a multimedia session between two
> parties, one or both of which use different devices for different
> media."
> 
> John

I agree with John.

	Paul
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 03 Feb 2009 22:02:52 +0200

<snip>
>>> Req A:  It must be possible, when establishing a dialog, to specify 
>>> that
I agree on the fact that the requirements have to be as general as possible.
In fact if you read my mail "Correlate sip sessions/dialogs" you can see
we have already have two requirements that are similar (almost equal) to 
the one suggested by John.

The requirement in this mail was about the possibility to create the 
initial dialog without knowing
in advance whether another dialog will want to correlate with it.
We can generalize it:

"It must be possible to create a dialog without knowing in advance 
whether or not
another dialog will want to correlate with it"

Maybe it is a redundant  requirement  but at this stage there are  
people that think it should be specified.

Sal