Subject: [Sipping] WGLC review: draft-johnston-sipping-cc-uui-07

From: "Mary Barnes" <[email-masked]>
Date: Fri, 13 Feb 2009 12:07:54 -0600

> Hi folks,
> 
> This email is intended to announce the WGLC review for the following
> document:
> http://www.ietf.org/internet-drafts/draft-johnston-sipping-cc-uui-07.t
> xt
> 
The intent of this review is to determine the completeness of the
problem statement and requirements (per SIPPING WG charter) and
readiness to propose that the solution be worked in SIP WG - with the
obvious understanding that SIP WG must go through the process of taking
on a new work item.  In particular we ask that the past reviewers (Vijay
Gurbani, Keith Drage, Laura Liess and Spencer Dawkins) ensure that their
previous concerns and comments have been adequately addressed in this
revision.

> Please send any and all comments on or before February 27th, 2008 (2
> weeks time). 
> 
> Regards,
> Mary.
> SIPPING WG co-chair

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 16 Feb 2009 15:11:44 -0600

WGLC review: draft-johnston-sipping-cc-uui-07Hi, Mary,

Spencer's concerns with 06 have been addressed ("ship it")...

Thanks,

Spencer
  ----- Original Message ----- 
  From: Mary Barnes 
  To: [email-masked] 
  Cc: Gonzalo Camarillo 
  Sent: Friday, February 13, 2009 12:07 PM
  Subject: [Sipping] WGLC review: draft-johnston-sipping-cc-uui-07

  Hi folks, 

  This email is intended to announce the WGLC review for the following document: 
  http://www.ietf.org/internet-drafts/draft-johnston-sipping-cc-uui-07.txt 

  The intent of this review is to determine the completeness of the problem statement and requirements (per SIPPING WG charter) and readiness to propose that the solution be worked in SIP WG - with the obvious understanding that SIP WG must go through the process of taking on a new work item.  In particular we ask that the past reviewers (Vijay Gurbani, Keith Drage, Laura Liess and Spencer Dawkins) ensure that their previous concerns and comments have been adequately addressed in this revision.

  Please send any and all comments on or before February 27th, 2008 (2 weeks time). 

  Regards, 
  Mary. 
  SIPPING WG co-chair 

------------------------------------------------------------------------------

  _______________________________________________
  Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
  This list is for NEW development of the application of SIP
  Use [email-masked] for questions on current sip
  Use [email-masked] for new developments of core SIP

---

From: <[email-masked]>
Date: Tue, 17 Feb 2009 09:26:23 +0100

Hi Mary,  

All my concerns and comments with the 06 draft have been adequately
addressed in the 07 revision.

Regards 
Laura

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Mary Barnes
> Sent: Friday, February 13, 2009 7:08 PM
> To: [email-masked]
> Cc: Gonzalo Camarillo
> <http://www.ietf.org/internet-drafts/draft-johnston-sipping-cc
> -uui-07.txt>  
> 
> The intent of this review is to determine the completeness of 
> the problem statement and requirements (per SIPPING WG 
> charter) and readiness to propose that the solution be worked 
> in SIP WG - with the obvious understanding that SIP WG must 
> go through the process of taking on a new work item.  In 
> particular we ask that the past reviewers (Vijay Gurbani, 
> Keith Drage, Laura Liess and Spencer Dawkins) ensure that 
> their previous concerns and comments have been adequately 
> addressed in this revision.
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 18 Feb 2009 11:41:11 -0600

Mary Barnes wrote:
> <http://www.ietf.org/internet-drafts/draft-johnston-sipping-cc-uui-07.txt>
> 

Alan, Laura:

I note that all of my comments were adequately addressed except
number 2 and 6 (for a list of my comments, please see
http://www.softarmor.com/sipping/process/wg-review/reviews/draft-johnston-sipping-cc-uui-06-gurbani.txt).

Regarding 2, I suspect that you have adequate reason for not
including this in the Appendix, so I will trust your judgment
here.

Regarding 6, any special reason why a shorter mnemonic of "UUI"
was not included as an alternative?

Other than that, I think the draft is ready to go.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Alan Johnston <[email-masked]>
Date: Wed, 18 Feb 2009 13:23:46 -0600

Vijay,

Thanks for bringing this up - I meant to respond on the list to the 
comment.  See below.

Thanks,
Alan

Vijay K. Gurbani wrote:
>> obvious understanding that SIP WG must go through the process of 
>> taking on a new work item.  In particular we ask that the past 
>> reviewers (Vijay Gurbani, Keith Drage, Laura Liess and Spencer 
>> Dawkins) ensure that their previous concerns and comments have been 
>> adequately addressed in this revision.
>
> Alan, Laura:
>
The only SIP header fields that I'm aware of that allow multiple 
encodings are the original RFC 2543 header fields which included the 
single character lower case short form.  I recall that we discontinued 
this because it was felt to be of minimal value in reducing SIP message 
size, while at the same time increasing the complexity of parsers and 
doubling the number of test cases needed to exercise the protocol.

Besides this, there are two reasons why we chose to not to change the 
header field name.  One is that the header field contents can be up to 
129 octets of data, which would result in the entire header field and 
contents adding up to 284 octets to a SIP message.  Saving 9 octets or 
about 3% doesn't seem to be extremely useful.

The other is that there are already multiple interoperable 
implementations that use the current header field, so we'd need a good 
reason to change it. 

If you feel message size is a problem with this header field, we could 
include text suggesting TCP transport be used.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 18 Feb 2009 13:47:13 -0600

> doubling the number of test cases needed to exercise the protocol.

Alan: That vestige from rfc2543 still persists.  The original
header fields in rfc2543 that had a one-letter equivalent
(Call-ID/i, Contact/m, From/f, Content-Encoding/e, etc.) still
persist in the rfc3261 ABNF.

> about 3% doesn't seem to be extremely useful.

Sure.

> implementations that use the current header field, so we'd need a good 

OK.

> include text suggesting TCP transport be used.

No, I don't think we need to do that.  I just wanted to ensure
that you had evaluated the alternative of using a shorter string
and had decided to disregard it because of certain drawbacks.  The
two you give above are good trade-offs.

That said, the revised draft is good to go.

Thanks,

- vijay