Subject: [Sipping] [sipping]About web service Over SIP

From: [email-masked]
Date: Thu, 12 Feb 2009 11:11:24 +0800

Dear all: 
    In telecom Industry, SIP based IMS is mature for commercial 
deployment, but most of the operators find that more and more applications 
are based on web and IMS is difficult to interact with these applications. 
On the other hand, Web applications can't be easily integrated into 
existing operation support system such as subscriber management, 
authentication and billing system. 
   I think it's a good idea to make the SIP transport SOAP protocol just 
like HTTP. If it comes true, applications rely on web service can be 
easily supported by IMS and operators can benefit from  the unified 
security framework and billing infrastructures.

Any suggestions and discussions are welcome.

---------------------------------------------------
    Wang Jun(Russell Wang)
 System Architecture Dept. of Centre R&D,ZTE Corp.
 Addr: 68 Zijinhua Road,Nanjing
 Mobile:13770604455 
 MSN: [email-masked] 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Dean Willis <[email-masked]>
Date: Thu, 12 Feb 2009 23:56:16 -0600

> Any suggestions and discussions are welcome.

See:

http://www.softarmor.com/wgdb/docs/draft-deason-sip-soap-00.txt

--
Dean

---

From: [email-masked]
Date: Fri, 13 Feb 2009 15:17:29 +0800

This article expired long ago. Has it been discussed or not?
Thanks

Dean Willis <[email-masked]> 
2009-02-13 13:56

收件人
[email-masked]
抄送
[email-masked]
主题
Re: [Sipping] [sipping]About web service Over SIP

See:

--
Dean

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 13 Feb 2009 07:45:22 -0800

> Has it been discussed or not?

The reminder for SIP and SOAP is most welcome since it may refocus on the SIP origins in the Web and hopefully its reintegration into the Web and Rich Internet Applications (RIA) and Web 2.0.
http://en.wikipedia.org/wiki/Rich_Internet_application 
http://en.wikipedia.org/wiki/Web_2.0 
(Note that Wikipedia is another web based service...)

However, what has emerged since SIP was invented in the mid-late 90s and is now dominant on the Internet makes the re-integration of SIP more complex than just SIP and SOAP.  So it is not the issue of "over SIP" but of "integrating SIP" into what has evolved on the ever changing Internet:

* p2p networks, 
* network games, 
* cloud computing (how/if does it change the VoIP and IM server infrastructure?), 
* web conferences, 
* blogs, 
* wikis, 
* social networks, including such as the Tweeter for mobile networks,
* software applications as a service (SaaS), 
* more as Rich Internet Applications (RIA) for Web 2.0.

Some of the dominant new web communications are not yet integrated with real time voice. The largest Internet companies may not even use SIP (Neither do we use SIPPING IM inside the IETF, though I believe it to be the superior protocol). 

This is a compelling reason for SIP/SIPPING to focus of (re-)integrating SIP with RIA and Web 2.0 in order for SIP to remain a long term viable protocol.

My two cents,

Henry
________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, February 13, 2009 1:17 AM
To: Dean Willis
Cc: [email-masked]
Subject: [Sipping] 答复: Re: [sipping]About web service Over SIP

See:

--
Dean

---

From: Dean Willis <[email-masked]>
Date: Fri, 13 Feb 2009 15:04:14 -0600

> This article expired long ago. Has it been discussed or not?

Yes, we discussed it, and at the time concluded that the SIP working  
group was not interested in standardizing the work.

I believe there is a white paper that further discusses the work on  
Ubiquity's web site.

--
Dean