Subject: [Sipping] [Technical Errata Reported] RFC4730 (2265)

From: RFC Errata System <[email-masked]>
Date: Tue, 18 May 2010 01:53:01 -0700 (PDT)

The following errata report has been submitted for RFC4730,
"A Session Initiation Protocol (SIP) Event Package for Key Press Stimulus (KPML)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4730&eid=2265

--------------------------------------
Type: Technical
Reported by: David Grant <[email-masked]>

Section: 10.2

Original Text
-------------
NOTIFY sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP subA.example.com;branch=3qo3j0ouq
To: <sip:[email-masked]>;tag=978675
From: <sip:[email-masked]>;tag=9783453
Call-ID: [email-masked]
CSeq: 3001 NOTIFY
Contact: <sip:[email-masked]>
Event: kpml
Subscription-State: active;expires=3442
Max-Forwards: 70
Content-Type: application/kpml-response+xml
Content-Length: 271

<?xml version="1.0" encoding="UTF-8"?>
<kpml-response xmlns="urn:ietf:params:xml:ns:kpml-response"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation=
        "urn:ietf:params:xml:ns:kpml-response kpml-response.xsd"
      version="1.0"
      code="200" text="OK"
      digits="9999888877776666"/>

Corrected Text
--------------
NOTIFY sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP subA.example.com;branch=3qo3j0ouq
To: <sip:[email-masked]>;tag=978675
From: <sip:[email-masked]>;tag=9783453
Call-ID: [email-masked]
CSeq: 3001 NOTIFY
Contact: <sip:[email-masked]>
Event: kpml
Subscription-State: active;expires=3442
Max-Forwards: 70
Content-Type: application/kpml-response+xml
Content-Length: 271

<?xml version="1.0" encoding="UTF-8"?>
<kpml-response xmlns="urn:ietf:params:xml:ns:kpml-response"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation=
        "urn:ietf:params:xml:ns:kpml-response kpml-response.xsd"
      version="1.0"
      code="200" text="OK"
      digits="9999888877776666" tag="card"/>

Notes
-----
The tag attribute is shown in the call-flow diagram, but not reproduced in the SIP message itself.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4730 (draft-ietf-sipping-kpml-08)
--------------------------------------
Title               : A Session Initiation Protocol (SIP) Event Package for Key Press Stimulus (KPML)
Publication Date    : November 2006
Author(s)           : E. Burger, M. Dolly
Category            : PROPOSED STANDARD
Source              : Session Initiation Proposal Investigation
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Eric Burger <[email-masked]>
Date: Tue, 18 May 2010 06:23:31 -0400

Verified.

On May 18, 2010, at 4:53 AM, RFC Errata System wrote:

> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP