Subject: Re: [Sipping] 3pcc - controller receiving invite

From: Niall Murray <[email-masked]>
Date: Tue, 10 Aug 2010 09:20:01 +0100

>
> Hello All,
>
> My question is probably quite simple as I am new to SIP but I have a
> questions in relation to 3PCC best practices with SIP :
> http://tools.ietf.org/html/rfc3725.
>
> In all of the examples in this document, the controller initiates the
> session. My query relates to the scenario whereby if a device acting as a
> controller *receives *an invite. If this called controlling device was
> aware of a number of local devices it wanted to use in the session I imagine
> that it could either parse the initial invite SDP, and send the updated or
> new SDP (with relevant SDP parts) to each of the respective devices e.g. m
> =audio is sent to speaker, whereas m=video is sent to display device. Or an
> alternative approach would be just to forward the initial invite SDP to all
> the devices and parse and edit the SDP "answer" back to the calling device.
> Are both of these approaches valid? Please see the flow below :
>
>
> Audio / Video Device           Controller         Speaker       Display
> Device
>
           |                          |
|                   |
           |(1) INV SDP (m=video,     |                   |
|
           |      m=audio )           |
|                   |
                     |   ------------>          |                   |
                   |
           |                          |2)INV SDP m=audio
|                   |
                     |                          |  ------------>    |
                   |
           |                          |3)INV SDP m=video
|                   |
                     |                          |  ------------
-----------------------> |
           |                          |
|                   |
                     |                          | (4) 200 OK answer1|
                   |
           |                          |  (audio)          |
|
           |                          |<------------------|
|
                     |                          |                   |(5)200
OK answer2  |
           |                          |                   | (video)
|
           |                          |
<--------------------------------------|
           |                          |
|                   |
           |                          |
|                   |
                      |              (6)Parsing and combining of
|                   |
                         audio/video SDP at controller   |
|
           | 200 OK(Combined a/v SDP) |
|                   |
           |   <------------------    |
|                   |
           |      (7) ACK             |
|                   |
           |      -------------->     |
|                   |
           |                          |         (8) ACK
|                   |
           |                          |  -------------->
|                   |
           |                          |
|                   |
           |                          |       (9) ACK   ------------------->
|

====================================================================
          ==================================Media
Flow========================

====================================================================

Are there any known issues with this?
Thanks in advance,
Niall

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 10 Aug 2010 09:42:10 -0400

Niall,

Yes, both of the things you describe are perfectly reasonable behaviors.

	Thanks,
	Paul

Niall Murray wrote:
>     questions in relation to 3PCC best practices with SIP
>     :http://tools.ietf.org/html/rfc3725.
> 
>     In all of the examples in this document, the controller initiates
>     the session. My query relates to the scenario whereby if a device
>     acting as a controller */receives /*an invite. If this called
>     controlling device was aware of a number of local devices it wanted
>     to use in the session I imagine that it could either parse the
>     initial invite SDP, and send the updated or new SDP (with relevant
>     SDP parts) to each of the respective devices e.g. m =audio is sent
>     to speaker, whereas m=video is sent to display device. Or an
>     alternative approach would be just to forward the initial invite SDP
>     to all the devices and parse and edit the SDP "answer" back to the
>     calling device. Are both of these approaches valid? Please see the
>     flow below :
> 
> 
>     Audio / Video Device           Controller         Speaker      
>     Display Device
> 
>            |                          |                   
> |                   |
>            |(1) INV SDP (m=video,     |                   
> |                   |             
>            |      m=audio )           |                   
> |                   |
>                      |   ------------>          |                   
> |                   |
>            |                          |2)INV SDP m=audio  
> |                   |
>                      |                          |  ------------>    
> |                   |
>            |                          |3)INV SDP m=video  
> |                   |
>                      |                          |  
> -----------------------------------> |
>            |                          |                   
> |                   |
>                      |                          | (4) 200 OK 
> answer1|                   |
>            |                          |  (audio)          
> |                   |
>            |                          
> |<------------------|                   |
>                      |                          |                   
> |(5)200 OK answer2  |
>            |                          |                   | 
> (video)           |
>            |                          
> |<--------------------------------------|
>            |                          |                   
> |                   |
>            |                          |                   
> |                   |
>                          audio/video SDP at controller   
> |                   |
>            |                          |       (9) ACK   
> ------------------->  |                  
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP