Subject: [Sipping] To Develop SIP Server

From: Vijayalakshmi <[email-masked]>
Date: Tue, 14 Sep 2010 13:08:27 +0530

Hi,

       Iam trying to develop a SIP server in VxWorks. Please assist me 
with how to implement SIP in my Server. Where do I get these info...????

Thanks in Advance...!!!!

Lakshmi Marudhanayagam

---

From: Terry Howe <[email-masked]>
Date: Tue, 14 Sep 2010 08:29:42 -0600

Off the top of my head, I'd think you'd need the following
objects/structures:

- call context has state and all other data about the call
- call map to hold the call contexts mapped by call id most likely
- some sort of stack manager to start/stop the stack and have a call map

I normally use the state pattern for states where you'd have states like
initial, ringing, answered, disconnecting, disconnected.

That is basic call stuff, not SIP specific.

On Tue, Sep 14, 2010 at 1:38 AM, Vijayalakshmi <[email-masked]>wrote:

> Hi,
>
>      Iam trying to develop a SIP server in VxWorks. Please assist me with
> how to implement SIP in my Server. Where do I get these info...????
>
> Thanks in Advance...!!!!
>
> Lakshmi Marudhanayagam
> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
>