Subject: [siprec] Comments about requirements draft

From: Nathan Kryger <[email-masked]>
Date: Fri, 19 Mar 2010 09:01:13 -0700

I have a few comments about the requirements draft:

1. Is it envisioned that media will arrive at the RS pre-mixed in the case of audio (all speaking parties in one stream) or as individual media streams (one per speaker).  Obviously this will depend on what the RC has access to as some of the media it is handling may already be mixed.  It would be nice if the RS could specify if it wants mixed or unmixed media from the RC via the Recording Control channel but if I had to pick one or the other I would want unmixed media.  I suppose one drawback to premixed media might be additional DSP resource consumption on the RC which could be a real limitation on some kinds of devices.  This is touched upon a little in Use Case 11 but it is not really clear what the requirement is.

2. Regarding REQ-024, it would be nice to be able to specify which specific leg of the communications has media injection.  For example, only the external caller should hear recorded messages or beep tones.  It would be nice to be able to play a message at the start of the session even if the session is not being initially recorded (in case recording starts mid-session)

3. I don't see any requirements on what the RC should do if it can't contact any RS, only requirements around what the RS should do if it can't record the call.

4. Is it possible for the RS to negotiate the media type being used so the RC translates whatever type of media it is handling into something the RS can decode?  That assumes that the RC itself knows how to decode the media it is handling.  Another alternative would be for the RS to tell the RC what types of media are allowed and the RC could force any media going through it to one of the allowed options assuming that the RC has the ability to modify the SDP going between the endpoints.  Having support for this would be useful in the case where you need to record a call between two internal users who have phones that support whatever fancy new codec happens to be the current fad.

Nathan

---

From: Deepanshu Gautam <[email-masked]>
Date: Mon, 22 Mar 2010 09:56:58 +0800

>2. Regarding REQ-024, it would be nice to be able to specify which specific
leg of the communications has media injection.  For example, only the
external caller should hear recorded >messages or beep tones.  It would be
nice to be able to play a message at the start of the session even if the
session is not being initially recorded (in case recording starts
mid-session)
 
Sorry for the clarification: but, do you mean to indicate to the end user
that the session they are going to participate in MAY BE recorded in future?

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Nathan Kryger
Sent: 2010年3月20日 0:01
To: [email-masked]
Subject: [siprec] Comments about requirements draft

1. Is it envisioned that media will arrive at the RS pre-mixed in the case
of audio (all speaking parties in one stream) or as individual media streams
(one per speaker).  Obviously this will depend on what the RC has access to
as some of the media it is handling may already be mixed.  It would be nice
if the RS could specify if it wants mixed or unmixed media from the RC via
the Recording Control channel but if I had to pick one or the other I would
want unmixed media.  I suppose one drawback to premixed media might be
additional DSP resource consumption on the RC which could be a real
limitation on some kinds of devices.  This is touched upon a little in Use
Case 11 but it is not really clear what the requirement is.

2. Regarding REQ-024, it would be nice to be able to specify which specific
leg of the communications has media injection.  For example, only the
external caller should hear recorded messages or beep tones.  It would be
nice to be able to play a message at the start of the session even if the
session is not being initially recorded (in case recording starts
mid-session)

3. I don't see any requirements on what the RC should do if it can't contact
any RS, only requirements around what the RS should do if it can't record
the call.

4. Is it possible for the RS to negotiate the media type being used so the
RC translates whatever type of media it is handling into something the RS
can decode?  That assumes that the RC itself knows how to decode the media
it is handling.  Another alternative would be for the RS to tell the RC what
types of media are allowed and the RC could force any media going through it
to one of the allowed options assuming that the RC has the ability to modify
the SDP going between the endpoints.  Having support for this would be
useful in the case where you need to record a call between two internal
users who have phones that support whatever fancy new codec happens to be
the current fad.

Nathan

---

From: Nathan Kryger <[email-masked]>
Date: Mon, 22 Mar 2010 09:23:49 -0700

Yes, I think that is accurate.  Take a look at use case 3 – it would be nice to have media injection at the start of or during the session, even if the recording has not started yet.

________________________________________
From: Deepanshu Gautam [mailto:[email-masked]] 
Sent: Sunday, March 21, 2010 6:57 PM
To: Nathan Kryger; [email-masked]
Subject: RE: [siprec] Comments about requirements draft

>2. Regarding REQ-024, it would be nice to be able to specify which specific leg of the communications has media injection.  For example, only the external caller should hear recorded >messages or beep tones.  It would be nice to be able to play a message at the start of the session even if the session is not being initially recorded (in case recording starts mid-session)
 
Sorry for the clarification: but, do you mean to indicate to the end user that the session they are going to participate in MAY BE recorded in future?

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nathan Kryger
Sent: 2010年3月20日 0:01
To: [email-masked]
Subject: [siprec] Comments about requirements draft
I have a few comments about the requirements draft:

Nathan

---

From: Deepanshu Gautam <[email-masked]>
Date: Tue, 23 Mar 2010 09:17:18 +0800

My point is, injecting media before the request-for-recording is made doesn't seems appealing.
The best point to indicate to the user (this is what REQ-024 is about) about the start of a recording (mid-session or not) is the time when the request-for-recording is made.
Consider, you played a message at the start of session but the recording was never actually requested.

-----Original Message-----
From: Nathan Kryger [mailto:[email-masked]] 
Sent: 2010年3月23日 0:24
To: Deepanshu Gautam; [email-masked]
Subject: RE: [siprec] Comments about requirements draft

>2. Regarding REQ-024, it would be nice to be able to specify which 
>specific leg of the communications has media injection.  For example, 
>only the external caller should hear recorded >messages or beep tones.  
>It would be nice to be able to play a message at the start of the 
>session even if the session is not being initially recorded (in case 
>recording starts mid-session)

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nathan Kryger
Sent: 2010年3月20日 0:01
To: [email-masked]
Subject: [siprec] Comments about requirements draft I have a few comments about the requirements draft:

Nathan