Subject: [siprec] #10: What is Meta-Data?

From: "siprec issue tracker" <[email-masked]>
Date: Fri, 09 Apr 2010 01:52:08 -0000

#10: What is Meta-Data?
-----------------------------------+----------------------------------------
 Reporter:  deepanshu@…            |       Owner:  krehor@…        
     Type:  defect                 |      Status:  new             
 Priority:  major                  |   Milestone:  milestone1      
Component:  Requirements           |     Version:                  
 Severity:  Candidate WG Document  |    Keywords:                  
-----------------------------------+----------------------------------------
 Definition of Metadata says that it describe the Communication Session. I
 think it may describes the Recording Session too. e.g "REC-Time" may
 provide the time when the RS was requested. "REC-Time" is not related with
 CS but RS.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/10>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Mon, 19 Apr 2010 12:11:55 -0000

#10: What is Meta-Data?

Comment(by rajnish.jain@…):

 Pls. clarify REC-Time.

 Metadata is intended to describe CS not RS. There will be some information
 in metadata that'll allow metadata records to be correlated to relevant CS
 and RS.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/10#comment:1>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 20 Apr 2010 01:44:14 -0000

#10: What is Meta-Data?

 > Pls. clarify REC-Time.
 REC-Time: time when the recording is started.

 few more for example.....
 REC-Len: the total length of media recorded
 REC-Type: type of media recorded (text, audio, vedio)

 > Metadata is intended to describe CS not RS.
 I think all the above will better describes a RS not CS.

 > There will be some information in metadata that'll allow metadata
 records to be correlated to relevant CS and RS.
 That what i'm saying. Metadata may relate to both RS and CS. In other
 words, it may contain some information related with RS too.

 Replying to [comment:1 rajnish.jain@…]:
 > Pls. clarify REC-Time.
 >
 > Metadata is intended to describe CS not RS. There will be some
 information in metadata that'll allow metadata records to be correlated to
 relevant CS and RS.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/10#comment:2>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 29 Apr 2010 11:58:25 -0000

#10: What is Meta-Data?

Comment(by leonp@…):

 It can make sense if RC established a recording session with one of the
 available RS, these recording sessions information (like start, stop,
 pause, resume) may also be reported via metadata to another metadata
 subscribers. Metadata subcribers can be not only Recording Servers but
 some another applications and also some logging mechanisms as well.

 Leon

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/10#comment:3>
siprec <http://tools.ietf.org/siprec/>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 29 Apr 2010 18:53:28 +0530

Leon,

I don’t see a need for indicating pause, resume, start, stop specifically using metadata.
We could use the existing SDP direction attribute to indicate start, stop, pause, resume. 
The assumption here is you have SIP dialog setup between RC and RS.

For e.g to pause a recording, the Recording Server would send a RE-INVITE with direction attribute a=inactive for those streams(m-lines)
for which it wants to pause the recording. 
              
 Pause recording

RecordingServer(RC)                      Recording Client(RC)
|---------------------------------------->|
|  INVITE + metadata                      |
|  + SDP(direction attrib a=inactive)     |
|                                         |
|<----------------------------------------|
|   200 OK ( SDP with a=inactive)         |
|                                         |
|   resume recording                      |
|                                         |
|                                         |
|---------------------------------------->|
|INVITE + metadata                        |
|  + SDP(direction attrib a=recvonly)     |
|                                         |
|<----------------------------------------|
|   200 OK ( SDP with a=sendonly)         |
|                                         |

In the same way the RC can stop/start recording on the same session by just sending a RE-INVITE with a=inactive and RE-INVITE with a=sendonly respectively.

Isn't this sufficient ? Do we see a need to have some additional information carried in metadata to indicate pause,resume,stop,start ?
I suppose the metadata subscribers you are referring to will be in the path of the SIP messages between RC and RS? right ? They can still look at the SDP direction attribute and get the details. Of course they need to be call statefull.

Ram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of siprec issue tracker
Sent: Thursday, April 29, 2010 5:28 PM
To: Ken Rehor (krehor); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [siprec] #10: What is Meta-Data?

#10: What is Meta-Data?

Comment(by leonp@…):

 Leon

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: Leon Portman <[email-masked]>
Date: Thu, 29 Apr 2010 17:41:41 +0300

Ram, 

I agree on the control part but I don’t want to assume that meta data subscribers will have visibility on RC-RS sessions

Leon

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: Thursday, April 29, 2010 4:23 PM
To: siprec issue tracker; Ken Rehor (krehor); [email-masked]; Leon Portman; [email-masked]
Cc: [email-masked]
Subject: RE: [siprec] #10: What is Meta-Data?

Leon,

              
 Pause recording

Ram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of siprec issue tracker
Sent: Thursday, April 29, 2010 5:28 PM
To: Ken Rehor (krehor); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [siprec] #10: What is Meta-Data?

#10: What is Meta-Data?

Comment(by leonp@…):

 Leon

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 29 Apr 2010 17:20:54 +0200

Leon,

What is meant by "meta data subscribers"? I see no mention of subscriber in the requirements draft. I think the requirements draft needs to be clearer on who/what requires access to metadata, e.g., is it just the recording server or other authorised parties? If entities other than the RS require access to metadata, will that necessarily be a SIP-based mechanism, and will it necessarily be within scope of SIPREC?

John (as individual)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: 29 April 2010 15:42
> To: Ram Mohan R (rmohanr); siprec issue tracker; Ken Rehor 
> (krehor); [email-masked]; [email-masked]
> Cc: [email-masked]
> I agree on the control part but I don't want to assume that 
> meta data subscribers will have visibility on RC-RS sessions
> 
> Leon
> 
> To: siprec issue tracker; Ken Rehor (krehor); 
> [email-masked]; Leon Portman; [email-masked]
> Cc: [email-masked]
> I don't see a need for indicating pause, resume, start, stop 
> specifically using metadata.
> For e.g to pause a recording, the Recording Server would send 
> a RE-INVITE with direction attribute a=inactive for those 
> streams(m-lines)
> In the same way the RC can stop/start recording on the same 
> session by just sending a RE-INVITE with a=inactive and 
> RE-INVITE with a=sendonly respectively.
> 
> Isn't this sufficient ? Do we see a need to have some 
> additional information carried in metadata to indicate 
> pause,resume,stop,start ?
> I suppose the metadata subscribers you are referring to will 
> be in the path of the SIP messages between RC and RS? right ? 
> They can still look at the SDP direction attribute and get 
> the details. Of course they need to be call statefull.
> 
> Ram
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of siprec issue tracker
>  Reporter:  deepanshu@...            |       Owner:  krehor@...        
> Comment(by leonp@...):
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/10#comment:3>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 29 Apr 2010 22:22:46 +0530

Leon,

Even I would like to understand what you mean by "metadata subscribers"
? Can you please elaborate on the same ?

Ram
-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Thursday, April 29, 2010 8:51 PM
To: Leon Portman; Ram Mohan R (rmohanr); siprec issue tracker; Ken Rehor

Leon,

What is meant by "meta data subscribers"? I see no mention of subscriber
in the requirements draft. I think the requirements draft needs to be
clearer on who/what requires access to metadata, e.g., is it just the
recording server or other authorised parties? If entities other than the
RS require access to metadata, will that necessarily be a SIP-based
mechanism, and will it necessarily be within scope of SIPREC?

John (as individual)