Subject: Re: [siprec] Comment of requirements draft

From: "Elwell, John" <[email-masked]>
Date: Thu, 8 Apr 2010 18:24:37 +0200

Deepanshu,

I didn't see any discussion on the list of the issues you raised. I don't know if you still have concerns or whether you have obtained clarification off-line from the author. Anyway, if you feel any of the unresolved issues are sufficiently important to capture in the issues tracker (don't bother with editorials), please raise appropriate tickets.

Thanks,

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Deepanshu Gautam
> Sent: 26 March 2010 08:15
> To: [email-masked]
> Subject: [siprec] Comment of requirements draft
> 
> Some comments on the requirement draft.
>  
> 1. I don't see any use case/requirements on search & 
> retrieval of the recorded session (archieved media), which i 
> think is the intergal part of every application (call center, 
> IVR, trading floors, etc.) mentioned/not-mentioned in the 
> draft. I request to have some requirement on this.
>  
> 2. Definition of Metadata says that it describe the 
> Communication Session. I think it may describes the Recording 
> Session too. e.g "REC-Time" may provide the time when the RS 
> was requested. "REC-Time" is not related with CS but RS.
>  
> 3. I'm having diffculity to understand the existence of Use 
> Case 7. Why we need this? What difference would it make to 
> RS, RC, CS when the enterprise workers are in company or at home?
>  
> 4. Figure 1 is kinda missleading. It imply that a RC 
> consitutes two user A and B. It is better either to show two 
> RCs both in A and B or one RC (shown seperately, not covering 
> A and B) shared by both A and B (as shown in ARC draft).
>  
> 5. Figure 2 shows "Call Metadata", i think it should be just Metadata.
>  
> 6. REQ-019 to 022: Isn't the Metadata is out-of-scope of this 
> draft (Section 2, 6th para, 6th line).
>  
> 7. REQ-032: I don't see any issues in RS using the same 
> encryption keys as CS. Why not?
>  
>  
> Regards
> Deepanshu
>

---

From: Deepanshu Gautam <[email-masked]>
Date: Fri, 09 Apr 2010 11:29:15 +0800

Thanks John for bringing it up. I have raised a couple to tickets.

Regards
Deepanshu

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: 2010年4月9日 0:25
To: Deepanshu Gautam
Cc: [email-masked]
Subject: RE: [siprec] Comment of requirements draft

Deepanshu,

I didn't see any discussion on the list of the issues you raised. I don't
know if you still have concerns or whether you have obtained clarification
off-line from the author. Anyway, if you feel any of the unresolved issues
are sufficiently important to capture in the issues tracker (don't bother
with editorials), please raise appropriate tickets.

Thanks,

John

> 1. I don't see any use case/requirements on search & retrieval of the 
> recorded session (archieved media), which i think is the intergal part 
> of every application (call center, IVR, trading floors, etc.) 
> mentioned/not-mentioned in the draft. I request to have some 
> requirement on this.
>  
> 2. Definition of Metadata says that it describe the Communication 
> Session. I think it may describes the Recording Session too. e.g 
> "REC-Time" may provide the time when the RS was requested. "REC-Time" 
> is not related with CS but RS.
>  
> 3. I'm having diffculity to understand the existence of Use Case 7. 
> Why we need this? What difference would it make to RS, RC, CS when the 
> enterprise workers are in company or at home?
>  
> 4. Figure 1 is kinda missleading. It imply that a RC consitutes two 
> user A and B. It is better either to show two RCs both in A and B or 
> one RC (shown seperately, not covering A and B) shared by both A and B 
> (as shown in ARC draft).
>  
> 6. REQ-019 to 022: Isn't the Metadata is out-of-scope of this draft 
> (Section 2, 6th para, 6th line).
>  
> 7. REQ-032: I don't see any issues in RS using the same encryption 
> keys as CS. Why not?
>  
>  
> Regards
> Deepanshu
> =