Subject: [siprec] #11: Alignment of media streams

From: "siprec issue tracker" <[email-masked]>
Date: Mon, 26 Apr 2010 08:03:41 -0000

#11: Alignment of media streams
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  enhancement                         |      Status:  new             
 Priority:  minor                               |   Milestone:  milestone1      
Component:  Requirements                        |     Version:                  
 Severity:  Candidate WG Document               |    Keywords:                  
------------------------------------------------+---------------------------
 Peter Musgrave wrote:
 http://www.ietf.org/mail-archive/web/siprec/current/msg00101.html

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/11>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 29 Apr 2010 12:09:08 -0000

Comment(by leonp@…):

 Assuming that that all media that RS is receiving from RC is sent in real
 time (no buffering)the simplest implementation can be that captured media
 will be stored in accordance of receive time (assuming packets of
 different media types will have similar latency). Otherwise, off course,
 some time synchronization method (via INFO may be) will be required. It
 can be very complex requirement for support, that I think should be
 deffered for later phases.

 Leon

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/11#comment:1>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 29 Apr 2010 12:22:27 -0000

Comment(by peter.musgrave@…):

 I agree using capture time is simplest. In some applications it may not
 provide sufficient alignment and recording RTCP SR's  as some kind of
 meta-data may be required. I'm not really a fan of adding stuff in the
 signalling path to do data alignment (i.e. INFOs).

 I agree the details can be deferred (as much as I'd love to think through
 the implementation). It seems the requirement is well understood.

 Thx, Peter Musgrave

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/11#comment:2>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 29 Apr 2010 14:49:07 +0200

For the time being, can we try to focus on whether this is a requirement or not, and hence whether it needs to go in the reqs document (perhaps using the text that Peter originally proposed)?

John (as chair)

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of siprec issue tracker
> Sent: 29 April 2010 13:09
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] #11: Alignment of media streams
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
>      Type:  enhancement                         |      
> Status:  new             
>  Priority:  minor                               |   
> Milestone:  milestone1      
> Comment(by leonp@...):
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/11#comment:1>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Brian Rosen <[email-masked]>
Date: Thu, 29 Apr 2010 09:19:50 -0400

<as individual>
First of all, if we assume RTP, then we have timestamps.  Clearly, we are
recording these.

Then, ISTM that it would be easy to allow recording of RTCP if available.

I wouldn't want to do any more than that on our first version.  I would
especially not want to see any INFO anything.

Brian 

> streams
------------------------------------------------+---------------------
> ------
 Reporter:  john.elwell@Š                       |       Owner:
> krehor@Š        
     Type:  enhancement                         |
> Status:  new             
 Priority:  minor                               |
> Milestone:  milestone1      
Component:  Requirements                        |
> Version:                  
 Severity:  Candidate WG Document               |
> Keywords:        

Comment(by leonp@Š):

 Assuming that that all media that RS is receiving from
> RC is sent in real
 time (no buffering)the simplest implementation can be that
> captured media
 will be stored in accordance of receive time (assuming packets
> of

> some time synchronization method (via INFO may be) will be required. It
 can
> be very complex requirement for support, that I think should be
 deffered for
> later phases.

 Leon

-- 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/11#comment:1>
siprec
> <http://tools.ietf.org/siprec/>

_____________________________________________
> __
siprec mailing
> list
[email-masked]