Subject: [siprec] #3: Mixed or separate media streams

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 08 Apr 2010 16:02:38 -0000

#3: Mixed or separate media streams
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  major                               |   Milestone:  milestone1      
Component:  Requirements                        |     Version:                  
 Severity:  Candidate WG Document               |    Keywords:                  
------------------------------------------------+---------------------------
 From posting at:
 http://www.ietf.org/mail-archive/web/siprec/current/msg00013.html
 by Nathan Kryger:
 "Is it envisioned that media will arrive at the RS pre-mixed in the case
 of audio (all speaking parties in one stream) or as individual media
 streams (one per speaker).  Obviously this will depend on what the RC has
 access to as some of the media it is handling may already be mixed.  It
 would be nice if the RS could specify if it wants mixed or unmixed media
 from the RC via the Recording Control channel but if I had to pick one or
 the other I would want unmixed media.  I suppose one drawback to premixed
 media might be additional DSP resource consumption on the RC which could
 be a real limitation on some kinds of devices.  This is touched upon a
 little in Use Case 11 but it is not really clear what the requirement is."

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/3>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 29 Apr 2010 11:42:38 -0000

Comment(by leonp@…):

 We have two separate use cases here:
 Speaker summation - where RX and TX (Agent voice and customer voice for
 example) are summed together by RC.
 Mixing - where to separate communication session (like left handset and
 right handset of trader turret are mixing together). It can be done in
 addition to summation where RX of left handset is mixed with RX of right
 handset to one media stream, and TX of left hand set is mixed with TX of
 right hand set.
 So we can have following configurations:
 1) RX+TX -> m-line of the recording session
 2) RX-> m-line, TX->m-line
 3) LH RX + RH RX -> m-line, LH TX + RH TX -> m-line

 From the protocol point of view, I think we should reuse SDP negotioation
 mechanism, where multiple m-line offering can exist (with summation and
 without for example if it is supported by RC) and RS will select desired
 one.

 Leon

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/3#comment:1>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 29 Apr 2010 14:30:19 +0200

It seems to me that from a requirements point of view we only need to capture:
a) the ability to record transmitted and received streams for a single conversation; and
b) multiple conversations (which is effectively multiple media of the same type, e.g., two audio rather in contrast to one audio plus one video.

I think capturing at this level would be sufficient for the requirements document. The place where mixing is done should probably be in the architecture document, and SDP details should be in the protocol document.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of siprec issue tracker
> Sent: 29 April 2010 12:43
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] #3: Mixed or separate media streams
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
>      Type:  defect                              |      
> Status:  new             
>  Priority:  major                               |   
> Milestone:  milestone1      
> Comment(by leonp@...):
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/3#comment:1>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Brian Rosen <[email-masked]>
Date: Thu, 29 Apr 2010 08:46:49 -0400

<as individual>
Just a suggestion:

Might it not be a better solution to always record separate streams
separately, and mix on output, regardless of the reason?  It makes the
function simpler (no mix on input), and I am always suspicious of assertions
like "we never need to know the difference between the trader speaking (or
hearing) from the left handset or the right handset".

Brian

> #3: Mixed or separate media
------------------------------------------------+---------------------
> ------
 Reporter:  john.elwell@Š                       |       Owner:
> krehor@Š        
     Type:  defect                              |
> Status:  new             
 Priority:  major                               |
> Milestone:  milestone1      
Component:  Requirements                        |
> Version:                  
 Severity:  Candidate WG Document               |
> Keywords:        

Comment(by leonp@Š):

 Speaker
> summation - where RX and TX (Agent voice and customer voice for
 example) are
> summed together by RC.
 Mixing - where to separate communication session (like
> left handset and
 right handset of trader turret are mixing together). It can
> be done in
 addition to summation where RX of left handset is mixed with RX of
> right
 handset to one media stream, and TX of left hand set is mixed with TX
> of
 right hand set.
 1) RX+TX ->
> m-line of the recording session
 3) LH RX + RH RX
> -> m-line, LH TX + RH TX -> m-line

 From the protocol point of view, I think
> we should reuse SDP negotioation
 mechanism, where multiple m-line offering
> can exist (with summation and
 without for example if it is supported by RC)
> and RS will select desired
 one.

 Leon

-- 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/3#comment:1>
siprec
> <http://tools.ietf.org/siprec/>

_____________________________________________
> __
siprec mailing
> list
[email-masked]

---

From: Leon Portman <[email-masked]>
Date: Thu, 29 Apr 2010 16:10:17 +0300

Today summation is done for two reasons: summed audio take 30% less storage space or it is already summed because of the conference. Our preference however (for voice analytics reasons) to record as separate recordings

Leon

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Thursday, April 29, 2010 3:47 PM
To: siprec issue tracker; [email-masked]; Leon Portman
Cc: [email-masked]
Subject: Re: [siprec] #3: Mixed or separate media streams

<as individual>
Just a suggestion:

Brian

     Type:  defect                              |
 Priority:  major                               |

Comment(by leonp@Š):

 example) are
 right hand set.

 one.

 Leon

-- 
siprec

siprec mailing
[email-masked]

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 29 Apr 2010 15:20:31 +0200

So by delivering the streams separately to the RS, the RS has a choice whether to mix before storing or mix on playback - outside the scope of SIPREC. On the other hand, delivering separate streams requires more bandwith, and might require more resource at the RC, depending how it is implemented (e.g., it could double the coding resource).

John (as individual)

> [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: 29 April 2010 14:10
> To: Brian Rosen; siprec issue tracker; [email-masked]
> Cc: [email-masked]
> Today summation is done for two reasons: summed audio take 
> 30% less storage space or it is already summed because of the 
> conference. Our preference however (for voice analytics 
> reasons) to record as separate recordings
> 
> Leon
>

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 29 Apr 2010 23:03:05 +0530

Audio Mixing will require more resources in RC.  In case of RC is a gateway/B2BUA, there will be considerable degrade in the performance of the system. RS will not be able to analysis the individual media stream if mixing is done at RC. Also, Mixing will not able applicable for Video.
 
Partha

________________________________

From: [email-masked] on behalf of Elwell, John
Sent: Thu 4/29/2010 6:50 PM
To: Leon Portman; Brian Rosen; siprec issue tracker; Ken Rehor (krehor)
Cc: [email-masked]
Subject: Re: [siprec] #3: Mixed or separate media streams

John (as individual)

>  Reporter:  john.elwell@S                       |       Owner:
> > krehor@S       
>      Type:  defect                              |
> > Status:  new            
>  Priority:  major                               |
> > Milestone:  milestone1     
> Comment(by leonp@S):