Subject: [siprec] #1: Reduce use cases to a manageable set

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 08 Apr 2010 15:01:43 -0000

#1: Reduce use cases to a manageable set
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  major                               |   Milestone:  milestone1      
Component:  Requirements                        |     Version:                  
 Severity:  Candidate WG Document               |    Keywords:                  
------------------------------------------------+---------------------------
 The number of use cases and the requirements derived from these are likely
 to lead to an amount of work substantially greater than can be achieved in
 anything like the timescales currently proposed. We should therefore
 attempt to reduce the use cases and requirements to a manageable set for
 which we can provide a solution within the next year.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/1>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Fri, 23 Apr 2010 10:07:13 -0000

Comment(by john.elwell@…):

 Concerning media, we seem to have consensus to limit to RTP-based media.
 Furthermore we will not necessarily address optimisations for all RTP-
 based media types, e.g., video will not be precluded, but video-specific
 optimisation work will be deferred.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/1#comment:1>
siprec <http://tools.ietf.org/siprec/>

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 23 Apr 2010 14:17:16 -0500

John

Some have expressed that your limitation to RTP 
will include video, yet your tone below isn't 
being optimistic about video, and this clearly to 
me - as an observer - isn't the sentiment of the 
WG as voiced on the list to date.

In other words, there are more wanting video to 
be included in the charter/WG than not, yet you 
phrase it as if "video is allowed, but can't be worked on".

I read this as an inconsistency wrt the WG's position.

James

At 05:07 AM 4/23/2010, siprec issue tracker wrote:
>Reporter:  john.elwell@…                       | 
>        Owner:  krehor@…             Type: 
>defect                               | 
>Status:  new             Priority:  major 
>                        |   Milestone: 
>milestone1      Component:  Requirements 
>                |     Version: 
>Severity:  Candidate WG 
>Document               |    Keywords: 
>Comment(by john.elwell@…): Concerning media, we 
>seem to have consensus to llimit to RTP-based 
>media. Furthermore we will not necessarily 
>address optimisations for all RTP- based media 
>types, e.g., video will not be precluded, but 
>video-specific optimisation work will be 
>deferred. -- Ticket URL: 
><http://trac.tools.ietf.org/wg/siprec/trac/ticket/1#comment:1> 
>_______________________________________________ 
>siprec mailing list [email-masked] 
>https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 26 Apr 2010 09:47:11 +0200

James,

There have been people suggesting we don't need to make video perfect at this stage, e.g:
http://www.ietf.org/mail-archive/web/siprec/current/msg00083.html
http://www.ietf.org/mail-archive/web/siprec/current/msg00082.html
http://www.ietf.org/mail-archive/web/siprec/current/msg00086.html

On the other hand, I can't recall anyone saying we have to do EVERYTHING for video at this stage.

If you can think of a better way of wording it, please make a proposal for text that can go into the Requirements draft.

John

> -----Original Message-----
> From: James M. Polk [mailto:[email-masked]] 
> Sent: 23 April 2010 20:17
> To: siprec issue tracker; [email-masked]; Elwell, John
> Cc: [email-masked]
> Subject: Re: [siprec] #1: Reduce use cases to a manageable set
> 
> John
> 
> >Reporter:  john.elwell@...                       | 
> >        Owner:  krehor@...             Type: 
> >defect                               | 
> >Comment(by john.elwell@...): Concerning media, we