Subject: [siprec] #18: Modify the text in Use Case 9 of REQ draft

From: "siprec issue tracker" <[email-masked]>
Date: Wed, 12 May 2010 06:08:04 -0000

#18: Modify the text in Use Case 9 of REQ draft
--------------------------------+-------------------------------------------
 Reporter:  rmohanr@…           |       Owner:  krehor@…         
     Type:  defect              |      Status:  new              
 Priority:  minor               |   Milestone:                   
Component:  Requirements        |     Version:  1.0              
 Severity:  Active WG Document  |    Keywords:  Recording Session
--------------------------------+-------------------------------------------
 The use case 9 (Record Complex call flows) says
  "Each conversation is stored as a *separate* recording. The Supervisor
 call must be associated with the original customer call."

 The text here needs to be modified to allow same RS record the call even
 after CS undergoes Changes (transfer, forward e.t.c)

 Please refer to
 http://www.ietf.org/mail-archive/web/siprec/current/msg00245.html

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/18>
siprec <http://tools.ietf.org/siprec/>

---

From: "siprec issue tracker" <[email-masked]>
Date: Wed, 12 May 2010 06:33:41 -0000

Comment(by john.elwell@…):

 I am not sure we even need this text - how recordings are stored is
 outside the scope of SIPREC. Assuming we add a requirement that the SRS
 MUST be able to relate RSs to CSs, it is up to the SRS how it arranges the
 storage.

 John (as individual)

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/18#comment:1>
siprec <http://tools.ietf.org/siprec/>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 May 2010 12:25:16 +0530

I thought we could add a text in this use case saying the same RS can be used 
to associate the complex call (transfer, hold, resume).

Ok. Assuming we add a new requirement that " The mechanism SHALL support means to relate RS(s) with CS(s)"
we can still avoid modifying the text here.

Thanks,
Ram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of siprec issue tracker
Sent: Wednesday, May 12, 2010 12:04 PM
To: Ken Rehor (krehor); [email-masked]
Cc: [email-masked]
Subject: Re: [siprec] #18: Modify the text in Use Case 9 of REQ draft

 John (as individual)

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 12 May 2010 09:23:27 +0200

> From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
> Sent: 12 May 2010 07:55
> To: siprec issue tracker; Ken Rehor (krehor); Elwell, John
> Cc: [email-masked]
> Subject: RE: [siprec] #18: Modify the text in Use Case 9 of REQ draft
> 
> Ok. Assuming we add a new requirement that " The mechanism 
> SHALL support means to relate RS(s) with CS(s)"
[JRE] On the contrary, I was suggesting we delete the existing text about how recordings are stored.

John (as individual)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of siprec issue tracker
>  Reporter:  rmohanr@...           |       Owner:  krehor@...         
> Comment(by john.elwell@...):
> 
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/18#comment:1>

---

From: Deepanshu Gautam <[email-masked]>
Date: Wed, 12 May 2010 15:31:43 +0800

+1

The first statement of the last bullet can be delete leaving only "The
Supervisor call must be associated with the original customer call." 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Elwell, John
Sent: 2010年5月12日 15:23
To: Ram Mohan R (rmohanr); siprec issue tracker; Ken Rehor (krehor)
Cc: [email-masked]
Subject: Re: [siprec] #18: Modify the text in Use Case 9 of REQ draft

> I thought we could add a text in this use case saying the same RS can 
> be used to associate the complex call (transfer, hold, resume).
> 
> Ok. Assuming we add a new requirement that " The mechanism SHALL 
> support means to relate RS(s) with CS(s)"
[JRE] On the contrary, I was suggesting we delete the existing text about
how recordings are stored.

John (as individual)

> outside the scope of SIPREC. Assuming we add a requirement that the 
> SRS  MUST be able to relate RSs to CSs, it is up to the SRS how it 
> arranges the  storage.
> 
>  John (as individual)
> 
> --
> Ticket URL:

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 May 2010 14:07:01 +0530

Inline

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Wednesday, May 12, 2010 12:53 PM
To: Ram Mohan R (rmohanr); siprec issue tracker; Ken Rehor (krehor)
Cc: [email-masked]
Subject: RE: [siprec] #18: Modify the text in Use Case 9 of REQ draft

> we can still avoid modifying the text here.
[JRE] On the contrary, I was suggesting we delete the existing text
about how recordings are stored.
<Ram> I am fine with deleting the existing text

Thanks
Ram

John (as individual)