Subject: [siprec] #31: Do we need REQ-019 and REQ-020 on metadata transport?

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 29 Jun 2010 16:17:30 -0000

#31: Do we need REQ-019 and REQ-020 on metadata transport?
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  minor                               |   Milestone:                  
Component:  Requirements                        |     Version:                  
 Severity:  Active WG Document                  |    Keywords:                  
------------------------------------------------+---------------------------
 REQ-019 "The mechanism MUST support the ability to transport the
    metadata in the same SIP dialog as the Recording Session." and
 REQ-020 "The mechanism MUST support the ability to transport the
    metadata outside of the Recording Session SIP dialog."
 These are getting rather solution-specific - why do we need these, and if
 we do need one, why do we need both?

 John

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/31>
siprec <http://tools.ietf.org/siprec/>

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Wed, 30 Jun 2010 22:33:22 +0530

John,
 
REG-019 is opened to track the following requirement: <To make the explicit requirement by which the single RS shall be related to multiple CS. The requirement text shall be "The mechanism SHALL support means to relate RS(s) with CS(s)" > which is different from REG-30 definition of REG-19: "The mechanism MUST support the ability to transport the metadata in the same SIP dialog as the Recording Session".
 
IMO, we discussed in detail before opening REG-019 and it has to be added as a requirement in requirement document. This requirement is discussed on the following mail thread(s):
 http://www.ietf.org/mail-archive/web/siprec/current/msg00249.html <http://www.ietf.org/mail-archive/web/siprec/current/msg00249.html> 
 http://www.ietf.org/mail-archive/web/siprec/current/msg00240.html <http://www.ietf.org/mail-archive/web/siprec/current/msg00240.html> 
 http://www.ietf.org/mail-archive/web/siprec/current/msg00241.html <http://www.ietf.org/mail-archive/web/siprec/current/msg00241.html> 

REG-019 does not mention about any specific solution. It only clarifies that there is a possibility of 1:N relationship between RS and CS. Could you please inlcude REG-019 in the requirement.
 
Thanks
Partha

________________________________

From: [email-masked] on behalf of siprec issue tracker
Sent: Tue 6/29/2010 9:47 PM
To: Ken Rehor (krehor); [email-masked]
Cc: [email-masked]
Subject: [siprec] #31: Do we need REQ-019 and REQ-020 on metadata transport?

 Reporter:  john.elwell@...                       |       Owner:  krehor@...       

 John

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec