Subject: [siprec] #26: Do we need REQ-008 on failover?

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 29 Jun 2010 16:08:37 -0000

#26: Do we need REQ-008 on failover?
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  minor                               |   Milestone:                  
Component:  Requirements                        |     Version:                  
 Severity:  -                                   |    Keywords:                  
------------------------------------------------+---------------------------
 REQ-008 "The mechanism SHOULD support SRS failover and migration of
    Recording Sessions to a working SRS without disconnecting the
    Communication Sessions."
 I would have thought most plausible mechanisms would not prevent this - it
 would be up to the SRC, if suitably configured, to failover to a different
 SRS. So is this requirement really needed? Or was it intended to express
 more than what it appears to express at face value, e.g., a requirement to
 failover without loss of recorded data?

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/26>
siprec <http://tools.ietf.org/siprec/>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 29 Jun 2010 12:57:16 -0400

If the SRC fails over from one SRS to another, is there a requirement 
that the resulting two RSs be correlated?

(Presumably somebody could just match properties from the two of them 
and infer a correlation. But is there a requirement for more than that?)

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 29 Jun 2010 19:02:29 +0200

Paul,

Yes, that was what I was searching for, something more than just the ability to failover. In fact, I am now reminded that we touched on that at the interim meeting, with the action to take it to the list. So we can continue discussion under this ticket. We need somebody to propose some words.

John

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 29 June 2010 17:57
> To: siprec issue tracker
> Cc: [email-masked]; Elwell, John; [email-masked]
> Subject: Re: [siprec] #26: Do we need REQ-008 on failover?
> 
> >  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
> >      Type:  defect                              |      
> Status:  new             
> >  Priority:  minor                               |   
> Milestone:                  
> >  Severity:  -                                   |    
> Keywords:

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 30 Jun 2010 09:25:47 -0400

A simple addition would be to add "or loss of any media" i.e.

 "The mechanism SHOULD support SRS failover and migration of
   Recording Sessions to a working SRS without disconnecting the
   Communication Sessions  or loss of any media."

In practical terms I think this will mean that data needs to be
streamed to the active and a standby SRS (with all the usual fun that
hot standbys etc. entail). Since if e.g. the hard drive on the primary
SRS crashes then there is no information there to correlate with....

So does the requirement really become a requirement for the solution
to allow full redundancy?

Peter Musgrave

On Tue, Jun 29, 2010 at 1:02 PM, Elwell, John
<[email-masked]> wrote:
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>